14:02:41 <ashimema> #startmeeting Development IRC meeting 15 July 2021
14:02:41 <huginn> Meeting started Thu Jul 15 14:02:41 2021 UTC. The chair is ashimema. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:41 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:41 <huginn> The meeting name has been set to 'development_irc_meeting_15_july_2021'
14:02:58 <ashimema> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_15_July_2021 Agenda
14:03:03 <ashimema> #topic Introductions
14:03:13 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:03:14 <ashimema> #info please use "#info" in front of your introduction to have it show up in the automatic minutes
14:03:16 <petrova> #info Peter (Petro) Vashchuk, National Library of Finland, Helsinki
14:03:21 <ashimema> #info Martin Renvoize, PTFS Europe, UK
14:03:29 <tuxayo> #info tuxayo/Victor Grousset, France
14:03:32 <Joubu> #info Jonathan Druart
14:03:35 <marcelr> #info Marcel de Rooy
14:03:43 <thd> #info
14:03:49 <Joubu> (I might disappear in the middle of the meeting)
14:04:02 <thd> #info Thomas Dukleth, Agogme, New York City
14:04:12 <ashimema> #chair Joubu
14:04:12 <huginn> Current chairs: Joubu ashimema
14:04:18 <ashimema> #chair tuxayo
14:04:18 <huginn> Current chairs: Joubu ashimema tuxayo
14:04:30 <tuxayo> :D
14:04:47 <ashimema> #topic Announcements
14:04:53 <ashimema> Anyone have anything to announce?
14:05:39 <ashimema> did I imagine hackfest dates have come out?
14:05:54 <tuxayo> no, it happened
14:06:01 * tuxayo digs
14:06:05 <Joubu> Next year: march 28th - april 1st.
14:06:11 <Joubu> " PS : it's not an april fool"
14:06:37 <ashimema> #info The next Marseille Hackfest has been announced: March 28th - April 1st.
14:06:45 <ashimema> Get those hotels booked :)
14:06:52 <tuxayo> thanks Joubu
14:07:04 <Joubu> be all there, it will be fun!
14:07:41 <ashimema> Paul also suggested that that's the new dates generally going forward didn't he..
14:07:46 * oleonard will move mountains to make it
14:07:49 <ashimema> so people can plan way ahead now :)
14:08:36 <ashimema> moving on
14:08:38 <ashimema> #topic Update from the Release manager
14:08:43 <ashimema> over to you Joubu
14:08:53 <Joubu> I am very slow at everything, sorry about that
14:09:08 <Joubu> Bug 17600 is going to be pushed very soon (for real), like tomorrow. It took me way more time than expected.
14:09:08 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17600 enhancement, P5 - low, ---, jonathan.druart+koha, Passed QA , Standardize the EXPORT
14:09:09 <tuxayo> found! https://lists.koha-community.org/pipermail/koha-devel/2021-July/046602.html
14:09:33 <tuxayo> #link next hackfest announcement https://lists.koha-community.org/pipermail/koha-devel/2021-July/046602.html
14:09:41 <Joubu> I will be back to process the PQA queue beginning of next week and I will deal with the conflicts (on those ones) caused by 17600.
14:10:03 <tuxayo> #info and fixed dates for futures ones: 4th week of March
14:10:08 <Joubu> that's all :D
14:10:27 <Joubu> ha
14:10:35 <ashimema> Joubu++
14:10:51 <ashimema> #topic Updates from the Release Maintainers
14:10:57 <Joubu> bug 12561, bug 3142, bug 27829, bug 25078
14:10:57 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12561 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Remove non-XSLT views
14:10:59 <Joubu> and bug 27526
14:10:59 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=3142 normal, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Standardize how OPAC and staff determine requestability
14:11:00 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27829 enhancement, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] Remove specific LANG installer data
14:11:01 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25078 enhancement, P5 - low, ---, jonathan.druart+koha, Signed Off , Update DB process - wrap each DBRev inside a transaction and better error handling
14:11:02 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27526 enhancement, P5 - low, ---, jonathan.druart+koha, Signed Off , Remove Mod/AddItemFromMarc from additem.pl
14:11:05 <Joubu> is my top priority list
14:11:13 <nugged> #info Andrew Nugged, National Library of Finland, HELSINKI
14:11:24 <ashimema> :)
14:11:25 <nugged> ( 🤷♂️ )
14:12:02 <ashimema> anything to say tuxayo.. think you're the only rmaint here
14:12:20 <tuxayo> right! missed the topic
14:13:16 <ashimema> well it looks like rmaint has been ticking along ot me
14:13:17 <ashimema> so lets move on
14:13:17 <ashimema> #topic Updates from the QA team
14:13:18 <ashimema> cait
14:13:18 <tuxayo> #info RMaint: few backports, one regression found in vairous releases and someone submitted a fix, do all good
14:14:41 <marcelr> cait1
14:15:11 * Joubu disappears
14:15:31 <tuxayo> :o
14:15:54 <tuxayo> Minimal QA from me in the form of following up on stuff that I tested.
14:16:31 <ashimema> #info QA is running OK. Please keep an eye on your emails QA team, cait gives good direction.
14:16:40 <tuxayo> indeed!
14:16:48 <ashimema> #topic Status of roadmap projects
14:17:09 <ashimema> I've not kept up at all this month.. has anything moved on the roadmap?
14:17:41 <ashimema> #info Bug 17600 is about to be pushed! :)
14:17:41 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17600 enhancement, P5 - low, ---, jonathan.druart+koha, Passed QA , Standardize the EXPORT
14:18:12 <ashimema> #info Bug 27526 is nearing the top of the RM's priorities again, lets get testing/qaing asap.
14:18:12 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27526 enhancement, P5 - low, ---, jonathan.druart+koha, Signed Off , Remove Mod/AddItemFromMarc from additem.pl
14:18:46 <ashimema> #info Bug 25078 is in good shape, needs a QA eye.
14:18:46 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25078 enhancement, P5 - low, ---, jonathan.druart+koha, Signed Off , Update DB process - wrap each DBRev inside a transaction and better error handling
14:19:28 <thd> I resent an email to people in the wiki group where Joubu had not seen messages from me.
14:19:30 <tuxayo> yep, it's greap!
14:19:45 <tuxayo> *great
14:19:48 <ashimema> #info Accessibility improvements - Bugs attached to bug 28188 - Please help them move forward by testing.
14:19:48 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28188 minor, P5 - low, ---, bolshawh, ASSIGNED , Accessibility: OPAC - the contrast ratio for text is insufficient [OMNIBUS]
14:20:12 <ashimema> #info Wiki migration - Email sent to the wiki group, please reply as necessary.
14:20:23 <thd> Gmail treats messages from my mail server as unauthenticated likely junk.
14:20:39 <oleonard> ashimema: Wrong bug number? I don't see dependent bugs on 28188
14:20:50 <ashimema> #info Bug 22544 is moving forward rapidly, needs a final QA and then next steps
14:20:50 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22544 enhancement, P5 - low, ---, jonathan.druart+koha, RESOLVED FIXED, Move C4:NewsChannels to Koha namespace
14:20:57 <thd> The important thing to know is merely whether someone did not receive a message from me last week.
14:21:20 <ashimema> humm.. that's the bug number listed on the roadmap.. seems they've not actually added bugs to it yet :(
14:21:26 <marcelr> pushed
14:21:29 <ashimema> I did.. but it went to spam again
14:21:47 <ashimema> ooh.. pushed now.. damn
14:21:51 <ashimema> I can't keep up :)
14:22:00 <marcelr> redundancy
14:22:18 <ashimema> #info News - I meant bug 24387
14:22:18 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24387 enhancement, P5 - low, ---, jonathan.druart+koha, Patch doesn't apply , Rename News tool
14:22:35 <ashimema> Joubu ^ I couldn't resolve the merge conflict there.. it confused me
14:22:51 <thd> ashimema: If you whitelist my domain agogme.com as Joubu did, I promise never to send any actual spam.
14:23:22 <tuxayo> ^^
14:23:42 <ashimema> I think the rest of them are further off.. I will send some chaser emails out asap.
14:24:11 <ashimema> #topic Actions from last meeting
14:24:20 <thd> Part of the issue for acceptance of my mail server is that my mail system actually runs on agogme.net and merely pretends to send from agogme.com .
14:24:27 <ashimema> #action ashimema Talk to key players about message passing for alerts
14:24:35 <ashimema> I didn't manage to get to that.. too many things on my plate :(
14:25:09 <ashimema> #topic General development discussion
14:25:37 <ashimema> I don't see any topic listed on the agenda, so we can move on unless anyone has anything they'd like to raise?
14:25:52 <ashimema> #topic Review of coding guidelines
14:25:57 <ashimema> #info Nothing to discus
14:26:05 <ashimema> #topic Set time of next meeting
14:26:46 <nugged> Victor wanted to discuss something about action_log and unblessed?
14:26:55 <nugged> (Petro?)
14:26:58 <tuxayo> oh right!
14:27:12 <ashimema> ok.. go for it.
14:27:12 <tuxayo> to follow up on the petrova email
14:28:56 <ashimema> I don't see an email from petrova
14:29:00 <tuxayo> I don't have anything myself to say on the topic but I can relay some things from http://irc.koha-community.org/koha/2021-07-12#i_2364995
14:29:12 <tuxayo> email => irc actually
14:29:40 <tuxayo> they found there action_logs table grow from 4g to 35g in weeks
14:29:47 <nugged> yes
14:30:06 <tuxayo> due to some perl blessing thing that caused date ending up in the DB in a very verbose form
14:30:13 <nugged> and it was because item MODIFY log entries was 370Kb each
14:30:55 <nugged> because two things: indented dumps with lot of spaces (370Kb -> 48Kb not indented)
14:31:46 <marcelr> there are some bugs in the queue now for that ?
14:31:59 <tuxayo> #info if anyone have a massive increase of action_logs, check out bug 28700 and 28692
14:31:59 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28700 enhancement, P5 - low, ---, stalkernoid, Needs Signoff , "Unblessed" method in Object.pm has blessed values for keys in some cases
14:32:00 <tuxayo> #info and eyes and opinions are needed for the proposed solutions
14:32:08 <nugged> and because Object.pm ->unblessed returns DateTime objects inside unblessed results (sometimes and for explained in the ticket reason reason)
14:32:24 <marcelr> there is also another one for whitespace
14:32:37 <ashimema> #info See bug 28700 and bug 28692 for details around action_logs growth and unblessed.
14:32:37 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28692 enhancement, P5 - low, ---, stalkernoid, Needs Signoff , Reduce DB action_log table size
14:32:58 <ashimema> too slow :)
14:33:05 <nugged> yes, these two tickets
14:33:07 <ashimema> ok.. lets take a look and get back later on those
14:33:23 <tuxayo> So that's the sums of the things.
14:33:29 <tuxayo> *sum up
14:33:29 * ashimema has to go collect kids from school
14:33:31 <ashimema> #info Next meeting: 21 July 2021, 14 UTC
14:33:35 <ashimema> seem OK to people?
14:33:44 <marcelr> huh 6 days
14:33:46 <nugged> our libraries started inventory check and get out of space on hosting :).
14:33:48 <tuxayo> in 6 days?
14:33:53 <nugged> ok then.
14:34:02 <ashimema> ack
14:34:07 <ashimema> I emant 28th
14:34:16 <ashimema> #info Next meeting: 28 July 2021, 14 UTC
14:34:17 <ashimema> my bad
14:34:18 <ashimema> thanks#
14:34:25 <tuxayo> good to me :)
14:34:37 * ashimema will not be around for 28th, but I'm sure someone can run it for us ;)
14:34:51 <ashimema> #endmeeting