14:00:32 <Joubu> #startmeeting Development IRC meeting 16 June 2021
14:00:32 <huginn> Meeting started Wed Jun 16 14:00:32 2021 UTC. The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:32 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:32 <huginn> The meeting name has been set to 'development_irc_meeting_16_june_2021'
14:00:48 <Joubu> #link Development_IRC_meeting_16_June_2021
14:00:55 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_16_June_2021
14:00:58 <tuxayo> rmaint in also wainui
14:00:59 <Joubu> #topic Introductions
14:01:00 <tuxayo> *es
14:01:03 <tuxayo> *is
14:01:06 <Joubu> #info Jonathan Druart
14:01:19 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:01:21 <Joubu> The bot (wahanui) is not here, tuxayo
14:01:33 <thd> #info Thomas Dukleth, Agogme, New York City
14:01:40 <tuxayo> Joubu: that's why I'm doing the job manually ^^"
14:01:41 <ashimema> #info Martin Renvoize, PTFS Europe, UK
14:01:52 <tuxayo> low-tech++
14:01:56 <tuxayo> #info tuxayo/Victor Grousset, France
14:01:56 * ashimema is on the school run, but will try to join by phone
14:02:16 <henryb> #info Henry Bolshaw, House of Lords, UK
14:02:25 <kidclamp> #info Nick Clemens, ByWater Solutions
14:03:20 <Joubu> cait1, are you around?
14:03:24 <Joubu> #topic Announcements
14:03:26 <Joubu> (keep the info for roadmap's topics for later)
14:03:43 <fridolin> #info Fridolin Somers, Biblibre, France
14:04:00 * fridolin waves
14:04:12 <Joubu> About the meeting facilitator role, I will join ashimema. We are going to prepare the meetings, like 2 days in advance
14:04:31 <Joubu> we will ping people with #actions and those who added topics to the agenda
14:04:52 <Joubu> the idea is to collect info ahead of the meeting
14:05:05 <Joubu> so please answer us if you get an email :)
14:05:10 <Joubu> something else?
14:05:13 <ashimema> +1
14:05:15 <cait1> oh sorry
14:05:16 <cait1> yes
14:05:20 <cait1> #info Katrin Fischer, BSZ, Germany
14:05:24 <fridolin> superbe
14:05:48 <ashimema> Thanks for the support Joubu.. apologies the meetings so far have caught me by surprise a bit
14:05:59 <Joubu> #topic Update from the Release manager (21.11)
14:06:18 <Joubu> Basically everything is (too) quiet, although we have tons of things planned :)
14:06:27 <Joubu> 1. Jenkins is red for a couple of days because of the "ugly patch" for the YAML::XS serializer for CGI::Session.
14:06:35 <Joubu> We moved it to a lib directory and bug 28519 that is waiting for QA.
14:06:35 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28519 enhancement, P5 - low, ---, dcook, Signed Off , Add a 2nd directory for Perl modules
14:06:40 <Joubu> I will push it tomorrow if nobody PQA it (!)
14:06:44 <Joubu> We need it for the 21.05.0
14:07:01 <cait1> I expect no strings with that, but plz keep string freeze in mind
14:07:13 <tuxayo> hi khall :)
14:07:14 <cait1> for other patches
14:07:15 <Joubu> 2. I sent some emails for the roadmap topics (more info in the dedicate agenda topic) and I am starting to prioritize them (will depend on the reply I get)
14:07:45 <Joubu> 3. Also sent an email to koha-devel about the early-push candidates for 21.06
14:07:46 <ashimema> Sorry, my QA time has been zero so far this cycle.. vacation, audit at work and other things getting in the way.. I hope to return asap
14:08:02 <Joubu> Bug 17600, bug 27526, bug 17427 and bug 25078
14:08:03 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17600 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Standardize the EXPORT
14:08:03 <cait1> similar, working through things, hope to have more time soon
14:08:04 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27526 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Remove Mod/AddItemFromMarc from additem.pl
14:08:05 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17427 normal, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Replace CGI::Session with Data::Session
14:08:06 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25078 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Update DB process - wrap each DBRev inside a transaction and better error handling
14:08:19 <Joubu> I really would like some pair of eyes on them this week or next week, they are important moves and must be pushed ASAP.
14:08:20 <cait1> ... but also little help with those apart from reminding devs
14:08:27 <Joubu> ASAP: in the next couple of weeks
14:08:45 <Joubu> any questions?
14:08:50 <cait1> I'll make sure to include those in the next QA mail
14:09:45 <koha-jenkins> Project Koha_Master_D9 build #1679: STILL UNSTABLE in 42 min: https://jenkins.koha-community.org/job/Koha_Master_D9/1679/
14:09:54 <tuxayo> :o
14:10:01 <Joubu> 17427 won't be pushed in the next couple of week however, IMO we should wait a couple of months to not diverge too much too quickly with 21.05.x (CGI::Session vs Data::Session)
14:10:19 <Joubu> questions, actions, nothing?
14:11:07 <tcohen> I'm not sure
14:11:07 <Joubu> #topic Updates from the Release Maintainers
14:11:15 <Joubu> not sure about?
14:11:35 <tcohen> what actions can we do, or how we split in teams to tackle things
14:11:43 <fridolin> I'm waiting on 21.05.x pushes
14:11:50 <tuxayo> 20.05: handover done on old branch, handover received on new branch, first backports done.
14:12:04 <ashimema> tuxayo++
14:12:09 <tuxayo> Do we have security repo access?
14:12:26 <ashimema> Are Wainui and Aliesha happy with things now
14:13:00 <Joubu> ashimema: yes
14:13:12 <ashimema> You should be able to tell that from the git UI tuxayo
14:13:20 <ashimema> Brill, thanks Joubu
14:13:25 <tuxayo> ashimema: thank, I'll check that out
14:13:26 <kidclamp> when Kyle is back we will coordinate on pushing for 21.05, he has been on vacation
14:13:35 <Joubu> tuxayo: did you use the security repo last cycle?
14:13:36 <fridolin> oki no pb
14:13:40 <kidclamp> tomorrow
14:13:49 <tuxayo> Joubu: thankfully, nope :D
14:14:02 <fridolin> (fingercrossed)
14:14:34 <Joubu> nobody has push access apparently
14:14:36 <ashimema> You will this cycle.. I'm working on a few
14:14:45 <Joubu> drop me an email please, I will have a look tomorrow
14:14:45 <tuxayo> ashimema: noooo
14:15:02 <tuxayo> ok thanks
14:15:23 <Joubu> kidclamp: there are few 21.05 candidates (see the bz kw), don't forget them
14:15:23 <ashimema> Interesting
14:15:32 <Joubu> #topic Updates from the QA team
14:16:13 <Joubu> I am running behind, and I would like to rely stronly on the QA team for the next couple of week (/one month?)
14:16:22 <Joubu> please QA in conservative mode
14:16:46 <tuxayo> No time for QA yet, still following up on ticket where I got answers, rebases, ect
14:17:09 <tcohen> ok
14:17:22 <cait1> we'll try our best
14:17:42 <Joubu> nothing from QAers?
14:17:47 <Joubu> I mean, others?
14:18:01 <cait1> I've been sending the welcome eamil and 2 more - we are already in week 3
14:18:17 <ashimema> So far this cycle is shaping up to be a busy one work wise for me.. just a warning there that I will try to QA but likely won't hit the flow I have been the last couple of cycles
14:18:17 <cait1> shoutout to kidclamp who took quite a few bugs out of our list last week :)
14:18:47 <cait1> I'll also remind more about "long sitting" bugs as i'd like to reduce the max time a bug sits in QA queue
14:18:59 <Joubu> yes, great QA run kidclamp, thanks! :)
14:19:11 <cait1> priorites apply as usually of course - bugs before enh etc.
14:19:17 <kidclamp> will try to keep up:-)
14:19:26 <cait1> a lot of bugs are a bit "out of reach" for me these days
14:19:35 <cait1> in terms of complexity
14:19:41 <ashimema> kidclamp++
14:19:47 <tuxayo> The recall one is tough, bug 19532
14:19:47 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19532 new feature, P1 - high, ---, aleisha, Signed Off , Recalls for Koha
14:19:59 <cait1> but will try to remind and pick on the others whenever i can
14:20:29 <cait1> if someone wants to team of up something - always happy to (like split GUI testing and technical)
14:20:40 <ashimema> I can't commit to the submitted recalls.. it would cause big issues here as it's not at all what we think of as recalls
14:20:55 <cait1> i think the question is if it's just a name problem
14:21:32 <cait1> if the featue is still useful, we shoudl consider it maybe
14:21:53 <cait1> and talk about how to communicate the difference from a classical recall feature
14:21:58 <tcohen> bug 25260 could be a good team work for QA team members
14:21:58 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25260 enhancement, P5 - low, ---, tomascohen, Signed Off , Merge 'reserves' and 'old_reserves' into a new 'holds' table
14:22:29 <ashimema> I'd like to see that one in tcohen.. I thought it was waiting for a rebasr or other work or something
14:22:30 <henryb> I hadn't noticed that it was recalls by patrons rather than the library
14:22:47 <Joubu> we need to sync and coordinate, or we won't finish anything (like the last cycle)
14:23:09 <Joubu> I am moving on
14:23:11 <ashimema> The logic is also somewhat weird/different henryb . Would love a librarians opinion for naming it
14:23:23 <Joubu> need to keep the meeting in its track
14:23:27 <cait1> henryb: i think comments from a library might help get it moving
14:23:33 <tcohen> we could call them 'patron recalls' :-P
14:23:41 <cait1> Joubu++
14:23:43 <tuxayo> to support companies: get customer feedback on it :)
14:23:51 <cait1> patron driven recalls?
14:24:11 <Joubu> if we need a discussion, we should start it ASAP on the mailing list
14:24:26 <Joubu> action?
14:24:28 <ashimema> Moving on
14:24:36 <Joubu> #topic Status of roadmap projects
14:24:47 <Joubu> I selected a few
14:25:07 <Joubu> I sent an email to the workgroups for:
14:25:11 <Joubu> * Get rid of non-XSLT views
14:25:43 <Joubu> => We are going to remove the non-XSLT views even if not all features have been moved, unless someone is opposed to that
14:25:52 <Joubu> * Fix item visibility at the OPAC
14:25:53 <ashimema> Nice
14:25:58 <Joubu> => Waiting for answers
14:26:03 <Joubu> * Koha Cookbook Project
14:26:06 <Joubu> => No answer yet
14:26:16 <Joubu> * Accessibility Improvements
14:26:20 <Joubu> Henry is going to work on the bug listed
14:26:31 <Joubu> henryb: do you want to say something about it?
14:26:36 <fridolin> ++
14:26:59 <ashimema> Excellent henryb,
14:27:02 <henryb> The bugs are mostly small things like adding labels
14:27:13 <cait1> I saw a lot of accessibility bugs move past - are those on the list?
14:27:23 <fridolin> "a small step for men ...
14:27:32 <Joubu> a lot has been pushed into 21.05
14:27:36 <henryb> There's one to fix the colour contrast issues on the OPAC which again is probably lots of small tweaks
14:27:37 <cait1> henryb++ small steps are good
14:27:59 <fridolin> they are not in 20.11.x to avoid to much backport job and translations
14:28:00 <henryb> Wainui is working on some others too like adding legends to tables
14:28:09 <Joubu> (https://annuel.framapad.org/p/koha_21.11_roadmap < we are talking about that, but you all know that)
14:28:11 <cait1> we had a question about this at the german user group meeting actually - so it seems there is definitely interest (contrast that is)
14:28:42 <henryb> I think they all have the 'accessibility' keyword but they're not all listed on the roadmap document
14:29:17 <henryb> That's it from me unless anyone has questions or ideas
14:30:06 <Joubu> https://bugs.koha-community.org/bugzilla3/buglist.cgi?cmdtype=dorem&list_id=372048&namedcmd=Accessibility&remaction=run&sharer_id=378
14:30:10 <Joubu> that's the list
14:30:28 <Joubu> thanks henryb, we will keep an eye on those bugs!
14:30:41 <Joubu> * Wiki migration
14:30:58 <Joubu> I sent en email and still waiting for more replies
14:30:59 <Joubu> We need to decide on the software (migrate to a newer version of mediawiki or switch to dokuwiki)
14:31:25 <Joubu> so either we restart the discussion on the general koha ML, or decide during a meeting?
14:31:27 <cait1> Joubu: sitting on a draft repy for that
14:31:36 <cait1> i think my main concern is moving from one wiki to another...
14:31:37 <Joubu> or we (the 4,5 members in the workgroup) decide?
14:31:41 <thd> I have been posting updates in the bug.
14:32:01 <cait1> in terms of both requiring wiki snytax etc. so there won't be much innovation, it's more bug fixing
14:32:21 <tuxayo> > I sent en email
14:32:21 <tuxayo> Is it in the general list? There are thing in march
14:32:33 <Joubu> tuxayo: to the workgroup only
14:32:34 <cait1> tuxayo: to everyone who signed up
14:32:37 <cait1> for the topic
14:32:39 <tuxayo> ok
14:33:03 <Joubu> no opinion?
14:33:11 <tuxayo> mediawiki++
14:33:12 <Joubu> thd: what's your opinion about this question?
14:33:19 <cait1> i think dokuwiki woudl work well, but requires some changes
14:33:21 <fridolin> 50% 50% for me
14:33:29 <thd> I have successfully tested excluding old content from simple search using the Vector skin.
14:34:05 <ashimema> I am open to either, but have basically no experience with doku
14:34:17 <thd> We have working code which I have posted for migrating the database and upgrading MediaWiki.
14:34:26 <thd> I am preparing another update.
14:34:38 <thd> ... to the code.
14:34:55 <ashimema> If we go the mediawiki route I do think we should add the editor
14:35:10 <cait1> editor = more wysiqyg?
14:35:14 <thd> I favour MediaWiki over Dokuwiki for much better support for many issues.
14:35:18 <ashimema> Yup
14:35:29 <ashimema> Go play on Wikipedia.. it has the editor
14:35:29 <cait1> i think they are really different "beasts" in some aspects
14:35:36 <tuxayo> ashimema: is that the thing that requires another service running? i've stumbled upon that when trying to setup my own mediawiki
14:35:36 <ashimema> Very much wysiwyg
14:35:41 <ashimema> Yup
14:35:45 <cait1> got no acount, but will try to look it up then
14:35:58 <thd> MediaWiki has the new VisualEditor extension.
14:36:08 <cait1> i think a part of our issue is that it's not easy to sue right now, i am in favor of trying an editor if there is one
14:36:16 <cait1> so that's a point for mediawiki then
14:36:27 <cait1> there are visual editors for dokuwiki, but i never found one that really worked well
14:36:29 <ashimema> I've not used either much recently but did have experience with mediawiki for a few years
14:36:33 <fridolin> bah we code so we are not afraid of wiki syntax
14:36:36 <cait1> especially if you switch modes
14:36:48 <tuxayo> cait1: no need for an accoun to play with the sandbox to test things https://en.wikipedia.org/wiki/Wikipedia:Sandbox
14:36:56 <cait1> thx tuxayo!
14:37:00 <ashimema> Yup
14:37:05 <henryb> As a complete beginner, mediawiki looks nicer and easier to use
14:37:06 <thd> There is a years old bug that search by tag is broken in MediaWiki.
14:37:22 <cait1> ok, so if we are leaning mediawiki
14:37:27 <thd> ooops
14:37:29 <cait1> 1) Figure out the update
14:37:36 <thd> There is a years old bug that search by tag is broken in Dokuwiki.
14:37:38 <cait1> 2) figure out a concept to mark outdated content for review?
14:37:56 <thd> Search by tag has always worked in MediaWiki.
14:38:03 <cait1> thd: i think tagging is actually a plugin fature in dokuwiki
14:38:03 <tuxayo> fridolin: «we code so we are not afraid of wiki syntax» a lot of stuff on the wiki is not only tech stuff
14:38:15 <ashimema> There are loads of templates available for mediawiki for maintainence making
14:38:19 <fridolin> indeed ;)
14:38:32 * cait1 waves at josef_moravec
14:38:45 <koha-jenkins> Project Koha_Master build #1673: STILL UNSTABLE in 55 min: https://jenkins.koha-community.org/job/Koha_Master/1673/
14:38:47 <cait1> so maybe we should call a wiki meeting to make more precise plans?
14:38:54 <Joubu> ok, perfect then. We will list/prepare the next steps and will report at the next meeting
14:38:57 <ashimema> Do it
14:39:03 <Joubu> cait1: between us it good enough
14:39:05 <ashimema> :)
14:39:07 <thd> cait1: Yes, but the tag which at one time allowed searching by tag has been long broken in MediaWiki.
14:39:07 <Joubu> small groups
14:39:09 <cait1> another plus for updating... user registration
14:39:31 <cait1> i am not sure if dokuwiki has the review options (at least witout plugins) and user migration might have been a bit bad
14:39:37 <cait1> yep, meant a meeting for the work group
14:39:52 <Joubu> I am moving on, we have a decision, more than I expected :)
14:39:57 <Joubu> * Bug 27829 - [OMNIBUS] Remove specific LANG installer data
14:39:57 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27829 enhancement, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] Remove specific LANG installer data
14:40:02 <cait1> thx Joubu
14:40:06 <Joubu> => Bernardo is working on creating a UNIMARC version for "en" that will be translatable via pootle.
14:40:15 <Joubu> We are certainly going to remove the specific fr-FR biblio frameworks.
14:40:18 <cait1> bgkriegel++
14:40:27 <Joubu> I will start the discussion with French (already started a bit) on the fr ML
14:40:34 <Joubu> I will create a patch for fr-CA and rebase nb-NO
14:40:38 <tcohen> bgkriegel++
14:40:42 <Joubu> the goal is to have them all remove for 21.11
14:40:43 <cait1> Joubu++ too
14:40:46 <Joubu> removed*
14:40:54 <cait1> please have an eye on items - fr-FR has a lot less standard mappings
14:41:00 <Joubu> that's all for the topics I listed
14:41:04 <ashimema> That will be so great
14:41:08 <cait1> might be nice to bring that up to date with MARC21 a bit more
14:41:25 <Joubu> cait1: Bernardo is doing a crazy work and is reviewing everything
14:41:29 <cait1> wow
14:41:33 <cait1> shoudl not have wondered about that :)
14:41:36 <cait1> bgkriegel++
14:41:59 <cait1> move on?
14:42:02 <Joubu> and we trying to provide a UNIMARC framework as closed as possible from the..
14:42:08 <Joubu> (cannot find the word)
14:42:13 <Joubu> standard/norm?
14:42:21 <cait1> makes sense yes
14:42:24 <cait1> UNIMARC standard
14:42:27 <ashimema> Excellent
14:42:58 <tuxayo> fridolin: any french libraries interested? Is actually the default framework much used?
14:43:07 <Joubu> something else you would like to add about the roadmap topics?
14:43:17 <cait1> just a Joubu++
14:43:23 <Joubu> I will continue to send few more emails in the upcoming days
14:43:27 <thd> I disfavour a new wiki.
14:43:38 <Joubu> and... I will drop the topic if I don't get answers
14:43:44 <cait1> thd: i think we have moved on from that
14:43:49 <thd> Ok.
14:43:58 <cait1> but we still need to makr and review tons
14:44:04 <Joubu> thd: we can continue by email of a bit after the meeting
14:44:05 <fridolin> sorry i dont know
14:44:07 <Joubu> or*
14:44:19 <cait1> Joubu: that's fair
14:44:25 <Joubu> #topic Actions from last meeting
14:44:29 <Joubu> postponing
14:44:33 <Joubu> (one more time)
14:44:47 <Joubu> #action ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695) - last postpone
14:44:47 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27695 minor, P5 - low, ---, oleonard, RESOLVED FIXED, Fix style of messages on Elasticsearch configuration page
14:44:57 <Joubu> #action kidclamp Ask the ML for additional info about how to implement opt-out for notices. One idea would be to have "My message" at the OPAC (last postpone)
14:44:59 <henryb> We should add a standing agenda item: "Postpone actions" :P
14:45:12 <tuxayo> bgkriegel++ Joubu++ great work on cleanup getting thing closer
14:45:18 <Joubu> #topic General development discussion (trends, ideas, ...)
14:45:22 <henryb> (sorry, that's unfair of me to say as I don't have any)
14:45:23 <Joubu> Sooo
14:45:28 <Joubu> #topic How to handle command line options vs system preferences in cron jobs?
14:45:43 <Joubu> this one, I haven't prepared, but we need to trigger actions
14:45:56 <cait1> that one was from me, i think i added bugs to agenda, sec
14:45:57 <Joubu> cait1: would you like to resume that please?
14:46:00 <fridolin> good question
14:46:02 <ashimema> Good topic
14:46:09 <Joubu> See Bug 28457 and Bug 25499 for recent discussion. And Bug 24968.
14:46:09 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28457 enhancement, P5 - low, ---, dcook, Needs Signoff , cleanup_database.pl self-registration options are not configurable
14:46:09 <tcohen> I propose using the 'configurations' table, to build a UI for managing cronjob default parameters
14:46:10 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25499 normal, P5 - low, ---, katrin.fischer, CLOSED FIXED, Fund code column is empty when closing a budget
14:46:11 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24968 enhancement, P5 - low, ---, koha-bugs, NEW , Add Syspref controls for cronjobs
14:46:26 <Joubu> tcohen: short term solution, not never implemented solution
14:46:49 <cait1> yes please, we have really needed feature stuck right now
14:46:49 <tcohen> -.-
14:46:52 <cait1> and we can migratie
14:46:55 <cait1> really open to that
14:47:19 <cait1> ok, so the idea is to move more control from Command line into the preferences/configuration GUI side
14:47:28 <cait1> this is especially helpful when you run multiple instances
14:47:32 <cait1> gives power to the libraries etc
14:47:42 <cait1> and you don't have to write complicated crontabs...
14:47:45 <tcohen> I volunteer to write some configuration page for cronjob parameters
14:47:54 <ashimema> Excellent
14:47:58 <cait1> i think we can do that and still have a discussion
14:48:00 <ashimema> I can test/qa
14:48:04 <cait1> the issue right now is 2 sided I think
14:48:16 <cait1> a) a new parameter for a database_cleanup.pl
14:48:16 <tcohen> - default params
14:48:20 <tcohen> - what to run
14:48:23 <cait1> so something that hasn't existed before
14:48:45 <cait1> at the moment we have instances where you enable the feature on CLI, but it's controlled by pref
14:48:58 <cait1> do we want the CLI switch? do we need it?
14:49:09 <tcohen> CLI switches should be overrides
14:49:14 <cait1> I thought we did.... because I am scared sometimes of things I can't control :) but i'd be open to not require
14:49:17 <tuxayo> > more control from Command line into the preferences/configuration GUI side
14:49:17 <fridolin> ++ for overide
14:49:18 * tuxayo will need to take a look if they can put evil stuff in that. Muhaha
14:49:27 <fridolin> for test instances with prod DB
14:49:49 <ashimema> Be nice if we could spot such overrides and now it in the GUI
14:49:54 <cait1> so say... deleting old label batches
14:50:11 <cait1> as an option toe cleanup_database
14:50:12 <ashimema> Like we do for the vhost syspref ones
14:50:34 <cait1> at the moment we'd add the "flag" to the conjob call
14:50:44 <ashimema> Indeed
14:50:46 <cait1> and then have a pref tell how long they shoudl be kept
14:50:49 <ashimema> So very hard to see
14:50:51 <tcohen> what is the stuck one?
14:50:58 <cait1> so it#s not really an override, it's more like an on off...
14:51:11 <Joubu> bug 25429 (not 25499)
14:51:11 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25429 enhancement, P5 - low, ---, kyle, Signed Off , Cleanup Database - remove resolved claims returned from db after X days
14:51:18 <cait1> there are 2 bug i am fraid i got the wrong bug number once mor eon the wiki :(
14:51:22 <cait1> ep that's the one
14:51:31 <cait1> thx Joubu
14:51:42 <cait1> and the other was self regs
14:51:51 <cait1> bug 28457
14:51:51 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28457 enhancement, P5 - low, ---, dcook, Needs Signoff , cleanup_database.pl self-registration options are not configurable
14:52:09 <tcohen> I think those bugs should move forward and add option switches
14:52:13 <cait1> so the question si: CLI additionally to pref for new ones?
14:52:21 <cait1> or just pref and that will be enough to turn the "feature"on
14:52:26 <tcohen> because it will then fit with a central config
14:52:32 <cait1> if the pref is empty, the fature is expected to be off
14:52:54 <ashimema> I think we need a standard options iterator in the scripts base class that would update a flag of were passed an override so we can thing that the option is being overridden at the flag level
14:53:09 <cait1> if we solved that... 2) is trickier: moving CLI optiosn into GUI - because then you already have crons scheduled that might need to be redone/rewritten
14:53:36 <cait1> so.. how to make it smooth for existing installations
14:53:59 <tcohen> just make the current behavior the default
14:54:05 <cait1> you can't
14:54:09 <tuxayo> cait1: warning in about page? Maybe something more visible
14:54:12 <cait1> unless you can see what they scheduled for the instance
14:54:22 <cait1> if they set dealy=10 for some option, you need the value
14:54:29 <cait1> delay
14:54:37 <cait1> that applies to this one instance... to rpefill the pref
14:54:40 <cait1> not sure if that is possible
14:54:49 <cait1> i saypref, but it could be a confguaration page of course
14:54:50 <tcohen> no
14:55:03 <tcohen> you will put some good default value for delay in the UI
14:55:16 <tcohen> and the configured cronjob will pass --dekay 10
14:55:27 <tcohen> and that option switch will have more precedence
14:55:46 <ashimema> Exactly
14:55:51 <Joubu> https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25429#c35
14:55:51 <huginn> 04Bug 25429: enhancement, P5 - low, ---, kyle, Signed Off , Cleanup Database - remove resolved claims returned from db after X days
14:55:58 <tcohen> I would totally avoid sysprefs for this
14:55:58 <ashimema> Let flags passed take precedence.
14:56:01 <Joubu> > It means that you need to have a sysadmin change a cronjob for ALL instances
14:56:01 <Joubu> > if there's just 1 instance that wants to be able to use the system
14:56:02 <Joubu> > preference "CleanUpDatabaseReturnClaims".
14:56:05 <Joubu> (from David)
14:56:25 <ashimema> Record that precidence with each run of the script to mark it as being used in the gui
14:56:29 <ashimema> That's my feeling
14:56:49 <ashimema> Then the librarian can see it's getting overriden... And can ask support to remove that if they want to change it
14:57:16 <tuxayo> > to mark it as being used in the gui
14:57:17 <tuxayo> nice
14:57:26 <ashimema> I like using your configuration table tcohen
14:58:57 <Joubu> I don't understand how the GUI will answer ALL the needs. IIUC we need to let the sysop turn off the feature even if the pref is ON
14:58:59 <tcohen> I like that idea as well, ashimema (noticing on the UI that is being overridden)
14:59:30 <Joubu> BUT David does not like the idea to have a separate cronjob, if one library wants a feature and others don't
14:59:54 <Joubu> (It's very warm here so just ignore me if what I am saying does not make sense)
15:00:24 <tuxayo> > we need to let the sysop turn off the feature even if the pref is ON
15:00:24 <tuxayo> if the cron args have precedence so can it be used to disable also?
15:00:41 <cait1> i think a default for deletes is a bad idea
15:00:46 <cait1> in other cases it works of ocurse
15:00:59 <cait1> but for deletes i'd rather have off as a default
15:01:42 <Joubu> actions? what do we do?
15:02:02 <Joubu> there is still a topic on the agenda
15:02:18 <tcohen> I volunteered to write something we can work on top
15:02:31 <cait1> maybe also comment on th bugs
15:02:32 <Joubu> you are suggesting a whole new feature
15:02:40 <cait1> hope we can unlock them
15:02:42 <Joubu> when need to unstuck the other bugs
15:02:51 <cait1> logic and implementation beign 2 different things her ei think
15:03:08 <cait1> first we need the logic... that can be moved to somehting nice
15:03:25 <cait1> and for the bugs awaiting using the pattern/logic would be ok already
15:03:38 <tcohen> ok,
15:03:39 <tuxayo> > default for deletes is a bad idea
15:03:40 <tuxayo> Would there be a way to visibly show somewhere a list of important crons with 'sane' exampl defaults. To have a hope that at least basic personal data cleanup would done?
15:04:15 <tuxayo> It's easy in the installer but what about existing installs?
15:05:39 <Joubu> I don't understand your questions
15:05:45 <Joubu> we need to move on anyway
15:05:54 <Joubu> please continue the discussion on the bug report
15:06:11 <Joubu> bug 25429 is where we discussed it
15:06:11 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25429 enhancement, P5 - low, ---, kyle, Signed Off , Cleanup Database - remove resolved claims returned from db after X days
15:06:11 <tuxayo2> ok
15:06:22 <Joubu> #topic Community infrastructure management. Docker swarm and Portainer (UI tool)
15:06:25 <Joubu> tcohen?
15:07:10 <tcohen> Theke provided a new server for the community. It is running a 'Docker swarm' with some tools to help with some use cases
15:07:41 <tcohen> - We want to interact with it from external places (e.g. webhooks making a service to react/update)
15:08:19 <tcohen> - We want to have 'admins' access to services maintenance, even if running on nodes provided by other community members
15:08:39 <tcohen> I did it, as a start, to run https://api.koha-community.org
15:09:03 <tcohen> and is set so everytime the Docker image for the API docs is updated, the site refreshes
15:09:15 <tcohen> the tool I installed there, is Portainer
15:09:26 <tcohen> it provides a nice interface for docker swarm
15:09:39 <tcohen> and also (more important) an API and webhooks
15:09:55 <tuxayo2> tcohen: so it's an easier way to host community tools for example API doc, schema spy and BZ splitter?
15:10:01 <tcohen> yes
15:10:12 <tcohen> it handles letsencrypt semi-automatically
15:10:18 <tcohen> so, it is really handy
15:10:33 <tcohen> my plan is to move jenkins there, once I figure the backup strategy
15:10:43 <tcohen> (the api site doesn't need such a thing)
15:10:44 <tuxayo2> great, I don't know who are these Theke people but they have been doing great stuff :D
15:10:53 <fridolin> +++
15:11:11 <tcohen> rangi++ # DNS things
15:11:14 <tcohen> oh, important
15:11:34 <tcohen> we have set *.test.koha-community.org wildcard domain pointing there
15:11:57 <tuxayo> like for hosting WIP and PoC stuff?
15:11:59 <tcohen> so, if we want to do things like testing some changes to (say) the dashboard or some other tool, we can
15:12:05 <tcohen> yes, exactly
15:12:39 <tcohen> anyone providing a VPS for the community
15:12:47 <tuxayo> ok
15:12:47 <ashimema> tcohen++
15:12:50 <tcohen> can run a command there, and make it part of the 'swarm'
15:12:51 <ashimema> theke++
15:13:01 <tcohen> so we can run things on any node, from this dashboard
15:13:03 <ashimema> tcohen == theke
15:13:13 <tcohen> it is all Docker
15:13:18 <tcohen> we are not all familiar with it
15:13:21 <tuxayo> I know :P
15:13:23 <tuxayo> tcohen ++
15:13:31 <tcohen> so feel free to ping me or amoyano
15:13:36 <tcohen> and we can help
15:14:02 <ashimema> if/when we manage to switch sandboxes to utilise this I'm sure I should be able to switch that ptfs-e server to donate the vps here instead which would give more control to community for the sandboxes
15:14:34 <tcohen> ashimema I'm working on tweaking the sandboxes to use swarm instead of the manual stuff we do today
15:14:42 <ashimema> awesome
15:15:07 <tcohen> I have a recipe, waiting for khall to be back
15:15:15 <tcohen> because I'm not familiar with the sandboxes
15:15:20 <tcohen> (yet)
15:15:47 <tcohen> that's all
15:15:50 <tcohen> thanks
15:15:52 <Joubu> nope :)
15:15:54 <Joubu> what's next?
15:16:00 <tuxayo> So this project would decouple more the server donation and it's service management?
15:16:11 <Joubu> we listed jenkins and jenkins's nodes
15:16:15 <Joubu> those are the easiest ones
15:16:23 <Joubu> but which ones do we target after?
15:16:40 <tcohen> I think the community site could be one
15:16:49 <tcohen> we could add HA to some services as well
15:16:53 <Joubu> we also talked about the ML server
15:16:58 <tcohen> yup
15:16:59 <ashimema> yes tuxaoy
15:17:04 <ashimema> that's exactly the idea
15:17:11 <tuxayo> nice
15:17:18 <tcohen> and we can have several managers
15:17:24 <tcohen> on different timezones
15:17:35 <tcohen> I picked this tech because it was the simplest
15:17:41 <tcohen> lower learning curve
15:17:43 * ashimema also wants to utilise it as his excuse to get a proper grip on containers ;)
15:18:16 <Joubu> all good?
15:18:29 <Joubu> #topic Set time of next meeting
15:18:38 <Joubu> #info Next meeting: 30 June 2021, 14 UTC
15:19:20 <Joubu> #endmeeting