14:02:18 <Joubu> #startmeeting Development IRC meeting 19 May 2021
14:02:18 <huginn> Meeting started Wed May 19 14:02:18 2021 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:18 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:18 <huginn> The meeting name has been set to 'development_irc_meeting_19_may_2021'
14:02:23 <Joubu> #topic Introductions
14:02:27 <tuxayo> #info tuxayo/Victor Grousset, France
14:02:28 <Joubu> #info Jonathan Druart
14:02:28 <tcohen> #info Tomás Cohen Arazi, Theke Solutions
14:02:43 <oleonard-away> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:02:46 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_19_May_2021
14:03:00 <lukeG1> #info Lucas Gass, ByWater Solutions
14:03:06 <ashimema> thanks for all the testing tuxayo
14:04:03 <tuxayo> ashimema: np, we will get this ticket! ^^
14:04:16 <Joubu> #topic Announcements
14:04:21 <Joubu> Anyone have something?
14:04:47 <cait1> meeting? :)
14:04:57 <ashimema> #info Martin Renvoize, PTFS Europe, UK
14:05:01 <cait1> sorry, need to scroll down first :)
14:05:09 <cait1> #info Katrin Fischer, BSZ, Germany
14:05:19 <Joubu> #topic Update from the Release Manager (21.05)
14:05:24 <Joubu> ok so that's me
14:05:37 <Joubu> No major will be pushed from now
14:05:43 <thd> #info Thomas Dukleth, Agogme, New York City
14:05:44 <Joubu> I will be conservative for the last week
14:05:53 <Joubu> some links:
14:05:57 <Joubu> * https://bugs.koha-community.org/bugzilla3/buglist.cgi?bug_status=Pushed%20to%20master&keywords=release-notes-needed%2C%20&keywords_type=allwords&list_id=372816&query_format=advanced
14:06:04 <Joubu> missing release notes for 21.05 ^
14:06:06 <tuxayo> only critical and blocker?
14:06:14 <ashimema> :)
14:06:23 <ashimema> No majors.. or Only majors?
14:06:25 <Joubu> * https://frama.link/koha_bz_rel_21_05_candidate the 21.05 candidates
14:06:29 <ashimema> ah, yes..
14:06:38 <ashimema> Critical/Blockers.. that makes sense
14:06:38 <Joubu> no >= majors!
14:06:43 <Joubu> no < majors!
14:07:02 <Joubu> * https://annuel.framapad.org/p/koha_21.11_roadmap
14:07:16 <Joubu> ^ the roadmap for 21.11, please add your names. New topics poped up
14:07:18 <tuxayo> Ok, the calendar says "Only > major", it seemed odd
14:07:28 <Joubu> there are still rooms for all of you
14:07:56 <Joubu> please read again the whole document and put your names there
14:08:07 <Joubu> * and, a new one: https://annuel.framapad.org/p/koha_21.11_tech_release_notes
14:08:28 <koha-jenkins> Project Koha_Master_D11 build #297: SUCCESS in 57 min: https://jenkins.koha-community.org/job/Koha_Master_D11/297/
14:08:38 <Joubu> I will send an email to the list shortly. You know the idea already. We want to highlight what has been done for this cycle
14:08:44 <Joubu> Arggggg
14:08:48 <Joubu> https://annuel.framapad.org/p/koha_21.05_tech_release_notes
14:08:54 <Joubu> This ^, we are still in 21.05..
14:09:02 <Joubu> I am messing with everything
14:09:59 <Joubu> so, with all the effort I made to create confusions, do you have any questions?
14:10:15 <Joubu> #link https://bugs.koha-community.org/bugzilla3/buglist.cgi?bug_status=Pushed%20to%20master&keywords=release-notes-needed%2C%20&keywords_type=allwords&list_id=372816&query_format=advanced
14:10:21 <Joubu> #link https://frama.link/koha_bz_rel_21_05_candidate
14:10:26 <Joubu> #link https://annuel.framapad.org/p/koha_21.11_roadmap
14:10:30 <Joubu> #link https://annuel.framapad.org/p/koha_21.05_tech_release_notes
14:10:59 <tcohen> is there a deadline for the roadmap?
14:11:04 <tcohen> :-D
14:11:39 <Joubu> we decided on June 1st IIRC
14:11:43 <fridolin> Git repository shrinking++
14:12:31 <Joubu> fridolin: add your name to "Remove remaining SQL based installers", we will need you (and few others) for fr-FR
14:12:37 <Joubu> and UNIMARC
14:12:56 <fridolin> ich id like to see jajm on that better
14:13:08 <fridolin> i prefer focus on other parts like ES
14:13:25 <Joubu> yeah, I prefer to focus on other parts as well
14:13:29 <Joubu> but it needs to be done
14:13:44 <fridolin> indeed
14:13:46 <ashimema> we're so close.. :|
14:13:56 <Joubu> I'd like to ask Nicolas and Séverine from BULAC, and Sonia
14:14:03 <ashimema> don't let it get to a third RM having to deal with it.
14:14:04 <ashimema> ;)
14:14:06 <fridolin> yep
14:14:17 <fridolin> i add my name to it
14:14:20 <Joubu> thx
14:14:31 <Joubu> tcohen: I'd like you on Remove Mod/AddItemFromMarc from item form
14:14:33 <ashimema> fridolin, can you envisage a hackfest this coming cycle?
14:14:46 <ashimema> it's the sort of thing where trapping the right people in a room for half a day and it'll be done..
14:14:57 <tcohen> Joubu sure!
14:15:09 <Joubu> tcohen: we need to decide for the merge of the old/deleted* tables
14:15:12 <Joubu> if we continue or drop
14:15:20 <tcohen> we should do it
14:15:22 <fridolin> ashimema: sure, as soon as possible HF in marseille
14:15:27 <Joubu> so it must be on the roadmap
14:15:43 * ashimema needs to renew his passport
14:16:08 <ashimema> We should do it..
14:16:13 <Joubu> pubs reopening today in France so hackfest is possible finally
14:16:19 <ashimema> but I don't know what's still required..
14:16:20 <tcohen> +1
14:16:22 <ashimema> is that not the one tomas and I pouired hours into QAing once.. perhaps twice.. already?
14:16:46 <ashimema> things have moved again since then.. but I think it's another one that feels very close and need a final push
14:16:48 <ashimema> lol
14:16:59 <Joubu> bug 20271 and bug 25260
14:16:59 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20271 enhancement, P1 - high, ---, koha-bugs, In Discussion , Merge deleted biblio, biblioitems, biblio_metadata, and items tables
14:17:00 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25260 enhancement, P5 - low, ---, tomascohen, Signed Off , Merge 'reserves' and 'old_reserves' into a new 'holds' table
14:17:14 * ashimema thinks some items on the roadmpa would lend themselves to group hack sessions at hackfest
14:18:07 <tuxayo> fridolin: if you can raise the question at BibLibre, because there are chances that a hackfest will be possible in the last months of the year
14:19:18 <Joubu> ok, moving on?
14:19:19 <koha-jenkins> Project Koha_Master build #1652: SUCCESS in 1 hr 10 min: https://jenkins.koha-community.org/job/Koha_Master/1652/
14:19:33 <Joubu> #topic  Updates from the Release Maintainers
14:19:59 <fridolin> sure
14:20:19 <fridolin> Release of 20.11.06 will be around 25
14:20:27 <fridolin> i'm up to date with master
14:20:35 <fridolin> nothing pending i'd say
14:20:47 <fridolin> Joubu: are there backoports to higlight ?
14:21:40 <Joubu> I don't know
14:21:54 <tcohen> yes
14:22:06 <fridolin> whooo I see Kyle and Nick will be on 21.05.x, super cool
14:22:40 <tcohen> bug 28351 is mandatory for all stables down to 20.05
14:22:40 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28351 major, P5 - low, ---, jonathan.druart+koha, Pushed to master , Cannot set restrictions when 'dateformat' is other than 'us'
14:22:40 <cait1> :)
14:22:46 <cait1> hackfest++
14:23:03 <cait1> for the raodmap: i put some comments also on the older ones - maybe check those
14:23:10 <fridolin> hackfest in Marseille is probably for 2022, sorry
14:23:21 <tuxayo> ok, noted 28351 to watch
14:23:32 <cait1> too bad... maybe we shoudl try a virtual one
14:23:34 <fridolin> oki notes
14:23:36 <fridolin> noted
14:23:48 <tcohen> +1 for an improvised hackfest once they allow us to get into Europe
14:23:55 <fridolin> i'll catch master on friday
14:24:00 <cait1> so people can plan on having free time for a timeframe and we could use zoom rooms or so
14:24:04 <ashimema> virtual hackfest perhaps?
14:24:13 <ashimema> so we have something to look forward to this year?
14:24:17 <fridolin> yep but real IPA ^^
14:24:21 <cait1> yeah, not hte same by far...
14:24:24 <tcohen> fridolin hehe
14:24:29 <ashimema> indeed
14:24:30 <cait1> but it could be helpful still to some extend
14:24:37 <cait1> i think the french librairans had one with some success?
14:24:47 <fridolin> we made a virtual biblibre meeting with online games a night and real IPAs
14:24:54 <tuxayo> :D
14:24:56 <Joubu> yes but they had real cheese, not virtual
14:25:06 <tcohen> oleonard is 'get rid of jquery-ui' already on the roadmap?
14:25:27 <oleonard> No, but in my mind the datepicker was the biggest impediment to doing so
14:25:42 <oleonard> If we agreed on a replacement that would really push the process forward.
14:26:02 <cait1> makes sense
14:26:28 <fridolin> +1
14:26:28 <tcohen> go for it!
14:27:16 <ashimema> perhaps ask henryb and wananui to help find an accessibility friendly one?
14:27:36 <tuxayo> *Wainui
14:27:45 <ashimema> dang.. thanks
14:27:50 <ashimema> keyboard blurr.. :P
14:28:29 <oleonard> I can work on a test patch with flatpickr just to get a feel for it
14:28:48 <ashimema> :)
14:29:23 <tcohen> oleonard++
14:29:25 <Joubu> so, moving on? :D
14:29:34 <Joubu> hard to stick to the current topic :)
14:29:35 <tcohen> but, for the sake of the meeting, add it to the roadmap
14:29:50 <Joubu> # Actions from last meeting
14:29:53 <Joubu> #topic Actions from last meeting
14:30:03 <Joubu> * ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)
14:30:03 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27695 minor, P5 - low, ---, oleonard, Pushed to stable , Fix style of messages on Elasticsearch configuration page
14:30:31 <ashimema> I was aiming to do it for next cycle..
14:30:39 <Joubu> #action ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)
14:30:40 <ashimema> kinda thought the next dev meeting was next cycle.. last meeting.. oops
14:30:45 <ashimema> so one last postpone ;)
14:30:45 <ashimema> hugs
14:30:50 <Joubu> * kidclamp Ask the ML for additional info about how to implement opt-out for notices. One idea would be to have "My message" at the OPAC (postponed)
14:31:49 <Joubu> #action kidclamp Ask the ML for additional info about how to implement opt-out for notices. One idea would be to have "My message" at the OPAC (postponed)
14:31:58 <Joubu> #topic General development discussion (trends, ideas, ...)
14:32:07 <Joubu> we can discuss anything you want now :)
14:32:28 <ashimema> Too close to end of cycle for me.. my brain is
14:32:29 <ashimema> mush
14:32:30 <ashimema> hehe
14:33:46 <thd> Sleep and eating some mushy mush helps with brain mush ;)
14:34:09 * thd needs more sleep at the moment
14:34:17 <oleonard> Same.
14:34:39 <Joubu> #topic Set time of next meeting
14:35:01 <Joubu> #info Next meeting: 2 June 2021, 14 UTC
14:35:14 <Joubu> #endmeeting