14:00:20 <Joubu> #startmeeting Development IRC meeting 21 April 2021
14:00:20 <huginn> Meeting started Wed Apr 21 14:00:20 2021 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:20 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:20 <huginn> The meeting name has been set to 'development_irc_meeting_21_april_2021'
14:00:25 <talljoy> no snow in the desert!!
14:00:29 <talljoy> right no
14:00:31 <talljoy> now
14:00:31 <Joubu> #topic Introductions
14:00:40 <Joubu> #info Jonathan Druart
14:00:47 <Joubu> sorry for interupting you! :)
14:00:54 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:00:56 <kidclamp> #info Nick Clemens, ByWater Solutions
14:01:05 <thd> #info Thomas Dukleth, Agogme, New York City
14:01:19 <henryb> #info Henry Bolshaw, House of Lords Library, UK
14:01:24 <talljoy> #info Joy Nelson, ByWater Solutions
14:01:31 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:01:43 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_21_April_2021
14:02:04 <Joubu> hi all :)
14:02:06 <Joubu> #topic Announcements
14:02:10 <Joubu> Anyone have something?
14:02:35 <ashimema> #info Martin Renvoize, PTFS-Europe
14:03:00 <Joubu> #topic Update from the Release Manager (21.05)
14:03:09 <Joubu> Release dates have been announced on the general mailing list earlier today:
14:03:12 <Joubu> * May 1st - "Soft" feature freeze, nothing big or with high risk of side-effects will be included into the final release if not marked as Passed QA
14:03:16 <Joubu> * May 4-7 - "Hard" feature freeze, nothing considered as an improvement will be pushed if not marked as Passed QA
14:03:20 <Joubu> * May 12th - String freeze, draft of release notes published
14:03:23 <Joubu> * May 19th - Only bug fixes considered as major, critical or blocker will be pushed
14:03:27 <Joubu> * May 28th - Final release
14:03:34 <tcohen> Joubu++
14:03:44 <Joubu> how does it sound?
14:04:06 <tcohen> Great, releasing a friday means beer party
14:04:06 <oleonard> +1
14:04:19 <Joubu> I will start using the rel_21_05_candidate bz keyword more and more, keep an eye on it - https://frama.link/koha_bz_rel_21_05_candidate
14:04:20 <thd> +1
14:04:20 <cait> souns good but scares me the same time
14:04:22 <cait> does that count?
14:04:27 <henryb> It sounds great but everything is happening so fast!
14:04:33 <cait> #info Katrin Fischer, BSZ, Germany
14:04:46 <cait> henryb foudn the better words :)
14:05:02 <ashimema> +1
14:05:06 <Joubu> cannot be later than on 28th :)
14:05:11 <ashimema> indeed
14:05:23 <Joubu> You should also watch the bug reports with missing release notes
14:05:24 <ashimema> it's the usual flow
14:05:28 <Joubu> There is a shared search
14:05:35 <Joubu> https://bugs.koha-community.org/bugzilla3/buglist.cgi?cmdtype=dorem&list_id=369387&namedcmd=Needs%20release%20notes&remaction=run&sharer_id=378
14:05:44 <khall> #info Kyle M Hall, ByWater Solutions
14:05:57 <Joubu> #info keep an eye on the 21.05 candidate list https://frama.link/koha_bz_rel_21_05_candidate
14:06:16 <Joubu> #info Watchout the missing release notes! https://bugs.koha-community.org/bugzilla3/buglist.cgi?cmdtype=dorem&list_id=369387&namedcmd=Needs%20release%20notes&remaction=run&sharer_id=378
14:06:30 <henryb> To clarify, I wasn't suggesting the timetable should change I'm just surprised how quickly time passes :)
14:07:16 <Joubu> heh yes, only 1 month left!
14:07:17 <cait> I understood it like that
14:07:19 <Joubu> 5 weeks!
14:07:26 <ashimema> is there a new roadmap doc for planning the next cycle yet?
14:07:52 <Joubu> ashimema: we could start thinking about it indeed, like in 2 weeks?
14:07:56 <koha-jenkins> Project Koha_Master_D9_MDB_Latest build #568: UNSTABLE in 34 min: https://jenkins.koha-community.org/job/Koha_Master_D9_MDB_Latest/568/
14:08:29 * ashimema likes to have a place to put things early.. that way he can put them there then they're out of his brain so he can concentrate on the more immediate tasks
14:08:32 <Joubu> ~2 weeks before the release. But we should focus on 21.05 first :)
14:09:00 <ashimema> haha.. I'll just note mine locally for now then .. and try to get them out of my brain
14:09:22 <Joubu> yes, I have mine already as well ;)
14:09:36 <Joubu> will be fun to merge them
14:09:50 <Joubu> #topic Updates from the QA team
14:10:01 <thd> Writing things tends to reduce brain consumption.
14:10:19 <Joubu> NQA queue is back under 100
14:11:01 <Joubu> but still too many, and we have 2 criticals + 2 majors
14:11:05 <ashimema> I've struggled to focus on QA much this month.. only really had a couple of days
14:11:14 <cait> same here
14:11:16 <kidclamp> trying to do what I can when I can
14:11:19 <cait> we need more hands on deck
14:11:29 <ashimema> little dissapointing I'm still number 3 in the list.. even with that being the case
14:11:42 * oleonard has been trying to focus on non-enh signoffs
14:11:55 <ashimema> nice one oleonard
14:12:01 <cait> yep
14:12:03 <Joubu> that's the way oleonard, thanks :)
14:12:07 <cait> but we also have some long istting stuff
14:12:22 <ashimema> istting?
14:12:24 <cait> personally... I'd be really really happy to see bug 14237 movign
14:12:24 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14237 enhancement, P2, ---, aleisha, Signed Off , Allow bibs to be added to course without items
14:12:30 <cait> sitting sorry
14:12:31 <maya-das> hi
14:12:58 <oleonard> Hi maya-das we are in the middle of a developers meeting at the moment, stick around until after if you have a question
14:13:02 <tcohen> cait: will take a look today
14:13:04 <cait> hi maya-das - we are just in ameeting, you are welcome to stay, but questions might be a bit hard to answer right now
14:13:18 <cait> oleonard: jinx? :)
14:13:27 <oleonard> :)
14:14:02 <maya-das> oleonard  >> ok
14:14:02 <cait> nothing more to add for QA i think
14:14:04 <Joubu> something else for/from QA?
14:14:15 <cait> please look at the bad and the old as pointed out in my mails :) (and beyond those of course)
14:14:33 <Joubu> #topic Updates from the Release Maintainers
14:14:58 <Joubu> (yes I did swap the 2 topics!)
14:15:30 <cait> trying to keep us on our toes
14:15:35 <Joubu> April releases are expected for Monday 26th
14:15:38 <Joubu> #info April releases are expected for Monday 26th
14:15:49 <cait> i noticed the strings haven't been updated for 20.11
14:16:03 <cait> they had been already updated before, but not since fridolin announced and there were some strings pushed
14:16:27 <Joubu> do we need to ping Bernardo?
14:16:43 <cait> i am not sure, i was hoping to catch fridolin today, but haven't spotted him yet
14:16:47 <cait> i am nto sure how this works at the moment
14:16:54 <Joubu> Were you saying pootle is not up-to-date?
14:16:58 <cait> it looks like the scheduled string update around 15th happened
14:17:00 <cait> but none after
14:17:08 <cait> yes
14:17:20 <ashimema> also.. manual builds for 20.11 are broken again
14:17:23 <cait> after 15th new strings were pushed and 20.11 string frezeed announced
14:17:38 <Joubu> ok, we will catch Frido when he will be around then
14:17:39 <cait> but i am waiting for some navigation links to show up and they haven't yet
14:18:08 <cait> bug 28006
14:18:08 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28006 enhancement, P5 - low, ---, oleonard, Pushed to stable , Restore "Additional fields" link on serials navigation menu
14:18:08 <Joubu> ashimema: because of disk space issues again?
14:18:17 <ashimema> I don't think so
14:18:42 <ashimema> it was the merges of translations that hit it.. those builds are taking longer than the 1h timeout on gitlab build servers I think
14:18:47 <ashimema> I've not investigated deeply yet
14:19:07 <Joubu> @later tell fridolin looks like the string for 20.11 are not up-to-date on pootle, something missing in your workflow for April?
14:19:07 <huginn> Joubu: The operation succeeded.
14:19:13 <Joubu> string*s*
14:20:00 <Joubu> ashimema: erk, did you raise an alert flag? Can we extend the timeout?
14:20:16 <ashimema> I literally got told about it 20 mins before this meeting
14:20:17 <ashimema> ;)
14:20:23 <ashimema> so haven't done anything yet ;)
14:20:26 <Joubu> ok, will see after the meeting then :)
14:20:33 <ashimema> looking at the builds it's been dead for a month
14:20:40 <Joubu> #topic Status of roadmap projects
14:21:07 <Joubu> things are stuck for most of the topics
14:21:20 <Joubu> I am still hoping a QA stamp on bug 22544
14:21:20 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22544 enhancement, P5 - low, ---, jonathan.druart, Patch doesn't apply , Move C4:NewsChannels to Koha namespace
14:21:51 <Joubu> ha, does not apply! I missed that one :D
14:21:54 <ashimema> Katrin was on that.. but it's failing to apply
14:21:56 <ashimema> aha :)
14:22:16 <Joubu> and some QA issues need to be fixed on bug 14957
14:22:16 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14957 new feature, P5 - low, ---, glasklas, Failed QA , Write protecting MARC fields based on source of import
14:22:16 <cait> yeah i tried, but didn't get far sorry
14:22:22 <cait> same
14:22:41 <Joubu> I will rebased the news stuff right after the meeting!
14:22:44 <mtj> #info Mason James, NZ
14:22:57 <Joubu> #topic  Actions from last meeting
14:22:58 <mtj> hi people, sorry i'm late :)
14:23:04 <Joubu> #topic Joubu create the "roles for 21.11" wiki page and send an email to the list
14:23:12 <Joubu> done, see https://wiki.koha-community.org/wiki/Roles_for_21.11
14:23:27 <Joubu> (lot of people missing there!)
14:23:32 <cait> hi mtj - difficult time for you!
14:23:56 <cait> maybe weshoudl put election date on the page
14:24:01 <cait> that's been set already, right?
14:24:07 <Joubu> yes, next general meeting
14:24:07 <wahanui> somebody said next general meeting was 13 November, so does 14 November 13:00 ITC work okay?
14:24:20 <Joubu> https://wiki.koha-community.org/wiki/General_IRC_meeting_12_May_2021
14:24:27 <Joubu> 12 May 2021, 14:00 UTC
14:24:34 <cait> and add elections there?
14:24:35 <cait> i am on it
14:24:42 <Joubu> thanks
14:25:00 <Joubu> #topic mtj write something about the new packages for the 21.05 release notes
14:25:05 <Joubu> done - https://wiki.koha-community.org/wiki/Package_types
14:25:08 <Joubu> thanks mtj for that one!
14:25:41 <Joubu> #info New wiki page to explain the different debian packages has been written - https://wiki.koha-community.org/wiki/Package_types
14:25:56 <Joubu> #topic ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)
14:25:56 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27695 minor, P5 - low, ---, oleonard, Pushed to master , Fix style of messages on Elasticsearch configuration page
14:26:18 <ashimema> I need to postpone that one once again
14:26:33 <ashimema> sorry.. just haven't had a moment
14:26:35 <Joubu> #action ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)
14:26:43 <ashimema> thanks
14:26:46 <Joubu> #topic General development discussion (trends, ideas, ...)
14:26:54 <Joubu> #topic Email unsubscribe - CAN-SPAM / GDPR - how to implement opt-out for Koha
14:26:56 <Joubu> kidclamp: ?
14:26:57 <cait> wiki updates done
14:27:12 <kidclamp> This is something we are working on as we face some issues in sending out emails
14:27:33 <kidclamp> Patrons will mark messages as SPAM, this eventually can put our servers on block lists
14:27:48 <cait> interesting
14:27:53 <kidclamp> one of the features that is needed is an 'Unsubscribe' link in the messages
14:28:15 <kidclamp> or alternately, a way to show that patrons have agreed to receive transactional message
14:28:15 <cait> sounds like a good idea in general
14:28:18 <Joubu> yes, definitely
14:28:41 <kidclamp> really we are interested in whether there are any GDPR related issues around this, or if anyone else int he community faces this problem?
14:28:43 <ashimema> yup..
14:28:55 <Joubu> it's mandatory
14:28:55 <ashimema> we've never had such a problem
14:29:05 <Joubu> you have to include an unsubscribe link
14:29:14 <Joubu> (I...think)
14:29:22 <cait> not sure if that applies to overdues
14:29:35 <kidclamp> how have libraries implemented it?
14:29:58 <kidclamp> in theory overdues are excluded for us too, but in practice they still count against us
14:30:18 <cait> I know that there is discussion about informational emails
14:30:24 <cait> if it's not related to their actions witht he library
14:30:30 <cait> you can't just emai them things
14:30:45 <cait> but stuff related to their circulation directly (renewal, overdue) should be ok i think
14:31:15 <cait> if we get questions about other types of email we help get a list, but we tell them to check with their appointed data privacy person
14:32:14 <cait> if that makes sense? we haven' t had requests so far as you can opt them out of most messages and we are not using all of them anyway
14:32:41 <cait> via messaging preferences you can turn off a lot of the emails... are there some more problematic than others?
14:32:50 <kidclamp> the patron_emailer script doesn't have an opt-out currently
14:33:05 <cait> yeah we don't use that at all at the moment
14:33:11 <kidclamp> and I think ooffering an unsubscribe on the overdues would be an eventual goal for us
14:33:59 <cait> if it's a marker you put in the templates, it's would be easy to control when it shows
14:34:07 <kidclamp> Kyle and I discussed this morning the possibility of adding 'my messages' to patron opac view, and adding a transport of way for patrons to get notices in the opac, but not necessarily have them 'sent'
14:34:32 <cait> i think there is an open bug to have the message view i staff in opac too alreay
14:34:39 <cait> that goes the same direction
14:34:40 <ashimema> for unsubscribe I really wonder about just linking to the patron messaging preferences
14:34:50 <kidclamp> largely though, it sounds like no one is finding they need additional option to meet GDPR requirements or others?
14:34:54 <cait> and then we culd have a message transport type "opac" to
14:34:55 <ashimema> and trying to follow through and add more of the notices to that set
14:35:03 <cait> but i'd still show them all if we are on that already
14:35:08 <Joubu> that's a nice idea, kidclamp. Even we could enqueue things even if a patron does not have the mtt (like no email), and it would be visible in their OPAC account
14:35:23 <ashimema> I do like that idea too
14:35:45 <Joubu> kidclamp: ask the list? :)
14:35:57 <tuxayo> #info tuxayo/Victor Grousset, France
14:36:20 * tuxayo scrolls back
14:36:39 <koha-jenkins> Project Koha_Master build #1620: UNSTABLE in 1 hr 2 min: https://jenkins.koha-community.org/job/Koha_Master/1620/
14:36:44 <kidclamp> can do, we are working on deciding waht we need and how we should implement, so just collecting info for now
14:37:08 <cait> kidclamp: i think having privacy features like that is never wrong, even if it's not a must have maybe
14:37:13 <cait> or not a must have evrywhere
14:38:12 <kidclamp> talljoy: any more questions you have?
14:39:16 <kidclamp> I think we can move on, and we will email the list if we have more questions
14:40:04 <Joubu> #action kidclamp Ask the ML for additional info about how to implement opt-out for notices. One idea would be to have "My message" at the OPAC
14:40:23 <Joubu> #topic Set time of next meeting
14:40:56 <koha-jenkins> Project Koha_Master_D9 build #1624: UNSTABLE in 32 min: https://jenkins.koha-community.org/job/Koha_Master_D9/1624/
14:41:06 <Joubu> #info Next meeting: 5 May 2021 14 UTC
14:41:21 <Joubu> no objections?
14:41:27 <Joubu> 5sec
14:41:31 <Joubu> #endmeeting