15:01:21 <tuxayo> #startmeeting Development IRC meeting 22 December 2021
15:01:21 <huginn`> Meeting started Wed Dec 22 15:01:21 2021 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:21 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:21 <huginn`> The meeting name has been set to 'development_irc_meeting_22_december_2021'
15:01:52 <tuxayo> #topic Introductions
15:01:57 <tuxayo> qa_team?
15:01:57 <wahanui> qa_team is cait, joubu, dcook, ashimema, marcelr, kohaputti, tcohen, kidclamp, khall, tuxayo, petrova, nugged
15:02:07 <fridolin> #info Fridolin Somers, Biblibre, Tahiti
15:02:35 <kidclamp> #info Nick Clemens, ByWater Solutions, US
15:02:39 <thd> #info Thomas Dukleth, Agogme, New York City
15:02:39 <davidnind> #info David Nind, New Zealand
15:02:40 <nugged> #info Andrew Nugged, National Library of Finland, HELSINKI
15:02:43 <tuxayo> #info Victor Grousset, Tuxayo LLC, France
15:04:22 <tuxayo> #topic KohaCon22
15:04:37 <tuxayo> #info Deadline is 8 January 2022 and decision was to be made at General IRC meeting 12 January 2022, so far there are no KohaCon22 proposals
15:04:51 <fridolin> arf
15:04:54 <tuxayo> Suggestion 1: Extend deadline to mid-February
15:04:57 <nugged> do we have some candidates already or that not public info?
15:05:02 <tuxayo> Suggestion 2: If an online-only event is proposed, don't remove the continent from rotation for next year
15:05:27 <tuxayo> That's was written on the meeting agenda โ†‘โ†‘
15:05:38 <nugged> ok tx
15:05:52 <fridolin> https://wiki.koha-community.org/wiki/KohaCon22_Proposals
15:05:54 <tuxayo> Anyone has more info?
15:06:20 <fridolin> me not
15:06:21 <nugged> I see ((so far there are no KohaCon22 proposals))
15:06:54 * fridolin suggests we do both
15:07:07 <fridolin> extending and no geo limit
15:07:26 <koha-jenkins> Project Koha_21.11_U20 build #10: SUCCESS in 56 min: https://jenkins.koha-community.org/job/Koha_21.11_U20/10/
15:07:30 <fridolin> Antartica can propose ^^
15:07:59 <tuxayo> ๐Ÿง๐Ÿ“•
15:08:02 <nugged> > extending and no geo limit
15:08:02 <nugged> +1
15:08:09 <davidnind> +1
15:08:27 <koha-jenkins> Project Koha_21.11_U18 build #12: SUCCESS in 35 min: https://jenkins.koha-community.org/job/Koha_21.11_U18/12/
15:08:40 <thd> Should proposals emerge we can give preference to within the geographic limit.
15:08:53 <fridolin> sure
15:09:10 * fridolin would love to go to south america
15:09:23 <tuxayo> > extending and no geo limit
15:09:23 <tuxayo> that's new, ยซdon't remove the continent from rotation for next yearยป doesn't mean no geo limit for this year right?
15:09:23 <tuxayo> Still a relevant idea.
15:10:26 <tuxayo> > Should proposals emerge we can give preference to within the geographic limit.
15:10:26 <tuxayo> right, so geo priority but not geo restriction.
15:10:35 <fridolin> you mean "this year=2022" ?
15:10:42 <tuxayo> yes
15:12:17 <fridolin> I say : lets change "geo limit" with "geo priority" for 2022
15:12:29 <fridolin> +extending
15:12:52 <fridolin> i see email is from 18 nov so short to build a proposal
15:13:12 <fridolin> and lets sent a reminder email
15:14:01 <tuxayo> Anyone up for taking the action of asking on the ML for the above changes? And announcing at the beginning of January these changes  if there was not opposition?
15:14:22 * fridolin can take
15:16:27 <tuxayo> #action fridolin asks general ML about the discussed KohaCon22 bidding changes and announcement them at the beginning of January if there was not opposition.
15:16:36 <tuxayo> fridolin++
15:16:38 <koha-jenkins> Project Koha_21.11_D10 build #20: UNSTABLE in 47 min: https://jenkins.koha-community.org/job/Koha_21.11_D10/20/
15:16:49 <tuxayo> CC kohadevel ML might help also
15:17:07 <tuxayo> Anything else about KohaCon?
15:17:41 <fridolin> i will had a call for sponsorship
15:17:57 <fridolin> they can already tell if they are interested
15:18:18 <fridolin> ( see KohaCon21 final email )
15:19:07 <tuxayo> ok thanks
15:19:19 <tuxayo> #topic Update from the Release manager (22.05)
15:19:33 <tuxayo> #link https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29652#c1
15:19:33 <huginn`> 04Bug 29652: enhancement, P5 - low, ---, koha-bugs, NEW , Move Koha::Biblio->get_marc_* to Koha::Biblio::Metadata
15:19:56 <tuxayo> the mic ๐ŸŽ™๏ธ is your's fridolin :)
15:19:58 <fridolin> just to point out a dev decision
15:20:14 <fridolin> Any reason to keep marcflavour has param ?
15:20:18 <koha-jenkins> Project Koha_21.05_U21 build #59: SUCCESS in 40 min: https://jenkins.koha-community.org/job/Koha_21.05_U21/59/
15:20:28 <fridolin> instead of fetching syspref
15:20:57 <fridolin> we must be consistant in all get_marc_*()
15:21:05 <fridolin> consistent
15:22:24 <tuxayo> no idea about this ^^"
15:22:25 <fridolin> tuxayo: lets postpone
15:23:30 <fridolin> For the other news of RM : i'm good
15:23:33 <tuxayo> #action fridolin bring back the topic of keeping or not marcflavour a param for: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29652#c1
15:23:33 <huginn`> 04Bug 29652: enhancement, P5 - low, ---, koha-bugs, NEW , Move Koha::Biblio->get_marc_* to Koha::Biblio::Metadata
15:24:03 <tuxayo> #topic Updates from the Release Maintainers
15:24:06 <tuxayo> rmaints?
15:24:07 <wahanui> rmaints is probably khall, AndrewFH, wainui and tuxayo
15:25:11 <tuxayo> We forgot to ask if the default release date (today/tomorrow) is okay since many people might be on leave
15:25:38 <tuxayo> AndrewFH: what about you? Do you know how would it be for khall?
15:25:39 <tcohen> hola
15:25:44 <tuxayo> o/
15:25:51 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
15:26:07 <AndrewFH> #info Andrew Fuerste-Henry, ByWater Solutions
15:26:37 <AndrewFH> hi! I'm ok with releasing today or tomorrow, but I'm not sure about khall. he's on vacation
15:26:46 <tcohen> he already released!
15:26:52 <AndrewFH> oh! I missed it
15:26:59 <tcohen> I saw an email in the list
15:27:05 <tcohen> a few minutes ago
15:27:18 <tuxayo> indeed!!
15:27:19 <tuxayo> https://git.koha-community.org/Koha-community/Koha/tags
15:27:30 <nugged> ๐Ÿ˜…
15:27:31 <AndrewFH> cool cool. I'll do the same in a bit here
15:27:48 <tcohen> AndrewFH++
15:28:33 <AndrewFH> (now I need to run off to the dentist, bye!)
15:28:43 <tuxayo> o/
15:28:54 <tuxayo> great so let's do that, let's release today or tomorrow
15:29:14 <schnydszch> mtj: thanks for bringing that one up. I moved the directory for that and I am now able to access /api/v1/.html without the Internal Server Error. the error now is Error 404
15:29:18 <tuxayo> I think wainui will also release a 19.11.x
15:30:02 <tcohen> cool
15:30:32 <tuxayo> #action tuxayo inform mtj about the minor release (and no big deal if packages come after, no hurry for this one)
15:30:51 <fridolin> tuxayo++
15:31:01 <tuxayo> #topic  Updates from the QA team
15:31:25 <tuxayo> cait sent apologies, not able to attend this meeting.
15:31:26 <tuxayo> qa_team?
15:31:27 <wahanui> qa_team is cait, joubu, dcook, ashimema, marcelr, kohaputti, tcohen, kidclamp, khall, tuxayo, petrova, nugged
15:32:13 <tcohen> Katrin sent the las QA email for 2021. She tried to prioritize the important bugs on BZ
15:32:28 <tcohen> and also pointed specific team members to specific bugs
15:33:05 <fridolin> cait++
15:33:14 <tcohen> in an attempt to get security and major bugs more attention
15:33:18 <tcohen> cait++
15:33:31 <tuxayo> There were some recent emails about the need to focus first on critical and security bugs when there are. cait's weekly emails already do the triage work about that
15:33:32 <tuxayo> cait++
15:33:56 <schnydszch> sorry about that, dev IRC meeting ongoing :)
15:34:05 <tuxayo> moving on?
15:34:08 <fridolin> I have a QA question : Adding test of _()/__() in QA tools ?
15:34:54 <tuxayo> what would this check do?
15:34:58 <tcohen> file an issue on the qa-test-tools repo?
15:35:03 <tuxayo> It's about string translation?
15:35:19 <fridolin> yep we have several bugs on that mistake
15:35:28 <fridolin> ah issue yep
15:35:38 <fridolin> will do
15:36:06 <tuxayo> What is the mistake? So we can pay attention to it meanwhile.
15:36:23 <davidnind> example bug 29588
15:36:23 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29588 normal, P5 - low, ---, jonathan.druart+koha, Pushed to master , Yesterday and tomorrow in datepicker don't translate
15:37:29 <tcohen> _() should be used in .tt files, and __() on include .js files?
15:37:34 <fridolin> exactly
15:37:34 <tcohen> is that it?
15:37:50 <fridolin> that is what i understand
15:37:58 <tuxayo> ok thanks!
15:38:29 <fridolin> tcohen: do we use qa-test-tools repo issues ?
15:38:49 <tuxayo> https://gitlab.com/koha-community/qa-test-tools/-/issues/
15:39:40 <tcohen> yes
15:39:42 <tuxayo> #action fridolin open a ticket for qa-test-tools about using _() or __() in the right context. .tt files vs .js files
15:39:49 <fridolin> thanks a lot
15:40:15 <tuxayo> thanks for the heads up, moving on
15:40:25 <tcohen> Joubu is not online, so it is safe to volunteer him haha
15:40:28 <tuxayo> #topic Updates from the documentation team
15:40:45 <davidnind> nothing to add to what was included in the agenda
15:40:51 <tuxayo> davidnind the mic ๐ŸŽ™๏ธ is your's ^^
15:41:01 <tuxayo> #info  First documentation IRC meeting for quite some time held on 16 December 2021
15:41:09 <tuxayo> #link https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_2021-12-16
15:41:30 <tuxayo> #info david:  I'm reviewing bugs pushed for 22.05 each week and updating a spreadsheet for documentation changes required for 22.05 - see 29640. As part of this I will:
15:41:35 <tuxayo> #info  add the Manual keyword to the bug if I think documentation changes are required, and
15:41:41 <tuxayo> #info  add or update the release notes text where required
15:41:44 <koha-jenkins> Project Koha_21.05_D10 build #187: SUCCESS in 1 hr 2 min: https://jenkins.koha-community.org/job/Koha_21.05_D10/187/
15:42:00 <tuxayo> #info When we have updated the documentation we will add a note to the bug saying:
15:42:09 <tuxayo> #info 1) Changes for this bug are now incorporated into the manual.
15:42:15 <tuxayo> #info 2) Here are the changes we have made (a link to the commit and section in the manual).
15:42:21 <tuxayo> #info 3. Any feedback or suggestions are welcome.
15:42:28 <tuxayo> #info 4) Remove the Manual keyword from the bug, if it was used, and add the new keyword Manual-updated.
15:42:43 <tuxayo> davidnind++
15:43:22 <tuxayo> thanks a lot :)
15:43:28 <davidnind> should start to see changes coming through soon for 21.11  backlog
15:43:42 <davidnind> :-D
15:44:08 <fridolin> super
15:44:22 <tuxayo> anything else to add?
15:44:52 <davidnind> that's all from me
15:45:22 <fridolin> Bug 29640
15:45:22 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29640 normal, P1 - high, ---, david, ASSIGNED , [DOCS 22.05] Documentation changes for 22.05
15:46:01 <tuxayo> #topic Status of roadmap projects
15:46:07 <tuxayo> #link https://annuel.framapad.org/p/koha_21.11_roadmap
15:46:22 <tuxayo> anyone on a topic have news?
15:47:31 <tuxayo> An item on the agenda has been adding fitting the topic of roadmap project: ES 6 EOL is soon
15:47:39 <tuxayo> bug 25439
15:47:39 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25439 enhancement, P5 - low, ---, koha-bugs, NEW , [Omnibus] Prepare Koha to ElasticSearch 7 - ES7
15:47:59 <tuxayo> There are a few changes to make for ES 7 to even start.
15:49:14 <fridolin> I'm made it a "topic"
15:49:19 <thd> Is the license change issue for Elastic to a non-OSI license something which should motivate consideration of the Amazon led fork OpenSearch?
15:49:40 <fridolin> indeed
15:49:46 <tuxayo> > Is the license change issue for Elastic to a non-OSI license something which should motivate consideration of the Amazon led fork OpenSearch?
15:49:46 <tuxayo> indirectly. Compatibility with ES 7 is needed for that.
15:50:20 <tuxayo> But it itself that needed even without considering ES 7 license change
15:50:32 <koha-jenkins> Yippee, build fixed!
15:50:32 <wahanui> Congratulations!
15:50:33 <koha-jenkins> Project Koha_21.11_D10 build #21: FIXED in 42 min: https://jenkins.koha-community.org/job/Koha_21.11_D10/21/
15:52:03 <tuxayo> How have we handle these kind of compat changes in the past?
15:52:24 <thd> Amazon may be the bad actor but if OpenSearch has enough independence it may be favored as MariaDB has been for MySQL.
15:52:33 <tuxayo> Were we just lucky and someone had the time to look into it before if became an issue? ^^"
15:54:08 <tuxayo> thd: hopefully it will be like that, MariaDB outcome was great.
15:54:52 <tuxayo> anyone up for a volunteer call in koha devel ML to get attention to ES 7 compat?
15:54:59 <fridolin> see https://github.com/opensearch-project/OpenSearch/pulse
15:56:22 <tuxayo> #action tuxayo calls for volunteers to work on ES 7 support in the koha-devel mailing list
15:56:55 <fridolin> tuxayo++
15:56:57 <tuxayo> fridolin: I'm not used to this page, we can see that the project is active, right?
15:57:17 <fridolin> yep its a start
15:57:34 <fridolin> we dont really see who is from Amazon
15:57:34 <tuxayo> moving on?
15:57:38 <fridolin> sur
15:59:27 <tuxayo> > we dont really see who is from Amazon
15:59:27 <tuxayo> a quick glace tells me it's between half and 2/3 of the top 10 contribs last month (does it includes tickets?)
15:59:32 <tuxayo> *glance
16:00:08 <tuxayo> not a concentrated as I though it would be but we will see, it was a quick check
16:00:38 <tuxayo> #topic  General development discussion (trends, ideas, ...)
16:01:05 <tuxayo> anything urgent? otherwise, putting in the agenda of next meeting would be better
16:01:16 <tuxayo> so we would have more time and a wider audience
16:02:03 <tuxayo> #topic Review of coding guidelines
16:02:08 <thd> Any code in Koha for Elastic Search should also work for OpenSearch at present.
16:02:44 <tuxayo> fridolin: as these are your's subtopics? https://wiki.koha-community.org/wiki/Development_IRC_meeting_22_December_2021
16:03:28 <tuxayo> Would postponing the 3 undone be be okay? for the above reasons
16:04:01 <tuxayo> *are there are your subtopics
16:04:04 <tuxayo> *these
16:04:09 <tuxayo> >_<
16:04:32 <davidnind> Have covered: Adding test of _()/__() in QA tools
16:04:50 <tuxayo> yes, 1 on the 4
16:05:23 <tuxayo> thd, indeed, I read that compat from OpenSearch with code working with ES7 will be ensured for now. (I forgot the details...)
16:05:29 <fridolin> tuxayo: yes postpone
16:06:08 <tuxayo> #action tuxayo put in next agenda the 3 postponed QA guidelines review topic
16:06:16 <tuxayo> #topic  Set time of next meeting
16:06:41 <tuxayo> 5 january, same hour?
16:06:46 <koha-jenkins> Yippee, build fixed!
16:06:46 <wahanui> Congratulations!
16:06:47 <koha-jenkins> Project Koha_21.11_U_Stable build #11: FIXED in 59 min: https://jenkins.koha-community.org/job/Koha_21.11_U_Stable/11/
16:07:56 <tuxayo> #info Next meeting: 5 January 2022, 15 UTC
16:08:04 <fridolin> cool
16:08:13 <tuxayo> #endmeeting