#koha: Development IRC meeting 24 February 2021

Meeting started by tuxayo at 20:05:48 UTC (full logs).

Meeting summary

  1. Introductions (tuxayo, 20:05:59)
    1. tuxayo/Victor Grousset, France (tuxayo, 20:06:12)
    2. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 20:06:15)
    3. Martin Renvoize, PTFS Europe (ashimema, 20:06:33)
    4. Katrin Fischer, Germany (cait, 20:07:45)

  2. Announcements (tuxayo, 20:08:51)
  3. Update from the Release manager (21.05) (tuxayo, 20:10:26)
    1. apologies from Joubu: (mostly afk this week) (tuxayo, 20:10:52)

  4. Updates from the Release Maintainers (tuxayo, 20:11:23)
    1. 2 security fixes and one bad bug that managed to get into this release (all 3 branche). team++ (tuxayo, 20:12:16)

  5. Updates from the QA team (tuxayo, 20:12:54)
    1. Thomas Dukleth, Agogme, New York City (thd, 20:13:20)

  6. Status of roadmap projects (tuxayo, 20:16:44)
    1. https://annuel.framapad.org/p/koha_21.05_roadmap (tuxayo, 20:16:57)
    2. Notices and Slips improvements slowly starting to move forward.. some foundational bugs need testing/QA . Listed on the pad (ashimema, 20:18:08)
    3. Translations.. not moved since last meeting.. needs a retest and getting moving again. Fresh eyes welcome (ashimema, 20:19:03)
    4. Transfers - Phase one is PQA, awaiting Joubu's review and push (ashimema, 20:20:10)
    5. Money - Likely delayed to next cycle (ashimema, 20:20:14)
    6. Performance - Moving ES indexing to background jobs.. background job infrastructure work underway to support this move better (ashimema, 20:20:59)
    7. Git shrinking - Joubu and I will look into this again soon (ashimema, 20:21:35)
    8. News - On my list to revisit.. not sure of current state. (ashimema, 20:22:05)
    9. Manual translations - The hosting is currently being upgraded for disk space which should get us back to building. The. We need to get back to next steps again. (ashimema, 20:23:50)

  7. Actions from last meeting (tuxayo, 20:24:26)
    1. ACTION: amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc. (tuxayo, 20:24:50)

  8. General development discussion (trends, ideas, ...) (tuxayo, 20:25:25)
  9. Review of coding guidelines (tuxayo, 20:35:01)
    1. VOTE: Voted on "Ok for using OPAC instead of Opac or opac?" Results are, yes: 4 (tuxayo, 20:47:40)

  10. Set time of next meeting (tuxayo, 20:48:07)
    1. Next meeting: 10 March 2021, 15:00 UTC (tuxayo, 20:51:14)


Meeting ended at 20:51:18 UTC (full logs).

Action items

  1. amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.


People present (lines said)

  1. tuxayo (51)
  2. ashimema (36)
  3. oleonard (14)
  4. huginn (7)
  5. davidnind (6)
  6. cait (5)
  7. thd (4)
  8. wahanui (3)
  9. caroline (1)


Generated by MeetBot 0.1.4.