14:02:44 <Joubu> #startmeeting Development IRC meeting 28 July 2021
14:02:44 <huginn> Meeting started Wed Jul 28 14:02:44 2021 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:44 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:44 <huginn> The meeting name has been set to 'development_irc_meeting_28_july_2021'
14:02:51 <kidclamp> info Nick Clemens,  ByWaterSolutions
14:02:54 <Joubu> #topic Introductions
14:02:59 <Joubu> #info Jonathan Druart
14:03:03 <nugged> #info Andrew Nugged, National Library of Finland, HELSINKI
14:03:04 <kidclamp> #info Nick Clemens,  ByWaterSolutions
14:03:06 <petrova> #info Peter (Petro) Vashchuk, National Library of Finland, HELSINKI
14:03:31 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_28_July_2021
14:03:42 <tuxayo> #info tuxayo/Victor Grousset, France
14:03:47 <khall> #info Kyle Hall, ByWater Solutions
14:03:52 <Joubu> cait1, tcohen, oleonard?
14:03:52 <thd> #info Thomas Dukleth, Agogme, New York City
14:03:59 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:04:05 <Joubu> #topic Announcements
14:04:10 <oleonard> I'm here Joubu it just take a long time to type all that :D
14:04:23 <marcelr> #info Marcel de Rooy, Rijksmuseum, Netherlands
14:04:25 <Joubu> I got a reply for the KohaCon21 team, and they sent an email to koha-devel
14:04:30 <Joubu> "Website of Kohacon2021 has been live. Kindly checked and inform then community accordingly." - http://kohacon2021.org
14:04:52 <Joubu> #info KohaCon21 has a website! http://kohacon2021.org
14:05:00 <tuxayo> :D
14:05:10 <marcelr> https
14:05:45 <Joubu> https://kohacon2021.org/submissions/
14:05:46 <Joubu> indeed
14:06:06 <Joubu> Anyone have something to announce?
14:06:14 <Joubu> (that is not related to the roadmap topics)
14:06:50 <Joubu> #topic Update from the Release manager (21.11)
14:07:00 <Joubu> Last week has been a bit chaotic for Jenkins after I pushed bug 17600. But it looks quite stable now.
14:07:00 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17600 enhancement, P5 - low, ---, jonathan.druart+koha, CLOSED FIXED, Standardize the EXPORT
14:07:08 <Joubu> It's still not green, for other reasons (bug 28632 and bug 28585).
14:07:08 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28632 normal, P5 - low, ---, tomascohen, In Discussion , patrons.t fragile on slow boxes
14:07:09 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28585 major, P5 - low, ---, tomascohen, Pushed to master , Cannot search on date fields
14:07:14 <Joubu> Other things coming later (roadmap)
14:07:19 <Joubu> any questions?
14:07:40 <Joubu> #topic Updates from the Release Maintainers
14:07:44 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:08:07 <Joubu> I think Kyle is going to announce 21.05.02 soon
14:08:21 <tuxayo> #info 20.05x & 20.11.x : last release went well.
14:08:24 <Joubu> others have been announced already I think
14:08:59 <Joubu> #topic Updates from the QA team
14:09:22 <cait1> #info Katrin Fischer, BSZ, Germany
14:09:26 <kidclamp> Trying to QA stuff and filing more bugs as i go :-)
14:09:59 <cait1> for Kohacon - can/shall I add the link to the webseite?
14:10:13 <cait1> sorry, was too late :)
14:10:39 <cait1> QA queue looks reasonable, but we have a lot of bigger patches I think and the NSO and bad bugs are up
14:10:59 <Joubu> cait1: yes I think so
14:11:22 <cait1> so... no time to rest really
14:11:43 <cait1> Joubu: do you want to higlight specific ones?
14:11:53 <Joubu> everything is a bit slow for the last weeks, maybe because of the holidays going on?
14:12:22 <Joubu> cait1: not now
14:12:51 <cait1> I believe it's the summer holidays yes
14:13:00 <cait1> at least in Europe... but that makes quite a few of the team
14:13:05 <Joubu> we lack QA dynamic
14:13:22 <Joubu> ok, moving on then..
14:13:28 <Joubu> Status of roadmap projects
14:13:31 <Joubu> #topic Status of roadmap projects
14:13:35 <Joubu> I am going to list some topics on which I'd like to provide some info.
14:13:43 <Joubu> About the following two topics:
14:13:46 <Joubu> * Remove Mod/AddItemFromMarc from item form
14:13:49 <Joubu> * Refactor BackgroundJobs into Tasks
14:13:58 <Joubu> I have spent several days working on adapting batchMod.pl (aka batch item deletion and modification) to use the task queue/Koha::BackgroundJobs. See bug 28445.
14:13:58 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28445 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Use the task queue for the batch delete and update items tool
14:14:04 <Joubu> The changes look great to me, and I really would like to see it pushed ASAP.
14:14:09 <Joubu> I remind you that we removed the progress bar on the batch item mod for 21.05.00 which makes it high priority for 21.11.
14:14:29 <Joubu> There is a commit message with all the details and a complete test plan on bug 28445 comment 8. There is also a remote branch (on my gitlab) with all the patches applied.
14:14:32 <Joubu> Please test and provide me feedback :)
14:14:49 <oleonard> Joubu++
14:14:49 <Joubu> And, it's fun to test!
14:14:57 <cait1> I'll be more available for testing in early August
14:15:09 <cait1> and Joubu++ for pushing those projects :)
14:15:14 <khall> Joubu++
14:15:40 <Joubu> any questions about this?
14:16:00 <Joubu> * Improve the update database proces
14:16:05 <Joubu> I really need this ASAP - bug 25078, please?
14:16:05 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25078 enhancement, P5 - low, ---, jonathan.druart+koha, Signed Off , Update DB process - wrap each DBRev inside a transaction and better error handling
14:16:38 <Joubu> And, as I am RM and I am the one that bothers, I might push it without PQA stamp (what I would like to avoid)
14:17:02 <Joubu> Any objections about this move?
14:17:15 <khall> Joubu I will QA it
14:17:22 <Joubu> thx khall!
14:17:32 <Joubu> #action khall QA 25078
14:17:34 <Joubu> :D
14:17:39 <Joubu> * Improve our "news" module
14:17:47 <Joubu> Bug 22544 has been pushed and bug 24387 is waiting for QA
14:17:47 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22544 enhancement, P5 - low, ---, jonathan.druart+koha, RESOLVED FIXED, Move C4:NewsChannels to Koha namespace
14:17:48 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24387 enhancement, P5 - low, ---, jonathan.druart+koha, Signed Off , Rename News tool
14:18:37 <Joubu> This is a nice move as well. It extends (at least better than now) the "news" area/code/db/ui to handle several type of content
14:18:53 <Joubu> it's still not perfect but goes into the right direction IMO
14:19:30 <Joubu> QAers, action?
14:20:24 <Joubu> * Get rid of non-XSLT views
14:20:28 <Joubu> Bug 12561 is ready for testing!
14:20:28 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12561 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Remove non-XSLT views
14:20:43 <Joubu> We have been waiting for this one for....
14:20:50 <marcelr> push it
14:20:50 <tcohen> 10 years?
14:20:53 <Joubu> ho, 7 years
14:20:58 <Joubu> please, test it!
14:21:00 <oleonard> Oh I didn't see that... I'll test it today
14:21:00 <tcohen> I'd like ti test it
14:21:27 <Joubu> #action oleonard is going to test 12561
14:21:31 <Joubu> thx!
14:21:38 <Joubu> * Remove remaining SQL based installers (fr-FR, fr-CA, nb-NO) (bug 27829)
14:21:38 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27829 enhancement, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] Remove specific LANG installer data
14:21:43 <Joubu> another big moves, cannot wait for too long
14:21:47 <Joubu> I want it for 21.11
14:21:55 <Joubu> Bug 27101 is ready for testing and bug 27622 needs bug 18984 first.
14:21:55 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27101 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Remove fr-CA installer data
14:21:56 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27622 minor, P5 - low, ---, magnus, NEW , Remove nb-NO installer data
14:21:57 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18984 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Remove support for NORMARC
14:22:03 <Joubu> About fr-FR (bug 27619), Bernardo is working on providing a yaml installer file for UNIMARC frameworks.
14:22:03 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27619 minor, P5 - low, ---, koha-bugs, NEW , Remove fr-FR installer data
14:22:09 <Joubu> The work is huge and will need to be move fast once it's submitted.
14:22:14 <Joubu> wI will keep you in touch!
14:22:20 <marcelr> what will be the work flow ?
14:22:25 <Joubu> but at least we have 2 ready for testing already
14:22:49 <Joubu> everything in the default yml
14:23:05 <Joubu> the strings are extracted, translatable via pootle, etc.
14:23:10 <Joubu> normal workflow for translation
14:23:24 <Joubu> it's already how it works for all other languages, expect those 3 ones
14:23:33 <Joubu> that's why we don't want to keep them anymore
14:23:53 <Joubu> was it your question, marcelr?
14:24:07 <tcohen> +1
14:24:12 <marcelr> hmm and when someone adds notices or other translatable stuff?
14:24:37 <Joubu> marcelr: it's already how it works for a couple of release
14:24:49 <cait1> just as info: have added the kohacon21 to the website.. still working out sorting in the menu, but proof reading would be nice
14:24:55 <Joubu> marcelr: have a look at installer/data/mysql/en/mandatory/sample_notices.yml
14:25:14 <cait1> marcelr: we switched all installers already last release, apart from these 3
14:25:17 <marcelr> yeah my question is the language stuff
14:25:24 <cait1> so if you add a new notice
14:25:35 <cait1> you need to change the notices.yml or someting and those 3 installers
14:25:44 <cait1> once they are gone, we can only change the .yml
14:26:24 <cait1> and the po files will catch it
14:26:33 <marcelr> great
14:26:36 <cait1> if you have things specific to a language, you can add a custom .sql file
14:26:47 <cait1> look ad de-DE - we use it to set up some prefs etc.
14:26:55 <cait1> dateformat and such
14:26:59 <Joubu> bug 13897 was the first move, part of 20.05
14:26:59 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13897 enhancement, P5 - low, ---, bgkriegel, CLOSED FIXED, Use YAML files for installer data
14:27:20 <Joubu> and there is a custom.sql for localization stuffs
14:27:38 <Joubu> installer/data/mysql/localization/de-DE/custom.sql for instance
14:28:27 <Joubu> ok, moving on
14:28:28 <Joubu> * Merge 'issues' and 'reserves' tables with the old* counterparts
14:28:33 <Joubu> There were some movements on bug 25260. Ready for testing again!
14:28:33 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25260 enhancement, P5 - low, ---, tomascohen, Needs Signoff , Merge 'reserves' and 'old_reserves' into a new 'holds' table
14:28:39 <Joubu> tcohen, something to add?
14:29:07 <tcohen> There was a test failure for which help is welcome
14:29:45 <tcohen> Please test!
14:29:46 <tcohen> :-D
14:30:01 <Joubu> tuxayo is saying it's not working ;)
14:30:04 <tuxayo> And a new warning about a notice template not found
14:30:05 <Joubu> but still NSO
14:30:23 <tcohen> will check!
14:31:24 <Joubu> * Wiki migration
14:31:38 <Joubu> I am waiting for thd reply to provide a version of what could be the new wiki, for testing
14:31:49 <Joubu> but he pingued me right before the meeting
14:32:16 <thd> I saw last weeks email today.  Last week I had to meet with my new landlord.
14:32:30 <tcohen> tuxayo you need to start over with ALL the patches applied
14:32:34 <Joubu> my main concern with your approach is the lack of versioning
14:32:48 <tcohen> it is not a 'rename this thing' atomic update (the last patch)
14:33:03 <Joubu> updating a .tar.gz with a bunch of directories and files make changes hard to follow
14:34:24 <thd> Versioning has been primitive and included a partial archive of image files etc. from the current wiki which I have moved over time.
14:35:18 <Joubu> thd: waiting for your reply by email
14:35:53 <thd> Changes have been documented in a changelog file but obviously not proper version control.
14:36:18 <Joubu> rm the unecessary files; git init; git add .; git commit -m"init"
14:36:20 <Joubu> then we are good :)
14:36:50 <Joubu> Should we approach another topic from the roadmap?
14:37:01 <Joubu> Did I miss one with activity on it?
14:37:34 <Joubu> I think I will reorder the different topics and move some of them down. Those that are lacking interest
14:38:10 <cait1> ok
14:39:56 <Joubu> No other topics? Only "mine"?
14:40:04 <marcelr> :)
14:40:11 <Joubu> Good, easy to choose then :)
14:40:16 <marcelr> you are the roadmap
14:40:37 <Joubu> :D
14:40:47 <Joubu> #topic Actions from last meeting
14:40:51 <Joubu> *     ashimema Talk to key players about message passing for alerts
14:41:00 <Joubu> we have been seeing this one for weeks
14:41:11 <Joubu> #action ashimema Talk to key players about message passing for alerts (last postpone)
14:41:17 <Joubu> #topic General development discussion (trends, ideas, ...)
14:41:26 <Joubu> #topic Where/how to add helper methods/static methods for objects - Bugs 28709, 20817
14:41:31 <Joubu> kidclamp?
14:41:39 <kidclamp> Hello
14:41:41 <Joubu> kidclamp sent an email to koha-devel about that
14:42:00 <kidclamp> We just need a decision about where/ow to add these methods
14:42:04 <marcelr> probably there is no generic answer
14:42:06 <Joubu> I bet everybody read it and have excellent suggestions
14:42:09 <kidclamp> :-)
14:42:29 <tuxayo> Of course! https://lists.koha-community.org/pipermail/koha-devel/2021-July/046618.html
14:42:40 <Joubu> I would start with: if you have "Util[s]" in the name of the module, you are wrong
14:42:46 <Joubu> because it's too generic
14:42:47 <kidclamp> Essentially, shoudl helper methods that don't use the objects be added to the Object modules, or a Util module
14:43:06 <Joubu> (and yes, I am the one who started C4::Utils)
14:43:11 <marcelr> imo a small helper method could be in the same module?
14:43:48 <marcelr> move it when it is needed on larger scale ?
14:44:34 <marcelr> Joubu: C4/Utils is a great name ;)
14:45:18 <Joubu> I had the same problem with 28445. Koha::Items->batch_update is calling a "apply_regex" method
14:45:32 <Joubu> but Koha::Items->apply_regex does not make sense (it's where it is, still...)
14:45:51 <Joubu> and it's hard to find another place because we don't have "generic but not to generic" modules
14:45:58 <Joubu> too*
14:46:35 <khall> Joubu this is why static methods exist in OOP, to keep related methods within the same class
14:47:15 <Joubu> it should be static and private then
14:47:35 <Joubu> but the apply_regex actually apply a regex on any strings :)
14:47:42 <tcohen> https://gitlab.com/thekesolutions/plugins/koha-plugin-innreach/-/blob/master/Koha/Plugin/Com/Theke/INNReach/Normalizer.pm
14:47:46 <Joubu> so it shouldn't belong to Koha::Items
14:47:50 <marcelr> that one could move
14:48:01 <tcohen> sample OO class for munging strings
14:48:01 <Joubu> but all can move :)
14:48:05 <Joubu> that was my point
14:48:23 <marcelr> depends if you think it will be used elsewhere too
14:48:31 <marcelr> this sounds like that
14:48:46 <marcelr> not just a private thingy
14:49:05 <khall> yeah, in this example, custom_cover_image_url would *not* be privige
14:49:53 <khall> but there's no reason to move it out of Koha::Biblio, it can and imo should be a static method since the code relates directly to Biblios
14:50:16 <marcelr> good case for keeping it
14:50:22 <Joubu> because you could get the url for an item? :)
14:50:29 <Joubu> cover images are for items as well now
14:51:02 <Joubu> so imo it should be part of a Koha::CoverImage[::Local?] module
14:51:06 <Joubu> and be a static method
14:51:53 <cait1> Sorry, have to leave a little early
14:53:01 * kidclamp can be convinced either way - I just want a path to PQA :-P
14:53:39 <Joubu> I don't care about your example, it can go however you want
14:53:57 <Joubu> but it would be good to discuss the problem, because it's global
14:54:10 <Joubu> we are recreating the "monolithic modules" problem we had with C4
14:54:50 <Joubu> "holdability calculation" business exploded in different Koha:: classes, etc. for instance
14:55:30 <Joubu> ok ok
14:55:50 <tcohen> I think we need to discuss case by case, sorry
14:55:55 <Joubu> a monologue was not the point, and I don't try to convince any of you about where we should have the image_url method
14:56:17 <marcelr> Koha is a mess before C4 disappears?
14:56:23 <khall> Joubu if I module gets to big, we can break it up, but there's no reason to create a new module to hold one sub
14:57:38 <tcohen> there are reasons
14:57:43 <tcohen> he, design reasons
14:57:46 <Joubu> it was an example
14:57:56 <tcohen> if you consider cover images as resources
14:58:01 <Joubu> Koha::Patron->queue_notice # this is not a patron business
14:58:22 <tcohen> we could make them fit the RESTful API design and be embeddable, etc
14:58:27 <Joubu> (and that's only an other example)
14:58:31 <marcelr> we could have a conference about these
14:59:10 <tcohen> like Koha::Item->cover_images return an array of Koha::CoverImage objects that know how to render themselves on an API response
14:59:31 <marcelr> cool
15:00:36 <Joubu> kidclamp: go with that, and open another bug report, please?
15:00:45 <Joubu> "with that" => your version
15:01:01 <Joubu> moving on?
15:01:13 <Joubu> #topic Can we move forward on Bug 28376 - Replace obsolete jquery-ui-timepicker-addon?
15:01:13 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28376 enhancement, P5 - low, ---, oleonard, In Discussion , Replace obsolete jquery-ui-timepicker-addon
15:01:18 <Joubu> oleonard: ?
15:01:28 <Joubu> (yes, replace)
15:01:40 <oleonard> I don't know if anyone has had a chance to look, but I've added a revised patch
15:01:57 <oleonard> It makes some improvements to integration and provides more examples of implementation
15:01:59 <Joubu> not yet, but I will
15:02:22 <oleonard> I'm very happy so far with its functionality
15:02:29 <kidclamp> Joubu: okay for me, but bug 28071? and there is another recently complaining og utl
15:02:29 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28071 new feature, P5 - low, ---, koha-bugs, NEW , Ability to batch remove titles from a list
15:02:34 <kidclamp> of util
15:02:38 <Joubu> if you are happy, we will be happy for sure :)
15:03:20 <oleonard> What kind of consensus do we want before it moves forward?
15:04:06 <Joubu> if it is looking good, works correctly, what else?
15:04:11 <tcohen> +1
15:04:22 <tcohen> Joubu you mentioned (yet) another library
15:04:33 <oleonard> It's a major change, so I wasn't sure if we wanted more than just a signoff.
15:05:06 <Joubu> if we want it into 21.11 it should be included soon
15:05:10 <oleonard> I'm hoping that we can start looking at replacing jQueryUI altogether as a next step.
15:07:07 <Joubu> I will try next week, oleonard
15:07:27 <Joubu> #topic Set time of next meeting
15:07:55 <Joubu> #info Next meeting: 11 August 2021, 14 UTC
15:08:21 <Joubu> #endmeeting