14:07:34 <Joubu> #startmeeting Development IRC meeting 5 May 2021
14:07:34 <huginn> Meeting started Wed May  5 14:07:34 2021 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:07:34 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:07:34 <huginn> The meeting name has been set to 'development_irc_meeting_5_may_2021'
14:07:52 <Joubu> #topic Introductions
14:07:57 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_5_May_2021
14:08:01 <Joubu> #info Jonathan Druart
14:08:02 <tuxayo> #info tuxayo/Victor Grousset, France
14:08:04 <tuxayo> thanks :D
14:08:05 <Joubu> qa_team?
14:08:05 <wahanui> qa_team is cait, dcook, amoyano, ashimema, marcelr, kohaputti, jajm, tcohen, josef_moravec, kidclamp, khall and tuxayo
14:08:08 <Joubu> rmaints?
14:08:08 <wahanui> rmaints is probably fridolin, AndrewFH and tuxayo
14:08:13 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:08:20 <kidclamp> #info Nick Clemens, ByWater Solutions
14:08:31 <thd> #info Thomas Dukleth, Agogme, New York City
14:08:35 <tuxayo> I need to make a bookmark folder with the meeting links useful to chair  ^^
14:08:52 <ashimema> #info Martin Renvoize, PTFS Europe
14:09:08 <Joubu> #topic Announcements
14:09:14 <cait1> #info Katrin Fischer, BSZ, Germany
14:09:46 <Joubu> I was in a meeting with BibLibre's sysop to get a new server for sandboxes. I have full access and will start the install very soon
14:10:04 <ashimema> Joubu++
14:10:07 <ashimema> sandboxes++
14:10:12 <Joubu> The goal is to make some instances available to the community to test the incoming release
14:10:15 <Joubu> biblibre++
14:10:15 <Joubu> lds++
14:10:36 <cait1> sounds great
14:10:37 <tuxayo> :D
14:10:38 <ashimema> :)
14:10:38 <tuxayo> biblibre++
14:10:39 <tuxayo> lds++
14:10:40 <cait1> lds++ biblibre++ Joubu++
14:10:42 <Joubu> not a big server but scalable when needed for hackfest
14:11:08 <cait1> will it be using the "newer" sandbox system?
14:11:08 <Joubu> anyone else?
14:11:19 <thd> I am about to post an update to Koha Wiki Database Migration and Upgrade scripts which will be more than an order of magnitude smaller for copying files for installation without redundancy in the archive.  Sorry for anyone who might have looked previously.
14:11:23 <Joubu> cait1: yes
14:11:42 <Joubu> I am planning to spend a bit of time on it to fix some bugs
14:12:21 <Joubu> thd: can you remind us where you put the code please?
14:12:23 <ashimema> very nice to be spreading the load sandboxes wise.. It'll be great having that extra set of eyes on bugs and improvements to make the sandboxes all the more usable
14:13:23 <tuxayo> > spreading the load sandboxes
14:13:23 <tuxayo> +1, so there isn't much pressure if on server is down
14:13:24 <thd> I will be updating the linked archive in the bug report.
14:13:47 <tuxayo> We have an almost complete 21.11 team :D The major thing missing is an RMaint for stable
14:13:48 <tuxayo> https://wiki.koha-community.org/wiki/Roles_for_21.11
14:14:29 <Joubu> yes, I wanted to highlight it in the next topic
14:14:30 <ashimema> ooh.. we're going for the full compliment I see..
14:14:43 <ashimema> stable, oldstable, oldoldstable and oldoldoldstable..
14:14:44 <Joubu> there are some "slot" still available
14:14:46 <thd> This file should be a more manageable archive in a few minutes, https://test01.agogme.com/koha_migrate_mwiki_db_and_upgrade_test.tgz .
14:14:47 <ashimema> not seen that for a while
14:14:57 <tuxayo> yep that looks good :)
14:15:00 <Joubu> we need a RMaint for 21.05 (or... I don't release it :D)
14:15:06 <oleonard> Joubu thanks for staying on for another release
14:15:06 <tuxayo> lol
14:15:10 <Joubu> we have 2 newcomers for the QA team
14:15:20 <Joubu> nugged++
14:15:24 <tuxayo> yep, Joubu++
14:15:42 <oleonard> Could each release maintainer move up one release and we'll drop support for 19.11 if necessary?
14:15:44 <Joubu> and... anyone interested by the new "IRC meeting facilitator" role?
14:15:44 <cait1> Joubu: sorry got called away - then we can maybe remove documentation for the older information from the wiki, let me know and i can do an update
14:15:54 <ashimema> That's great to see :)
14:16:06 <Joubu> thx thd
14:16:41 <cait1> Joubu++ nugged++
14:16:43 <tuxayo> > Could each release maintainer move up one release
14:16:43 <tuxayo> I was thinking that we might have to do that. A bit scared by oldstable but I should survive ^^"
14:16:57 <Joubu> oleonard: I guess Catalyst want to stay on 19.11 and so maintain it a bit longer
14:17:20 * oleonard wonders what that's about
14:17:35 <cait1> or maybe just starting out with the oldest?
14:17:43 <cait1> it's a good "start out" one
14:17:48 <tuxayo> > Catalyst want to stay on 19.11
14:17:48 <tuxayo> could be
14:17:56 <cait1> ah ok, so not sure
14:17:58 <ashimema> do biblibre utilise every release or are they a .11's only shop.. or similar
14:18:09 * ashimema is wondering if that's why Fridolin is sticking to the .11
14:18:13 <tuxayo> > maybe just starting out with the oldest
14:18:16 <tuxayo> could bit also, since I took oldoldstable ^^"
14:18:28 <tuxayo> > utilise every release
14:18:29 <tuxayo> only .11
14:18:30 <Joubu> Which "older information" are you talking about?
14:18:32 <ashimema> I could take on a .11, but the .05 aren't used by ptfs-e now so that would be a harder sell
14:18:42 <cait1> we aim for .11 at the moment, but we arenot set at it
14:18:50 <tuxayo> > that's why Fridolin is sticking to the .11
14:18:50 <tuxayo> Yes
14:19:02 <oleonard> Everyone should alternate .11 or .05 XD
14:19:54 <Joubu> kidclamp: do you know if someone at bywater is willing to maintain 21.05? :)
14:20:03 <tuxayo> Not a secret, their upgrade to 20.11 should be in july in case that info helps
14:20:14 <kidclamp> We are discussing - Kyle or I might be able to
14:20:19 <kidclamp> will let you know ASAP
14:20:28 <Joubu> thanks kidclamp!
14:20:40 <tuxayo> Thanks for considering the thing :D
14:20:42 <cait1> thx :)
14:20:50 <cait1> also still need documentation and translation managers i see
14:20:59 <cait1> caroline: maybe? *kitty eyes*
14:21:19 <tuxayo> > translation managers
14:21:19 <tuxayo> oh right 😱
14:21:21 <ashimema> perhaps we could share it kidclamp?
14:21:22 <cait1> (thought that would work better than puppy eyes in this case)
14:21:24 <Joubu> (but it's QA time that will be spend on RMaint.. :-/)
14:21:32 <caroline> I can do docs if no one wants to,,, I feel like I slacked off big time this cycle
14:21:42 <khall_> #info Kyle Hall, ByWater Solutions
14:21:46 <Joubu> oleonard: not interested by the new "IRC meeting facilitator" role?
14:21:51 <cait1> I didn't have the same feeling and still have tons to translate for 20.11 manual
14:22:00 <Joubu> or.. caroline?
14:22:02 <oleonard> Joubu: Sorry I can't take on anything new at the moment
14:22:02 <tuxayo> > we could share it
14:22:02 <tuxayo> The RMaint of stable?
14:22:08 <ashimema> tcohen.. is bernardo still OK doing translation management?
14:22:10 <tuxayo> > it's QA time that will be spend on RMaint
14:22:10 <tuxayo> Indeed
14:22:21 <caroline> what is irc facilitator?
14:22:31 <Joubu> https://wiki.koha-community.org/wiki/Project_roles#IRC_meeting_facilitator
14:22:39 <Joubu> The community has general and development IRC meetings respectively every 1 month and 2 weeks. The goal of this new role (from 21.11 development cycle) would be to:
14:22:42 <ashimema> caroline, I could pursuade lucy to help on docs ;)
14:22:43 <Joubu> Prepare in advance Chair Keep track of the actions for the next meeting and ping individual to know the progress Make a resume of the progress of the roadmap Anticipate with the next meeting date (watch out the timezones) Run the meeting script
14:22:59 <caroline> I don't think i'm orgnized enough to do that
14:23:43 <caroline> lucy is already a great help! she's my #1 <3
14:24:22 <caroline> if she wants to take a swing at being manager I'd be happy to let her, or we could co-manage
14:24:46 <ashimema> maybe co-manage.. I'll grab her later and see what she says :)
14:25:17 <cait1> :)
14:25:18 <ashimema> Does Todd or anyone from KohaUS think the facilitator role might fit with their mantra?
14:25:40 <cait1> bernardo might just need to be asked - not sure how close he follows mailing list/release schedule
14:25:50 <cait1> Andrew maybe?
14:26:10 <Joubu> cait1: I will send him an email after the meeting
14:26:35 <ashimema> Andrew for what.. IRC Facilitator.. which Andrew?
14:26:56 <Joubu> AndrewFH
14:27:32 <Joubu> @later tell AndrewFH we all think you would be a great IRC meeting facilitator https://wiki.koha-community.org/wiki/Project_roles#IRC_meeting_facilitator Are you willing to try it for the next release cycle?
14:27:33 <huginn> Joubu: The operation succeeded.
14:27:52 <caroline> you have been volunteered as tribute
14:27:53 <Joubu> ok, moving on?
14:27:58 <ashimema> lol
14:28:12 * fridolin sorry I had netwrok issues
14:28:17 <Joubu> #topic Update from the Release Manager (21.05)
14:28:27 <Joubu> not much to say, release is approaching, keep an eyes on the 21.05 tags. https://frama.link/koha_bz_rel_21_05_candidate
14:28:40 <Joubu> hard feature freeze ends in a couple of days
14:28:54 <fridolin> #info Fridolin Somers, Biblibre, France
14:29:00 <Joubu> #link https://frama.link/koha_bz_rel_21_05_candidate # This is the list of things you must keep an eye on for the next couple of weeks
14:29:24 <Joubu> any questions about 21.05?
14:29:52 <Joubu> #topic Updates from the Release Maintainers
14:29:59 <fridolin> We will release around 25/26 may, to be before 21.05 release
14:30:17 <ashimema> :)
14:30:26 <fridolin> 24/25 I mean
14:30:36 <fridolin> no big problems with 20.11.x I'd say /D
14:30:38 <fridolin> :D
14:30:52 * fridolin will continue RMaint on this branch for next cycle
14:30:55 <cait1> fridolin++
14:31:00 <Joubu> #info May stable releases planned on 24/25th
14:31:05 <tuxayo> 19.11 is fine
14:31:09 <tuxayo> fridolin++
14:31:22 <fridolin> we search a Rmaint for 21.05.x right ?
14:31:51 <fridolin> https://wiki.koha-community.org/wiki/Roles_for_21.11
14:31:56 <Joubu> yes fridolin, maybe kidclamp or khall. Or it will be you
14:32:01 <tuxayo> fridolin: yep: http://irc.koha-community.org/koha/2021-05-05#i_2350959
14:32:06 <ashimema> lol
14:32:30 <Joubu> #topic Updates from the QA team
14:32:41 <cait1> oops, almost missd my topic
14:32:52 <cait1> thanks to everyone doing QA the last few weeks!
14:33:09 <cait1> still as always tons to do, please QA away with RM priorities in mind for release!
14:33:12 * ashimema cuaght back up the leaderboard by the end of the month
14:33:26 <cait1> I'd also like to put a bit more focus on "oldest first" next release cycle
14:33:48 <cait1> i have neglected the old bugs in favor of the bad bugs a bit... but it's really hard to choose, more hands should help
14:33:56 <cait1> I hope
14:33:57 <ashimema> There's a fair few 'In discussion' on the rel_21_05 and RM priority list right now
14:34:02 <ashimema> I'm not sure how to get them moving again
14:34:28 <cait1> maybe we could discuss some of them on irc (outside the meeting)
14:34:56 <ashimema> regarding "oldest first".. I struggle at times doing that when it often takes a while for devs to get back to queries for older ones.. it's a hard thing to juggle
14:35:32 <ashimema> yeah. lets try to get some moving after this meeting
14:36:06 <ashimema> oldest first.. I'd suggest when pikcing a bug.. it's often worthwhile poking the dev to arrange a mutually agreeable slot..
14:36:14 <Joubu> it's quite easy for the next couple of weeks to choose, it's either bugfixes to write/test/QA
14:36:19 <Joubu> or find bugs
14:36:26 <Joubu> and you have 2 days for small enhancements
14:36:29 <ashimema> deffo the next few weeks is easy to choose
14:37:00 <cait1> yes
14:37:11 <Joubu> moving on?
14:37:11 <cait1> i just think out of fairness we need to avoid having stuff sittitng for too long waiting
14:37:18 <cait1> so it's as always a matter of balance
14:37:20 <ashimema> totally
14:37:27 <cait1> yep
14:37:29 <cait1> moving on
14:37:40 <Joubu> #topic Status of roadmap projects
14:37:46 <Joubu> (insert void here)
14:38:02 <Joubu> #topic Actions from last meeting
14:38:11 <Joubu> * ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)
14:38:11 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27695 minor, P5 - low, ---, oleonard, Pushed to stable , Fix style of messages on Elasticsearch configuration page
14:38:11 <ashimema> ES Tests - Assume that's not moved :(
14:38:15 <Joubu> did you?
14:38:17 <ashimema> oh, ok
14:38:20 <Joubu> ashimema: nothing has moved
14:38:40 <ashimema> no, I think I need to regroup on writing that beggining of next cycle at this point
14:38:48 <ashimema> been trying to fit in as much QA as possible instead.
14:38:56 <ashimema> so please postpone it one last time :(!
14:38:58 <Joubu> do I postpone it?
14:39:04 <Joubu> #action ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)
14:39:07 <ashimema> yes please
14:39:10 <Joubu> * kidclamp Ask the ML for additional info about how to implement opt-out for notices. One idea would be to have "My message" at the OPAC
14:39:32 <Joubu> I don't think I saw it on the list
14:39:35 <ashimema> roadmap wise.. the slips stuff has moved a little :).. the accounts slips all now run through GetPreparredLetter.. that was my starting point ;)
14:40:40 <ashimema> hmm.. I don't remember seeing such an email either
14:40:47 <Joubu> ashimema: I am abandoning the roadmap for 21.05 as it's too late. But will start a 21.11 one in the next 2,3 of weeks. Keep in mind your projects for 21.11 please
14:41:02 <Joubu> we will group them and form new action groups
14:41:04 <ashimema> ta
14:41:16 <Joubu> my goal for 21.11 is to work/help only things that are in the roadmap
14:41:50 <Joubu> #action kidclamp Ask the ML for additional info about how to implement opt-out for notices. One idea would be to have "My message" at the OPAC (postponed)
14:41:57 <Joubu> #topic General development discussion (trends, ideas, ...)
14:42:06 <Joubu> something else?
14:42:42 <Joubu> #topic Set time of next meeting
14:42:47 <Joubu> #info Next meeting: 19 May 2021, 14 UTC
14:43:17 <Joubu> 3
14:43:18 <Joubu> 2
14:43:20 <Joubu> 1
14:43:20 <cait1> :)
14:43:21 <cait1> go
14:43:22 <Joubu> #endmeeting