15:00:22 <Joubu> #startmeeting Development IRC meeting 7 April 2021
15:00:22 <huginn> Meeting started Wed Apr  7 15:00:22 2021 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:22 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:22 <huginn> The meeting name has been set to 'development_irc_meeting_7_april_2021'
15:00:29 <Joubu> #topic Introductions
15:00:32 <Joubu> rmaints?
15:00:32 <wahanui> rmaints is fridolin, AndrewFH and tuxayo
15:00:38 <Joubu> qa_team?
15:00:38 <wahanui> rumour has it qa_team is cait, dcook, amoyano, ashimema, marcelr, kohaputti, jajm, tcohen, josef_moravec, kidclamp, khall and tuxayo
15:00:41 <ashimema> #info Martin Renvoize
15:00:41 <wahanui> i guess #info Martin Renvoize is getting back the the Accounts Rewrite bugs
15:00:47 <Joubu> #info Jonathan Druart
15:01:05 <oleonard-away> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
15:01:15 <tuxayo> #info tuxayo/Victor Grousset, France
15:01:21 <thd> #info Thomas Dukleth, Agogme, New York City
15:01:53 <tuxayo> Thanks for the call :)
15:02:27 <Joubu> #topic Announcements
15:02:32 <Joubu> Anyone have something?
15:02:48 <thd> I have put up some testing sites
15:03:05 <thd> https://koha-mw-pg-test01.agogme.com/wiki/Main_Page
15:03:25 <thd> https://koha-mw-my-test01.agogme.com/wiki/Main_Page
15:03:51 <thd> Shortly there should also be https://koha-mw-my-test01-upgr.agogme.com/wiki/Main_Page
15:04:16 <Joubu> What are your plans, thd?
15:04:19 <thd> The last one will be upgraded to MediaWiki 1.35
15:04:33 <thd> I will post the code to get there later today
15:04:45 <tcohen> hi
15:04:59 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
15:05:13 <kidclamp> #info Nick Clemens, ByWaterSolutions
15:05:26 <thd> I merely plan to test upgrading to MediaWiki 1.35 in MySQL today
15:05:45 <thd> I also plan to test to different searches later.
15:05:50 <Joubu> we need to agree first on what we need
15:06:03 <thd> This is merely a test
15:06:05 <Joubu> it's not clear to me if we stick to Mediawiki or move to dokuwiki
15:06:49 <thd> People will obviously choose what to move to but we should test the possibilities.
15:07:24 <Joubu> in any cases please publish the steps to redo and the scripts, in case someone else wants to play with it as well
15:07:33 <thd> I intend to try testing two different searches one for current and one for old running in the same wiki.
15:08:49 <thd> Yes, I will publish today and continue to publish improvements.
15:09:21 <Joubu> we should also publish a plan and timeframe
15:09:33 <thd> Even, if we move everything to DokuWiki, this will make it easier.
15:09:58 <Joubu> maybe once 21.05 is published, I won't have much time to dedicate to that before end of May
15:10:03 <tcohen> Yeah, we need a timeframe
15:10:15 <Joubu> end of June
15:10:24 <tcohen> +1
15:10:53 <Joubu> anyone else?
15:10:58 <Joubu> something else?
15:11:03 <thd> I may have the upgrade working by the end of the meeting.
15:11:24 <Joubu> #topic Update from the Release Manager (21.05)
15:11:30 <Joubu> Slowly back to normal speed, processing the PQA queue.
15:11:48 <Joubu> I FQAed a bunch of bugs today
15:11:56 <Joubu> Please provide answers/feedback/follow-ups quickly to keep moving and have your stuffs pushed soon.
15:12:12 <Joubu> 21.05 will be released in about 1.5 month and big stuffs must be PQAed in the next two couple of weeks. Release dates will be published soon.
15:12:37 <Joubu> My wish list (as you are all asking for it): bug 27829 (see related), bug 27526, bug 22544 and bug 26703. And I will try to get back to bug 25078 ASAP.
15:12:37 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27829 enhancement, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] Remove specific LANG installer data
15:12:38 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27526 enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , Remove Mod/AddItemFromMarc from additem.pl
15:12:39 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22544 enhancement, P5 - low, ---, jonathan.druart, Signed Off , Move C4:NewsChannels to Koha namespace
15:12:40 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26703 enhancement, P5 - low, ---, wainuiwitikapark, Signed Off , We should reconsider best practice for our title elements
15:12:41 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25078 enhancement, P5 - low, ---, jonathan.druart, In Discussion , Update DB process - wrap each DBRev inside a transaction and better error handling
15:12:46 <Joubu> Should we create the "roles for 21.11" wiki page?
15:13:19 <ashimema> Yes, probably
15:13:19 <wahanui> probably is too hard.
15:13:27 <oleonard> good one wahanui
15:13:31 <Joubu> I'd like we create a ~"meeting facilitator" role
15:13:49 <Joubu> to prepare, organize ping people, deal with timezone, etc.
15:14:06 <Joubu> I will create it
15:14:17 <ashimema> Nice idea... I shan't be stepping forward for that one though, haha
15:14:22 <Joubu> #action Joubu create the "roles for 21.11" wiki page and send an email to the list
15:14:33 <ashimema> But I do imagine someone out there keen to help
15:15:01 <Joubu> any questions?
15:15:11 <Joubu> #topic Updates from the Release Maintainers
15:15:22 <Joubu> (I forgot)
15:15:24 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_7_April_2021
15:15:35 <Joubu> from Frido: Sorry I cant be there. All sounds good in 20.11.x. For next cycle I'd like to continue on this branch so oldstable then. Best regards :D
15:16:11 <Joubu> #info Fridolin is candidate for RMaint 20.11 during the next release cycle
15:16:16 <tuxayo> 19.11: last release when well
15:16:39 <Joubu> #topic Updates from the QA team
15:16:44 <Joubu> cait1: ?
15:17:01 <Joubu> SPREAD THE LOAD (still)
15:17:02 <Joubu> please
15:17:02 <ashimema> Numbers are high again
15:17:46 <Joubu> qa_team? please help on the final push during the next month
15:18:15 <Joubu> #info QA members should help a bit more on the final push during the next month
15:18:39 <tcohen> too many majors!
15:18:44 <ashimema> Indeed
15:19:07 <ashimema> How can we further motivate SO/QA.?
15:19:25 <Joubu> yes, and people shouldnt focus on new enhancements when we have as many majors
15:19:41 <tuxayo> Got it
15:20:18 <oleonard> QA folks please feel free to ask me to look at specific bugs for signoff if you'd like.
15:20:41 <ashimema> there needs to be a balance..
15:20:51 <Joubu> https://frama.link/koha_bz_nso-so-pqa_maj-blo-cri
15:20:58 <ashimema> how do we encourage devs and testers to spend time on Majors
15:21:05 <Joubu> all waiting for QA, and one for me
15:21:32 <ashimema> I try to pick them off, but need to also show movement on enhancements and new features
15:21:39 * tcohen will spend as many hours on those
15:21:54 <ashimema> and also find it hard picking off bugfixes when they then get stuck untested for weeks/months often
15:22:05 <severine_q> I admit i never really mind about the severity, but I will now :)
15:22:16 <tcohen> I've been distracted by bug 27526
15:22:16 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27526 enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , Remove Mod/AddItemFromMarc from additem.pl
15:22:18 <ashimema> it's the same few people trying to pick them all off.. we need to work out how to encourage more hands
15:22:58 <ashimema> that one is on RM's priority list tcohen.. so personally I'm happy seeing that as a priority at a similar level to the majors
15:23:15 <ashimema> I'm totally in agreement we need to hit majors and hit them hard.. I just want to see more hands doing it.
15:24:01 <thd> Free vaccines
15:24:19 <ashimema> like.. perhaps we should downgrade majors if the person reporting the bug doesn't then followup with testing
15:24:38 <koha-jenkins> Project Koha_20.11_D11 build #95: SUCCESS in 47 min: https://jenkins.koha-community.org/job/Koha_20.11_D11/95/
15:24:53 <koha-jenkins> Project Koha_20.11_U2010 build #57: SUCCESS in 52 min: https://jenkins.koha-community.org/job/Koha_20.11_U2010/57/
15:25:07 * ashimema will be quiet again now
15:25:30 <thd> ashimima: Are you suggesting that many|some majors not really majors?
15:25:42 <Joubu> you can report a bug without having the ability/time to test. But yes, I know the frustration.
15:26:48 <Joubu> moving on?
15:26:52 <tcohen> yes
15:26:55 <Joubu> #topic Status of roadmap projects
15:27:12 <Joubu> nothing new there, not much have changed AFAIK
15:27:44 <Joubu> (that's one thing for the "meeting facilitator" role)
15:28:00 <Joubu> anyone willing to add something?
15:28:01 <tcohen> can you post the link
15:28:15 <Joubu> https://annuel.framapad.org/p/koha_21.05_roadmap
15:28:21 <tuxayo> https://annuel.framapad.org/p/koha_21.05_roadmap
15:28:25 <Joubu> you should have bookmarked it months ago!
15:28:37 <tcohen> I do
15:28:37 <Joubu> ;)
15:28:45 <tcohen> it was just for the record
15:28:48 <tuxayo> Lost the bookmark? :P
15:28:50 <tuxayo> ok
15:29:06 <Joubu> #topic Actions from last meeting
15:29:14 <Joubu> #action mtj write something about the new packages for the 21.05 release notes
15:29:23 <Joubu> (postponed, I forgot to ping him I think)
15:29:33 <Joubu> #topic ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)
15:29:33 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27695 minor, P5 - low, ---, oleonard, Failed QA , Fix style of messages on Elasticsearch configuration page
15:29:40 <Joubu> ashimema: did you do that?
15:29:48 <ashimema> hmm, I think I did
15:29:50 * ashimema goes digging
15:30:21 <ashimema> seems not
15:30:29 <Joubu> #action ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)
15:30:36 <Joubu> #topic Joubu we need to push 26703 asap
15:30:49 <tuxayo> bug 26703
15:30:49 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26703 enhancement, P5 - low, ---, wainuiwitikapark, Signed Off , We should reconsider best practice for our title elements
15:30:50 <Joubu> I marked it as RM priority, cannot do more, please QA this one ASAP
15:31:00 <Joubu> #topic ashimema Write a guideline for 26703
15:31:09 <tcohen> I want to mention rangi has pointed api.koha-community.org to one of Theke servers
15:31:20 <tcohen> and I plan to have that set soon
15:31:36 <tcohen> ashimema suggested usgin redoc
15:31:50 <Joubu> tcohen: can you detail a bit more?
15:32:17 <ashimema> Idea is to have a central public place for a pretty set of the api docs
15:32:28 <ashimema> to encourage development against the api's for plugins etc
15:32:44 <ashimema> at the moment you have to have a koha installed and know where to look
15:32:47 <Joubu> #info Guideline about 26703 is at  https://wiki.koha-community.org/wiki/Coding_Guidelines#ACC3:_Title_elements_should_contain_unique_information_information_first
15:33:03 <ashimema> if you google for other ils's api's you'll find such a page for each of them.. a developers portal as such
15:33:54 <Joubu> 1 per Koha supported version then? or only master?
15:35:58 <ashimema> still working on the idea ;)
15:36:09 <ashimema> I think we decided for one per supported koha
15:36:23 <ashimema> as that would be simpler to maintain than adding a version tag to our swagger specs
15:36:30 <ashimema> per route
15:36:51 <Joubu> yup
15:37:02 <Joubu> timeframe? :)
15:37:14 <koha-jenkins> Project Koha_Master_D11 build #252: SUCCESS in 39 min: https://jenkins.koha-community.org/job/Koha_Master_D11/252/
15:37:48 <ashimema> as soon as tomas and I have bashed heads together again and got it working
15:37:59 <ashimema> I'd try to time it with the next feature release
15:37:59 <Joubu> #topic General development discussion (trends, ideas, ...)
15:38:04 <ashimema> as a target for us
15:38:11 <Joubu> yep, good plan
15:38:25 <Joubu> other topics?
15:39:04 <Joubu> # Set time of next meeting
15:39:21 <Joubu> #info Next meeting: 21 April 2021, 14 UTC
15:39:46 <Joubu> all good, everybody happy?
15:39:48 <ashimema> +1
15:39:57 <Joubu> #endmeeting