15:05:15 <tuxayo> #startmeeting Development IRC meeting 8 December 2021
15:05:15 <huginn`> Meeting started Wed Dec  8 15:05:15 2021 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:15 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:15 <huginn`> The meeting name has been set to 'development_irc_meeting_8_december_2021'
15:05:27 <tuxayo> #topic Introductions
15:05:35 <tuxayo> #info Victor Grousset, Tuxayo S.A., France
15:06:09 <fridolin> #info Fridolin Somers, Biblibre, Tahiti
15:06:13 <tuxayo> qa_team?
15:06:14 <wahanui> somebody said qa_team was cait, dcook, amoyano, ashimema, marcelr, kohaputti, jajm, tcohen, kidclamp, khall, tuxayo, petrova, nugged
15:06:18 <tuxayo> rmaints?
15:06:19 <wahanui> rmaints is fridolin, khall, kidclamp, wainui and tuxayo
15:06:26 <nugged> o/
15:06:28 <AndrewFH> #info Andrew Fuerste-Henry, AndrewFH, ByWater, US
15:06:32 <ashimema> hi
15:06:32 <wahanui> niihau, ashimema
15:06:36 <fridolin> nugged: welcome
15:06:39 <kidclamp> #info Nick Clemens, ByWater Solutions
15:06:43 <ashimema> #info Martin Renvoize, PTFS-Europe, UK
15:06:54 <nugged> #info Andrew Nugged, National Library of Finland, HELSINKI
15:07:04 <fridolin> ahhh good to see you all
15:07:30 <thd> 
15:07:48 <cait1> #info Katrin Fischer, BSZ, Germany
15:07:54 <thd> #info Thomas Dukleth, Agogme, New York City
15:08:28 <tuxayo> #topic Update from the Release manager (22.05)
15:08:52 <tuxayo> fridolin: you noted some things in the agenda
15:09:00 <fridolin> First meeting at this chair
15:09:13 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_8_December_2021 Today's agenda
15:09:15 * fridolin very proud to be there
15:09:18 <fridolin> yep
15:09:21 <tuxayo> ^^
15:09:22 <nugged> "XSLT::Base: Could not create file parser context for file" ...what does this mean when trying to point  XSLTDetailsDisplay to a URL?
15:09:22 <nugged> oleonard: I have the solution
15:09:22 <nugged> here: https://github.com/NatLibFi/Koha/commit/ce56f8760bb8e4e4bebc855e4352d9c564e43760
15:09:22 <nugged> we will publish with Petro this tomorrow if no one yet started :)
15:09:24 <ashimema> welcome to the RM's club
15:09:27 <fridolin> Bug 17600 do we need to review all plugins/libs for 21.11 compatibility ?
15:09:28 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17600 enhancement, P5 - low, ---, jonathan.druart+koha, RESOLVED FIXED, Standardize the EXPORT
15:09:42 <fridolin> I've seen plugins seem OK
15:10:03 <fridolin> but home-made libs need to be ajusted on C4 imports
15:10:08 <fridolin> anyone confirm ?
15:10:30 <cait1> sorry, no plugin expert
15:10:33 <cait1> tcohen: maybe?
15:11:06 <Joubu> yes, imports need to be checked
15:11:12 <Joubu> #info Jonathan Druart
15:11:12 <nugged> this about those "third party worldwide plugins" or our internals?
15:11:32 <fridolin> "third party worldwide plugins"
15:11:35 <Joubu> any plugins
15:11:38 <fridolin> like KitchenSink
15:11:43 <nugged> many plugins lost compatibility because need to explicitly import like this:
15:11:44 <nugged> use Koha::DateUtils qw( dt_from_string );
15:12:17 <cait1> Hm is there a place we could publish information like this? a general wiki dev page or so?
15:12:26 <fridolin> ah ok so C4 and Koha scope need update
15:12:55 <fridolin> cait1: in plugins page for start https://wiki.koha-community.org/wiki/Koha_Plugin_Hooks
15:13:34 <nugged> even more – I found some older had
15:13:34 <nugged> `C4::Debug` and `$debug`
15:13:45 <nugged> which make them die as well
15:14:12 <ashimema> plugins are versioned
15:14:20 <nugged> (we removed C4::Debug at all)
15:14:32 <fridolin> ah but its more simple
15:15:16 <fridolin> About Koha scope, need export when its a ORM object ? like Koha::Patron
15:15:26 <fridolin> i bet no
15:16:11 <fridolin> its a big subject, I propose I open a mail for koha-devel
15:16:14 <fridolin> tuxayo: ^
15:16:32 <Joubu> I tried to explain it correctly in the tech release notes
15:16:42 <sta> #info Peter (Petro) Vashchuk, National Library of Finland, HELSINKI
15:16:44 <Joubu> it's for subroutines, so it will mainly affect C4 modules
15:16:48 <ashimema> yup
15:16:51 <ashimema> it was in the release notes
15:16:56 <ashimema> I think that's enough publication
15:17:07 <ashimema> devs and support companies should be reading those 😉
15:17:19 <Joubu> maybe I should have tell explicitely it would affect plugins
15:17:31 <Joubu> but the solution and explanation are the same
15:17:35 <fridolin> Joubu: ok thanks i just wanted confirmation
15:17:43 <tuxayo> #action fridolin open a topic for koha-devel about plugins updates about Bug 17600 - Standardize the EXPORT
15:17:43 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17600 enhancement, P5 - low, ---, jonathan.druart+koha, RESOLVED FIXED, Standardize the EXPORT
15:18:01 <fridolin> ok next
15:18:10 <fridolin> Hooks for barcode transform are with ref, how to document this ? See https://github.com/bywatersolutions/dev-koha-plugin-kitchen-sink/pull/17
15:18:48 <fridolin> should we explain in https://wiki.koha-community.org/wiki/Koha_Plugin_Hooks ?
15:19:01 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
15:19:06 <oleonard> [off] Sorry was afk
15:19:16 <Joubu> fridolin: see release notes for bug 28211
15:19:16 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28211 enhancement, P5 - low, ---, kyle, RESOLVED FIXED, Replace use of call_recursive() with call()
15:19:31 <fridolin> I've added an example in KitchenSink but it's very tricky
15:19:52 <ashimema> that whole debate was a pain
15:20:02 <fridolin> Ah ok indeed its in notes
15:20:17 <fridolin> KitchenSink having an example is OK
15:20:31 <fridolin> and there is a BarcodeTransformer plugin (now fixed)
15:21:21 <fridolin> I will put a link to KitchenSink in this page
15:21:33 <fridolin> tuxayo: ^
15:22:08 <tuxayo> which page?
15:22:08 <wahanui> rumour has it which page is this
15:22:23 <fridolin> tuxayo: https://wiki.koha-community.org/wiki/Koha_Plugin_Hooks
15:22:48 <fridolin> i see there are some links already in table but better be a section
15:23:11 <fridolin> any help is welcomed
15:23:11 <wahanui> i already had it that way, fridolin.
15:23:19 <fridolin> not you ^^
15:23:30 <tuxayo> fridolin: yes so I don't know was to note. You can #action since you know better than me what to note about this topic ^^
15:23:36 <tuxayo> *you can
15:23:43 <cait1> any update on the planned wiki update btw?
15:23:54 * ashimema listens up
15:23:56 <tuxayo> ok I note that as topic
15:24:06 <cait1> thx tuxayo :)
15:24:40 <thd> Yes
15:24:47 <fridolin> #action fridolin add section to KitchenSink in Hooks wiki page
15:24:57 <fridolin> ok continue
15:24:57 <tuxayo> good, next ^^
15:25:05 <fridolin> about my RM job
15:25:06 <tuxayo> #topic  Updates from the Release Maintainers
15:25:10 <tuxayo> oh
15:25:22 <fridolin> ah juste to say i'm OK
15:25:42 <tuxayo> first pushes, fridolin++
15:25:43 <fridolin> started pushing, had some advices from Joubu
15:25:47 <fridolin> rools
15:25:53 <thd> I am fixing some bugs in the separation of binary and version control which had been hidden by not moving and then complete reinstalling.
15:26:41 <tuxayo> thd ok, I note that for when the topic will came up again in a few moments
15:26:47 <tuxayo> rmaints?
15:26:48 <wahanui> well, rmaints is fridolin, khall, kidclamp, wainui and tuxayo
15:27:54 <tuxayo> #info last 20.05 went well, hopefully all the major regressions due to the recent (few months) security fixes have been found an fixed so people staying on 20.05 wouldn't have major bugs
15:28:07 <tuxayo> but should upgrade asap anyway since it's EOL
15:28:38 <cait1> tuxayo++
15:28:58 <fridolin> tuxayo++
15:29:16 <fridolin> RIP 20.05.x
15:29:45 <fridolin> I've looked at HEA there are a lot of 19.11 remaining
15:29:53 <fridolin> https://hea.koha-community.org/systempreferences
15:29:55 <tuxayo> And they aren't upgrading
15:30:07 <tuxayo> When they have the chance to have a supported version ^^"
15:31:18 <tuxayo> hum no 19.11 last month. even though there are a few backports on top of the previous release
15:32:15 <tuxayo> Anyone heart something from Wainui?
15:32:36 <fridolin> maybe release only for security updates
15:33:38 <tuxayo> Indeed, it's been 2 or 3 weeks that Wainui's messages on the tickets mention that it's only about security bugs.
15:33:46 <tuxayo> moving on
15:33:51 <tuxayo> #topic Updates from the QA team
15:33:54 <tuxayo> qa_team?
15:33:54 <wahanui> hmmm... qa_team is cait, dcook, amoyano, ashimema, marcelr, kohaputti, jajm, tcohen, kidclamp, khall, tuxayo, petrova, nugged
15:34:51 * ashimema is catching up on customer work at the moment so hasn't done much QA yet this cycle
15:35:25 <ashimema> saying that.. I'm still on the leaderboard this month.. which is better than many 😉
15:35:40 <nugged> 💪
15:35:55 <ashimema> we need to get the 'Patches pushed for release' updated and working on the dashboard too
15:36:26 <tuxayo> what is that?
15:36:35 <kidclamp> been trying to keep an eye, but not had much time lately
15:36:35 <ashimema> 112 Majors.. that's a little scary
15:36:36 <Joubu> I've attached the dashboard for 22.05
15:36:40 <tuxayo> a counter of the RM's pushes?
15:36:42 <Joubu> updated*
15:37:22 <Joubu> the last section needs rangi's hands
15:37:28 <ashimema> hmm.. the countdown to next release seems to be broken to me.
15:37:32 <ashimema> yeah.. that last section needs some attention
15:38:48 <ashimema> I see.. I'll review and merge your request today Joubu
15:38:49 <Joubu> yes but it was broken last cycle as well
15:38:57 <ashimema> that'll bring the dashboard up to speed
15:39:12 <ashimema> but yeah.. it won't help that bottom section... I'll ask rangi to explain how that works.
15:39:56 <Joubu> it's kudos.json that needs to be regenerated
15:40:05 <ashimema> indeed
15:40:23 <ashimema> any other QA news?
15:40:56 <tuxayo> moving on
15:41:00 <tuxayo> #topic Updates from the documentation team
15:41:23 <tuxayo> #info David Nind: «the latest update sent to mailing list - intend to send each week to keep everyone informed»
15:41:37 <cait1> sorry - phone call :(
15:41:41 <tuxayo> #link https://lists.koha-community.org/pipermail/koha-docs/2021-December/000271.html
15:42:41 <tuxayo> #info documentation IRC meeting 9 December 2021, 16:00 UTC
15:43:06 <tuxayo> see David's email for more details
15:43:09 <fridolin> A reminder : Manual fixes are managed in Bugzilla, not gitlab issues. For example Bug 29638
15:43:09 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29638 minor, P5 - low, ---, david, RESOLVED FIXED, [DOCS] Framework default value for year is not <<YEAR>> but is <<YYYY>>
15:44:12 <tuxayo> There is a gitlab project for the manual and some tickets are open there?
15:44:58 <fridolin> https://gitlab.com/koha-community/koha-manual
15:46:46 <tuxayo> ok thanks
15:46:50 <tuxayo> notes left if today's agenda: « David Nind: is having a quick update (either written or at the meeting) something you would like for development meetings? »
15:46:53 <tuxayo> Does anyone have a message to transmit?
15:48:05 <tuxayo> so moving on ^^
15:48:12 <tuxayo> #topic  Status of roadmap projects
15:48:33 <tuxayo> #info Recalls - Aleisha is available over the weeks leading up to Christmas to do whatever it takes to get recalls upstreamed. Please discuss a plan that works for testers/QA team so Aleisha can action.
15:49:02 <tuxayo> #link https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19532 Bug 19532 - Recalls for Koha
15:49:02 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19532 new feature, P1 - high, ---, aleisha, ASSIGNED , Recalls for Koha
15:49:03 <huginn`> 04Bug 19532: new feature, P1 - high, ---, aleisha, ASSIGNED , Recalls for Koha
15:50:05 <thd> Breaking out files for version control of wiki migration into binary or otherwise not tracked broke some things which I had thought were working because I had not moved everything and then run the scripts again.
15:50:08 <fridolin> i dont yet understand this feature, i will look at it
15:50:19 <tuxayo> thd not yet about the wiki ^^
15:50:48 <fridolin> but QA team decivisions first
15:51:07 <fridolin> decisions
15:51:39 <tuxayo> There were a few emails about that topic (which lead to the topic ending up here) and here is one from Aleisha:
15:51:40 <tuxayo> «The code is all there - I need to know how best to format the patches so
15:51:40 <tuxayo> that it can be effectively tested and QAed. So I would like those who
15:51:40 <tuxayo> would be testing and QAing it to please discuss the best way forward.»
15:53:23 <tuxayo> What could be said except the coding guidelines as usual. The rest is specific feedback when actual reviewing could be done on this big patcheset. Right?
15:54:57 <fridolin> This feature can be turned on/off its a good point
15:56:24 <tuxayo> #action tuxayo forward to fridolin the recent email thread started by Aleisha with the few people that already took a look to recalls.
15:56:28 <tuxayo> moving on
15:56:43 <tuxayo> Anything else about roadmap projects?
15:56:59 <thd> Yes, fixing symlinks.
15:57:31 <tuxayo> thd: ah the wiki fit there right?
15:57:59 <thd> Symlinks were necessarily excluded from wiki migration version control and had been managed outside it.
15:58:02 <tuxayo> so, thd «I am fixing some bugs in the separation of binary and version control which had been hidden by not moving and then complete reinstalling.»
15:58:09 <tuxayo> «Breaking out files for version control of wiki migration into binary or otherwise not tracked broke some things which I had thought were working because I had not moved everything and then run the scripts again.»
15:59:00 <thd> Proper testing showed that when I was merely updating code without moving files I missed where some things were not copied.
15:59:48 <thd> I did the separation of version control / non version control in the most painful way possible for the version history.
16:00:53 <tuxayo> thd: don't worry too much I guess, the most direct stuff that ends up working would do
16:01:15 <thd> I will fix that so that text files which could possibly be managed by version control but have never changed from defaults are not obscuring where the real work would do.
16:01:44 <thd> oops I copied your would do into my typing ;)
16:01:56 <tuxayo> ^^
16:02:09 <tuxayo> anything else to add thd?
16:02:46 <thd> Making something that merely works is a modest task sharing it in a manner that others can understand everything is a bigger task.
16:04:54 <thd> I try to skip sleep and fix everything in short spurts but I have too much accumulated sleep loss for that to work since the pandemic has wrecked my time and I work a crazy schedule.
16:05:13 <thd> That is all at the moment.
16:06:09 <tuxayo> With too large version jumps it wouldn't be a surprise to need not always clean and simple understandable fixes. That' just a general though, I don't know how it actually looks like.
16:06:12 <tuxayo> Thanks for the update
16:06:17 <tuxayo> #topic  Actions from last meeting
16:06:34 <tuxayo> «tuxayo KohaCon Process: holiday clash: get more feedback from Indranil Das Gupta about Hindu holidays and change that part»
16:06:47 <tuxayo> Ops, didn't reemail Indranil
16:06:50 <tuxayo> *oops
16:06:58 <tuxayo> #action tuxayo KohaCon Process: holiday clash: get more feedback from Indranil Das Gupta about Hindu holidays and change that part
16:07:09 <tuxayo> #topic  General development discussion (trends, ideas, ...)
16:07:31 <tuxayo> Anything urgent?
16:07:36 <tuxayo> Since time is running out
16:08:09 <tuxayo> #topic Review of coding guidelines
16:08:13 <tuxayo> fridolin:
16:08:24 <fridolin> Should we to add a line for Bug 28606 change ?
16:08:24 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28606 enhancement, P5 - low, ---, jonathan.druart+koha, RESOLVED FIXED, Replace $ENV{DEBUG} and $DEBUG with Koha::Logger->debug
16:08:24 <tuxayo> «Should we to add a line for Bug 28606 change ? »
16:08:45 <fridolin> i'm not really a developper so i dont fully understand this change
16:09:04 <fridolin> but for guide lines it may be helpfull
16:10:06 <tuxayo> qa_team?
16:10:07 <wahanui> qa_team is cait, dcook, amoyano, ashimema, marcelr, kohaputti, jajm, tcohen, kidclamp, khall, tuxayo, petrova, nugged
16:10:30 <tuxayo> The list is not  up to date actually
16:10:49 <tuxayo> Joubu missing from it
16:11:09 <fridolin> maybe add a line on Koha::Logger ?
16:11:17 <fridolin> for all its levels
16:12:28 <tuxayo> fridolin: I would say postpone it due to the lack of quorum ^^"
16:12:38 <fridolin> yep
16:13:24 <tuxayo> That could allow to get feedback on the mailing list meanwhile
16:13:39 <tuxayo> #topic Set time of next meeting
16:13:49 <tuxayo> Same hour right?
16:14:17 <oleonard> fridolin do you want to try changing the time?
16:14:19 <fridolin> ok for me
16:14:32 <fridolin> oleonard: i can manage its ok
16:15:06 <tuxayo> So 22 december 15:00 UTC
16:15:32 <thd> Is the earlier local time preferable to people?
16:16:28 <tuxayo> fridolin: ? ↑ since it's the hardest for you. And you will have a few topics
16:16:41 <nugged> thd: we're ok to be earlier from Finland if that's help for others
16:16:54 <fridolin> thd: you mean wich UTC hour ?
16:16:56 <thd> Keeping the same UTC time across local time changes does not seem best to me unless the later local time is preferable.
16:17:31 <thd> Adjusting for the change in local time recently would be an hour earlier.
16:17:45 <tuxayo> > Keeping the same UTC time across local time changes
16:17:45 <tuxayo> It changed actually I think
16:18:25 <nugged> (looks like changed:  we have it now 17:00 our time and we had 17:00 before DST change)
16:18:49 <tuxayo> Since it's the same local time (16:00) for mainland France even though there we switched to DST(or the reverse)
16:19:50 <fridolin> this is a tricky rock-around-the-clock situation, needs discussion
16:19:52 <thd> Maybe I am confused about the transition.
16:20:07 <tuxayo> yes
16:20:20 <tuxayo> (yes to frido ^^")
16:20:30 <tuxayo> #info Next meeting: 22 December 2021, 15 UTC
16:20:40 <fridolin> hohoho ^^
16:20:42 <tuxayo> #endmeeting