16:00:45 <davidnind> #startmeeting Documentation IRC meeting 16 December 2021
16:00:46 <huginn`> Meeting started Thu Dec 16 16:00:45 2021 UTC.  The chair is davidnind. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:46 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:46 <huginn`> The meeting name has been set to 'documentation_irc_meeting_16_december_2021'
16:00:56 <aude_c> hi davidnind :)
16:00:59 <davidnind> #info Agenda https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_2021-12-16
16:01:18 <davidnind> great to have you as part of the team!
16:01:25 <davidnind> #topic Introductions
16:01:33 <davidnind> #info David Nind, New Zealand
16:01:34 <aude_c> thanks; excited to be here!
16:01:41 <cait1> #info Katrin Fischer, BSZ, Germany
16:01:41 <ashimema> #info Martin Renvoize, PTFS Europe, UK (lurking on his day off)
16:02:00 <aude_c> #info Aude Charillon, PTFS Europe, UK
16:02:09 <davidnind> ashimema: dedicated!
16:02:29 <ashimema> :)
16:02:29 <aude_c> ashimema: wondered what you were doing here! ;)
16:03:01 <cait1> I am tempted to send him off to have fun... but worry a little where he'd end up :)
16:03:06 <ashimema> Reminder came through whilst the was on the school run ;-)
16:03:38 <davidnind> #topic Review of action points
16:03:51 <davidnind> There are no action points!
16:03:59 <cait1> Fresh start :)
16:04:01 <reiveune> bye
16:04:28 <ashimema> Action is to make lots of actions
16:05:19 <cait1> are we supposed to create them now? :)
16:05:21 <davidnind> But I will go through the last few (from earlier in 2021 and late 2020) and add any still current or relevant to Bugzilla
16:06:09 <davidnind> #action davidnind to look at previous meetings and add any current or still relevant items as tasks to Bugzilla
16:06:44 <davidnind> #topic Project updates
16:07:06 <davidnind> #link https://wiki.koha-community.org/wiki/Koha_Documentation_Team#Projects
16:07:49 <davidnind> I'm adding these as tasks to Bugzilla (not quite there yet) - but no other update than that at the moment
16:08:31 <aude_c> ok
16:08:35 <cait1> davidnind++
16:08:36 <davidnind> If any of them are of interest feel free to add your name to them!
16:09:10 <davidnind> aude_c: I hope things like Bugzilla and Git are not too overwhelming eyt!
16:09:19 <aude_c> still feeling a bit too new to this to add my name there
16:09:19 <davidnind> ..yet
16:09:53 <aude_c> davidnind: thanks, I've used them in small ways so just a case of getting more familiar :)
16:10:02 <ashimema> I'll take a look, see if any would suit my help.. but I won't be active until the new year ;)
16:10:44 <davidnind> we need to update our documentation to make it easier to get up to speed, so a fresh perspective will be very helpful
16:10:44 <ashimema> aude_c I'm always open to help and guide, just poke me ;)
16:11:01 <davidnind> thanks ashimema!
16:11:02 <aude_c> ashimema: thank you!
16:11:40 <davidnind> #topic What's been done so far
16:11:47 <cait1> I hope to help some too, but also want to know how docs team works, so I can make sure QA takes care of things important to the team
16:11:51 * ashimema wondered about checking for visual editors for sphinx again.. make contributions a little easier
16:12:46 <cait1> maybe we shoudl also think about splitting some more files, navigation can be hard because of length
16:13:01 <davidnind> you can also use markdown with Sphinx, so something to look at - a lot of similarity - markdown is a lot simpler though
16:13:15 <cait1> i've tried some visual editors, but it can be alittle hard where links and pictures are concerned, for text is usually no issue
16:13:44 <aude_c> What's Sphinx?
16:13:46 <cait1> markdown might be interesting - more people might know it
16:13:52 <davidnind> one of the projects is to reorganise the contents (long overdue)
16:13:59 <cait1> Sphinx is the software used to create the manual
16:14:04 <aude_c> oh
16:14:07 <cait1> I think the format is... restructured text ?
16:14:24 <davidnind> Sphinx is the tool that takes the source "code" for the manul and then turns it into HTML or PDF, ePub, etc
16:14:28 <cait1> someone correct me if I remember wrong please
16:14:59 <davidnind> reStructuredText - is a lightweight markup klanguage - like HTML but a bit more constrained...
16:15:08 <ashimema> You all described it perfectly
16:15:17 <aude_c> ok, thank you
16:15:24 <cait1> davidnind++
16:15:43 <davidnind> #link https://wiki.koha-community.org/wiki/ReStructuredText_-_Tips_and_Tricks
16:16:02 <cait1> one thing to maybe keep on mind when restructuring the manual - we also link from Koha to it, so it would be good to have a nice landing point for each page in Koha
16:16:46 <davidnind> good point
16:16:50 <cait1> right now we jump to the chapter in the manual... maybe it could also be a shorter summary page with links that relate to the topic
16:17:20 <cait1> but finding quick help what goes in a field/form might still be a goal when starting from Koha
16:17:45 <cait1> or a use case
16:17:45 <wahanui> a use case is, like, just wanting more options for date in notices
16:18:18 <cait1> wahanui: forget use case
16:18:19 <wahanui> cait1: I forgot use case
16:18:20 <davidnind> ideally we would have linked help from pages in Koha, but there is probably some work to get to that stage
16:18:44 <cait1> can you describe that idea a bit more?
16:19:45 <davidnind> sounds like a good idea, so people using Koha can find the information quicker, rather than googling...
16:20:38 <davidnind> embedded type help like microsoft or other tools where you click on the help button and it takes you somewhere (hopefully with the answers)
16:20:55 <davidnind> I'm not sure whether Koha used to to that in the distant past...
16:21:16 <cait1> we do that now
16:21:22 <cait1> but i might be misunderstanding
16:21:26 <ashimema> I thought it did that already
16:21:43 <cait1> the Help link in the upper right corner in Koha links to the most specific spot in the manual for the current page
16:21:50 <ashimema> Can't say I've used it for a while personally
16:21:57 <aude_c> that's my understanding too (I use it a lot!!)
16:21:59 <cait1> there is a mapping for each template file to a section in the manual
16:22:02 <oleonard> Previously the help files were local which created a problem keeping them in sync with the online manual
16:22:19 <ashimema> I seem to remember you can even set the base URL to point to your own docs site if you wanted to
16:22:26 <cait1> exactly, also with translations (needed to do them twice)
16:22:34 <ashimema> :-)
16:22:41 <ashimema> Glad it does still work
16:22:42 <cait1> yes, that's also a feature, with the docs url you can also make sure it goes to the preferred language
16:23:03 <cait1> we have set ours to german and the manuals on translate at the moment (because the ones on the website do't have current translations often)
16:23:22 <ashimema> How it works might be good to have documented somewhere.. it's not something I ever check for in QA or think to do as a dev
16:23:27 <ashimema> I should probably
16:23:43 <cait1> it's necessary for new pages added... but you are right, we need to check the help link
16:24:21 <cait1> if you don't have a sepcific link, I believe the help will just link to the manual start page
16:24:31 <lucyvh> Hi all, sorry I'm late
16:24:34 <davidnind> #action davidnind to add a task to Bugzilla to document how the linking from Koha to the  manual works
16:24:44 <davidnind> hi lucyvh!
16:25:16 <davidnind> no problem!
16:26:11 <davidnind> where was I?
16:26:54 <aude_c> "What’s been done so far"?
16:27:15 <davidnind> hehe - easy to get distracted!
16:27:33 <lucyvh> My fault, apologies
16:27:45 <aude_c> haha, yes; I wasn't sure where to start explaining to Lucy what you were talking about!
16:27:56 <davidnind> I've not done too much more since my update to the mailing list
16:28:26 <davidnind> #info Documentation Manager update - 2021-12-07 https://lists.koha-community.org/pipermail/koha-docs/2021-December/000271.html
16:28:52 <cait1> davidnind: you can also use  #link url linktext if you want
16:29:19 <davidnind> our IRC is logged, so you can always keep an eye on what the developers are up to :-D http://irc.koha-community.org/
16:30:08 <davidnind> the only other thing has mostly been trying to work out the translation works  -= is on the agenda lately
16:30:18 <cait1> thanks a lot for that
16:30:31 <cait1> is it a good moment to ask workflow questions?
16:30:38 <aude_c> davidnind: thanks (about the IRC logs) :D
16:31:28 <davidnind> cait1: that's next on the agenda
16:31:39 * cait1 will wiat
16:32:11 <davidnind> that's it from me on things - finally actually starting to do some actual writing!
16:32:25 <davidnind> anything else you have all been working on that you would like to share?
16:33:19 <davidnind> bearing in mind I haven't been that active until now - my apologies for that fro the last release cycle
16:33:20 <aude_c> nothing yet; planning to start looking at it properly with lucyvh early January
16:34:21 <davidnind> great - things tend to get busy in real life at this time of the eyar!
16:34:44 <lucyvh> I haven't been abe to contribute much this year, hoping that changes in the new year
16:34:52 <davidnind> hopefully I will have some of the Wiki pages updated on processes and step-by-step instructions
16:34:54 <cait1> i think only complaining about the translations... so not being very helpful
16:35:09 <lucyvh> Great that aude_c is getting involved
16:35:18 <davidnind> #link https://wiki.koha-community.org/wiki/Koha_Documentation_Team
16:35:31 <davidnind> it's great to have you all involved!
16:36:15 <davidnind> always helpful cait1 - hopefully we can get the translation stuff sorted out and running smoothly
16:36:47 <davidnind> #topic Content development guidelines
16:37:41 <davidnind> You can go first if you like cait1 (content development guidelines = things like a style guide, terminology, processes, and how we do things)
16:37:57 <cait1> my question was more about how we workwith the spreadsheets
16:38:14 <cait1> i think the original idea was to mark all bugs that require docs updates with the keyword "Manual" in bugzilla
16:38:20 <cait1> so you could then search for that and work throught hem
16:38:33 <cait1> and then remove the Manual keyword when done
16:38:57 <cait1> is this still the idea - and shoudl we then wait for you to keywords (or help with that) / amke a note on the spreadsheet?
16:40:10 <davidnind> That's how I see it working as well, for bug 29473 (21.11) and 29460 (22.05) I'm using that more as a way for me to make sure all the release changes are reviewed
16:40:10 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29473 normal, P1 - high, ---, david, ASSIGNED , [DOCS 21.11] Documentation changes for 21.11
16:40:20 <davidnind> bug 29460
16:40:20 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29460 normal, P5 - low, ---, m.de.rooy, Pushed to stable , Typo 'pendin    g approval'
16:41:04 <davidnind> so basically I will review what is pushed and see if I thing a change is required to the documentation and add the manual keyword
16:41:06 * ashimema would like to see the SO/QA/Push process link up with the docs process.. making sure we somehow keep on top of things..
16:41:10 <cait1> ok, so maybe if we get to work on something that has not been 'keyworded' or actually always, we could also add a little comment with the merge request maybe?
16:41:19 <ashimema> Cool, that works
16:41:40 <cait1> merge request _link_
16:42:18 <davidnind> for 22.05 this is up-to-date and you can see the list - there is a link in the agenda - it is quite long!
16:42:53 <davidnind> I'm still wokring through the 21.11 ones to add the manual keyword, but there are quite a few already with it
16:44:10 <lucyvh> It's great to have the spreadsheet with everything centralised
16:44:12 <davidnind> cait1: yes, that woudl be good
16:45:00 <lucyvh> I think we need something more that just removing the 'manual' keyword.  Could we have a 'Manual - done' tag for something similar
16:45:20 <davidnind> I might also be wrong about what needs documenting - architecture and developer specific things aren't covered by the manual
16:46:03 <cait1> lucyvh: that's also an idea, it might not work in the beginning, but culd be helpful in the future
16:46:25 <cait1> Manual and Manual_Done keywords
16:46:38 <davidnind> I was proposing that we add a comment to the bug saying:
16:46:38 <davidnind> 1. Changes for this bug are now incorporated into the manual.
16:46:38 <davidnind> 2. Here are the changes we have made (a link to the commit and section in the manual).
16:46:38 <davidnind> 3. Indicate that any feedback or suggestions are welcome.
16:46:38 <davidnind> 4. Remove the Manual keyword from the bug, if it was used.
16:46:48 <davidnind> This will give contributors to the bug a chance to make sure we've reflected the change correctly
16:47:35 <cait1> sounds good
16:47:49 <davidnind> What's the process of adding a keyword to Bugzilla?
16:48:07 <lucyvh> That sounds good
16:48:31 <davidnind> It would be useful to show what we have done as well
16:48:56 <cait1> I think I can do that actually
16:49:06 <cait1> ashimema probably too sec
16:49:32 <cait1> i can
16:49:33 <davidnind> #action davidnind to look at getting a keyword added to Bugzilla to capture that the documentation/manual has been updated for this bug
16:49:37 <cait1> most seemto prefer undercores
16:49:43 <cait1> I cando it right now if you want
16:49:44 <davidnind> great
16:49:54 <cait1> Manual_done ok? or Manual_Done?
16:50:02 <davidnind> go for it - one less action for me
16:50:18 <davidnind> Manual_Updated?
16:50:21 <cait1> ok
16:50:25 <davidnind> anyone have any preferences?
16:50:28 <cait1> i seee one with - too heh
16:50:30 <cait1> Manual-updated?
16:50:38 <davidnind> +1
16:50:47 <lucyvh> +1
16:50:58 <aude_c> +1
16:51:09 <cait1> Indicates that the changes from this bug have been incorporated into the Koha manual.
16:51:13 <cait1> for a description
16:51:35 <davidnind> okay, so once we've updated the manual for a bug, we change the keyword to Manual-updated
16:51:40 <davidnind> sounds good
16:52:08 <davidnind> thanks cait1!
16:52:21 <davidnind> okay 10 minutes to go...
16:52:43 <cait1> I've changed the description for Manual a litlte too: Indicates that this bug makes changes that will need to be documented in the Koha manual.
16:53:19 <davidnind> cait1++
16:54:03 <davidnind> I've been adding [DOCS] to Bugzilla tasks as I add them or review them - see https://bugs.koha-community.org/bugzilla3/buglist.cgi?bug_status=NEW&bug_status=REOPENED&bug_status=ASSIGNED&f1=keywords&f2=component&j_top=OR&known_name=Documentation%20To-do&list_id=394372&o1=allwords&o2=equals&query_based_on=Documentation%20To-do&query_format=advanced&v1=Manual&v2=Documentation
16:55:12 <davidnind> is this helpful and should we expand - or just go with that for the moment. For me it makes documentation bugs *tasks) stand a bit more in Bugzilla.
16:55:34 <cait1> we have a documentation component, but it's true that often you don't spot it right away
16:55:38 <cait1> especially in the email inbox
16:55:42 <cait1> I like it
16:56:08 <davidnind> I don't envy your inbox!
16:56:29 <davidnind> okay, I'll stick with that for the moment and keep it simple
16:56:29 <ashimema> I can add a list to the dashboard that tracks the manual keyword
16:57:05 <cait1> yah... i am behind with bug mails this week already again
16:57:08 <ashimema> I use the dashboard a lot as my starting point for picking community work to get on with
16:57:48 <davidnind> that would be great - we can see how it goes, at least make the work on the documentation a bit more visible and perhaps encourage contributions...
16:57:53 <ashimema> Would that be helpful for just another place to get confused by?
16:58:01 <ashimema> Indeed
16:58:19 <cait1> I also like hat idea :)
16:58:25 <cait1> davidnind: quick, action him!
16:58:29 <ashimema> Wouldn't be too hard to have docs leaderboards like we have for SO and QA come to think of it
16:58:51 <ashimema> Hehe.. Okies.. I'll take a look over Xmas . Action me ;)
16:58:58 <davidnind> I better do some work then:-D
16:59:17 <cait1> i think you'll need a combination of keywords and component + manual - i have a saved shared search for the open ones
16:59:31 <cait1> it was a little tricky to get right, until Caroline approved :)
16:59:52 <davidnind> #action ashimema to look at adding docs tasks to the dashboard https://dashboard.koha-community.org/
17:00:20 <davidnind> using the version released in helps as well
17:00:52 <davidnind> ashimema++
17:01:08 <davidnind> I'll defer the other agenda items to the enxt meeting!
17:01:17 <davidnind> #topic Set time for next meeting
17:01:31 <davidnind> Does this time work for you all - earlier, later?
17:01:50 <davidnind> It's okay for me (normally...)
17:02:00 <aude_c> it works for me. Earlier would work too
17:02:04 <cait1> same
17:02:09 <cait1> but it hink earlier is hard for davidnind
17:02:19 <cait1> 12 hours to nz currently - so now is 6am
17:02:28 <aude_c> oh, I'm thinking about time zones the wrong way, then! Sorry
17:02:41 <davidnind> I could make it half an hour earlier if that works better for the UK/Europe
17:02:46 <cait1> aude_c: i think nz is about the only one i get right after years of training and especially in winter :)
17:03:05 <aude_c> cait1: haha! I'll get used to it
17:03:10 <davidnind> it's basically 12 hours difference, give or take daylight savings
17:03:36 <cait1> yes, 10 in summer (in the future), 12 in winter and very confusing 11 for a short time period in betweens
17:03:52 <cait1> but I am distracting ... concentration is fading a little
17:04:03 <aude_c> So, keep the same time?
17:04:18 <davidnind> okay, I'll make it UTC 15:30 and we can see how it goes
17:04:34 <lucyvh> Same time works for me
17:04:42 <aude_c> no need for you to get up earlier on our behalf davidnind!
17:05:16 <aude_c> the meeting started at 4pm in the UK so easy for us
17:05:39 <cait1> 5pm here is good too - it's a little late, but that means that things have quieted down a bit which also helps
17:05:43 <davidnind> okay, we'll stick with 16:00 and see how it goes...
17:06:18 <davidnind> the other idea I had was to have every 3rd or 4th meeting a video conference one, any thoughts?
17:06:33 <aude_c> that would be nice
17:07:01 <lucyvh> Great idea
17:07:11 <davidnind> that way it would be easier to demonstrate things and it can be easier to discuss some topics
17:07:13 <ashimema> Great idea
17:07:31 <davidnind> I'll schedule it in
17:08:11 <davidnind> is the 6th okay for the first meeting for next year - basically the 1st Thursday (or Friday?) of the month?
17:08:33 <aude_c> yes for me
17:08:46 <cait1> yes
17:08:49 <cait1> sorry, got distracted :)
17:09:01 <davidnind> #info Next meeting: 6 January 2022, 16:00 UTC
17:09:04 <lucyvh> yep
17:09:11 <davidnind> #endmeeting