14:01:36 <tuxayo> #startmeeting Development IRC meeting 12 October 2022
14:01:36 <huginn`> Meeting started Wed Oct 12 14:01:36 2022 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:36 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:36 <huginn`> The meeting name has been set to 'development_irc_meeting_12_october_2022'
14:01:55 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_12_October_2022 Today's agenda
14:02:00 <tuxayo> #topic Introductions
14:02:19 <ashimema> not sure it'll help or not oleonard.. but we updated all our ill backends today for 21.11 compatability: https://github.com/PTFS-Europe/koha-ill-freeform
14:02:23 <tuxayo> #info Victor Grousset, Tuxayo Empire
14:02:24 <ashimema> ooop
14:02:32 <ashimema> #info Martin Renvoize, PTFS Europe
14:02:34 * tuxayo is starting to get paid for Koha work!
14:02:53 <thd> #info Thomas Dukleth, Agogme, New York City
14:03:08 * ashimema is currently going through CV's.. PTFS-E are hiring.
14:03:32 <tuxayo> Great to hear that your job offer got candidates :)
14:04:15 <tuxayo> rmaints?
14:04:15 <wahanui> rmaints are lukeg, liliputech and tuxayo
14:04:18 <tuxayo> qa_team?
14:04:18 <wahanui> qa_team is cait, marcelr, khall, kidclamp, kohaputti, lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova, Joubu and dcook
14:04:59 <nugged> #info Andrew Nugged, National Library of Finland, HELSINKI
14:05:14 <tuxayo> #topic Announcements
14:05:25 <tuxayo> Anything to announce that doesn't fit better the other topics?
14:05:51 <kidclamp> #info, Nick Clemens, ByWater Solutions
14:06:12 <khall> #info Kyle M Hall, ByWater Solutions
14:06:23 <lukeg> #info, Lucas Gass, ByWater Solutions
14:06:42 <tuxayo> nugged: maybe you can quickly sum up the stuff you said in the other meeting slot two week again for the people that weren't there at this time slot.
14:07:56 <tuxayo> Or i can just post the link to the logs were you started informing us about next KohaCan last time: http://irc.koha-community.org/koha/2022-09-28#i_2452713
14:08:05 <tuxayo> *KohaCon
14:08:29 <tuxayo> Moving on?
14:08:39 <nugged> yes
14:08:46 <nugged> so - we confirmed the dates,
14:08:54 <ashimema> excellent
14:08:54 <wahanui> darn tootin' it is.
14:08:57 <marcelr> #info Marcel de Rooy, Rijksmuseum
14:09:09 <nugged> and last Friday I personally inspected booked "rooms" in University building
14:09:31 <nugged> Dates:
14:09:31 <nugged> (CONFIRMED) 14-16 August 2023 (14-18 with workshops and extras).
14:09:31 <nugged> recommended trip: Sat 12 Aug .. Sun 20 Aug.
14:09:34 <nugged> as said here:
14:09:34 <nugged> https://bit.ly/PerlKohaCon_welcome
14:09:42 <tuxayo> nugged++
14:09:52 <nugged> some FAQ section updated because of Perl Community requests
14:10:29 <nugged> but I still working with Perl Community part. Allowed to their Slack now not as Guest but member & will have announce talk maybe (I am trying and doing my best) no later next week
14:10:35 <nugged> to start those movements as well
14:11:26 <nugged> then I'll start coming to bigger players to ask for participation (PTFS-E, BibBlibre, of course ByWater, so on) and our Core team members, getting some feedback and coordination
14:11:57 <nugged> I _hope_ through october having full agreements/OKs & form up the final plan and start work on ogra- steps on December.
14:12:38 * ashimema has added it to the Koha Calendar now
14:12:40 <nugged> If anyone of you already know some gathering (Perl or Koha or Library-IT related where it's good for me to come and announce the Conference) – tell me please, I will be glad (Zoom/etc)
14:12:59 <nugged> I mean - I will come with talk on meetings you will have so if someone already can propose some to me - PM me.
14:13:23 <nugged> then - let's say - let's put in meeting schedule my report once more in here in IRC on our next IRC meeting.
14:13:27 <kidclamp> :q
14:13:32 <tuxayo> «Should Perl people be concerned about "Koha" everywhere? NO. You won't get bored if you don't want to get around Koha»
14:13:32 <tuxayo> Ha ha ha. Great, we don't want to scare people with book stuff :P They might end up sucked into Koha anyway. He he he.
14:14:23 <nugged> Final thing: yes, I want to be as much as possible visitors from Perl world, as well from Koha world, even if those are non-crossed entities (we will work on that further :) )
14:14:34 <ashimema> excellent
14:14:34 <wahanui> darn tootin' it is.
14:14:47 <tuxayo> Great information page!
14:14:51 <nugged> (final thing cont): so I am asking all to prep to VISIT Helsinki! :) Beer & fun from me guaranteed! :)
14:14:54 <nugged> that's it for now.
14:15:12 <nugged> PM me for any more you want me to do on this or ideas.
14:15:20 <tuxayo> Thanks the update!
14:15:30 <nugged> ashimema: and yes, we should put "PTFS-E" HR booth there in lobby as well as others.
14:15:34 <tuxayo> «heal post-covid anthropophobia and huggophobia.»
14:15:34 <tuxayo> 🤗++
14:16:17 <tuxayo> Moving on if nothing to add.
14:16:29 <nugged> Yes, I want us to make something really impressive and unusual. Will lay all my extra time on that.
14:16:39 <nugged> yes. Moving further.
14:16:39 <tuxayo> ++
14:16:53 <tuxayo> #topic Update from the Release manager (22.11)
14:17:13 <tuxayo> Is El tcohen around?
14:17:47 <ashimema> he was a moment ago
14:18:15 <thd> He has been very busy.
14:18:15 <kidclamp> one sec, we distracted him
14:18:19 <tuxayo> ^^
14:18:21 <tcohen> #info Tomas Cohen Arazi
14:18:27 <tcohen> hi all <.<
14:18:30 <tuxayo> tcohen: 🎙️
14:18:40 <tuxayo> hi ^o^
14:18:51 <tcohen> re-reading, sorry
14:19:10 <tcohen> Hi all, I'm back from a short vacation
14:20:04 <tcohen> I've been pushing a lot, and I'm about to push the 'staff revamp'
14:20:12 <tcohen> so we have time to fix things
14:20:47 <tuxayo> > I'm about to push the 'staff revamp'
14:20:47 <tuxayo> wooooow 🤩🤩🤩🤩
14:20:51 <tcohen> I want bug 31378 in, and more eyes are needed tehre
14:20:51 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31378 new feature, P5 - low, ---, agustinmoyano, Needs Signoff , Add a generic OAuth2/OIDC client implementation
14:20:52 <tuxayo> team++
14:22:03 <tcohen> bug 26635 should be in too, I will focus on that the rest of the week, as it is a blocker for serious API usage
14:22:03 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26635 enhancement, P5 - low, ---, agustinmoyano, In Discussion , Expand authorised values in REST API call
14:22:47 <ashimema> tcohen++
14:22:53 <tcohen> #action khall offered to restore progress bars if peple file bugs, depending on bug 31666 for that
14:22:53 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31666 enhancement, P5 - low, ---, kyle, Pushed to master , Add job progress bar to stage-marc-import.pl
14:23:00 <nugged> > and more eyes are needed tehre
14:23:00 <nugged> <tcohen> - I'll get back Slava to it to check too.
14:23:01 <ashimema> khall++
14:23:33 <tcohen> khall++
14:24:04 <tcohen> About ERM: I'm in talks with PTFS-e and ByWater about that.
14:24:26 <tcohen> it has a chance as an opt-in experimental feature imho
14:24:28 <tuxayo> Talks about what? ^^"
14:24:38 <tcohen> about the progress and the state it is at
14:24:45 <tuxayo> Great!
14:24:51 <tcohen> i.e. if it is gonna be pushable soon
14:24:56 <tuxayo> Ah yes!
14:25:16 <thd> khall++ # verbose console output is the best progress bar
14:25:19 <tcohen> jonathan had concerns about some decisions he made on vue integration
14:25:41 * ashimema has been working through the erm code the past few days.. generally happy with what I see..
14:25:45 <tcohen> which are legit and need to be considered, that's why it is important that PTFS hired someone to pick and continue that work
14:25:47 <tuxayo> > an opt-in experimental feature imho
14:25:47 <tuxayo> For a new and independent module that seems safe.
14:25:48 <ashimema> few little fixes here and there..
14:26:14 <ashimema> but.. I'm no vue expert.. that's where we fall down.. none of us are really... so it makes it hard to guide/advise/review
14:26:31 <ashimema> but.. it does all feel pretty solid from my perspective at the moment
14:27:04 <tcohen> ptfs++
14:27:06 <tcohen> Joubu++
14:27:09 <tcohen> bywater++
14:27:26 <tuxayo> > I'm no vue expert.. that's where we fall down.. none of us are really
14:27:26 <tuxayo> If stuff still makes sense without being an expert, that great. It means it won't be much of an entry barrier.
14:27:54 <tcohen> #action tcohen will send an email with release dates this week, won't differ from usual release dates
14:28:13 <tcohen> this time there are lots of strings for sure, with big refactoring on templates, but it is just a guess
14:28:14 <tuxayo> > PTFS hired someone to pick and continue that work
14:28:14 <tuxayo> ptfs++
14:29:07 * tuxayo promises they won't submit massive string changes this time.
14:29:17 <tuxayo> (at the last moment)
14:29:19 <tcohen> heh
14:29:26 <tcohen> tuxayo++ # translatability
14:30:08 <tuxayo> I still will do something about the breadcrumb strings at some point.
14:30:10 <tcohen> questions for the RM?
14:30:38 <tcohen> tuxayo bug 31670
14:30:38 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31670 enhancement, P5 - low, ---, isobel.graham09, NEW , Fix inconsistency with breadcrumbs in the Patrons module
14:30:48 <tcohen> cait++ # always
14:31:31 <tuxayo> That could be done at the same time. Thanks tcohen, I'm noting it my "notes for follow up patches"
14:32:18 <ashimema> breadcrumbs are a mess.. I have no idea if my daughter will get a let up at school though to take a look.. might grab them myself if she doesn't
14:32:41 <ashimema> isobel.graham09 = ashimema's daughter 😜
14:33:05 <tuxayo> he he
14:33:06 <tcohen> isobel++
14:33:15 <tuxayo> isobel++
14:33:39 <tuxayo> Send congrats for the nice patches in the last months.
14:33:43 <tuxayo> #topic Updates from the Release Maintainers
14:34:00 <tuxayo> rmaints?
14:34:00 <wahanui> rmaints are lukeg, liliputech and tuxayo
14:34:01 <tuxayo> rmaint?
14:34:01 <wahanui> it has been said that rmaint is definitely a great job to find all kinds of things to fix and clarify in translations, system requirements, CI among others.
14:34:49 <tuxayo> I have some catch up before string freeze. And some requested patch to monitor if they come upstream.
14:35:03 <tuxayo> *patches
14:35:48 <tuxayo> Not much to add otherwise
14:36:02 <tuxayo> #topic Updates from the QA team
14:36:03 <tuxayo> qa_team?
14:36:03 <wahanui> rumour has it qa_team is cait, marcelr, khall, kidclamp, kohaputti, lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova, Joubu and dcook
14:37:02 <tuxayo> Tomorrow, patch testing session with french speakers. Crossing finger. I also have to send a poll for an English speaking session quick.
14:37:17 <oleonard> tuxayo++
14:37:52 <ashimema> tuxayo++
14:38:02 <ashimema> doing a great job getting more people onboard tuxayo
14:38:19 <ashimema> qa wise.. I've been a bit low on numbers recently.. just overly busy
14:38:45 <ashimema> marcelr++ and cait++ for picking up the slack so it's not so noticable
14:39:13 <tcohen> tuxayo++
14:39:34 <tuxayo> Any additional hints for channels to reach librarians and system librarians using Koha? (Internationally) I addition to the general list and Koha US list.
14:39:51 <ashimema> QA emails have been taking a difference approach of late.. highlighting nice things that have gone in to help motivate the team.. cait++
14:40:35 <tuxayo> > great job getting more people onboard tuxayo
14:40:35 <tuxayo> Still not sure about that, but the potential is definitely here.
14:40:42 <ashimema> there's also now more sections.. old bugs, interesting bugs and bad bugs.. not always present in every email.. but cait is generally doing great things.
14:40:45 <tuxayo> Need to keep going
14:40:45 <marcelr> tuxayo Koha user group in NL/BE
14:41:04 <marcelr> cait++
14:41:30 <tuxayo> marcelr: yes, that's what we need! I'll ping you about that later.
14:41:34 <ashimema> there isn't really a single user group in the UK.. there are a few that are just getting up and running.. but not ready for contributing much yet..
14:41:37 <marcelr> sure
14:42:27 <ashimema> coms channels aren't yet disassociated from ptfs-e.. we're trying to wean them off of us and make them more independant basically.
14:43:07 <marcelr> coms?
14:43:22 <ashimema> communications
14:43:22 <tuxayo> communications I guess
14:43:44 <tuxayo> I'll keep ccing you ashimema and people from Interleaf to relay messages.
14:43:55 <tuxayo> Moving on?
14:44:05 <ashimema> ta
14:44:25 <tuxayo> #topic Status of roadmap projects
14:44:30 <tuxayo> https://annuel.framapad.org/p/koha_22.11_roadmap
14:46:01 <tcohen> we already talked about most of it on the RM section
14:46:09 <tuxayo> thd, tcohen: news about the wiki?
14:46:15 <tcohen> the only thing that I didn't mention is thd's wiki migration
14:46:23 <tcohen> that is blocked because of my own lack of time
14:46:26 <tcohen> thd++
14:46:50 <thd> tcohen and I have been missing times when we are both not too busy or sleepy to connect a customised MediaWiki Canasata to Koha infrastructure .
14:46:58 <tuxayo> Everyone needs rest from time to time :)
14:47:16 <tcohen> thd: do you think we can defer the ES stuff for after the migration?
14:47:21 <thd> I tried stalking tcohen yesterday but that was not nice.
14:47:24 <tcohen> or you think we shuold do it all together?
14:47:39 <thd> ElasticSearch is the easy part.
14:47:49 <tcohen> ok
14:48:09 <thd> The whole wiki indexes in 5 min. with 1 GB RAM.
14:48:20 <tcohen> #action tcohen and thd will arrange a date in the next few days
14:48:34 <ashimema> ++
14:48:41 <ashimema> it all feels sooooo close
14:49:04 <thd> It supports good customisations with extensions depending on ElasticSearch which I have customised.
14:49:08 <ashimema> 22.11 is uber close too.. yikes..
14:49:24 * ashimema just made the realisation
14:49:45 <marcelr> feel the freeze
14:49:57 <tcohen> heh
14:49:59 <tuxayo> > 22.11 is uber close too
14:49:59 <tuxayo> Yes, not enough time to rebase and finish a dev of mine T_T still gonna do it like it's possible so at last the thing is submitted.
14:50:20 <ashimema> there's never enough time :(..
14:50:33 <thd> ElasticSearch does not seem to be a problem when it can be so easily reindexed if with few resources if anything goes wrong.
14:50:57 <tcohen> thd: I only asked because it is just another moving piece adding complexity to the migration
14:51:03 <tcohen> but we will sort it out, for sure
14:51:41 <tcohen> tuxayo: moving on?
14:51:59 <tuxayo> #topic Actions from last meeting
14:52:00 <thd> I have tamed it with a special script for reindexing and customised Extensions such as AdvancedSearch which depend on ElasticSearch.
14:52:14 <tuxayo> «tcohen to schedule/call a "CSRF day" to work on related patches together»
14:52:30 <tcohen> damn :-D
14:53:00 <tuxayo> #action tcohen to schedule/call a "CSRF day" to work on related patches together
14:53:39 <tcohen> nugged and team started that, and we got distracted by other urgent stuffs
14:54:12 <tuxayo> #action cait /Katrin to update LTS wiki page with current information from last dev meeting
14:54:15 <tuxayo> Page not updated. And Katrin sent apologies for not being able to attend today.
14:54:29 <tuxayo> «ashimema will file a bug making Koha::Object::public_read_list throw an exception »
14:54:32 <nugged> tcohen: that means - one more "re-start" day for CSRF? (me: yes, if so).
14:54:42 <tuxayo> «Not required, see commit: https://git.koha-community.org/Koha-community/Koha/commit/e0de8364b7c197cd3bd1b70f93766ecc6da11216»
14:54:48 <ashimema> I commented.. we decided it wasn't required
14:54:59 <tuxayo> So that's done :)
14:55:04 <ashimema> yup 🙂
14:55:16 <tuxayo> «tcohen draft proposal for master→main change and draft of action list »
14:55:50 <tcohen> I haven't had the chance to review Joubu's proposal to shrink the repo, which was part of the plan
14:56:36 <ashimema> one for next cycle now I reckon
14:56:50 <tcohen> I would like to be able to talk to Joubu about that plan
14:56:55 <ashimema> especially with Joubu out for now.. he had dug a lot in that area
14:56:56 <tcohen> before moving forward
14:57:05 <ashimema> agreed
14:57:14 <ashimema> I think we can live one more cycle
14:57:14 <tcohen> what ashimema said
14:57:27 <tuxayo> tcohen: I have a side proposal: run on our git server `git gc --prune=now --aggressive` locally it skrink my repo down to 700 MiB
14:57:47 <tuxayo> Hopefully that will do the same and will affect the download size
14:58:07 <tcohen> tuxayo: I think we have that cron-ed
14:58:16 <ashimema> I believe so
14:58:28 <tcohen> Joubu's proposal had to do with removing translations from the main repo
14:58:44 <tcohen> which take most of the (historically) used space
14:58:49 <tuxayo> Great! Yikes it would be much worse without that cron then.
14:59:11 <tuxayo> > which take most of the (historically) used space
14:59:11 <tuxayo> ++
14:59:44 <ashimema> we shoudl probably encourage shallow clones.. but I'd need to remind myself how they work before recommending it.
14:59:44 <tcohen> I've gotta run
14:59:52 <tuxayo> When to ask again about the master→main thing?
14:59:59 <tcohen> shallow clones take server's CPU
15:00:06 <ashimema> ah.. ok
15:00:11 <tcohen> tuxayo: right after the release
15:00:16 <ashimema> +1
15:00:22 <tuxayo> tcohen: CPU: Not for very long I guess?
15:00:32 <tcohen> we need to measure it, for sure
15:00:50 <ashimema> next topic?
15:00:50 <tcohen> we could encourage people to pull from Gitlab as well
15:01:15 <tuxayo> #action tcohen [WAIT after 21.11 release] draft proposal for master→main change and draft of action list
15:01:33 <tuxayo> «thd give their two cents on bug 31150 in order to tilt the scale to on side.»
15:01:33 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31150 enhancement, P5 - low, ---, koha-bugs, In Discussion , _on or _date for DB date columns?
15:02:13 <tuxayo> «to tilt the scale to on side» <= I failed english XD it was late for my defence
15:02:15 <marcelr> or or xor
15:02:48 <tuxayo> Moving one, it was just a minor reminder for thd
15:02:52 <tuxayo> «tuxayo ask on the mailing list « are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL 8 on main/master. » »
15:02:58 <tuxayo> Done on koha-devel today
15:03:14 * thd retracted his perception of ambiguity unless we rename every use to $date_time
15:03:42 <tuxayo> «tuxayo can for volunteers on the mailing list to «Update coding guidelines with the replacement of jQueryUI Datepicker with flatpickr - introduced in bug 29239. And document the usage in the wiki. cc Aleisha who had trouble with using flatpickr for the detail of what is missing» »
15:03:42 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29239 enhancement, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] Replace jQueryUI's timepicker with flatpickr
15:03:56 <tuxayo> Done on koha-devel today.
15:04:10 <tuxayo> «tuxayo maybe create a ticket for updating the guidelines about flatpickr»
15:04:12 <tuxayo> bug 31741
15:04:12 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31741 enhancement, P5 - low, ---, koha-bugs, NEW , Update coding guidelines with the replacement of jQueryUI Datepicker with flatpickr
15:04:28 <tuxayo> #topic General development discussion (trends, ideas, ...)
15:04:29 <thd> We merely need some coding guidance that a variable with date only should be $date_only
15:04:41 <tuxayo> «Bug 31674 - We need a template/guideline around how to consistently form our modals»
15:04:41 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31674 enhancement, P5 - low, ---, martin.renvoize, NEW , We need a template/guideline around how to consistently form our modals
15:05:27 <ashimema> I raised that one.. whilst reviewing the staff client refresh and whilst working on some other code.m
15:05:36 <tuxayo> So coding guideline that links to somewhere (to be written) part of the developper handbook with the template?
15:05:49 <tcohen> gotta leave
15:05:53 <tcohen> laters!
15:05:57 <ashimema> We are generally really inconsistent with things...  We need a style guide for a lot more things..
15:05:58 <tuxayo> o/
15:06:03 <ashimema> Including examples .
15:06:11 <oleonard> I can work on some updates to the wiki
15:06:26 <ashimema> I've already suggested I work on it with oleonard assuming that's still ok oleonard
15:06:42 <ashimema> Perfect
15:06:42 <wahanui> Perfect is, like, the enemy... (of what I forgot)
15:07:11 <ashimema> A nice simple modal dialogue for starters.. then another example for a modal that includes a form
15:07:30 <ashimema> Those two I think would cover most use cases..
15:08:15 <ashimema> I would help if we could link to the right bootstrap docs too.. I constantly find myself confused with which bootstrap versions where using where
15:08:34 <ashimema> Anywho.. that's enough explanation for today I reckon
15:08:59 <tuxayo> Then this? : #action oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.
15:09:12 * ashimema wants to pick off components one by one for this.. clear guidelines of breadcrumbs would be good too.. tcohen raised that above
15:09:19 <oleonard> tuxayo: Yes
15:09:24 <ashimema> Great tuxayo
15:09:42 <tuxayo> > pick off components one by one for this.. clear guidelines of breadcrumbs would be good
15:09:42 <tuxayo> Similar to the needs with flatpickr
15:09:55 <tuxayo> But for now modals, then
15:09:59 <tuxayo> #action oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.
15:10:07 <tuxayo> «git-bz is stuck on Python 2 which went end of life on January 1st 2020.. should we start to consider alternatives? »
15:10:44 <ashimema> This is a bigger discussion.. maybe postpone it .
15:10:45 <tuxayo> Python2 It's still in Debian and Ubuntu but for example Arch dropped it. Now it's an unofficial package harder to install.
15:10:51 <tuxayo> Ok
15:10:57 <oleonard> +1 postpone
15:11:15 <ashimema> With tcohen gone and me about to go.. it's something we can consider during the next cycle again
15:11:15 <tuxayo> #action tuxayo postpone «git-bz is stuck on Python 2 which went end of life on January 1st 2020.. should we start to consider alternatives?»
15:11:29 <nugged> git-bz related: we use own patched version
15:11:42 <nugged> to be Py3 compatible
15:11:46 <tuxayo> !!!
15:12:11 <tuxayo> nugged: please publish it somewhere! :D
15:12:16 <ashimema> Oh nice.. submit that patch to Koha ;)
15:12:18 <thd> Python 2 forever :)
15:12:22 <ashimema> That would make me very happy
15:12:23 <tuxayo> lol
15:12:52 <nugged> that what I also wanted to ask because we thought everyone on P2 and only we "kill it everywhere in MacOSes :)"
15:13:25 <tuxayo> merge requests welcome ^^ : https://gitlab.com/koha-community/git-bz
15:13:29 <nugged> good
15:13:39 <nugged> we'll put our draft for critics tomorrow
15:13:40 <tuxayo> > kill it everywhere in MacOSes
15:13:40 <tuxayo> ?
15:13:58 <ashimema> We can always advice on using the right branch for your distro if we're worried about breaking back compat
15:14:04 <nugged> tuxayo: there's no P2 anymore in some environments
15:14:20 <tuxayo> yes, that's the problem
15:14:50 <nugged> ok noted, changes will be proposed.
15:14:50 <tuxayo> > because we thought everyone on P2
15:14:50 <tuxayo> Every Linux distro ships with a P3 install in parallel of P2
15:15:11 <tuxayo> #topic Review of coding guidelines
15:15:14 <thd> There are still major enterprise programs at big businesses running Python 2.
15:15:35 <tuxayo> nugged: thanks again
15:15:47 <tuxayo> « SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now. »
15:16:11 <tuxayo> IIUC, it means only .pm are allowed to have SQL
15:16:25 <ashimema> arch python3 is only available in the aur now.. and is slightly challenging to compile due to failing tests
15:16:39 <ashimema> but anyway.. a python 3 version of git-bz would be awesome
15:16:44 <tuxayo> But DBIC schema file should be also allowlisted.
15:16:57 * ashimema has to runn
15:17:03 <tuxayo> > arch python3
15:17:03 <tuxayo> *arch python2
15:17:09 <tuxayo> > a python 3 version of git-bz would be awesome
15:17:09 <tuxayo> ++
15:17:19 <oleonard> I think we'd better wrap it up we keep losing people :D
15:17:37 <nugged> ++
15:18:15 <tuxayo> #action tuxayo postpone «SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now.»
15:18:28 <tuxayo> #topic Set time of next meeting
15:19:03 <tuxayo> Next meeting for the oceania-americas timeslot has been decided last time. I'll go get it
15:19:18 <tuxayo> For next meeting this slot: 16th november?
15:19:52 <tuxayo> There will be (and already have been) winter time changed in some countries in the mean time.
15:20:09 <oleonard> Is there a need to have more than one between now and the release?
15:20:32 <tuxayo> > 16th november?
15:20:32 <tuxayo> 9th, I jumped a week
15:21:40 <tuxayo> > Is there a need to have more than one between now and the release?
15:21:40 <tuxayo> Since we split in two time slots, we can do that for releases.
15:22:16 <oleonard> Anyway... 9th is good for me
15:22:39 <tuxayo> #info Next meeting: 26 October 2022, 22 UTC
15:22:45 <tuxayo> That's for oceania-americas
15:23:33 <tuxayo> > Anyway... 9th is good for me
15:23:33 <tuxayo> Ok, if needed when can do the 2th of november and the 16th
15:23:50 <tuxayo> *we can do
15:24:57 * thd is never awake on the 2th of November.
15:25:29 <tuxayo> Still planing the 9th then
15:25:29 <tuxayo> > There will be (and already have been) winter time changed in some countries in the mean time.
15:25:29 <tuxayo> So what about 15 UTC? It means 16 in france, 10 new york, 7 in LA
15:25:54 <oleonard> +1
15:25:56 <tuxayo> 12 argentina
15:26:15 <thd> +1
15:26:31 <tuxayo> I never realized part of the US couldn't attend these meetings now.
15:26:38 <tuxayo> Let's settle for that then
15:27:24 <tuxayo> #####info Next Americas-Europe slot meeting: 9 November 2022, 15 UTC
15:27:48 <tuxayo> #endmeeting