15:01:37 <tuxayo> #startmeeting Development IRC meeting 14 December 2022
15:01:37 <huginn> Meeting started Wed Dec 14 15:01:37 2022 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:37 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:37 <huginn> The meeting name has been set to 'development_irc_meeting_14_december_2022'
15:02:51 <kidclamp> #info Nick Clemens, ByWater Solutions
15:02:59 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
15:03:04 <tuxayo> rmaints?
15:03:09 <ashimema> #info Martin Renvoize, PTFS-Europe
15:03:11 <tcohen> qa_team
15:03:53 <thd> #info Thomas Dukleth, Agogme, New York City
15:04:41 <tuxayo> #info Victor Grousset, Tuxayo Ltd., France
15:06:12 <tuxayo> qa_team is cait, marcelr, khall, kidclamp,  lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova, Joubu and dcook
15:07:16 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_14_December_2022 Today's agenda
15:07:31 <tuxayo> #topic Announcements
15:07:42 <cait> sorry for being late
15:07:42 <tuxayo> anything to announce that doesn't fit better in the other topics?
15:07:48 <cait> @info Katrin Fischer, BSZ, Germany
15:07:48 <huginn> cait: Error: The command "info" is available in the Factoids and RSS plugins.  Please specify the plugin whose command you wish to call by using its name as a command before "info".
15:08:16 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
15:08:38 <cait> #info Katrin Fischer, BSZ, Germany
15:09:04 <tuxayo> #topic Update from the Release manager
15:09:18 <tuxayo> tcohen: 🎙️
15:10:02 <tcohen> Things are moving a bit slow
15:10:21 <tcohen> school ended for the rest of the year so figuring how to organize the little kids
15:10:34 <tcohen> I've been focused on KTD and jenkins
15:10:45 <tcohen> particularly, I made jenkins notifications work again
15:10:51 <cait> tcohen++
15:11:00 <liliputech> tcohen++
15:11:04 <tcohen> and I added the QA team on CC for failures (so more eyes there)
15:11:14 <tuxayo> tcohen++
15:11:30 <tuxayo> Should there already have been emails sent?
15:11:57 <tcohen> nope
15:12:00 <tcohen> no pushes :-D
15:12:11 <tcohen> I only tweaked the 'master' tasks
15:12:30 <tcohen> I created an email alias for rmaints and the qa team
15:12:37 <tcohen> on my own domain
15:12:41 <tcohen> I will be using that
15:12:45 <tuxayo> thanks :)
15:12:46 <tuxayo> And almost all is green :)
15:12:55 <tcohen> we should rather have something in @koha-community.org
15:12:59 <tcohen> but this will work for now
15:13:08 <tuxayo> > we should rather have something in @koha-community.org
15:13:08 <tuxayo> ++
15:13:13 <cait> oh I wonder, didn't we have a christmas/winter theme for the dashboard?
15:13:22 <tuxayo> I guess mason also get the failures?
15:13:37 <tuxayo> > winter theme for the dashboard?
15:13:37 <tuxayo> Ah, maybe!
15:14:57 <tcohen> I expected more movement after the release, tidying things on the new interface revamp
15:15:13 <tcohen> but that is not the case, so I might start pushing new things soon
15:15:15 <cait> same, but I think everybody is tired and busy - holidays coming up
15:15:35 <tcohen> on the other hand, we are in the process of reviewing our build pipeline
15:15:45 <tuxayo> How is the .00 ? Anything terrible found?
15:16:07 <tcohen> and there was some consensus about not pushing generated code like CSS, vue-related stuffs
15:16:09 <cait> tuxayo: check QA emails ;)
15:16:10 <tcohen> to the repo
15:16:27 <tuxayo> > check QA emails
15:16:27 <tuxayo> Ah yes, I'm late on them!
15:16:36 <tcohen> so I've pushed a couple CSS fixes, but in master you need to build it yourself
15:17:02 <cait> is there information on the wiki for that yet?
15:17:08 <cait> maybe also an email would be good
15:17:23 <cait> how does it work?
15:17:28 <cait> when I am yarn building now
15:17:33 <tcohen> the main problem is we haven't come up with a proposal yet
15:17:38 <cait> i always have to stash clean before SO as the untracked files get in the way
15:17:42 <tcohen> cait: you need to
15:17:44 <tcohen> yarn build
15:17:48 <tcohen> yarn build --view opac
15:17:50 <tcohen> and
15:17:52 <tcohen> yarn build_js
15:18:04 <cait> I am pretty sure right now i liked the commited files better
15:18:04 <tcohen> for a complete working build
15:18:06 <tuxayo> > but in master you need to build it yourself
15:18:06 <tuxayo> The new yarn steps when starting ktd also do the CSS?
15:18:16 <ashimema> Sorry, I'm on the school run so catching up and site
15:18:17 <ashimema> Slow
15:18:28 <cait> are these files added to an ignore file automatically?
15:18:42 <cait> and is there a shortcut to run all 3?
15:18:45 <tcohen> they are in .gitignore
15:18:50 <cait> will ktd come up with them pre-built?
15:18:52 <cait> ok
15:18:58 <oleonard> I was just thinking a shortcut for all three would be a great idea
15:18:58 <ashimema> Winter theme for dashboard was something catalyst/rangi usually did.. I think it still exist but would need a rebase
15:19:09 <ashimema> Merge requests welcome. I can review
15:19:12 <tcohen> I will submit an alias for that
15:19:21 <cait> maybe an option for restart_all
15:19:25 <tcohen> fyi: it should be run on the kshell
15:19:48 <cait> ktd --kshell or one level deeper?
15:19:49 <ashimema> Submit requests to ktd cait
15:19:54 <ashimema> We're still working on it all
15:20:24 <ashimema> I intend to help tcohen more asap.. been struggling to keep up with assigning work to our new team here
15:20:27 <tcohen> ktd --shell -> kshell
15:20:38 <cait> you don't need to with yarn bulid now
15:20:54 <tcohen> cait: that's correct
15:20:56 <tcohen> BUT
15:21:05 <tcohen> beware you are generating files as root user
15:21:30 <cait> hm
15:21:30 <tuxayo> Is it bad? They aren't commited
15:21:39 <cait> had the same thought :)
15:21:42 * ashimema wonders if there would be a was for ktd --kshell to dump you straight in at kshell.. not sure what requires root now
15:21:49 <cait> and still: please document and send an email to list
15:21:55 <tcohen> you probably won't be able to delete them outside ktd
15:22:35 <tuxayo> > not sure what requires root now
15:22:35 <tuxayo> Oh that changed!
15:24:03 <tuxayo> I'll try using only the non root user and see if anything goes wrong
15:24:21 <ashimema> Some commands probably do.. but I'm thinking a nice improvement would be to try and only require the env we have inside kshell and dump the user there instead of root
15:25:33 <tcohen> restart_all and other stuff requires root
15:26:00 <tcohen> running the qa command outside kshell results in bad permission problems on the git repo
15:26:15 <tuxayo> > outside kshell
15:26:15 <tuxayo> So in root?
15:26:29 <ashimema> Yup
15:26:56 <tcohen> right, if you perform a checkout as root (outside kshell) then some refs on the git repo (that are not evident with git status)
15:27:16 <tcohen> will be owned by root and working with git outside KTD will fail
15:27:21 <tcohen> with some weird errors
15:27:51 <ashimema> Yup
15:28:32 <ashimema> I would say for now the rule of thumb should be do it inside kshell.. if you hit a permission issue exit out to root
15:28:44 <tuxayo> So first steps would be make a ticket to have restart_all/reset_all to work on the kohadev user (by using sudo or something) and another to have ktd --kshell to dump you straight in kohadev user. Is that it?
15:28:58 <ashimema> For those that don't fully grasp it, that's a fair default modus operandi
15:29:33 <ashimema> Yeah, that's the idea I was just spitballing tuxayo
15:29:53 <ashimema> Anywho, let's take that discussion off meeting I reckon
15:30:20 <tuxayo> => https://gitlab.com/koha-community/koha-testing-docker/-/issues/270
15:30:51 <thd> weird dev environment => weird errors
15:31:02 <tuxayo> #action tuxayo open tickets on ktd for the basic stuff needed to easily work on the non-root user
15:31:16 <tuxayo> tcohen: other updates?
15:31:31 <tcohen> nope
15:31:37 <tcohen> QA all the bugs!
15:31:53 <tuxayo> ^^
15:31:56 <tuxayo> #topic Updates from the Release Maintainers
15:32:15 <tuxayo> lukeg , Wainui ashimema
15:32:21 <tuxayo> liliputech:
15:32:26 <ashimema> We're getting back up to speed at ptfs-e
15:32:56 <ashimema> We're 2 days behind right now due to company Xmas meeting this week . I will catch us up tonight
15:33:17 <ashimema> I fixed a bunch if issues with koha-push script too
15:33:25 <ashimema> And git hooks
15:33:57 <ashimema> It's was a baptism of fire for our new Devs, but they're enjoying it and getting onboard fast
15:34:01 <tuxayo> Your new recruits doing RMaint with you are Matt and Jacob is that how it is?
15:34:08 <ashimema> Correct
15:34:09 <tuxayo> ashimema++
15:34:29 <tuxayo> Then send welcome to them :)
15:34:39 <ashimema> Pedro will also come in board when he goes full time in January.. right now he's contracting for us part time whilst he serves his notice
15:35:09 <ashimema> Will do, they're flying back from Edinburgh right now.. else they'd be here
15:35:11 <tuxayo> Pedro is the person that helped for ERM IIRC
15:35:14 <reiveune> bye
15:35:56 <cait> oops
15:36:06 <ashimema> Yup
15:36:15 <cait> sorry, got distracted for a moment
15:36:24 <tuxayo> Many good news, ptfs-e++
15:36:39 <tuxayo> #topic Updates from the QA team
15:36:52 <tuxayo> qa_team?
15:37:01 <tuxayo> qa_team is cait, marcelr, khall, kidclamp,  lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova, Joubu and dcook
15:37:13 <cait> as tcohen has said, things have been a little slow
15:37:25 <cait> queues are filling up, but at least a bit slower than usual too
15:37:47 <cait> please check QA emails, I tried to include urgent stuff or things people asked for help for
15:38:14 <cait> other than that... please QA all the bugs!
15:38:31 <ashimema> QA has been slow from me.. again it's because I'm upskilling the team right now so a bit swamped
15:38:44 <tuxayo> Last patch testing session has been better in terms of attendance that the others.
15:38:58 <ashimema> Awesome
15:39:00 <tuxayo> I'll wait for January to plan others
15:39:31 <tuxayo> ashimema and tcohen visit on the call was lovely ^^
15:39:35 <ashimema> I reckon we should promote new year's resolutions of attending those bug testing sessions ;)
15:39:49 <tuxayo> That's how I'll advertise it :P
15:39:59 <ashimema> tuxayo++
15:40:04 <ashimema> It's a great initiative
15:41:00 <tuxayo> Still not reaching parity of signoff bug vs when I'm directly doing it.
15:41:11 <tuxayo> But there is also the outreach value
15:41:13 <tcohen> gotta go feed the kids
15:41:20 <tcohen> laters
15:42:01 <tuxayo> And some stuff we where able to team on for testing and being with librarians allowed to understand tricky stuff :)
15:42:21 <tuxayo> #topic KohaCon24 bidding
15:42:24 <ashimema> That's great :)
15:42:29 <tuxayo> «Set the rough schedule» «Find a volunteer to oversee the process and trigger actions»
15:42:49 <ashimema> Really helpful to have the right people in the room together sometimes
15:43:05 <tuxayo> yes!
15:44:14 <tuxayo> Knowing the quirks of patch testing tools and workflow + the more advanced uses of Koha doesn't leave much people that can a fair share of the patches
15:44:48 <tuxayo> So, it's a follow up to the last general meeting
15:45:05 <tuxayo> (about the KohaCon24 bidding)
15:47:02 <tuxayo> I found the logs!
15:47:02 <ashimema> Super organised
15:47:03 <tuxayo> «So start in January the bidding so if someone wants to host in January 2024»
15:47:31 <tuxayo> Start early to allow already bids to have time
15:48:15 <tuxayo> And let the big run for 2 months
15:48:44 <tuxayo> And see if we have a proposal at the next general meeting in april
15:49:11 <tuxayo> Any chance/refinement to the plan?
15:50:01 <ashimema> Still on school run and losing feeling in fingers
15:50:30 <tuxayo> > losing feeling in fingers
15:50:30 <tuxayo> due to cold?
15:51:30 <thd> cold is presumed
15:51:42 <tuxayo> Let's keep the above plan. Any volunteer to oversee the process and trigger actions?
15:52:04 <thd> ... where ashimea is located.
15:53:18 <tuxayo> What would be needed besides making the wiki page using the template and announcement email using paste ones?
15:56:01 <thd> Prompting on email if there is no or little response.
15:56:19 <tuxayo> Anyway, I still have to call for volunteer on the mailing list as planned in last weeks meeting and I'll ask for the step also there.
15:56:34 <tuxayo> #action tuxayo call for a volunteer on mailing lists to open the bidding for KohaCon24 and confirm the task list for that.
15:56:49 <tuxayo> #topic Status of roadmap projects
15:57:03 <tuxayo> Do we have anything for now about roadmap projects?
15:57:05 <thd> Possibly agreeing to alter regional rotation for the year if no response forthcoming.
15:58:13 <tuxayo> thd: that was already considered I think when we where out of proposals, but we have a lot of time for now
15:58:26 <thd> gmcharlt had sent a message indicating that Equinox was still interested in hosting the wiki which is good for infrastructure distribution.
15:58:34 <tuxayo> thd: "roadmap projects" any news about wiki email notifications?
15:58:43 <tuxayo> nice
15:58:53 <thd> However, gmcharlt is always super busy so no further response.
15:59:08 <ashimema> sorry.. home now and reading back
15:59:39 <thd> tcohen has been starting to set up the SMTP server for the server where the wiki runs.
16:00:12 <tuxayo> So Equinox would attach a server to our portainer thing?
16:00:25 <tuxayo> great :)
16:00:35 <tuxayo> Thanks for the news
16:00:37 <thd> What Equinox might do needed discussion.
16:01:10 <thd> However, many people have trouble with the human bandwidth required for discussion.
16:01:18 <tuxayo> ^^
16:01:26 <cait> for Kohacon: Basically that, mails to the mailing lsit, wiki page and adding to agendas for next steps or if any decisions need to be made
16:01:45 <tuxayo> thanks cait!
16:01:58 <tuxayo> anything else thd? Or someone else about roadmap stuff?
16:02:12 <cait> doesn't need to do the hard stuff, but makes ure it doesn't get out of sight and progresses
16:02:23 * thd does not know why the mail system connected to portainer, etc. had stopped working.
16:03:05 <thd> However, virtualising everything creates weird problems as we discussed previously in this meeting.
16:03:22 <tuxayo> > had stopped working
16:03:22 <tuxayo> IIRC it wasn't working on this server since before. But it wasn't a problem since the wiki wasn't there.
16:03:56 <tuxayo> #topic Actions from last meeting
16:04:09 <tuxayo> cait Update wiki page for LTS: completed, see https://wiki.koha-community.org/wiki/LTS_workflow_proposal
16:04:13 <tuxayo> cait++
16:04:19 <thd> It had not been a wiki problem when the wiki was not there so a smaller problem became larger.
16:05:02 <tuxayo> See also https://wiki.koha-community.org/wiki/Koha_Versioning
16:06:03 <tuxayo> next: «Deferred until after the 22.11 release»
16:06:03 <tuxayo> tcohen to schedule/call a "CSRF day" to work on related patches together
16:06:03 <tuxayo> tcohen to draft proposal for master→main change and draft of action list
16:06:33 <tuxayo> oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.: focus is currently on staff interface redesign changes, see the  draft style guide:
16:06:34 <tuxayo> https://annuel.framapad.org/p/koha-styleguide-draft
16:07:31 <tuxayo> #action tcohen to schedule/call a "CSRF day" to work on related patches together
16:07:40 <tuxayo> #action tcohen to draft proposal for master→main change and draft of action list
16:08:11 <tuxayo> #action oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft
16:08:42 <tuxayo> #topic General development discussion (trends, ideas, ...)
16:08:51 <tuxayo> «git-bz is stuck on Python 2 which went end of life on January 1st 2020… should we start to consider alternatives?»
16:09:36 <tuxayo> I email nugged to ask if with Helsinki Uni they have their Python 3 fork of git-bz published somewhere
16:10:16 <tuxayo> So hopefully git-bz won't be an issue
16:10:36 <tuxayo> « git bz attach -e BUGNUMBER HEAD~X.. (where X = number of patches (davidnind) »
16:10:44 <tuxayo> «I've always done it this way when signing off patches as it is what I was told to do»
16:11:00 <tuxayo> «There was some discussion on IRC on using -e or not, and obsoleting patches http://irc.koha-community.org/koha/2022-10-20#i_2457161»
16:11:11 <tuxayo> «Just seeking guidance on best practice, including whether old patches should be obsoleted (by adding the obsolete tag) to make the bug "cleaner"»
16:11:22 <tuxayo> «There maybe a number of scenarios where different options are preferred (for example, sign off vs. passed QA)»
16:11:51 <tuxayo> Ah ok, marking the comment with the obsolete tag so it's hidden. And not just obsoleting the attachement.
16:17:03 <tuxayo> After a quick read there doesn't seem to be a way to have the patch comments also obsoleted with git bz (to have them collapsed for old patches). But for the most tech tinkerers here, there is a script that can be ran with stuff like the Greasemonkey Firefox extension: https://pastebin.com/c99G9KgG
16:17:59 <tuxayo> I never used -e , is that an alternative to interacting with ticket via the web ui?
16:18:25 <tuxayo> Is there something that is much faster to do there?
16:21:59 <tuxayo> @later davidnind: not much workflow feedback on your git-bz question http://irc.koha-community.org/koha/2022-12-14#i_2467175  likely koha-devel would have a wider reach.
16:22:00 <huginn> tuxayo: I suck
16:22:07 <tuxayo> @later tell davidnind: not much workflow feedback on your git-bz question http://irc.koha-community.org/koha/2022-12-14#i_2467175 likely koha-devel would have a wider reach
16:22:07 <huginn> tuxayo: The operation succeeded.
16:22:25 <tuxayo> #topic Review of coding guidelines
16:23:08 <tuxayo> #action tuxayo defer "SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now. (Deferred from previous meeting(s).)"
16:23:13 <tuxayo> #topic Set time of next meeting
16:23:23 <tuxayo> «Should the next meeting be the 28th (straight after Christmas for countries that observe this) or 11th January?»
16:23:28 <tuxayo> «Should it then be in a timeslot more suitable for Oceana-Americas?»
16:24:15 <tuxayo> For 2nd question, David N will plan a date in january. For now we can plan here any date for this timeslot.
16:24:18 * thd prefers Jan.
16:25:35 <tuxayo> Ah yes, that was the idea.
16:25:39 <tuxayo> (finally the calendar loaded)
16:26:09 <tuxayo> Not much hope for January 4th. The 11 then?
16:26:31 <thd> yes please
16:26:33 <ashimema> 11th is better
16:27:03 <tuxayo> Great, thanks!
16:27:22 <tuxayo> #info Next meeting: 11 January 2023, 15:00 UTC
16:27:26 <tuxayo> #endmeeting