#koha: Development IRC meeting 14 September 2022

Meeting started by cait at 14:11:54 UTC (full logs).

Meeting summary

  1. Introductions (cait, 14:12:04)
    1. Katrin Fischer, BSZ, Germany (cait, 14:12:22)
    2. Paul Derscheid, LMSCloud GmbH, Munich, Germany (paulderscheid[m], 14:12:39)
    3. Thomas Dukleth, Agogme, New York City (thd, 14:12:53)
    4. https://wiki.koha-community.org/wiki/Development_IRC_meeting_14_September_2022 Today's agenda (tuxayo, 14:13:10)
    5. Martin Renvoize, PTFS Europe, UK (ashimema, 14:13:18)
    6. Victor Grousset, Tuxayo Limited, France (tuxayo, 14:14:00)
    7. Nick Clemens, ByWater Solutions (kidclamp, 14:15:01)

  2. Announcements (cait, 14:15:27)
    1. Arthur Suzuki, BibLibre, France (liliputech, 14:15:53)
    2. KohaCon next week! If you are attending, feel free to add yourself to arrivals and departures on the wiki: https://wiki.koha-community.org/wiki/KohaCon22_Social (cait, 14:15:58)
    3. https://koha-community.org/kohacon/kohacon22/ KohaCon22 website - presentations will also be streamed to YouTube (cait, 14:16:31)
    4. National Library of Finland to host KohaCon23 in Helsinki, Finland! (cait, 14:16:50)

  3. Update from the Release manager (22.11) (tuxayo, 14:18:00)
  4. Updates from the Release Maintainers (tuxayo, 14:18:45)
  5. Updates from the QA team (tuxayo, 14:20:36)
    1. QAM is looking for some topic expert for LDAP - we got about 4 bugs waiting both queues since forever and I am calling for help! (cait, 14:21:13)
    2. QA Team is down another person with kohaputti leaving - thanks a lot for everything! You'll be missed! (cait, 14:22:37)
    3. monday 26th, patch testing session: https://lists.katipo.co.nz/pipermail/koha/2022-September/058422.html (tuxayo, 14:23:09)

  6. Status of roadmap projects (tuxayo, 14:25:13)
    1. https://annuel.framapad.org/p/koha_22.11_roadmap (tuxayo, 14:25:24)
    2. Wiki update is to continue ASAP - thd fixed another error and we hope for news very soon (cait, 14:30:14)
    3. Staff interface redesign (bug 30952) is being worked on intensely. You can use patches on bug to set up a sandbox, issues for the branch are tracked on github: https://github.com/jajm/koha-staff-interface-redesign/issues (lots of screenshots to see) (cait, 14:32:02)
    4. Task queue: is moving along: API for jobs info is NQA, moving MARC import is PQA (cait, 14:32:40)
    5. ERM Any Vue experts: Please have a look at the ERM development (cait, 14:33:07)
    6. Rewrite of C4::Biblio and C4::Items is progressing with some bigger patches pushed lately (cait, 14:34:01)
    7. ACTION: tcohen to schedule/call a "CSRF day" to work on related patches together (cait, 14:34:53)
    8. https://gitlab.com/thekesolutions/Koha/-/commits/oauth_client (tcohen, 14:36:04)
    9. OAuth2/OIDC work is progressing, see https://gitlab.com/thekesolutions/Koha/-/commits/oauth_client (cait, 14:37:15)

  7. Actions from last meeting (cait, 14:38:42)
    1. ACTION: liliputech (deferred from previous meetingx3) discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI. (tuxayo, 14:41:25)
    2. ACTION: Katrin to update LTS wiki page with current information from last dev meeting (tuxayo, 14:43:12)

  8. General development discussion (trends, ideas, ...) (cait, 14:46:03)
    1. ACTION: ashimema will file a bug making Koha::Object::public_read_list throw an exception (tuxayo, 14:46:10)
    2. im working on a wiki doc to fix API proiblems, will upload today (mtj, 14:48:18)
    3. i'll aim to chat to arthur about the koha CI stuff on AFI (mtj, 14:52:57)
    4. VOTE: Voted on "Renaming master branch to main?" Results are (tuxayo, 14:57:47)
    5. VOTE: Voted on "Renaming master branch to main?" Results are, Yes: 6 (tuxayo, 15:03:41)
    6. AGREED: Renaming master branch to main (tuxayo, 15:05:09)
    7. ACTION: tcohen Date proposal for master→main change and draft of action list (tuxayo, 15:08:38)
    8. i think we should aim to have koha 22.11 with ES7, running on deb11 and higher (mtj, 15:11:56)
    9. perhaps we suggest ES6 on koha-22.05 with deb10, and ES7 on koha-22.11 with deb11 (mtj, 15:18:31)
    10. good news is we do have ES7 tests passing on 22.05 and 21.11 (mtj, 15:20:55)
    11. Advertise support for ES7 for all branches on 22.11 release. Or sooner if ES7 real world feedback is enough in the meantime. (tuxayo, 15:26:10)
    12. ACTION: tuxayo postpone « Are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL 8 on main/master. » (tuxayo, 15:27:28)
    13. ACTION: tuxayo postpone « SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now. » (tuxayo, 15:27:53)
    14. ACTION: tuxayo postpone «Update guidelines with the replacement of jQueryUI Datepicker with flatpickr - introduced in bug 29239. And document the usage in the wiki» (tuxayo, 15:28:33)

  9. Set time of next meeting (cait, 15:28:57)
    1. Next meeting: 28 September 2022, 21 UTC (tuxayo, 15:31:05)
    2. Next Americas-Europe slot meeting: 12 October 2022, 14 UTC (tuxayo, 15:33:12)


Meeting ended at 15:33:25 UTC (full logs).

Action items

  1. tcohen to schedule/call a "CSRF day" to work on related patches together
  2. liliputech (deferred from previous meetingx3) discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.
  3. Katrin to update LTS wiki page with current information from last dev meeting
  4. ashimema will file a bug making Koha::Object::public_read_list throw an exception
  5. tcohen Date proposal for master→main change and draft of action list
  6. tuxayo postpone « Are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL 8 on main/master. »
  7. tuxayo postpone « SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now. »
  8. tuxayo postpone «Update guidelines with the replacement of jQueryUI Datepicker with flatpickr - introduced in bug 29239. And document the usage in the wiki»


Action items, by person

  1. ashimema
    1. ashimema will file a bug making Koha::Object::public_read_list throw an exception
  2. liliputech
    1. liliputech (deferred from previous meetingx3) discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.
  3. tcohen
    1. tcohen to schedule/call a "CSRF day" to work on related patches together
    2. tcohen Date proposal for master→main change and draft of action list
  4. tuxayo
    1. tuxayo postpone « Are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL 8 on main/master. »
    2. tuxayo postpone « SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now. »
    3. tuxayo postpone «Update guidelines with the replacement of jQueryUI Datepicker with flatpickr - introduced in bug 29239. And document the usage in the wiki»


People present (lines said)

  1. cait (120)
  2. tuxayo (104)
  3. tcohen (43)
  4. ashimema (31)
  5. huginn` (21)
  6. mtj (20)
  7. wahanui (12)
  8. thd (7)
  9. liliputech (1)
  10. oleonard (1)
  11. kidclamp (1)
  12. paulderscheid[m] (1)


Generated by MeetBot 0.1.4.