15:07:41 <tuxayo> #startmeeting Development IRC meeting 16 November 2022
15:07:41 <huginn`> Meeting started Wed Nov 16 15:07:41 2022 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:41 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:07:41 <huginn`> The meeting name has been set to 'development_irc_meeting_16_november_2022'
15:07:50 <tuxayo> #chair cait
15:07:50 <huginn`> Current chairs: cait tuxayo
15:08:28 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_16_November_2022 Today's agenda
15:08:29 <tuxayo> #topic Introductions
15:08:37 <cait> #info Katrin Fischer, BSZ, Germany
15:08:46 <tcohen> #info Tomas Cohen Arazi, Theke Solutions, Argentina
15:08:49 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
15:09:32 <lukeg> #info Lucas Gass, ByWater Solutions, Colorado, USA
15:10:09 <tuxayo> #info Victor Grousset, Tuxayo Limited, France
15:10:25 <tuxayo> #topic Announcements
15:10:38 <cait> kidclamp: ashimema Joubu?
15:10:45 <tuxayo> Anything to announce that doesn't fit in the other topics?
15:10:55 <cait> nothing from me
15:11:02 <tcohen> I've got some RM announcements
15:11:10 <cait> you got your own topic :)
15:11:34 <tuxayo> Wiki upgrade! Thanks again to the people that did it! ^^
15:11:42 * tcohen is feeding the kids minutes before school drop
15:12:25 <tuxayo> moving on?
15:12:28 <tcohen> can I go first?
15:12:39 <tuxayo> ok
15:12:43 <cait> #info Wiki upgrade is done! Thanks to thd, mtj and tcohen and everyone involved :)
15:12:49 <tuxayo> #topic Update from the Release manager (22.11)
15:13:13 <tcohen> #info Last translations update done, minor thing
15:13:39 <tcohen> #info Please take care of the Major and Critical bugs in the queue ASAP
15:13:54 <kidclamp> #info Nick Clemens, ByWater Solutions
15:14:08 <ashimema> #info Martin Renvoize, PTFS-E
15:14:10 <tcohen> #info Our CI and KTD tools are being upgraded for the new node.js dependencies introduced by ERM, please keep your KTD updated
15:14:21 <tcohen> i.e. ktd pull
15:14:34 <tuxayo> ok ๐Ÿ‘๏ธ
15:14:47 <tcohen> that's it, not much time left for the releaes
15:14:58 <tcohen> get involved on fixing things, please
15:15:09 <cait> +1 :)
15:15:10 <ashimema> [off] brrr, it's cold in Leeds waiting for the train
15:15:14 <tuxayo> > keep your KTD updated
15:15:14 <tuxayo> Good to know, since the images are regenerated on every push on main/master. Even if no change.
15:15:49 <tcohen> #info the KTD images have been added the node_modules
15:16:02 <tcohen> #info to allow offline working
15:16:08 <tuxayo> Ah cool
15:16:32 <tcohen> also, so we have a more robust way to test things on CI
15:16:44 <ashimema> ๐Ÿ™‚
15:16:57 <thd> #info Thomas Dukleth, Agogme, New York City
15:17:31 <tcohen> thd++
15:17:34 <tcohen> thd++
15:17:46 <cait> thd++
15:17:46 <tuxayo> thd++
15:17:55 <tuxayo> Moving on?
15:17:59 <tcohen> yup
15:18:06 <tuxayo> #topic Elections: Roles for 23.05
15:18:08 <tcohen> I'll bother everyone until the release
15:18:10 <tcohen> anyway :-D
15:18:24 <tuxayo> #info https://wiki.koha-community.org/wiki/Roles_for_23.05
15:18:28 <tuxayo> old stable RMaint missing ๐Ÿ˜ฑ
15:18:43 <thd> Before moving on
15:19:06 <cait> yes, we have some roles missing i think
15:19:16 <ashimema> Hmm, no 22.05...
15:19:25 <tuxayo> Translation Manager ๐Ÿ˜ฑ
15:19:27 <thd> I assume we are still waiting for the mail system to be fixed on the server where the wiki is running.
15:19:28 <cait> also translation manager
15:19:35 <ashimema> I'd offer but I'm going to have my hands full getting our new Devs up to speed
15:19:36 <cait> tcohen: do you know if Bernardo wants to continue?
15:19:50 <tuxayo> Packaging Team ๐Ÿ˜ฑ Continuous integration infrastructure maintainer ๐Ÿ˜ฑ
15:20:02 <cait> oh ok, yes, that too
15:20:05 <cait> mtj: around by chance?
15:20:22 <ashimema> And I have a seeking suspicion it is going to be a hard one to maintain for the next cycle with the changes in 22.11
15:20:56 <tuxayo> > a hard one to maintain for the next cycle
15:20:56 <tuxayo> 22.05? Right ><
15:21:06 <cait> I suggest we have elections anyway and maybe a mail askin for those specific roles to list again?
15:21:18 <tuxayo> Yeah
15:21:27 <tuxayo> At least vote for all the rest
15:21:30 <tcohen> Bernardo is in
15:21:37 <ashimema> Intention here is to get the new Devs involved in community from day one . Well, tomorrow really as day one was Monday, but they've not got their computers yet ๐Ÿ˜‚
15:21:51 <cait> one less worry :) bgkriegel
15:21:54 <tuxayo> bgkriel++
15:21:54 <lukeg> I signed up for 22.11 rmaint but I am amendable to maintaining any version :)
15:21:54 <cait> bgkriegel++
15:22:07 <oleonard> composing patches in their heads I hope ashimema
15:22:07 <tuxayo> thanks tcohen for reaching
15:22:15 <ashimema> Haha
15:22:29 <tcohen> he's always open to continue, or step down if there's another volunteer
15:22:40 <tuxayo> write patch on paper and fax them!
15:22:47 <tuxayo> low tech
15:22:51 <ashimema> At a push I might be able to sell maintaining 22.11 as a team here.. would need a conversation with the boss first
15:23:04 * tcohen remembers writing assembler on a paper sheet for an exam...
15:23:11 <cait> java ... hell.
15:23:23 <cait> such a talkative language
15:23:29 <cait> anyway, good ideas all around
15:23:32 * ashimema forsee lots of patches to 22.11 in the next few months.. but hopefully mostly easy ones
15:23:45 <cait> i thnk 22.11 is gonna be hit hard for a while as we are still fixing styles
15:23:53 <ashimema> Yup
15:23:58 <ashimema> Agreed
15:23:58 <tuxayo> Worst case, we might ask Arthur or Wainui to move up a release but keep the same backport policy than their current commitment. Thus much less backport to 22.05
15:24:01 <cait> but those should not be super evil ones
15:24:15 <ashimema> But I could us it to sharpen my new Devs git skills ;)
15:24:22 <ashimema> With my watchfull eye on top
15:24:34 * tcohen has to leave
15:24:43 <tuxayo> Or ashimema you could also have a restricted backport policy to limit your commitment.
15:24:45 <tcohen> +1 on a vote
15:24:48 <ashimema> Vote . Well sort the rest between us ๐Ÿ˜œ
15:24:55 * tuxayo too
15:25:05 <tcohen> didn't lukeg volunteer for 22.11?
15:25:12 <ashimema> He did
15:25:25 <ashimema> 22.05 is missing, he said he could do either
15:25:30 <tcohen> ah
15:25:31 <tcohen> ok!
15:25:35 <tcohen> bbiab
15:25:45 <ashimema> I think 22.05 is too high commitment for ptfs-e right now
15:25:58 <tuxayo> #startvoteTEST Do you approve the current proposals for th 23.05 Team Yes, No, Abstain
15:26:05 <tuxayo> โ†‘something like that?
15:26:12 <tuxayo> *for the
15:26:18 <ashimema> Yup
15:26:20 <oleonard> =1
15:26:36 <cait> i think you need something before Yes
15:26:49 <cait> so it recognizes the options?
15:26:54 <tuxayo> ashimema: even if treating it like oldoldstable instead of oldstable. Not ideal but if noone have the time to commit full that's a backup plan.
15:27:09 <tuxayo> Ah yes lol
15:27:30 <tuxayo> #startvote Do you approve the current proposals for the 23.05 team? Yes, No, Abstain
15:27:30 <huginn`> Begin voting on: Do you approve the current proposals for the 23.05 team? Valid vote options are Yes, No, Abstain.
15:27:30 <huginn`> Vote using '#vote OPTION'. Only your last vote counts.
15:27:36 <tuxayo> #vote yes
15:27:40 <oleonard> #vote yes
15:27:42 <cait> #vote yes
15:27:44 <kidclamp> #vote yes
15:28:02 <thd> #vote Yes
15:28:14 <ashimema> #vote yes
15:28:15 <tuxayo> cait: the meeting it yours!
15:28:21 <tcohen> #vote yes
15:28:22 * tuxayo runs away => [ ]
15:28:33 <tuxayo> see ya
15:28:51 <cait> hm
15:28:53 <ashimema> Coolios
15:28:56 <cait> hope I can end the vote then :)
15:29:00 <cait> giving it a few more secons
15:29:04 <ashimema> Did he chair you
15:29:07 <cait> yep
15:29:07 <ashimema> If so you can
15:29:13 <tcohen> yes
15:29:29 <cait> #endvote
15:29:29 <huginn`> Voted on "Do you approve the current proposals for the 23.05 team?" Results are
15:29:29 <huginn`> Yes (7): cait, oleonard, ashimema, tuxayo, kidclamp, tcohen, thd
15:29:29 <lukeg> #vote yes
15:29:37 <ashimema> Haha
15:29:45 <ashimema> Too slow lukeg ๐Ÿ˜‚
15:29:45 <khall> #vote yes
15:29:48 <lukeg> lol
15:29:53 * khall shakes fist
15:29:54 <ashimema> Super quick vote, lol
15:29:56 <thd> Missed a few votes
15:29:57 <cait> #agreed The release team for 23.05 is  elected as stated on the wiki page today :)
15:30:02 <ashimema> Never seen one that quick
15:30:04 <ashimema> Hehe
15:30:10 <cait> was i too fast?
15:30:23 <ashimema> #koha in race mode
15:30:33 <cait> well... apply some speed to your queues!
15:30:37 <cait> ok, we are moving on in a moment
15:30:39 <ashimema> Nah, we had a solid yes from all.. the last vote will be in the meeting logs too
15:30:40 <cait> after celebrations
15:30:53 <cait> confetti!
15:31:02 <thd> A few too many people not in front of their IRC interfaces.
15:31:25 <cait> ok moving on
15:31:35 <cait> #topic Updates from the Release Maintainers
15:31:55 <cait> lukeg? lilliputech?
15:32:39 <cait> Well, lots of pushing happened, so I think we are probably good there
15:32:47 <cait> #topic Updates from the QA team
15:33:06 <cait> Nothing new here - get to the bad bugs please!
15:33:23 <cait> someone still with me? :)
15:33:36 <oleonard> Still here!
15:33:37 <ashimema> I'm here
15:33:42 <cait> #topic Status of roadmap projects
15:33:51 <cait> I propose postponing that to next meeting, ok?
15:33:52 <ashimema> QA has been fast and furious of late..
15:34:01 <ashimema> Lots and lots of small quick bugs..
15:34:13 <ashimema> Yeah, postpone that one I reckon
15:34:20 <oleonard> +1 to postponing roadmap
15:34:32 <cait> #info update on road map is postponed to next meeting
15:34:41 <cait> #topic Actions form last meeting
15:35:04 <cait> #action cait Update wiki page for LTS
15:35:12 <cait> taking over from davidnind again
15:35:26 <cait> davidnind to send an email to the mailing lists on roles for 23.05: DONE
15:35:49 <cait> For after release, but so we don't lose them:
15:35:53 <cait> #action tcohen to schedule/call a "CSRF day" to work on related patches together - deferred until after the 22.11 release
15:36:10 <cait> #action tcohen to draft proposal for masterโ†’main change and draft of action list
15:36:21 <cait> #action oleonard ashimema draft in the developer handbook how to form our  modals. With template of a simple case and a case with form inside.:  focus is currently on staff interface redesign changes, see the draft style guide (WIP)
15:36:33 <cait> Next one we can maybe resolve, but in the next topic
15:36:44 <oleonard> Too busy chasing bugs in master to work on handbook
15:36:47 <cait> #topic General development discussion
15:37:09 <cait> #info Question: Can we claim ES7 support now?
15:37:22 <cait> kidclamp maybe?
15:38:17 <cait> ook
15:38:21 <cait> let's keep this for th enext one
15:38:45 <cait> I have a feeling we won't make much prorss on the other topics today either, are we ok with postponing?
15:39:20 <cait> #info Topics postponed to next meeting (after release)
15:39:35 <cait> #topic Set time of next meeting
15:39:47 <thd> Moved meetings are tricky?
15:39:49 <cait> can someone help me out there? 2 weeks, wednesday, but what time?
15:40:06 <cait> thd: yeah, we had missed the one before this
15:40:15 <ashimema> Gotta go, dashing for the train now
15:40:26 <cait> have a safe trip!
15:41:54 <cait> #info Next meeting: 30 November 2022, 15 UTC
15:42:04 <cait> thx all for voting!
15:42:07 <thd> Checking for what we did previously for next meeting.  The previous next meeting was already scheduled for a date and time next week.
15:42:08 <cait> #endmeeting