14:14:28 <cait1> #startmeeting Development IRC meeting 17 August 2022
14:14:28 <huginn> Meeting started Wed Aug 17 14:14:28 2022 UTC.  The chair is cait1. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:14:28 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:14:28 <huginn> The meeting name has been set to 'development_irc_meeting_17_august_2022'
14:14:34 <cait1> #topic Introductions
14:14:40 <cait1> Please introduce yourself using #info
14:14:46 <tcohen> #info Tomas Cohen Arazi
14:14:47 <cait1> rmaints?
14:14:47 <wahanui> rmaints are lukeg, liliputech and tuxayo
14:14:54 <cait1> qa_team?
14:14:54 <wahanui> it has been said that qa_team is cait, marcelr, khall, kidclamp, kohaputti, lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova and Joubu
14:14:55 <kidclamp> #info Nick Clemens, ByWater Solutions
14:14:58 <ashimema> bob
14:15:06 <cait1> #info Katrin Fischer, BSZ, Konstanz
14:15:09 <ashimema> #info Martin Renvoize, PTFS Europe
14:15:11 <Joubu> #info Jonathan Druart
14:15:19 <thd> #info Thomas Dukleth, Agogme, New York City
14:15:20 <cait1> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_17_August_2022 Meeting agenda for today
14:15:20 <wajasu> oh i see koha-common in /etc/cron.d
14:15:36 <cait1> wajasu: all the important ones shoudl work out of the box
14:15:54 <tcohen> yeah, there's cron.weekly, cron.daily etc
14:15:59 <tcohen> for koha-common
14:16:05 <marcelr> #info Marcel de Rooy
14:16:10 <tcohen> but I'd add your own as well
14:16:14 <tcohen> that's what I do
14:16:36 <tcohen> then when the community patches things (adding new crons, etc) it is easier to spot the changes
14:16:58 <tcohen> agenda?
14:16:58 <wahanui> agenda is probably in: https://wiki.koha-community.org/wiki/General_IRC_meeting_5_June_2019
14:17:08 <cait1> tcohen: already posted it above ;)
14:17:30 <cait1> moving on
14:17:34 <cait1> #topic Announcements
14:17:45 <khall> #info Kyle M Hall, ByWater Solutions
14:17:50 <cait1> #info Online registrationf or KohaCon22 closes end of August - get registered!
14:18:02 <cait1> ... and please all ignore my typos
14:18:08 <cait1> anyone anything else?
14:18:38 <Joubu> yes
14:18:47 <tcohen> <.<
14:18:53 <cait1> go on
14:18:56 <Joubu> thanks to thos how helped on bug 27272 and friends!
14:18:56 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27272 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Move C4::Items::GetItemsInfo to Koha namespace
14:18:59 <Joubu> those*
14:19:13 <Joubu> still a small bit missing, but most of the job has been pushed already \o/
14:19:26 <Joubu> that's all :D
14:19:27 <cait1> as of this morning, it was only 2 bugs missing - go get them!
14:19:30 <tcohen> everyone is happy with those refactorings, well done Joubu
14:19:34 <tcohen> Joubu++
14:19:40 <cait1> #info Joubu says thank for helping the complex Bug 27272 along
14:19:48 <cait1> moving on
14:19:49 <tcohen> I wanted
14:19:51 <tcohen> to say
14:20:05 <tcohen> I'll be afk the week of 5th-10th September
14:20:27 <tcohen> will ask the RM assistants to assist if important stuff requires it
14:20:34 <cait1> #topic Update from the release manager (22.05)
14:21:07 <cait1> #info RM Tomas will be afk from 5th-10th September
14:21:13 <tcohen> thanks
14:21:21 <cait1> #info RM assistants will step in if needed
14:21:50 <ashimema> oh.. does that leave me.. as Joubu will likely be away too
14:21:51 <ashimema> okies
14:21:52 <ashimema> noted
14:21:57 <tcohen> Things are pretty stable/solid in master. Only one failing test but it has more to do with how the tests are built than functionality
14:22:01 <cait1> good point
14:22:13 <cait1> still some time to break things too :P
14:23:05 <tcohen> #actions ashimema needs to remove an introduced warning on bug 28854 tests (or test for its existence)
14:23:05 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28854 new feature, P5 - low, ---, martin.renvoize, Pushed to master , Add ability to create bundles of items for circulation
14:23:37 <tcohen> #info The RM requests more eyes on bug 29697 failing test when run in non-light mode
14:23:37 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29697 enhancement, P5 - low, ---, jonathan.druart+koha, Pushed to master , Replace GetMarcBiblio occurrences with $biblio->metadata->record
14:23:52 <tcohen> kidclamp offered to take a look earlier today
14:23:56 <tcohen> kidclamp++
14:23:58 <tcohen> Joubu++
14:24:01 <ashimema> oop.. ta
14:24:03 <ashimema> I missed that
14:24:04 <cait1> #action ashimema needs to remove an introduced warning on bug 28854 tests (or test for its existence)
14:24:08 <tcohen> ashimema: me too :-P
14:24:15 <wajasu> does the dashboard need to be updated with build status area? i don't have gitlab access yet, but someone could possibly take my edited template toolkit file and push it to git, etc.
14:24:38 <tcohen> wajasu: later, on a meeting
14:24:43 <wajasu> ok
14:24:53 <tcohen> cait1: something else
14:25:03 <cait1> yes?
14:25:03 <wahanui> i think yes is something different :)
14:25:11 <cait1> forget yes
14:25:11 <wahanui> cait1: I forgot yes
14:25:16 <ashimema> where did you put your edited template?
14:25:22 <tcohen> I feel confident about the things in PQA now
14:25:26 <ashimema> I'm not on a phone now.. so can take a look properly
14:25:43 <tcohen> But we need some teamwork on the koha-security bugs there
14:25:52 <cait1> qa_team++
14:25:53 <tcohen> Volunteers should contact me
14:26:08 <cait1> ok, I will need to check for that - but not sure I can help, but send an email to the ones not here today on the sec list
14:26:34 <tcohen> can we have a security@ list?
14:26:45 <tcohen> do we have it?
14:27:05 <marcelr> bugzilla grouip
14:27:11 <cait1> i think we ask to file on bugzilla, no email list I know of, I'd have emailed the qa team as they are all members
14:27:26 <tcohen> ah, right, that's the right list
14:27:29 <tcohen> nm
14:27:59 <tcohen> I have a bunch of bugs that could deserve some coding guideline added
14:28:03 <cait1> It loos like there are default CC in bugzilla: https://bugs.koha-community.org/bugzilla3/enter_bug.cgi?product=Koha%20security
14:28:12 <tcohen> but we can do it on the next section of the meeting
14:28:51 <cait1> sec
14:28:54 <tcohen> Not sure what you mean cait, I don't have admin access there
14:28:56 <marcelr> cait1 thats the one i meant
14:29:07 <cait1> #topic Updates from the release maintainers
14:29:14 <tcohen> ah
14:29:16 <cait1> tcohen: you don't need to - open the link, it shows all the emails
14:29:29 <cait1> and I and Joubu have access if you need it
14:29:33 <tcohen> 'Show advanced fields' did the trick, thanks
14:29:40 <cait1> ah right, that's a default for me
14:29:43 <tcohen> I prefer not to :-D
14:29:50 <cait1> rmaints?
14:29:50 <wahanui> rmaints are lukeg, liliputech and tuxayo
14:30:27 <cait1> i thik they are not here but
14:30:39 <cait1> #info String freeze has been called, translations have been updated, go translate!
14:30:39 <tcohen> lukeg just signed
14:31:15 <cait1> #topic Updates from the QA team
14:31:39 <cait1> #info Lots of progress on Joubu's bugs before his pendng leave - thanks to the team!
14:32:17 <cait1> #info QA and NSO queues are down a little, but we got a bit more bad bugs
14:32:18 <tcohen> It was the right time to push those too
14:32:53 <Joubu> (bug 30718 is awesome, in can you don't know already)
14:32:53 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30718 enhancement, P5 - low, ---, jonathan.druart+koha, Signed Off , Use flatpickr's altInput option everywhere
14:32:54 <cait1> still some stuff to finsh and refine, but glad to see soem bigger bugs already dealt with for this release
14:33:15 <cait1> yes, some remaining - see today's QA email too, team :)
14:33:20 <cait1> anything else to add anyone?
14:34:33 <cait1> ok, moving on :)
14:34:39 <tcohen> +1
14:34:41 <cait1> #topic Status of roadmap projects
14:34:53 <cait1> can someone get the link for me?
14:35:00 <tcohen> #link https://annuel.framapad.org/p/koha_22.11_roadmap
14:35:04 <cait1> thx
14:35:10 <thd> From two weeks  ago I have had pg_restore running on Debian 8 with no warnings or errors, then running database migration to MySQL; copying the MySQL dump to Debian 10 and upgrading on Debian 10 which could also be Debian 11.
14:35:52 <tcohen> # Task queue streamlining
14:36:02 <cait1> ?
14:36:15 <cait1> thd: are we still aiming for an update in August?
14:36:22 <tcohen> there's been some shy progress. The discussion about RabbitMQ hasn't moved
14:36:28 <cait1> thd: what's the next step?
14:36:28 <wahanui> the next step is to rewrite Koha into Whitespace language :D
14:36:30 <thd> I expect to commit the cleaned code tonight with the new options which invoke the different usage for different Debian versions.
14:36:32 <tcohen> the UI has seen some fixes
14:36:34 <cait1> forget next step
14:36:34 <wahanui> cait1: I forgot next step
14:37:01 <marcelr> i take 27421
14:37:15 <cait1> bug 27421
14:37:15 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27421 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Porting tools/stage-marc-import.pl to BackgroundJob
14:37:27 <tcohen> marcelr++
14:37:27 <marcelr> and 30718
14:37:31 <cait1> marcelr++
14:37:37 <cait1> bug 30718
14:37:51 <thd> tcohen and I have been discussing running a migraton progress using the Canasta container for MediaWiki which tcohen found next Tuesday.
14:38:03 <cait1> sounds great
14:38:18 <tcohen> thd++
14:38:20 <cait1> fingers crossed. will this be a test run or the real thing?
14:38:25 <cait1> thd++ tcohen++
14:38:31 <tcohen> about the task_queue...
14:38:44 <tcohen> There's a bug that introduces an API for tasks
14:38:50 <tcohen> I'll be taking a look shortly
14:38:54 <tcohen> Joubu provided the patches
14:39:01 <Joubu> bug 30462 and bug 30982
14:39:01 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30462 enhancement, P5 - low, ---, martin.renvoize, Signed Off , Should the background job list view hide index tasks by default?
14:39:02 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30982 enhancement, P5 - low, ---, jonathan.druart+koha, Signed Off , Use the REST API for background job list view
14:39:04 <cait1> #action Task queue: marcelr willt take on bugs 27421 and 30718
14:39:11 <thd> If the test run succeeds without problems we can make it official.
14:39:20 <tcohen> thd: awesome :-D
14:39:32 <tcohen> will get everything ready for next week then :-D
14:39:48 <tcohen> please email me about the specific versions you need for production
14:39:54 <thd> We probably will not lock the database for an initial run so as not to give false warnings.
14:39:56 <tcohen> (mariadb, mediawiki)
14:39:57 <cait1> #info Wiki update: test run (and maybe more ) scheduled for next Tuesday (2022-08-23)
14:40:26 <cait1> tcohen: bit lost about taks queue, anything to #info or #action?
14:40:43 <tcohen> qa_team: high priority for 30462 and 30982 please
14:40:50 <thd> We may never lock the database.  A warning message may be placed on the wiki instead.  Locking through MediaWiki was deprecated.
14:41:00 <cait1> #action qa_team high priority for bugs 30462 and 30982
14:41:11 <tcohen> # ERM
14:41:14 <tcohen> Joubu?
14:41:14 <wahanui> Joubu is starting to brew again
14:41:20 <tcohen> \o/
14:41:48 <thd> tcohen: Everything is really ready now but I have not committed and have to go out this afternoon.
14:42:09 <tcohen> thd: I need to take the kids to school as well
14:42:22 <cait1> we can come back to ERM
14:42:27 <cait1> anything on other roadmap projects?
14:42:53 <cait1> I think we arleady covered some of C4 rewrite and dates handling with the bugs mentioned before
14:43:13 <tcohen> only the CSRF framework they've been building, high priority and team work required. Andrii offered his team's help
14:43:16 <tcohen> nugged++
14:43:22 <Joubu> tcohen: nothing new
14:43:27 <cait1> for the staff interface design, oleonard showed some really nice mock-ups for changing up the search a bit the other day
14:43:31 <Joubu> test the UI, read the code, be involved
14:44:03 <cait1> #info ERM: test the UI (sandbox is provided), read the code, be involved
14:44:39 <Joubu> ERM entry point is: https://tree.taiga.io/project/joubu-koha-erm/wiki/home
14:44:42 <Joubu> everything is there
14:44:43 <wahanui> i already had it that way, Joubu.
14:44:49 <cait1> #info Staff interface design: Test and give feedback, sandbox also provided
14:45:05 <cait1> #info ERM: entry point is Taiga: https://tree.taiga.io/project/joubu-koha-erm/wiki/home
14:45:24 <cait1> giving you another minute while i type the next topic
14:45:29 <tcohen> moving on
14:45:35 <cait1> #topic Actions from last meeting
14:45:52 <cait1> liliputech is not around - so I think we'll postpone that one again
14:46:05 <cait1> #action liliputech (deferred from previous meeting) discuss koha CI (docker  image built + manual build) hosting on gitlab instance provided by  BibLibre's partner AFI.
14:46:17 <cait1> #topic General development discussion (trends, ideas)
14:46:23 <cait1> I got something here
14:46:27 * tcohen too
14:46:48 <cait1> at the last dev meeting, which was in the other timeslot, we made a decision on LTS
14:47:28 <cait1> #info First LTS version will be 22.11, maintained for 3 years. Regular releases maintained for 1.5 years. Support for LTS versions will overlap 1.5 years. 4 Rmaints required, but we expect lower load on the older LTS.
14:48:03 <cait1> i think sending an email was planned - updating the wiki page for LTS at least
14:48:25 <cait1> #action Katrin to update LTS wiki page with current information from last dev meeting
14:48:37 <cait1> tcohen?
14:48:37 <wahanui> tcohen is the man you want to thank
14:48:50 <Joubu> tcohen: thanks
14:50:55 <cait1> tcohen, your turn :)
14:51:00 <tcohen> a sec
14:52:07 <tcohen> ok
14:52:28 <tcohen> Bug 31374 introduces a non public attribute for suggestions
14:52:28 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31374 enhancement, P5 - low, ---, lucas, NEW , Add a non-public note column to the suggestions table
14:52:52 <anne> Hello again, I want to change type document to book.  Thanks for the help : I tried to use the batch item modification tool. I got something like this : It will be processed as soon as possible. But nothing happens... Is there anything specific to be run ?
14:52:56 <tcohen> I would like to propose some guideline about generating the public_read_list sub
14:53:03 <tcohen> even if there's no public API yet
14:53:11 <tcohen> so there's no leak
14:53:22 <tcohen> once someone writes the API
14:53:47 <tcohen> this could be defered until the API is written, but worth asking if we shuold enforce at QA
14:53:56 <tcohen> opinions?
14:53:56 <wahanui> opinions are good, base for discussion
14:54:15 <marcelr> what is your guidline ?
14:54:42 <cait1> what is a read_list?
14:54:56 <tcohen> "If you are adding a non-public attribute, and the class doesn't have public_read_list yet, you need to add it'
14:54:59 <marcelr> i remember writing the famous AllowList and DenyList
14:55:12 <tcohen> yes, marcelr that one
14:55:18 <tcohen> sort of
14:55:28 <tcohen> do we agree on such requirement?
14:55:32 <marcelr> yes
14:55:46 <tcohen> I know lukeg will do it because he asked me and it felt like a good compromise
14:56:46 <ashimema> from memory public_read_list is a allowlist..
14:56:57 <tcohen> it is
14:57:07 <ashimema> the question is do we require the sub yet.. or gracefully fall back to all fields
14:57:16 <ashimema> if we fall through.. we probably shouldn't
14:57:23 <ashimema> we should force devs to impliment the sub
14:57:37 <tcohen> I feel like we should force it
14:57:48 <marcelr> Koha Object ?
14:57:56 <marcelr> empty list
14:58:15 <cait1> just a warning: please summarize your conclusion yourself, I got lost
14:58:38 <tcohen> marcelr: things don't break, there's an empty list
14:58:38 <cait1> #chair tcohen
14:58:38 <huginn> Current chairs: cait1 tcohen
14:58:41 <cait1> #chair ashimema
14:58:41 <huginn> Current chairs: ashimema cait1 tcohen
14:58:53 <ashimema> https://git.koha-community.org/Koha-community/Koha/src/branch/master/Koha/Object.pm#L664
14:58:58 <ashimema> we should throw an exception there instead
14:59:08 <tcohen> the situation is you're adding a non-public attribute and that's when you need to address it
14:59:13 <ashimema> so it requires devs to always impliment it
14:59:42 <ashimema> hmm
14:59:45 <ashimema> hard
15:00:08 <tcohen> if you delay it, the next one will need to go through the fields to check again...
15:00:11 <ashimema> 'private' could have been an attribute of the field itself.. but I don't think we ever got that far
15:00:17 <ashimema> it turned out more complex
15:00:44 <tcohen> we could've gone the is_boolean route at the schema level... hmmm
15:00:53 <ashimema> indeed, we could
15:01:17 <ashimema> I like the simple allowlist approach as it's fail safe though
15:01:51 <ashimema> but throwing an exeption would require all existing public endpoints get the corresponding public_read_list sub adding properly
15:01:58 <ashimema> not sure how many of those there are already.
15:02:07 <ashimema> I'm sure we could knock them off pretty quick
15:02:54 <tcohen> ok, I will make a counter proposal
15:03:14 <tcohen> let's accept patches introducing public_read_list() even if it is not used yet
15:03:29 <cait1> #action tcohen will make a counter proposal about public_read_list()
15:03:29 <tcohen> that way devs can help our future us
15:03:36 <cait1> i hope that makes sense
15:03:39 <ashimema> fair enough
15:03:44 <tcohen> it doesn't cait haha
15:03:57 <ashimema> I'm still not so sure
15:04:32 <tcohen> what's causing your doubt?
15:04:34 <ashimema> if your adding a private field now.. is it your job to ascertain which other fields that already exist should also be private?
15:04:50 <cait1> tcohen: you can fix it :)
15:04:59 <ashimema> or.. should the person adding the /public route in the API do that job..
15:05:02 <cait1> we are running a bit overtime
15:05:29 <tcohen> ashimema: that's why I counter-proposed
15:05:44 <ashimema> as it's an allowlist not a denylist we would fail safer by someone missing adding the a public field to the public_read_list
15:05:46 <tcohen> that if the dev has the time to invest on publid_read_list(), accept the submission
15:06:01 <ashimema> ah.. okies.. i see
15:06:08 <ashimema> yeah.. I'm game for that certainly
15:06:21 <tcohen> any objections?
15:06:36 <ashimema> I still think it would be a really good idea to throw an exception in that line I linked to above..
15:06:51 <ashimema> to 'force' use the public_read_list for any/all /public endpoints..
15:07:11 <ashimema> so we can't forget and inadvertently open a private field up.
15:07:17 <tcohen> Yeah, I like it
15:07:22 * ashimema did this only a day or two ago in a local development ;P
15:07:23 <tcohen> would you please file it?
15:07:27 <ashimema> sure
15:07:46 <tcohen> thanks, CC or assign it to me whatever you wanna do about it
15:08:03 <cait1> please action and info now :)
15:08:13 <tcohen> #action Martin will file a bug making Koha::Object::public_read_list throw an exception
15:08:33 <cait1> done?
15:08:55 <tcohen> #info When adding a private attribute to a Koha::Object class, remember to check public_read_list()
15:08:58 <tcohen> yes
15:09:01 <cait1> #topic Review of coding guidelines
15:09:03 <cait1> thx!
15:09:15 <ashimema> ho.. I'm wrong..
15:09:18 <cait1> tcohen: You mentioned earlier that there was a need for new coding guideline additions
15:09:33 <ashimema> we already fail safe.. we just don't pass any fields so you wouldn't see anything in the response
15:09:37 <ashimema> coolios
15:09:37 <cait1> is there any list or anything specific or could we move that to next meeting?
15:09:50 <tcohen> we are overtime
15:09:55 <tcohen> let's move it
15:09:55 <ashimema> indeed
15:10:08 <tcohen> I'll add anything relevant on next's agenda
15:10:11 <cait1> woudl be great if you coudl give some pointers on ageda or on the bugs (and I'Ll move it to agenda)
15:10:13 <cait1> yep
15:10:33 <cait1> #action tcohen to add anything relevant to next meeting's agenda (or point out the bugs)
15:10:39 <cait1> #topic Set time of next meeting
15:10:51 <cait1> I thin ti would be Wednesday in 2 weeks at last meetings timeslot?
15:10:55 * tcohen has to go downstairs feed the little beasts
15:10:57 <cait1> 31 August 2022, 21 UTC
15:11:02 <cait1> ok?
15:11:03 <tuxayo> Hi and I missed the meeting :o
15:11:04 <tcohen> ok
15:11:14 <tuxayo> let me check the last logs
15:11:38 <cait1> waiting for you tuxayo
15:11:56 <tuxayo> Yes 31 August 2022, 21 UTC
15:12:01 <cait1> thx
15:12:03 <cait1> #info Next meeting: 31 August 2022, 21 UTC
15:12:09 <cait1> #endmeeting