14:04:04 <tuxayo> #startmeeting Development IRC meeting 20 April 2022
14:04:04 <huginn> Meeting started Wed Apr 20 14:04:04 2022 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:04 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:04:04 <huginn> The meeting name has been set to 'development_irc_meeting_20_april_2022'
14:04:27 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_20_April_2022 Today's agenda
14:04:33 <tuxayo> #topic Introductions
14:04:40 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:04:50 <tuxayo> #info Victor Grousset, Tuxayo sh.a., France
14:05:06 <fridolin> #info Fridolin Somers, BibLibre, France (Tahiti)
14:05:23 <AndrewFH> #info Andrew Fuerste-Henry, ByWater Solutions, USA
14:05:42 <fridolin> we are acutally installing Koha to French Polynesia University :D
14:07:28 <tuxayo> :D
14:07:30 <kidclamp> #info Nick Clemens, ByWaterSolutions
14:07:57 <tuxayo> #topic Announcements
14:08:09 <oleonard> qa_team?
14:08:09 <wahanui> i think qa_team is cait, joubu, tuxayo, marcelr, kidclamp, khall, tcohen, ashimema, nugged, kohaputti, petrova
14:08:26 <tuxayo> Any announcement that doesn't fit in other agenda items?
14:08:34 <tuxayo> rmaints?
14:08:34 <wahanui> rmaints is khall, AndrewFH, wainui and tuxayo
14:08:42 <tuxayo> thanks oleonard  :)
14:09:02 <oleonard> Felt like too few introductions :(
14:09:20 <fridolin> we may wait a few minutes
14:10:01 <liliputech> #info Arthur Suzuki, BibLibre, France (Annecy)
14:10:34 <fridolin> ah, smells like melted cheese ^^
14:10:56 <tuxayo> ?
14:11:06 <fridolin> French Alps "Fondue"
14:11:11 <tuxayo> fridolin: did you brought back hackfest cheese to Tahiti?
14:11:19 <fridolin> omg no
14:11:29 <oleonard> Quick, run back
14:11:40 <fridolin> its has been finished by Biblibre users ;)
14:11:58 <fridolin> even the big Conté
14:12:11 <oleonard> omg Annecy looks beautiful
14:12:11 <tuxayo> *paddle back
14:12:21 <tuxayo> #topic  Update from the Release manager (22.05)
14:12:27 <tuxayo> « End of cycle dates fixed »
14:12:34 <liliputech> even better when seen from the sky :) #paragliding
14:12:56 <tuxayo> 🤩
14:13:34 <tuxayo> So the dates are in the calendar. What is "22.05 beta" ?
14:13:50 <fridolin> ah let me look
14:14:16 <fridolin> "Only bug fixes considered major, critical or blocker will be pushed"
14:14:25 <fridolin> there was no short name for this event
14:14:37 <fridolin> so feels like it is the béta test
14:15:03 <nikkom> asimema: Hello asimema. If you remember, I was trying to block the payment if the user has overdue payments. You directed me to the payment pages. I need more help. Please tell me how can I get the overdue information while on pay.pl or paycollect.pl?
14:15:05 <tuxayo> Ok, past cycle it was named "Only > major bugfixes"
14:15:12 <fridolin> i mean i copies from previous cycle
14:15:40 <liliputech> ashimema: ^
14:15:47 <fridolin> ah can be renamed
14:15:50 <oleonard> nikkom: We are having a meeting at the moment
14:16:05 <thd> #info Thomas Dukleth, Agogme, New York City (carrier interrupt)
14:16:11 <tuxayo> «Waiting for bug 29155»
14:16:11 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29155 enhancement, P5 - low, ---, oleonard, Signed Off , Upgrade jquery version
14:16:17 <tuxayo> fridolin: anything to add?
14:16:39 <liliputech> yup, what about bug 25408 ?
14:16:39 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25408 normal, P5 - low, ---, arthur.suzuki, Signed Off , CanBookBeReserved & CanItemBeReserved should check "opacitemholds" policy
14:16:52 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:16:53 <liliputech> it just got signed off by tuxayo (tx!)
14:17:06 <tuxayo> liliputech: not a critical as a jquery update :P
14:17:27 <liliputech> oh sure, not critical!
14:17:42 <liliputech> (missed the "critical" information, sry)
14:17:51 <tuxayo> «Find people for https://wiki.koha-community.org/wiki/Roles_for_22.11»
14:17:56 <fridolin> no pb liliputech
14:18:00 <fridolin> yep
14:18:09 <fridolin> we have not yet RMaint for stable
14:18:15 <fridolin> a difficult position
14:18:26 <tuxayo> liliputech: It's the "Update from the Release manager" topic and I'm coping what Fridolin wrote in the agenda
14:18:32 <tuxayo> ouch
14:18:46 <fridolin> I will talk to Biblibre to find someone (not me)
14:19:01 <oleonard> Oh I missed that tcohen volunteered (or was forcibly volunteered??) to be RM
14:19:06 <oleonard> tcohen++
14:19:10 <fridolin> yeyyyyy
14:19:30 <fridolin> we talked about that underground in HF
14:19:40 <fridolin> super we have RM of course
14:20:02 <oleonard> I imagine Wainui will still maintain 19.11 unless Catalyst has dropped support
14:20:16 <tuxayo> Not sure, we will see.
14:20:38 <ashimema> oop
14:20:40 <ashimema> hello
14:20:40 <wahanui> hi, ashimema
14:20:45 <tuxayo> Wainui is on leave for at least two week I think. Rangi took over rmaint this month.
14:21:01 <fridolin> and if nobody takes 20.11 we drop support
14:21:35 <fridolin> ashimema: may there be someone for RMaint in PTFS ?
14:21:45 <fridolin> ... we have cookies ^^
14:22:33 <liliputech> ashimema: and nettle cakes ;) people in annecy liked it btw ^^
14:23:23 <fridolin> if it is still empty I will use ML next week
14:23:34 <ashimema> #info Martin Renvoize, PTFS Europe.
14:23:38 <fridolin> before General meeting may 4th
14:23:41 <ashimema> We're mid hiring people at the minute so can't commit more this coming cycle
14:23:50 <fridolin> no pb
14:23:56 <ashimema> hopefully 23.05 I might be able to get more community time again
14:24:13 <fridolin> cool
14:24:14 <lukeg> #info Lucas Gass, ByWater Solutions
14:24:22 <fridolin> hi lukeg
14:24:34 <fridolin> thanks for proposing RMaint 21.11
14:24:44 <tuxayo> np if you can still do some QA that's already the best help. Good luck with your hire
14:24:44 * ashimema only has one dev other than himself right now.. so we're a bit snowed under ;P
14:24:45 <tuxayo> fridolin: anything else from you to add?
14:24:45 <tcohen> lukeg++ # on the QA team
14:25:08 <liliputech> fridolin: are we looking for rmaint 20.11 or 21.11?
14:25:22 <fridolin> liliputech: for stable 22.05
14:25:32 <fridolin> its mandatory
14:25:52 <fridolin> lukeg: you did chose oldstable on purpose ? not willing to be stable ?
14:25:52 <liliputech> ok. that one is not installed by biblibre to our partners right?
14:26:05 <fridolin> indeed
14:26:20 <ashimema> we're a .11 shop in ptfs-e these days.. so it's easier for me to commit people to .11 releases 😉
14:26:22 <lukeg> fridolin: I would do either 22.05 or 21.11
14:26:45 <tuxayo> Which is actually the hardest?
14:26:46 <lukeg> whatever is needed
14:26:54 <ashimema> there's more to port to 22.05, but the backports tend to be a little easier
14:26:57 <fridolin> lukeg: ahhh super because stable it more work, i may take oldstable
14:26:58 <tcohen> lukeg on 22.05, ptfs on 21.11
14:27:10 <tuxayo> stable should be easy at the beginning since it's close to master
14:27:15 <ashimema> though it kinda depends on your next RM and how bold they are at big changes early
14:27:21 <tuxayo> But in the end of cycle it's harder
14:27:33 <tcohen> <.<
14:27:55 <fridolin> and you have to deal with dependancies a lot
14:28:04 <tuxayo> > ptfs on 21.11
14:28:04 <tuxayo> biblibre you mean tcohen ?
14:28:30 <fridolin> but its a famous place, like Prince for the RM king :D
14:28:43 * ashimema hopes so.. I hope to continue to focus on QA next cycle in what little time I'll have for community
14:29:08 <fridolin> sure, RMaints needs mandatory time around month releases
14:29:11 <liliputech> if i get dedicated time for this I wouldn't mind doing it but got to talk about it with paul / laurence first.
14:29:13 <tuxayo> Ah ok so clearly, stable is more work that oldstable?
14:29:46 <fridolin> liliputech: yep super, we will mail them with a proposition
14:30:06 <fridolin> tuxayo: i'd say a bit more
14:30:07 <liliputech> fridolin: how much time would it take? approx per week?
14:30:21 <fridolin> around 1h / day
14:30:23 <tuxayo> thank fridolin I note that
14:30:28 <ashimema> liliputech, that would be awesome
14:30:39 <tuxayo> Lot of patches to test
14:30:44 <ashimema> and I could certainly support anyone who did take on an RMaint role
14:31:03 <liliputech> fridolin: ok. ashimema : 21.11 is interesting version for me, working on a frontend. it bring a lot of new apis
14:31:17 <liliputech> ashimema++
14:31:24 * ashimema spent a little time every day on RMaint duties.. like I did an hour or two before our company morning call
14:31:46 <liliputech> would have to learn everything. would take some time at the beginning.
14:31:49 <lukeg> its best to do a little everyday and not let things stack up
14:31:52 <ashimema> so 5 hours a week or so.. sometimes a little more sometimes a little less
14:31:58 <ashimema> that's how I managed it anyways
14:32:47 <liliputech> 'kay. that mean apply/test/push patches to the main Koha repository on the proper branch right?
14:32:55 <fridolin> OK lets wait new week to see if it changes
14:33:09 <fridolin> liliputech: i will lead you to this role, its easy ;)
14:33:36 <fridolin> lets continue
14:33:37 <tuxayo> liliputech: most of the time is doing the test plan. And some is conflict resolution.
14:33:47 <liliputech> ok
14:34:08 <fridolin> it is well described https://wiki.koha-community.org/wiki/Release_maintenance
14:34:15 <tuxayo> great that we have good leads to fill our rmaint position :)
14:34:22 <tuxayo> #topic  Updates from the Release Maintainers
14:35:32 <tuxayo> oldstable has been quiet this month so for oldoldstable, I didn't have much to chew on.
14:35:40 <tuxayo> rmaints?
14:35:40 <wahanui> i think rmaints is khall, AndrewFH, wainui and tuxayo
14:36:26 <AndrewFH> yeah, I haven't managed to make as much time for it as I should. hoping to find time for some catchup here shortly
14:36:53 <tcohen> AndrewFH++
14:36:54 * ashimema wants a time machine
14:38:03 <tuxayo> AndrewFH: not complaining, I could QA instead :P But I'll monitor oldstable closely to not get behind.
14:38:22 * tcohen wants a second monitor to keep QAing and following the meeting without completely switching desktops
14:38:23 <AndrewFH> tuxayo++
14:39:16 <tuxayo> #info Wainui is on leave for a month. It started two weeks ago i think. Rangi took over rmaint this month.
14:39:33 * ashimema is QAing and watching meeting on the second monitor right now
14:39:42 <tcohen> -.-
14:39:45 * ashimema is finding QA slow though.. the meeting is interesting.
14:39:53 <tuxayo> #topic Updates from the QA team
14:39:57 <tuxayo> qa_team?
14:39:57 <wahanui> qa_team is cait, joubu, tuxayo, marcelr, kidclamp, khall, tcohen, ashimema, nugged, kohaputti, petrova
14:40:03 <tuxayo> speaking of qa!
14:40:30 <marcelr> qa++
14:40:42 <nugged> qa++! ❤️
14:40:47 <koha-jenkins> Project Koha_21.11_U22 build #1: UNSTABLE in 1 hr 1 min: https://jenkins.koha-community.org/job/Koha_21.11_U22/1/
14:41:56 <nugged> we took abroad +1 guy and discussing this week with piloting library to help with pre-release build testing for master branch as we did for 21.11 so same I will provide for Fridoling and Jonathan as before, we just will agree with another our library to help & test build and probably we will start that already from next week
14:42:33 <tuxayo> The technique of beginning sorting tickets by small or trivial patches to get started without fearing getting stuck works great. Thank ashimema++ for the advice.
14:42:50 <ashimema> pleasure
14:43:09 <ashimema> nugged++
14:43:17 <tcohen> nugged++
14:43:32 * ashimema has not forgotten his promises from hackfest.. just been away and stuff here so haven't got to them yet
14:44:02 <nugged> ashimemta tcohen: all other things (wikies + props on ill, erm, holdings, circrules: I am preparing, just drown with onboarding for that new guy)
14:44:04 <tcohen> sounds familiar
14:44:08 <ashimema> there's plenty more space on the QA team so sign up peeps: https://wiki.koha-community.org/wiki/Roles_for_22.11
14:44:14 <tuxayo> nugged++ and to your team also and the voluntary libraries. Doing that is very valuable to have better releases.
14:44:14 <tuxayo> Joubu++ and fridolin++ also.
14:44:25 <ashimema> getting people up to speed on QAing is something I am more than happy to devote time to.. just ask
14:44:25 * nugged not forget so will bring all others to the articles once /me will create
14:45:04 <ashimema> 🙂
14:45:40 <ashimema> I'd love to see some other companies represented on the QA team.. InLibro perhaps for example?
14:45:56 <tcohen> qa++
14:45:56 <fridolin> indeed
14:46:17 <fridolin> they do great work in patching and testig
14:46:28 <ashimema> indeed
14:46:57 <ashimema> hmm.. though looking at the numbers.. I see the NSO queue is the bottle neck right now..
14:47:06 <ashimema> 325 reports in there!
14:48:23 <tuxayo> everyone test patches!
14:48:32 <nugged> I'll attract those my librarians for SO as we agreed on hackfest, I will have next thursday customers meeting, so I am ready to explain them that we wait some regular contribution, so let's check how MY (our) subpart for SO goes in 4-6 weeks
14:48:35 <marcelr> lots of older ones
14:48:54 <marcelr> probably PNA
14:49:16 * ashimema really should fix the ptfs-e sandboxes
14:49:17 <nugged> ... I mean - to see the numbers and trend in 4-6 weeks from us, from Finland
14:50:19 * oleonard hoped there would be more signoffs coming from librarians at the Hackfest
14:50:48 <ashimema> we tied up some of them with bug scary ones I'm afraid
14:51:03 <ashimema> severine did an awesome job of the patron searching stuff
14:51:15 <liliputech> oleonard: we managed to install a few koha-testing-docker on librarians PC but most of them use corporate-locked windows pcs
14:51:26 <nugged> oleonard: hackfest - people spent there more experience exchange and socializing & coordinating & training each other, so it was anyway very good gathering
14:51:29 <liliputech> severine_q++
14:51:54 <ashimema> indeed
14:52:19 <tuxayo> nugged: I can also guide librarians to do SO. You can give them my email or IRC nick so it's doesn't only rely only on your team.
14:52:30 <oleonard> I'm certainly not accusing them of laziness! :)
14:53:05 <nugged> tuxayo: 📝✔️
14:53:11 <tuxayo> ^^
14:54:07 <tuxayo> liliputech in the end koha-testing-docker directly on Windows didn't work well right?
14:54:09 <ashimema> should we arrange another bug squashing day?
14:54:10 <liliputech> some training might be needed though. also some patches need specific commands which are not possible to do on sandboxes
14:54:16 <ashimema> try and encourage a group SO fest
14:54:31 <liliputech> ashimema++
14:54:44 <ashimema> magnuse used to be the king of arranging those
14:55:19 <liliputech> I think there used to be a "bug squashing day" organized by kohala before, during their meetup. dunno if they still do it
14:55:35 <tuxayo> liliputech: the symposium?
14:55:40 <liliputech> yen
14:55:42 <liliputech> yes
14:56:20 <lukeg> ByWater has a Bug Squashing Event scheduled for May 3
14:56:32 <tuxayo> That's perfect!
14:56:34 <ashimema> aha, excellent
14:57:03 <liliputech> information should be shared on the koha-devel newsletter :)
14:57:24 <tuxayo> newsletter + mailing lists
14:57:31 <liliputech> (might already...) also to koha-info user group :)
14:57:34 <liliputech> yes
14:57:39 <lukeg> https://bywatersolutions.com/education/celebrate-open-source-with-this-bug-squashing-event
14:57:54 <tuxayo> Who can add that to the community calendar?
14:57:54 <tcohen> bywater++
14:58:04 <tcohen> that'd be wizzyrea ?
14:58:19 <ashimema> I can
14:58:23 <fridolin> tuxayo:  it is already in calendar
14:58:35 <ashimema> oh yes.. so it is
14:58:44 <tuxayo> I only see "Hard feature freeze"
14:58:52 <tuxayo> Friday, May 6, 2022
14:59:31 <ashimema> Bug Squashing Event
14:59:31 <ashimema> Tuesday, 3 May⋅4:00 – 6:50pm
14:59:43 <tuxayo> oh it's the 3 may!
14:59:45 <tuxayo> great!
14:59:46 <fridolin> bug squashing will likely be on bugs not features
14:59:59 <ashimema> I'll start advertising it in the UK too 😉
15:00:01 <tuxayo> hence the name "bug squashing" :P
15:00:09 <fridolin> "May the tree be with you"
15:00:18 <fridolin> XD
15:00:32 <liliputech> pity it'll be on US timezone... (that makes the 4'th for french people? ^^)
15:00:37 <tuxayo> nugged: you can mention the bug squashing event at you meeting next thursday.
15:01:11 <reiveune> bye
15:01:24 <tuxayo> liliputech: If some people to guide tester are available in europe hours, the bug squashing can start early.
15:01:51 <nugged> tuxayo: ok yes noted
15:01:55 <tuxayo> That doesn't change the date though?
15:02:18 <ashimema> 11am US = 4pm UK
15:02:20 <liliputech> that would be cool. I'm sending a mail to french community already
15:02:22 <ashimema> so not too terrible for us
15:02:38 * ashimema would be happy to start early here
15:02:42 <liliputech> same here then I guess.
15:03:12 <tuxayo> same, we can be here early on with european librarians
15:03:52 <tuxayo> moving on?
15:03:57 <liliputech> that means if we do the afternoon on 3 may, we will be in sync with US afternoon, that's great :)
15:04:13 <liliputech> I meant US morning
15:06:01 <tuxayo> Yes, we can start on our morning in the afternoon have some overlap with the Americas.
15:06:02 <tuxayo> #topic Actions from last meeting
15:06:08 <tuxayo> « tuxayo send ideas to have an easier time with big changes to koha-devel to get more of them and document them »
15:06:09 <tuxayo> done
15:06:24 <tuxayo> « tuxayo add to terminology "use restriction, not debar/debarment" and notify koha-devel in case that wasn't a good idea. »
15:06:24 <tuxayo> done
15:06:29 <tuxayo> #topic General development discussion (trends, ideas, ...)
15:06:34 <ashimema> 🙂
15:06:37 <tuxayo> « Vote on using Vue3 for the new ERM module (as a proof of concept of the framework) https://lists.koha-community.org/pipermail/koha-devel/2022-April/046998.html »
15:06:46 <ashimema> +1
15:07:07 <tuxayo> So Joubu needs a greenlight to continue the new ERM module using Vue3
15:07:37 <ashimema> did you hear anything from batman nugged?
15:07:43 <fridolin> I could not say, knowing to few on JS frameworks
15:07:52 <tuxayo> same
15:08:18 <ashimema> well.. tomas and I both think we should go for it.. and I think jajm seemed happy too
15:08:21 <fridolin> but confident Joubu as choosen wisely
15:08:34 <ashimema> oleonard and kidclamp both made positive noises as well in our call at hackgest
15:08:46 <ashimema> so to me.. I think we should go for it.. pull the band aid off
15:08:51 <fridolin> ah jajm is our JS ninja so green
15:08:57 <oleonard> Agreed
15:09:00 <tcohen> jajm wasn't that sure
15:09:01 <tcohen> :_D
15:09:08 <tuxayo> ashimema: «and I think jajm seemed happy too» That changed from the beginning, right?
15:09:17 <ashimema> we've been circling around a JS framework for years.. I don't think we'll gain anything from delaying further personally
15:09:20 <fridolin> even 51% sure is ok
15:09:29 <tcohen> jajm: around?
15:09:39 <tcohen> overall we agreed
15:09:45 <ashimema> hmm, ok
15:09:53 <ashimema> I can't remember details from jajm then
15:10:04 <tcohen> he had concerns about the extra boilerplate with no obvious gain
15:10:10 <tuxayo> yes
15:10:22 <jajm> yes, exactly what tcohen just said ;)
15:10:32 <ashimema> boilerplate compared to another framework..
15:10:33 <tcohen> but the conversation circled around new technologies inviting new devs to contribute
15:10:40 <tuxayo> a jajm apears :D
15:10:45 <ashimema> or compared to jQuery and our current way of doing things?
15:10:54 <tcohen> and we had paulderscheid[m] working on his project with a similar structure
15:11:05 <nugged> ashimema: he somewhat away from messengers these days, still not read my message. I wasn't insistent - and this went away from focus, I will re-send email him, but we found the answer those days - it's just to know, not to switch, vue3 is came through these years a lot and svelte  still "so small" in community so moving harder
15:11:19 <nugged> but I will anyway bring his answer, thanks for reminder.
15:11:51 <tcohen> I vote +1 for adopting Vue3 as a POC, not sure about jajm's vote
15:12:58 <ashimema> +1
15:13:35 <tuxayo> jajm: overall, does that looks like a gain compared to the current approach?
15:15:07 <tuxayo> > adopting Vue3 as a POC
15:15:07 <tuxayo> POC but still means going in Koha and be released. POC as it's only for ERM and we will see the results to tell if future developments can use Vue?
15:16:53 <tuxayo> We can still vote here and ask also in the mailing list to have a wider reach.
15:17:12 <tcohen> Encapsulated module inside Koha, that will be funcional and will serve as playground and we will eventually generate guidelines for using it on other pages
15:17:36 <liliputech> +1 for the POC, but when it comes to move Koha as a whole that's going to be a lot of work. might introduce breaking change in graphic personnalisation or some plugins which relies on JS+DOM to insert new element on a page.
15:17:58 <thd> I assume that replacing every use of jQuery with vue.js is not intended at least not at this time.
15:18:26 <tcohen> thd: it is not
15:18:54 <tuxayo> #startvote Shall Vue3 be used for the new ERM module? Yes, No, Abstain.
15:18:54 <huginn> Begin voting on: Shall Vue3 be used for the new ERM module? Valid vote options are Yes, No, Abstain, .
15:18:54 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
15:19:08 <oleonard> #vote Yes
15:19:10 <liliputech> #vote Yes
15:19:12 <thd> #vote Yes
15:19:13 <ashimema> #vote Yes
15:19:13 <tcohen> #vote Yes
15:19:26 <nugged> #vote Yes
15:20:12 <jajm> #vote Abstain
15:20:32 <tuxayo> #vote Abstain
15:20:33 <tuxayo> I trust our JS gurus. I didn't review the code and done research so I can't say I can choose.
15:20:51 <tuxayo> But I'm confident it will okay :)
15:20:54 <ashimema> 🙂
15:21:18 <tuxayo> fridolin: ?
15:21:26 <tcohen> khall_: it is being voted if we use Vue3 for the ERM module in Koha
15:21:42 <tuxayo> marcelr?
15:21:42 <wahanui> marcelr is just amazed that next is faster than count
15:21:52 <tuxayo> lol
15:21:54 <fridolin> #vote Yes
15:22:05 <tuxayo> AndrewFH?
15:22:16 <tcohen> kidclamp:
15:22:17 <tuxayo> lukeg?
15:22:17 <wahanui> lukeg is around now :)
15:22:24 <tcohen> Joubu?
15:22:24 <wahanui> well, Joubu is starting to brew again
15:22:27 <AndrewFH> #vote Yes
15:22:33 <lukeg> #vote Abstain
15:22:37 <kidclamp> #vote Yes
15:23:07 <tuxayo> > Joubu is starting to brew again
15:23:07 <tuxayo> And the result was successful at the hackfest.
15:23:20 <liliputech> indeed
15:23:22 <fridolin> ^^
15:23:29 <tcohen> specially the sour, tuxayo
15:23:40 <tuxayo> letting 1min in case someone else comes up.
15:23:45 <fridolin> very nice sour beer
15:24:03 <oleonard> I don't think any stragglers will overwhelm the yes votes ;)
15:24:59 <khall_> #vote Yes
15:25:25 <tuxayo> #endvote
15:25:25 <huginn> Voted on "Shall Vue3 be used for the new ERM module?" Results are
15:25:25 <huginn> Yes (10): liliputech, oleonard, ashimema, khall_, kidclamp, fridolin, tcohen, nugged, thd, AndrewFH
15:25:25 <huginn> Abstain (3): tuxayo, jajm, lukeg
15:25:48 <nugged> (oh, I forgot to register myself :P ):
15:25:50 <nugged> #info Andrew Nugged, National Library of Finland, HELSINKI
15:25:52 <tuxayo> Can anyone also reach koha-devel about this?
15:27:20 <liliputech> I think my favourite was the pepporter one :)
15:27:33 <tuxayo> #action tuxayo ask confirmation from koha-devel about using Vue3 for the new ERM module.
15:28:25 <tuxayo> Next topic
15:28:31 <tcohen> gotta feed the kids... bbl
15:28:33 <tcohen> koha++
15:28:34 <tuxayo> « Make the IRC less noisy and more newcomer friendly my moving some bots outputs to another channel (#koha-logs/#koha-technical/#koha-bots) »
15:28:36 <tcohen> tuxayo++
15:28:45 <tcohen> fridolin++
15:28:53 <ashimema> good plan
15:28:59 * ashimema should join the other channel
15:29:03 <tuxayo> - koha-jenkins: continuous integration failures or success
15:29:03 <tuxayo> - huginn (keep part of output in main channel because they have multiple roles): new commits pushed to main/master branch
15:29:03 <tuxayo> - alohabot: package builds
15:29:08 <liliputech> more humans / less bots
15:29:13 * liliputech should join more often
15:29:31 <ashimema> we should also update the irc page on koha-community to give instructions on how to use matrix/element as you suggested at hackfest tuxayo
15:29:59 <tuxayo> So no issues with that?
15:29:59 <tuxayo> Then are there more bot output to move that the above 3?
15:30:39 <tuxayo> Any idea how to name the new channel? Ideas are #koha-logs/#koha-technical/#koha-bots
15:30:50 <fridolin> tuxayo: koha-dev ?
15:30:52 <fridolin> like ML
15:31:01 <oleonard> Confusing
15:31:06 <tuxayo> Yes
15:31:20 <fridolin> too obvious maybe
15:31:26 <tuxayo> Actual dev talk will still be here
15:31:29 <liliputech> i find it clear. that makes not too much names to recall
15:31:47 <liliputech> koha-bots is nice.
15:31:50 <domm> there is a matrix channel?
15:32:05 <tuxayo> nugged: what was you preference again?
15:32:07 <tuxayo> *your
15:32:21 <fridolin> koha-bots sounds good
15:32:25 <liliputech> people willing to check the bots message would go there, and dev talks + actual humans would sstay here
15:32:37 <fridolin> i'm ok with that
15:32:47 <liliputech> koha-bots++
15:32:55 <ashimema> +1
15:32:57 <fridolin> koha-AI ^^
15:33:11 <fridolin> bots talking to bots
15:33:17 <oleonard> +1 for koha-bots
15:33:20 <tuxayo> ashimema: «give instructions on how to use matrix/element» Indeed, in addition to the web IRC chat we could add that and the future Telegram bridge that nugged mentioned.
15:33:39 <tuxayo> domm: #koha-irc:matrix.org
15:33:40 <nugged> tuxayo: first and main goal was to remove any automated messages form our discussion channel, "koha_bots", or alike
15:34:16 <liliputech> nop >< bots are no AI :) telegram or mattermost are easy to make with matterbridge
15:34:18 <nugged> *move to "koha_bots", I mean
15:34:21 <ashimema> agreed
15:34:41 <ashimema> hmm
15:34:45 <ashimema> I like some bots
15:34:53 <tuxayo> koha bots seems to have the preference. Hyphen or underscore? I don't know the IRC conventions.
15:34:56 <ashimema> I'd miss the bz links for example
15:35:05 <ashimema> i hope we're not going to lose that
15:35:07 <nugged> <liliputech> idea was to clean up our atuomatons posting here messing with our talks into separate channel
15:35:12 <tuxayo> ashimema: yes we would keep huginn and wahanui
15:35:30 <oleonard> huginn and wahanui get special ID cards that let them into the restricted area
15:35:31 <huginn> oleonard: I'll give you the answer just as soon as RDA is ready
15:35:31 <wahanui> i already had it that way, huginn.
15:35:32 <ashimema> yes
15:35:33 <ashimema> good
15:35:53 <tuxayo> But need to find a way for huginn to not output each new master commit here
15:35:58 <nugged> yes, helper bots is ok, for people communications, but all build messages, all whatever-related - to the separate channel
15:36:04 <tuxayo> +1
15:36:09 <thd> wahanui++
15:36:23 <fridolin> wahanui: coffee please
15:36:23 <wahanui> fridolin: no idea
15:36:30 <tuxayo> lol
15:36:31 <fridolin> tea then
15:36:35 <liliputech> +1
15:37:31 <tuxayo> #startvote Which channel name? koha_bots, koha-bots, something else
15:37:31 <huginn> Begin voting on: Which channel name? Valid vote options are koha_bots, koha-bots, something, else.
15:37:31 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
15:37:52 <liliputech> #vote koha-bots
15:37:55 <tuxayo> #endvote
15:38:00 <ashimema> #vote koha-bots
15:38:01 <tuxayo> #startvote Which channel name? koha_bots, koha-bots, something_else
15:38:01 <huginn> Already voting on 'Which channel name'
15:38:10 <tuxayo> #endvote
15:38:10 <huginn> Voted on "Which channel name?" Results are
15:38:10 <huginn> koha-bots (2): ashimema, liliputech
15:38:10 <nugged> <tuxayo> (Hyphen or underscore? I don't know the IRC conventions) - so any hint about convestions or I missed the thread/reply?
15:38:15 <tuxayo> #startvote Which channel name? koha_bots, koha-bots, something_else
15:38:15 <huginn> Begin voting on: Which channel name? Valid vote options are koha_bots, koha-bots, something_else.
15:38:15 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
15:38:30 <liliputech> #vote koha-bots
15:38:35 <oleonard> #vote koha-bots
15:38:35 <ashimema> #vote koha-bots
15:38:37 <fridolin> #vote koha-bots
15:38:42 <thd> #vote koha-bots
15:38:54 <nugged> how can I now say koha_bots? :)
15:38:59 <nugged> #vote koha-bots
15:38:59 <oleonard> koha-🤖?
15:39:23 <tuxayo> nugged: «so any hint about convestions or I missed the thread/reply?» I launched the vote to have this question sorted out ^^
15:39:32 <liliputech> oleonard: you silly >< that will be hard to join ;)
15:39:44 <tuxayo> #endvote
15:39:44 <huginn> Voted on "Which channel name?" Results are
15:39:44 <huginn> koha-bots (6): liliputech, oleonard, ashimema, fridolin, nugged, thd
15:40:23 <tuxayo> Also OFTC right?
15:40:42 <ashimema> yeah, I reckon so
15:40:45 <tuxayo> At the hackfest it was mentioned to do that in Libera.chat
15:40:55 <tuxayo> But I didn't get it
15:41:03 <tuxayo> cc nugged
15:41:04 <liliputech> that would be easier to have both chats on the same server
15:41:26 <tuxayo> #agreed Move the bots output mentioned in the agenda to #koha-bots
15:41:31 <ashimema> we actually have a #koha channel reserved in libera.chat
15:41:42 <tuxayo> good
15:41:44 <nugged> yes, some talks (not my origin) was that to use another server I don't get clear point why (fresher, beter, faster?)
15:41:46 <ashimema> in case oftc ever dissapears
15:42:02 <liliputech> nugged: harder better faster stronger ;)
15:42:14 <nugged> daft
15:42:18 <liliputech> ^^
15:42:38 <liliputech> if u like daft, try yellow magic orchestra, japanese precursor
15:42:41 <tuxayo> Ok so OFTC unless we find a concrete reason.
15:42:50 <nugged> .. and we speaking about bots so daftpunk just in ontopic here right :)
15:42:59 <tuxayo> Any other dev discussion?
15:43:00 <liliputech> Haha ^^
15:43:34 <nugged> ... also discussion was to have separate more-techy channel for current release manager team, i.e. all who hels and communicates with release menager to have one channel and all discussion about quick tests and so on (as well from my libraries piloting pre-release master build)
15:44:09 <tuxayo> Ah yes, because this cycle you will be 3 people to coordinate so you need a channel
15:44:21 <tuxayo> (You, Frido, Jonathan)
15:44:28 <ashimema> we have a rmains channel I think already
15:44:35 <ashimema> we used to
15:44:38 <tuxayo> Ah yes
15:44:38 <ashimema> maybe it went bye bye
15:44:43 <tuxayo> #_oftc_#rmchat:matrix.org
15:44:48 <ashimema> that's the one
15:45:07 <nugged> ... and to have +1 more channel for less-techy talks to especially attract librarians to come for help and see less noise from deep tech talks from joubu and ashimema (and others, glob(*) you are) - some chan like #koha-userhelp
15:45:08 <liliputech> it still exist :)
15:45:54 <oleonard> This channel is quiet 95% of the time these days
15:46:04 <nugged> the idea to especially make comfortable place for humans and human quesitons about usage, to be more brave asking "noob" questions, alike. And have web interface promoted for that channel as well other easy-to-join bridges
15:46:19 <ashimema> that's a nice idea
15:46:48 <nugged> > This channel is quiet 95% of the time these days
15:46:48 <nugged> oleonard: indeed, but if you come to read history and be just librarian you'll be scared. But yes, we can let this opinion ripe for a moments later,
15:47:01 <ashimema> I think that might best be done once we've made it easier for the general public to use.. I still hear complaints about irc even though I personally think it works ok
15:47:28 <tuxayo> ashimema: complains even with the webchat?
15:47:39 * ashimema hopes oleonard likes that he just filled his inbox
15:47:42 <ashimema> pass
15:47:55 <ashimema> the webchat feels very dated too
15:48:02 <oleonard> ashimema: 👍🏻
15:48:15 <ashimema> I think people are just expecting slack, whatsapp, disourse or whatever
15:48:31 <ashimema> telegram bridging will help with that
15:48:32 <liliputech> signal?++
15:48:40 <nugged> oleonard: sometimes name of channel "allows" people to be more brave when they noobs, + same topic of channel with some hint "don't afraid ask dumb, we won't freak" and also previous history they will see
15:48:50 <tuxayo> Ah yes
15:49:34 <liliputech> let's setup a bbs like in the goldays (good old days?)
15:49:36 <nugged> > telegram bridging will help with that
15:49:36 <nugged> let me anyway bring POC of this as I said on hackathon, so we will see, I just will ask 1 month (around) please, /me drowning :) but badly want to make that
15:49:52 <tuxayo> > the webchat feels very dated too
15:49:53 <tuxayo> The one used by libera.chat is great.
15:50:24 <ashimema> interesting
15:50:38 <fridolin> keep it simple, and free
15:50:44 <fridolin> and opensource i mean
15:50:52 <ashimema> indeed
15:51:02 <thd> People are always expecting whatever is most familiar and not whatever is most helpful or good for freedom.
15:51:32 <nugged> my proposal:
15:51:32 <nugged> - bots to be separated.
15:51:32 <nugged> - rmaint channel we have, I'll call frido and joubu and others to join or others calls me, when needed and time comes
15:51:32 <nugged> - let us our feeling about more channels like "koha-userhelp" ripe for some time
15:51:32 <nugged> - I'll bring telegram bridge like we did for Perl community (YAPC conferences) so let's see this too + we bring more other tools (matrix, etc) - so let's arise this quesiton one again in a month or around
15:53:27 <tuxayo> If people want to use Telegram we could let them have a bridge. We could still have a modern libre/open source choose promoted first on the website. Like a better IRC webchat and Element/Matrix.
15:54:06 <tuxayo> nugged: okay let's got with this :)
15:54:24 <tuxayo> > rmaint channel we have
15:54:24 <tuxayo> "rmchat" actually
15:54:38 <nugged> rmchat, thanks, sorry. ok
15:54:42 <tuxayo> So let that sink for some time and move one?
15:54:44 <tuxayo> *on
15:55:11 <nugged> +1
15:55:53 <ashimema> kiwiirc is indeed pretty and modern looking.. that would be a nice replacement for our web chat
15:55:53 <ashimema> anyhow
15:55:56 <ashimema> moving on
15:56:06 <ashimema> I like all nugged suggestions
15:56:16 <tuxayo> #topic Set time of next meeting
15:56:39 <tuxayo> Shall we aim for NZ, Tahiti and Americas for next meeting?
15:57:50 <tuxayo> (can't do Australia, current DST it can't reach South America east)
15:58:49 <fridolin> good for me
15:58:56 <tuxayo> Last time it was great to have some people from NZ and fridolin can't every time come in the middle of night.
15:59:51 <fridolin> was it 22:00 UTC ?
15:59:52 <tuxayo> It would be the 11th due to general meeting
15:59:52 <liliputech> ok for me as well
16:00:10 <fridolin> https://wiki.koha-community.org/wiki/Development_IRC_meeting_6_April_2022
16:00:45 <tuxayo> 21 actually
16:00:54 <tuxayo> This time we make it 9:00 am for NZ
16:01:04 <tuxayo> Wait
16:01:08 <tuxayo> 21 UTC
16:01:49 <tuxayo> I though it was about french mainland time but it 21 UTC
16:02:14 <tuxayo> 11 May 2022, 21 UTC
16:02:29 <fridolin> 11am for me
16:02:42 <tuxayo> thanks for the double check
16:02:48 <liliputech> 22h for french is that right?
16:02:53 <tuxayo> 23
16:02:59 <liliputech> ouche. ok
16:03:39 <tuxayo> It should still be Wednesday I think. But not for NZ, no issues I think
16:03:43 <nugged> tuxayo: google shows 23 it's for EET / Finland (us)
16:04:21 <nugged> (DST/noDST because, winter time it will be 3 hours from UTC for us now we have two)
16:04:31 <tuxayo> Thanks for the check. I have a hard time getting my mind right about these time calculation
16:04:42 <tuxayo> #info Next meeting: 11 May 2022, 21 UTC
16:04:48 <ashimema> fridolin, when you come to work through the jQuery UI tree.. push bug 30466 fairly early.. some of them are not direct depends on it.. but it does make them all look better 😉
16:04:48 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30466 enhancement, P5 - low, ---, oleonard, Passed QA , Convert serials pages tabs to Bootstrap
16:04:55 <ashimema> i.e. this tree: https://bugs.koha-community.org/bugzilla3/showdependencygraph.cgi?id=29226
16:05:09 <tuxayo> #endmeeting