14:02:10 <tuxayo> #startmeeting Development IRC meeting 20 July 2022
14:02:10 <huginn> Meeting started Wed Jul 20 14:02:10 2022 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:10 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:10 <huginn> The meeting name has been set to 'development_irc_meeting_20_july_2022'
14:02:39 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_20_July_2022 Today's agenda
14:02:48 <tuxayo> #topic Introductions
14:02:56 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:03:06 <marcelr> #info Marcel de Rooy, Rijksmuseum
14:03:12 <paulderscheid[m]> #info Paul Derscheid, LMSCloud GmbH, Munich, Germany
14:03:14 <cait1> #info Katrin Fischer, BSZ, Germany
14:03:19 <kidclamp> #info Nick Clemens, ByWater Solutions
14:03:21 <Joubu> #info Jonathan Druart
14:03:22 <thd> #info Thomas Dukleth, Agogme, New York City
14:03:47 <tuxayo> #info Victor Grousset, Tuxayo Europe, France
14:03:49 <khall> #info Kyle M Hall, ByWater Solutions
14:03:54 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:04:39 <tuxayo> #topic Announcements
14:04:51 <tuxayo> Anything to announce that doesn't fit the other topics?
14:04:59 <Joubu> Yes, announcement, me
14:05:09 <tuxayo> ๐ŸŽ™๏ธJoubu
14:05:14 <Joubu> (could have fit later but ... well)
14:05:17 <ashimema> #info Martin Renvoize
14:05:17 <wahanui> i heard #info Martin Renvoize was getting back the the Accounts Rewrite bugs
14:05:25 <Joubu> I will be on leave for 2+ months, starting in less than a month.
14:05:30 <cait1> forget #info Martin Renvoize
14:05:30 <wahanui> cait1: I forgot #info martin renvoize
14:05:40 <Joubu> I have several things in the queue that would be nice to have for 22.11
14:05:50 <Joubu> especially because they are a nightmare to rebase
14:06:05 <Joubu> and I don't think I will pick them back if they haven't been pushed until then...
14:06:12 <Joubu> bug 27272
14:06:12 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27272 enhancement, P5 - low, ---, stalkernoid, Needs Signoff , Move C4::Items::GetItemsInfo to Koha namespace
14:06:12 <cait1> you already gave me a list with a few, but can you name them somewhere?
14:06:17 <Joubu> bug 30718 (and friends)
14:06:17 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30718 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Use flatpickr's altInput option everywhere
14:06:22 <Joubu> bug 30982
14:06:22 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30982 enhancement, P5 - low, ---, jonathan.druart+koha, Signed Off , Use the REST API for background job list view
14:06:27 <Joubu> bug 27421
14:06:27 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27421 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Porting tools/stage-marc-import.pl to BackgroundJob
14:06:28 <Joubu> they are always the same...
14:06:37 <Joubu> (people wanted them, I wrote a patch)
14:06:44 <Joubu> Then, ERM
14:06:53 <oleonard> Joubu: I will test 30718 again soon
14:07:04 <Joubu> If we don't want it to be stuck for months, I need (at least) one or two of you onboard with me
14:07:14 <Joubu> You need to know what the current state is (see kanban)
14:07:27 <Joubu> and understand a bit of the code (I am currently more than 130 commits above master...).
14:07:29 <tuxayo> this one? https://tree.taiga.io/project/joubu-koha-erm/kanban
14:07:45 <cait1> do youmean testing or actual developing?
14:07:46 <Joubu> yes, there is only one
14:07:59 <Joubu> There are missing tests, missing documentation, it's a lot of code and both ERM and Vue are new for most of us
14:08:09 <koha-jenkins> Yippee, build fixed!
14:08:09 <koha-jenkins> Project Koha_Master_D11_My8 build #926: FIXED in 57 min: https://jenkins.koha-community.org/job/Koha_Master_D11_My8/926/
14:08:09 <wahanui> Congratulations!
14:08:12 <Joubu> cait1: depending on your skills. Feedback from the UI/testing, feedback on the code
14:08:43 <Joubu> if we don't want the project to fail, I need help now. I will be able to answer your questions and it will be easier for you
14:08:44 <paulderscheid[m]> I can help with Vue if you want
14:08:51 <cait1> say I have something like "input fields shoudl be longer here and there" - would I put that on the kanban?
14:08:51 <paulderscheid[m]> Sharpened my skills a little
14:09:01 <Joubu> Especially if we want a first shoot into 22.11 (which would help to get feedback from end users).
14:09:09 <Joubu> cait1: not about the UI
14:09:24 <Joubu> it should be rewritten using Bootstrap 5, but we are not there now
14:09:52 <Joubu> I don't care much about how the UI is (button too big, etc.) considering that minor for now
14:09:56 <ashimema> I'm out for two weeks from Friday, then have some urgent development work to complete the week after...
14:10:01 <ashimema> that kinda rules me out โ˜น๏ธ
14:10:10 <ashimema> but I was hoping to help progress all of them
14:10:17 <cait1> ... and with 2 QAers gone, I'll need help too
14:10:36 <cait1> and I am serious this time. The queue is too full already and we have 2 major QA people on leave soon.
14:10:54 <cait1> Joubu: so UI testing should be limited to functionality not looks?
14:11:02 <paulderscheid[m]> Ah yes, summertime ^^
14:11:10 <oleonard> ...but lots of people on the QA team list, so we shouldn't be so short-handed.
14:11:18 <cait1> yes, but we are
14:11:20 <koha-jenkins> Project Koha_Master_U20 build #495: SUCCESS in 39 min: https://jenkins.koha-community.org/job/Koha_Master_U20/495/
14:11:25 <marcelr> summertime is for all queues
14:11:27 <Joubu> mostly, yes. global ergonomic issues could be raised, not "button too big"
14:11:41 <Joubu> it's not there yet
14:12:23 <cait1> when you say help now, is the intention to get this in before you leave? or what is the goal?
14:12:28 <ashimema> the ERM is an optional module isn't it..
14:12:53 <Joubu> cait1: to not let it stuck for several months, without move
14:12:55 <ashimema> how tied in to other things is it in terms of possibility to break other area's
14:13:05 <Joubu> it's completely isolated
14:13:15 <ashimema> brill.. I thought it was
14:13:22 <marcelr> experimental module..
14:13:32 <cait1> yeah, I thnk we are having the same thought
14:13:36 <Joubu> but no point to push it if I am the only one aware of the code (and not around)
14:14:03 <tcohen> we all need to be aware of the code sooner or later
14:14:05 <tcohen> to maintain it
14:14:09 <ashimema> I'll get up to speed.. but it'll likely be in your last week
14:14:29 * ashimema assumes he knows why your off and that assumes things don't happen early ;P
14:14:30 <Joubu> anyway, I didn't want to monopolise the meeting
14:14:45 <tcohen> it's a good thing to talk about
14:14:49 <marcelr> :)
14:14:57 <tuxayo> completely isolated: Does that mean it could be pushed with rough edges and in 3 mo you iterate on it?
14:15:02 <tuxayo> Does the stuff to do in a month also include integrating the Cypress tests in our suite and pipeline?
14:15:27 <Joubu> not necessarily
14:15:33 <tcohen> oh, that's a really good question
14:15:34 <cait1> we have only about 4 months left - so close call, but maybe we could make it work
14:15:45 <Joubu> IIRC it won't work anyway, cypress cannot work without x server
14:16:02 <tcohen> we can have a headless X server, don't we?
14:16:06 <tuxayo> we can use xvfb likely
14:16:14 <Joubu> I didn't manage to make it work within ktd
14:16:26 <tcohen> ok
14:17:13 <tuxayo> It's a matter of time tinkering (during hackfest I tried to find a container with cypress and browsers ready but couldn't make it work with ktd...)
14:17:14 <Joubu> I don't remember the exact reason. And know I didn't spend much time on it, but I think I found something in the official repo's issue ssaying it couldn't work
14:18:02 <tcohen> ok
14:18:10 <tuxayo> Anything else to announce?
14:18:12 <tcohen> that won't prevent integration in the codebase
14:18:20 <Joubu> that's minor anyway, if we are 2 dev on it we can run the tests locally
14:18:31 <cait1> we should add an info
14:18:34 <cait1> about the leave
14:18:38 <tuxayo> right
14:18:51 <tcohen> tuxayo: I wanted to mention that ashimema asked me if we could test running a vector-im instance for the community
14:19:11 <tcohen> and I will set it soon
14:19:25 <tcohen> https://github.com/vector-im/element-web#running-from-docker
14:19:31 <tcohen> element, client
14:19:36 <cait1> ah
14:19:40 <cait1> I was going to ask what that is :)
14:20:17 <tcohen> the idea is to provide more interesting ways for people to interact with the community
14:20:25 <tcohen> testing phase
14:20:27 <tuxayo> #infodraftJoubu needs help on bugs 27272, 30718, 30982, 27421 and ERM before going on long starting in less than a month.
14:20:33 <tuxayo> like that the note?
14:21:03 <cait1> sounds good to me
14:21:10 <ashimema> a more modern webchat with access to our IRC channel.... thinking as a replacement for the current oftc hosted webchat
14:21:13 <tcohen> info Joubu needs help on bugs 27272, 30718, 30982, 27421 and ERM before going AFK in less than a month.
14:21:17 <cait1> tcohen: let me know when it's there, happy to hang out and we use element at work
14:21:22 <tuxayo> #info Joubu needs help on bugs 27272, 30718, 30982, 27421 and ERM before going AFK in less than a month.
14:21:32 <tcohen> cait1: sure!
14:21:38 <ashimema> excellent
14:21:39 <wahanui> darn tootin' it is.
14:21:42 <ashimema> thanks tcohen
14:21:55 <tcohen> I'll call it https://element.test.koha-community.org
14:22:25 <ashimema> Once we're happy it's ready we could tweak https://koha-community.org/get-involved/irc/ a bit
14:22:43 <ashimema> perhaps drop 'irc' as a wording and just say 'chat' instead..
14:22:51 <tuxayo> > vector-im instance
14:22:51 <tuxayo> Hosting a Matrix server and Element webchat? Shouldn't we try first to find a respectable already hosted public instance?
14:23:10 <tuxayo> I know already one from the https://www.chatons.org collective.
14:23:26 <tcohen> tuxayo: that's a good option too. I prefer to try it to get used to it, but yeahg
14:23:29 <ashimema> the irc channel is already bridged to the matrix.org servers and I think serves well enough
14:23:59 <ashimema> this is just to have a simple client and try to encourage people down the matrix/element path rather than joining with irc
14:24:00 <tuxayo> I used it a bit https://element.tedomum.net
14:24:00 <tuxayo> People managing it and the other services are quite active.
14:24:18 <tuxayo> Ah, hosting just the webchat
14:25:03 <tuxayo> To have a direct link to come here without creating an account?
14:25:21 <ashimema> that's the aim.. we'll see once testing
14:25:35 <ashimema> lets see.. give it a little trial
14:25:53 <ashimema> shall we move on?
14:26:01 <oleonard> We've been talking about it for ages, it's definitely worth trying
14:26:01 <tcohen> yeah
14:26:07 <tuxayo> That's great aim, thank
14:26:11 <tuxayo> *thanks
14:26:19 <tuxayo> #topic Update from the Release manager (22.05)
14:26:27 <tuxayo> tcohen: ๐ŸŽ™๏ธ
14:26:53 <koha-jenkins> Yippee, build fixed!
14:26:53 <koha-jenkins> Project Koha_Master_U22 build #144: FIXED in 1 hr 7 min: https://jenkins.koha-community.org/job/Koha_Master_U22/144/
14:26:53 <wahanui> Congratulations!
14:27:06 <tcohen> #info master has had some small hiccups, but I've managed to push enhancements and new features
14:27:44 <tcohen> #info tried to detect possible conflicts  with bugfixes as much as possible until last week
14:27:58 <tuxayo> what do you mean?
14:28:06 <tcohen> master has seen more than 500 commits in the last two months, mostly bugfixes
14:28:25 <tcohen> I mean that I started to push enhancements more often
14:29:04 <tcohen> been trying to mark things for stable and communicated with lukeg about must-backport stuffs for 22.05
14:29:33 <ashimema> tcohen++
14:29:43 <tcohen> there are a couple failures in Koha_Master that I cannot reproduce locally and cannot commit time to find a fix right now
14:30:03 <tcohen> I'm happy with the QA team so far, they kept me super busy pushing thing
14:30:05 <tcohen> s
14:30:19 <tuxayo> revert the culprit ticket? and the dev find it :P
14:30:24 <tuxayo> *let the dev
14:30:34 <tcohen> the problem is this has been like that for a while
14:30:49 <tcohen> before the 22.05 release AFAICT
14:31:16 <tcohen> and I cannot ask Joubu for more than he already does
14:31:18 <tcohen> Joubu++
14:31:34 <ashimema> this is the failing selenium test right?
14:31:37 <tcohen> (he introduced the changes in the testing pipeline)
14:31:40 <tcohen> yes
14:31:40 <ashimema> I've been meaning to take a look
14:31:50 <tcohen> it doesn't fail on normal KTD
14:31:55 <ashimema> but I'm not entirely sure I've got my head around the problem yet
14:32:01 <ashimema> yeah.. that's where I've struggled
14:32:04 <tcohen> it has to do with the way it is installed I think
14:32:28 <tcohen> also, I've been meaning to stop the Ubuntu 18.04 master job
14:32:37 <ashimema> good idea
14:32:43 <tcohen> as we don't really need to support it
14:32:52 <tcohen> and it has a failing test
14:33:13 <tuxayo> wait, it can catch early stuff that might fail when backported
14:33:25 <tcohen> ok, that's all from me. About devs, I will focus on some refactoring bugs Joubu already mentioned
14:33:33 <tcohen> ah
14:33:40 <tuxayo> Or if the probability that it helps it too low let's drop it anyway
14:33:42 <tcohen> it serves rmaints
14:33:50 <tcohen> ok, no problem from me
14:33:57 <koha-jenkins> Yippee, build fixed!
14:33:57 <koha-jenkins> Project Koha_Master_D11_MDB_Latest build #1022: FIXED in 46 min: https://jenkins.koha-community.org/job/Koha_Master_D11_MDB_Latest/1022/
14:33:57 <wahanui> Congratulations!
14:33:58 <tcohen> I will remove it from the 'Supported' tab
14:34:11 <tcohen> to avoid confusing people seeking for answers in Jenkins
14:34:30 <tcohen> ok, another thing I wanted to mention
14:34:34 <tuxayo> If it still fail constantly it not useful as a warning
14:35:27 <tuxayo> I think I had something that failed only Ubuntu 18.04 on oldoldstable and I reverted. I had not idea. Maybe it's the same ticket!
14:35:41 <Joubu> no
14:36:25 <tuxayo> Ah it was for Ubuntu 16.04 (bug30035)
14:36:27 <tcohen> this: https://jenkins.koha-community.org/job/Koha_Master_U18/lastCompletedBuild/testReport/
14:36:28 <tuxayo> so not related
14:37:03 <tuxayo> Ah this ><
14:37:22 <tcohen> I think it is just that the lib version doesn't explode the way our test expects
14:37:36 <tcohen> anyway
14:37:46 <tcohen> that's all from me on this topic
14:37:50 <tuxayo> ok
14:37:57 <tuxayo> #topic  Updates from the Release Maintainers
14:38:01 <tuxayo> rmaints?
14:38:01 <wahanui> rmaints are lukeg, liliputech and tuxayo
14:38:11 <ashimema> anyone know when lilputech is back?
14:38:14 <tuxayo> nothing interesting from me this month.
14:38:29 <ashimema> I have a few bugs I'm keen to see in the next 21.11.x
14:38:50 <tcohen> ashimema: urgent ones?
14:39:43 <ashimema> the analytics search error one.. the biblioitems acquisisitions on the api one
14:39:50 <tcohen> ah yes
14:39:56 <tcohen> we all need them
14:40:00 <ashimema> mm
14:40:02 <ashimema> indeed
14:40:14 <tcohen> I will contact liliputech
14:40:20 <ashimema> I think he's on leave
14:40:33 <tcohen> yeah, but will ask for permission to push things
14:40:40 <ashimema> I've been chasing them through lucas first ๐Ÿ˜œ
14:40:51 <ashimema> but i'm aware next release is pretty iminent
14:40:56 <ashimema> brill
14:41:13 <ashimema> I can help pushing.. just didn't want to upset his queue if he has a method for working through
14:42:02 <koha-jenkins> Yippee, build fixed!
14:42:02 <koha-jenkins> Project Koha_Master_D10 build #749: FIXED in 1 hr 1 min: https://jenkins.koha-community.org/job/Koha_Master_D10/749/
14:42:02 <wahanui> Congratulations!
14:42:22 <tcohen> ashimema: ok
14:42:33 <tuxayo> There could be a 21.11.x ready with the bugs tested and applied
14:42:42 <tuxayo> *21.11.x fork
14:43:05 <tuxayo> So when they come back they just have to merge it and release
14:43:58 <tuxayo> ashimema: tcohen can you add 21.05.x releases candidate tag on the bug and CC if they need to be in the next 21.05.x also?
14:44:17 <tcohen> yeah, I try to do that
14:44:21 <tuxayo> So I can eventually delay the release a bit to be sure I get then from upstream
14:44:33 <tuxayo> *on the bugs
14:44:38 <cait1> I was wondering, do you guys still work from git? like checking all commits for need to backport or do you have a different way?
14:44:40 <tuxayo> *and CC me
14:44:57 <cait1> I noticed some bugs that had been sitting form around May mostly
14:45:00 <tcohen> there's one security bug that we need to add to the release on the last day
14:45:57 <tuxayo> cait1: I don't know about the others but I do git log on the upstream branch and process (backport or leave a comment telling I skipped) every ticket
14:46:15 <cait1> That's good, thx tuxayo
14:46:22 <tuxayo> > I noticed some bugs that had been sitting form around May mostly
14:46:22 <tuxayo> Maybe there was a handover issue
14:46:47 <tuxayo> And some bugs where never examined
14:46:56 <cait1> it could be, I CCd Rmaint with a comment
14:47:13 <ashimema> I had a script that ran daily to check master vs my todo list.. it would append every bug to my todo list
14:47:18 <tcohen> Lucas was out for a couple weeks. Maybe that's why some things haven't reached the 21.11 and 21.05 branches
14:47:19 <ashimema> then I worked through that
14:47:25 <ashimema> yeah.
14:47:27 <ashimema> timing..
14:47:41 <ashimema> all good.. I just have some squeeking customers ๐Ÿ˜œ
14:47:48 <tuxayo> > I CCd Rmaint with a comment
14:47:48 <tuxayo> That's reliable for me but unless the other RMaint confirm it, we don't know if they can process all their bugzilla notifications
14:48:34 <tuxayo> The commitment for oldoldstable it way more managable and it's possible to follow everything.
14:48:54 <tuxayo> The other have also way more BZ notification since they touch more tickets than me
14:49:23 <tuxayo> moving on?
14:49:39 <cait1> y
14:49:41 <tuxayo> #topic Updates from the QA team
14:49:44 <tuxayo> qa_team?
14:49:44 <wahanui> qa_team is, like, cait, marcelr, khall, kidclamp, kohaputti, lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova and Joubu
14:49:57 <cait1> where to start..
14:50:06 <cait1> queue is full of stuff, some from May
14:50:18 <cait1> we notice the summer time and as said earlier, there will be people on leave
14:50:39 <cait1> so if you signed up for the team, now is the time to step up :)
14:50:52 <koha-jenkins> Project Koha_Master_D11_My8 build #927: SUCCESS in 39 min: https://jenkins.koha-community.org/job/Koha_Master_D11_My8/927/
14:51:24 <cait1> I still send weekly emails with the bad and the ugly
14:51:39 <tuxayo> cait++ for that
14:51:43 <oleonard> cait1++
14:51:46 <cait1> anything to add?
14:52:08 <Joubu> you always forget the good
14:52:11 <tcohen> cait1++
14:52:14 <Joubu> :D
14:52:18 <wajasu> i will be around after next week to do signoffs so if anyone is in channel and sees me, please suggest which bugs have priority.
14:52:21 <tcohen> yeah, add cool things too
14:52:30 <cait1> Joubu: that's a good point, I shoudl ty to point the good too
14:52:34 <tuxayo> wajasu++
14:52:56 <tuxayo> The good as in the easy and quick ones?
14:52:56 <ashimema> we should celebrate successes more.. Joubu is right
14:53:06 <tcohen> cait1: at least put your favourites :-D
14:53:08 <ashimema> I'm super happy to see the bundles/collections work in ๐Ÿ™‚
14:53:09 <Joubu> well I was only refering to the movie :D
14:53:12 <cait1> wajasu: ususally start with bugs (errors) and if you could look at stuff that has been sitting a while that#s great
14:53:25 <ashimema> I'm super happy to see some of the C4 -> Koha move stuff moving along
14:53:32 <ashimema> hehe..
14:53:34 <ashimema> yeah.. I know
14:53:34 <wajasu> cait1: ok
14:53:44 <cait1> tcohen: I am not doing favourites, so usualyl don't want to single out people :)
14:54:01 <ashimema> but I do think it would be a good thing to remind ourselves that although the queues often look high.. there is still loads of progress
14:54:12 <tcohen> it is fair to ask for things you need/want
14:54:14 <ashimema> I often forget that myself and can end up stuck in nagativity ๐Ÿ˜œ
14:54:27 <cait1> yep, all good points will try :)
14:54:41 <cait1> but you can always chime in too - that's how it's supposed to work
14:55:00 <tcohen> sorry for this
14:55:11 <tcohen> noise
14:55:16 <ashimema> wajasu, the dashboard is a great place to start.. I can give you some hints and tips on workflows
14:55:18 <huginn> News from kohagit: Bug 31192: Check for item before calling is_bundle <https://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=de6ca8aa3d291edc054028fb4f16bc6540ab47fb>
14:55:19 <huginn> News from kohagit: Bug 31186: Fix the hidingrules test for result numbering <https://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=d7647052f20104b70ba6b02d1535874fb9ab3b61>
14:55:20 <huginn> News from kohagit: Bug 27045: (follow-up) Fix delimiter in header rows <https://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=2eea061ca30e4810b07ca2920bfe1e55762fab02>
14:55:21 <huginn> News from kohagit: Bug 30268: Check mandatory fields in addorderiso2709.pl <https://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=e37359cae96535e45ccb26a5e22d5b67920d27cd>
14:55:22 <huginn> News from kohagit: Bug 27045: Fix other exports using CSV profiles <https://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=7cd84171ab57a35138fa5c585d2ed6de442e453c>
14:55:23 <huginn> News from kohagit: Bug 27045: Fix items lost report export if delimiter is tab <https://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=983965ee4790fd7841af87fcfdb8395ccea9e813>
14:55:31 <cait1> we like this kind of noise!
14:55:31 <tuxayo> lol
14:55:35 <cait1> tuxayo: move on?
14:55:43 <ashimema> I tend to pick a small one or two bugs to get me started then follow with a harder one to keep the queues moving.
14:56:29 <tuxayo> #topic  Status of roadmap projects
14:56:39 <wajasu> i'm getting used to ktd. with an easy bug. then will move on.
14:57:06 <tuxayo> Anything from anyone on a project?
14:57:18 <tcohen> #link https://annuel.framapad.org/p/koha_22.11_roadmap
14:57:37 <thd> Deferred pointing to test01 for wiki testing while standing up test00 running on Debian 10.
14:58:09 <tcohen> #info ashimema and tcohen have been talking about spending some days on C4::Reserves
14:58:12 <koha-jenkins> Project Koha_Master_D11_ES7 build #29: SUCCESS in 8 min 24 sec: https://jenkins.koha-community.org/job/Koha_Master_D11_ES7/29/
14:58:21 <ashimema> +1
14:58:39 <cait1> thd: do you still need testing, waht makes sense right now?
14:58:50 <cait1> I saw tuxayo had left a commen ton the wiki bug
14:59:01 <tcohen> #info many things in the Roadmap have patches and need eyes/testing
14:59:17 <thd> Testing is still needed I just did not want to confuse the whole mailing list by changing URIs.
14:59:28 <ashimema> I'll be taking stock and getting back to the roadmap things once I'm back from vacation ๐Ÿ˜œ
14:59:40 <ashimema> been a crazy few weeks... but then,, when is it not
15:00:07 <cait1> thd: can you give the current one?
15:00:09 <thd> You would not be confused.  The same bugs will be present but I might only fix them on Debian 10.
15:00:11 <cait1> I'll try to make time end of week
15:01:00 <oleonard> I've been working on follow-ups to Bug 30952. I'm doing some cleanup to reduce the number of template changes.
15:01:00 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30952 enhancement, P5 - low, ---, solene.desvaux, Failed QA , New interface for staff client
15:01:29 <ashimema> oleonard++
15:01:34 <tcohen> great
15:01:36 <Joubu> thd: are you planning to go live on D10?
15:01:37 <tcohen> oleonard++
15:01:39 <thd> https://koha-mw-my-test00-upgr.agogme.com/ is not up yet.  I just now fixed a manual package override needed for running apt-listbugs for a kfreebsd issue nothing to do.
15:01:57 <thd> We should probably go live on Debian 11.
15:02:20 <cait1> thd: just point me where i need to test - I'll try to spend some time Friday
15:02:34 <thd> Debian 10 has one slightly different package names.
15:02:39 <Joubu> thd: what's the timeframe?
15:02:41 <tcohen> thd: do you have an automated process for migrating the data?
15:03:05 <thd> The process is entirely automated as much as possible.
15:03:31 <thd> https://koha-mw-my-test01-upgr.agogme.com on Debian 9 is still current at this moment.
15:03:53 <Joubu> when will it be ready? What's missing? What's the timeframe? Do you need help? If so, what?
15:03:58 <thd> https://koha-mw-my-test00-upgr.agogme.com should become current anytime now.
15:03:58 <Joubu> I am tired of waiting for this wiki
15:04:06 <Joubu> I have helped 2 years ago, it was ready...
15:04:09 <ashimema> ++
15:04:23 <tcohen> thd: would you be ok with us launching a mediawiki instance in wiki.test.koha-community.org in which we use the automated process you come up with?
15:04:25 <Joubu> cannot we just go live "now"?
15:04:36 <cait1> I am also in favor of a quick move
15:04:36 <wahanui> okay, cait1.
15:04:44 <cait1> I think we coudl still fix some stuff later
15:05:12 <tuxayo> If the full size images don't work for now that's okay
15:05:15 <tcohen> I agree
15:05:20 <thd> There are a few installation bugs for changed package names which I may have now fixed.
15:05:46 <tcohen> thd: but what if we had the vanilla install sorted
15:06:04 <tcohen> https://hub.docker.com/_/mediawiki
15:06:07 <cait1> there is not a ton of changes on the current wiki, having a bit of a 'freeze' would not hurt a lot if it helps the move
15:06:23 <thd> Full sized images is not a problem with apache.
15:06:34 <tuxayo> good
15:06:47 <tuxayo> So any blockers?
15:06:56 <thd> It only takes about an hour to run.
15:07:40 <thd> Blockers are just finishing standing things up on Debian 10 which probably also works on Debian 11.
15:08:24 <Joubu> when can we go live?
15:08:30 <Joubu> we need a deadline
15:08:38 <tcohen> thd, I will send you an email about your automated migration process. So we can test it too
15:08:59 <tcohen> I really think we could simplify the process by using the OFFICIAL Docker images
15:09:01 <tcohen> as-is
15:09:16 <tcohen> I see there's a LocalSettings.php file
15:09:26 <thd> We should be able to go live by the end of Aug.
15:09:34 <tuxayo> great!
15:09:42 <tcohen> excellent
15:09:42 <wahanui> darn tootin' it is.
15:09:44 <Joubu> do we need a server?
15:09:56 <Joubu> or will we use the current one?
15:09:57 <thd> There are four LocalSettings.php files.
15:10:31 <thd> The current one runs on an old version of Debian which is needed to make it work.
15:10:38 <tcohen> ok, can you put some of those specifics on an email to Joubu, ashimema and I?
15:10:45 <Joubu> I won't be able to help
15:10:49 <Joubu> no need to include me
15:10:53 <tcohen> ok
15:10:58 <tcohen> include Joubu anyway
15:10:59 <tcohen> :-P
15:11:04 <ashimema> lol
15:11:20 <tcohen> I would like to know which MediaWiki version is too
15:11:41 <cait1> if the process is almost done, maybe we shoudl not make big changes now
15:11:43 <tcohen> we need a sustainable way to handle the wiki deployment
15:11:44 <thd> We will need a new Debian 10 or 11 instance for live.
15:12:04 <tcohen> and I think the great job you've done with the migration process
15:12:18 <tcohen> could pair well with one of this modern deployment methods available
15:12:24 <tcohen> so we can team up
15:12:54 <thd> Changes are merely to have things running on Debian 10 or 11 and reproducible.
15:13:10 <tuxayo> > I would like to know which MediaWiki version is too
15:13:12 <tuxayo> https://wiki.koha-community.org/wiki/Special:Version
15:13:16 <tuxayo> https://koha-mw-my-test01-upgr.agogme.com/wiki/Special:Version
15:13:23 <tcohen> thanks Tuxayo
15:13:50 <thd> MediaWiki 3.5 LTS
15:14:11 <tuxayo> *1.35 ?
15:14:31 <tcohen> 1.37
15:14:41 <tcohen> 1.35.7
15:14:41 <thd> The scripts I have written can be adapted to any future update for testing.
15:14:45 <tcohen> ok, it is the LTS
15:15:14 <tcohen> ok, can you write us an email so we exchange information about the migration process you come up with?
15:15:17 <thd> Yes 1.35.07 which is the current LTS
15:15:27 <koha-jenkins> Project Koha_Master_D11_ES6 build #27: SUCCESS in 8 min 31 sec: https://jenkins.koha-community.org/job/Koha_Master_D11_ES6/27/
15:15:52 <tcohen> and then we can certainly provide you with the deployed mediawiki instance
15:16:02 <thd> It is all documented in git with a README.txt file.
15:16:09 <tcohen> and we, together, perform the final migration
15:16:29 <tcohen> so you don't need to spend a lot of time making MediaWiki work on specific conditions
15:17:06 <thd> However, definitely some bug fixes which I have almost completed needed for installation to work in Debian 10 or 11.
15:17:16 <alohabot> ๐ŸŽ ๐Ÿฆ„ Koha 'master' packages pushed to 'koha-staging' repo  ๐Ÿ๐Ÿ๐Ÿˆ
15:18:06 <tuxayo> moving on?
15:18:37 <tuxayo> #topic Actions from last meeting
15:18:44 <tuxayo> ยซ thd sends a message to the mailing list about testing the wiki upgrade ยป
15:19:02 <tuxayo> Still relevant? No, right?
15:19:27 <tuxayo> ยซ cait finish the LTS drawing example with 4 rmaints and sometimes 3 ยป
15:19:38 <cait1> I finished it
15:19:39 <tuxayo> https://lite.framacalc.org/29o8a7mlwc-9v57
15:19:51 <thd> Yes, I deferred for sending people to a different URI for Debian 10 which is almost ready.
15:20:24 <cait1> thd: I'll wait for that email then
15:20:27 <tuxayo> thd: IIUC it's not relevant and now the aim is to deploy
15:20:28 <thd> ...so as not to confuse people on the mailing list by changing URIs.
15:20:36 <tuxayo> or is it?
15:20:43 <cait1> the tables now show what it looks like for 1 year maintenance and 1.5
15:20:49 <cait1> of the regular releases
15:20:56 <cait1> that's the main difference between the 3 tables
15:21:20 <tuxayo> there are 3?
15:21:51 <cait1> 3=
15:21:52 <thd> https://koha-mw-my-test01-upgr.agogme.com still works fine and is perfectly good for testing but we might have some different bug with Debian 10.
15:21:53 <cait1> ?
15:22:15 <tuxayo> There are 3 tables in the document?
15:22:21 <cait1> oh typo, 2 tables, I am sorry
15:22:29 <tuxayo> ok
15:22:44 <thd> We cannot deploy the wiki on Debian 9 where all previous testing has been done.
15:23:24 <tuxayo> thd yes so having D10 working and then deploying. Without needing more testing
15:23:37 <cait1> I think we had agreed on having the questions to vote for th emeeting, but we didn't do that - so maybe we can have the vote next time
15:24:12 <tuxayo> LTS: I think we need to have constantly 4 RMaints, because 1 year overlap isn't enough. Because the first 6mo of overlap are on the first 6mo of the life of the new LTS, so not enough bugs ironed out. So it leaves 6 months for upgrade.
15:24:13 <tuxayo> Which will be in the wrong year part for part of the libraries. Some do major upgrade in the middle of the year (summer in northern hemisphere) and other in the beginning/end (summer in the southern)
15:25:01 <cait1> my feeling is 1.5 years as well
15:25:59 <tuxayo> Yes, otherwise the same problem as above will happen for libraries following the other releases
15:26:55 <cait1> so next steps... mailng list email and vote on the next meeting?
15:26:55 <tuxayo> So does it make sense to have constantly 4 RMaints and not some cycles with only 3.
15:27:09 <tuxayo> ยซ davidnind Extended support/LTS release - send notice to mailing list ยป
15:27:22 <cait1> the 3 is because of the tls overap
15:27:30 <tuxayo> Did it happen and let's see what the email saud
15:27:30 <tuxayo> *said
15:27:44 <cait1> I think no email yet
15:27:56 <tcohen> thd: https://wiki.test.koha-community.org/
15:29:18 <tuxayo> > the 3 is because of the tls overap
15:29:18 <tuxayo> when the newer LTS is oldoldstable, the table shows the old LTS is dropped. So 3 RMaint needed in total. I meant that the old LTS shouldn't be dropped and we constantly keep 4 RMaints
15:29:55 <cait1> then you get an even bigger overlap with the old LTS
15:30:02 <cait1> we coudl do that, but we already have a year
15:30:10 <tuxayo> 6mo really
15:30:19 <tuxayo> the first 6mo of overlap are on the first 6mo of the life of the new LTS, so not enough bugs ironed out
15:30:50 <cait1> maybe make a variation of the table with 4
15:30:51 <koha-jenkins> Project Koha_Master_D11_ES7 build #30: SUCCESS in 7 min 37 sec: https://jenkins.koha-community.org/job/Koha_Master_D11_ES7/30/
15:30:51 <tuxayo> So only 6mo of overlap and for part of the libraries it will be the wrong part of the year
15:30:56 <cait1> and then we can add that to the vote/discussion
15:30:56 <tuxayo> ok
15:31:50 <cait1> but do we agree on email on vote? then we can move on
15:32:45 <tuxayo> on email on vote?
15:33:16 <cait1> we'll send an email to the ML and vote on the model next meeting
15:33:21 <tuxayo> yes
15:33:43 <cait1> I see David said he drafted an email already - so I'll try to get in touch with him
15:33:49 <tuxayo> thanks
15:33:55 <tuxayo> #action  davidnind Extended support/LTS release - send notice to mailing list
15:33:56 <thd> tcohen: Starting with a blank wiki will fail as a process for data migration.  Starting with a base Debian 10 system to which appropriate files can be added by scripts on the command line will work.
15:34:18 <tuxayo> #action  Extended support/LTS release - vote at the next meeting with questions added to the agenda, those unable to attend (time zone challenges) can add their votes to the agenda
15:34:40 <tuxayo> ยซ davidnind setup the KohaCon23 bid Wiki page and draft a message for the mailing lists: completed - wiki page KohaCon23 Proposals, development mailing list message ยป
15:34:58 <tuxayo> https://wiki.koha-community.org/wiki/KohaCon23_Proposals
15:34:59 <tuxayo> done :)
15:35:00 <koha-jenkins> Project Koha_Master_D11_MDB_Latest build #1023: SUCCESS in 38 min: https://jenkins.koha-community.org/job/Koha_Master_D11_MDB_Latest/1023/
15:35:47 <tuxayo> https://lists.koha-community.org/pipermail/koha-devel/2022-July/047210.html
15:35:52 <cait1> should we postpone the guidelines one? not sure which coding guidelines need to be updated and no draft
15:36:23 <oleonard> Yes, we're 1.5 hours in already
15:36:35 <cait1> maybe... someon coudl just do it?
15:36:37 <tuxayo> ok
15:36:41 <cait1> there is probably no need for discussion there :)
15:37:00 <tuxayo> Yes it's just confirming and having someone to update the guidilines
15:37:43 <tuxayo> But for the KohaCon, the draft is there, it looks good so who to send it now?
15:37:53 <cait1> tuxayo: email went out
15:38:11 <cait1> yesterday I think
15:38:13 <cait1> so that's done
15:38:14 <tuxayo> Ah right!
15:38:17 <cait1> just have to watch the deadline
15:38:25 <tuxayo> davidnind++
15:38:33 <cait1> davidnind++
15:38:45 <tuxayo> #action  liliputech discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.
15:38:56 <koha-jenkins> Project Koha_Master_D11_My8 build #928: SUCCESS in 48 min: https://jenkins.koha-community.org/job/Koha_Master_D11_My8/928/
15:39:11 <tuxayo> #action tuxayo postpone      Update guidelines with the replacement of jQueryUI Datepicker with flatpickr
15:39:18 <tuxayo> #topic  Set time of next meeting
15:39:43 <tuxayo> 17 august, same hour?
15:39:44 <tuxayo> For the next meeting of this timeslop
15:39:47 <tuxayo> *slot
15:40:33 <cait1> we jused to be biweekly
15:41:01 <cait1> did we change?
15:41:33 <tcohen> same hour would be ideal
15:41:37 <tuxayo> #info Next meeting: 3 August 2022, 21 UTC
15:42:09 <tuxayo> > did we change?
15:42:09 <tuxayo> No but the next meeting is for the other timeslot
15:42:28 <tcohen> ok
15:42:36 <cait1> ok
15:42:44 <tuxayo> So I ask here for the next next meeting and for the next meeting I copy what we said on the previous meeting
15:43:07 <tcohen> we didn't talk about Gitlab :-D
15:43:49 <tuxayo> shoots I forgot "General development discussion (trends, ideas, ...) " and call for anything to say
15:43:55 <tuxayo> Any quick news?
15:44:36 <tuxayo> #info meeting after the next one: 17 August 2022, 14 UTC
15:45:17 <cait1> tcohen: ?
15:45:55 <tcohen> Gitlab approved our Open Source Program status
15:46:04 <cait1> !
15:46:05 <tuxayo> wow great
15:46:22 <cait1> tcohen++ gitlab++ that's great news
15:46:24 <koha-jenkins> Project Koha_Master_D11_ES6 build #28: SUCCESS in 7 min 45 sec: https://jenkins.koha-community.org/job/Koha_Master_D11_ES6/28/
15:46:25 <tcohen> it was a generic response, they didn't answer specific things I mentioned on the details field
15:46:27 <tuxayo> they are flexible cool
15:46:43 <tcohen> they have a third party company that ponders cadidates
15:46:50 <tuxayo> lol
15:47:28 <tuxayo> tcohen++ thanks for managing to explain how we work and that even if we can't say we are non profit, we are respectable ^^
15:47:34 <tcohen> and they have an 'Exception clause' by which they can release the project from requirements for 'strategic reasons' (meaning marketing, etc)
15:47:56 <tcohen> that said, they don't mention anything about the exception being made
15:48:01 <tuxayo> Koha is strategic yay!
15:48:01 <tuxayo> (actually yes!)
15:48:02 <tcohen> or address any of my questions
15:48:26 <tuxayo> #info Gitlab approved our Open Source Program status
15:48:30 <tcohen> But I wanted to hear about liliputech's offer from AFI
15:48:43 <tuxayo> still relevant indeed
15:48:46 <cait1> tuxayo: we are as a community non profit, the only thing we miss is some type of organisaton that could apply
15:48:55 <tcohen> we'll see how things work once liliputech is back
15:49:04 <tuxayo> let's wrap it up then
15:49:05 <tuxayo> #endmeeting