15:02:11 <tuxayo> #startmeeting Development IRC meeting 23 March 2022
15:02:11 <huginn> Meeting started Wed Mar 23 15:02:11 2022 UTC. The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:11 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:11 <huginn> The meeting name has been set to 'development_irc_meeting_23_march_2022'
15:02:21 <tuxayo> #topic Introductions
15:02:28 <tuxayo> #info Victor Grousset, Tuxayo S.L., France
15:02:31 <cait1> #info Katrin Fischer, BSZ, Germany
15:02:32 <ashimema> #info Martin Renvoize, PTFS Europe, UK
15:02:46 <tuxayo> rmaints?
15:02:46 <wahanui> rmaints is probably khall, AndrewFH, wainui and tuxayo
15:02:49 <AndrewFH> #info Andrew Fuerste-Henry, ByWater Solutions, USA
15:02:51 <tuxayo> qa_team?
15:02:51 <wahanui> qa_team is cait, joubu, tuxayo, marcelr, kidclamp, khall, tcohen, ashimema, nugged, kohaputti, petrova
15:03:12 <nugged> #info Andrew Nugged, National Library of Finland, HELSINKI
15:04:48 <thd> #info Thomas Dukleth, Agogme, New York City
15:05:00 <udkoha> tuxayo: I found this information : echo "DROP DATABASE koha_kohadev; CREATE DATABASE koha_kohadev;" | koha-mysql kohadev
15:05:48 <marcelr> #info marcelr
15:05:50 <udkoha> it seems to me that if I would change this , than I couldd make my koha-testing-docker DB persistant
15:05:54 <udkoha> true?
15:06:15 <udkoha> sorry persistent
15:06:48 <tuxayo> udkoha: I never used persistance. the kp alias should do the trick. Can't say more, it's meeting time ^^
15:06:57 <cait1> we just started a meeting - maybe better to sort this out a little later or in pm
15:07:24 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_23_March_2022 Today's agenda
15:07:38 <tuxayo> #topic Announcements
15:07:57 <tuxayo> Anything to announce that doesn't fit in another topic of the agenda?
15:08:24 <ashimema> none from me
15:08:28 <tuxayo> Hackfest will be next week!
15:08:46 <nugged> 👍
15:08:57 <Joubu> #info Jonathan Druart
15:09:10 <ashimema> 44 attendees too 🙂
15:09:24 <ashimema> so, 38 of them are local. ish
15:09:32 <ashimema> but still.. nice to see people going
15:09:38 <tuxayo> No need to be a dev to attend, registration: email paul.poulain AT biblibre DOT com
15:10:07 <Joubu> Is Cheese Day on Wednesday as usual?
15:10:56 <tuxayo> Any news from the survey for the attendance of the KohaCon?
15:11:05 <ashimema> Tuesday by the looks Joubu
15:11:11 <tuxayo> (for electing the venue size)
15:11:13 <ashimema> Arrosoir... (full message at https://matrix.org/_matrix/media/r0/download/matrix.org/SYHDOvpRdebpMnoXVLYFDenm)
15:11:52 <Joubu> ho! hadn't looked at the other tabs :D
15:12:05 <tuxayo> ↑ name of the meals providers
15:12:06 * ashimema has no idea what most of those mean..
15:12:23 <ashimema> * but does recognise Fromage, hehe
15:12:41 <tuxayo> Arrosoir is the name of the thing to water on plants ^^"
15:12:55 <tuxayo> nothing else to announce?
15:13:06 <Joubu> https://www.arrosoir-marseille.com/
15:13:09 <ashimema> watering can.. lol
15:13:15 <ashimema> cool
15:13:34 <tuxayo> #topic Update from the Release manager (22.05)
15:13:47 <tuxayo> Apologies from Fridolin
15:13:56 <tuxayo> «I've pushed recently some major bugs to master, RMaints please have a look if it is not too late for this month release.»
15:13:59 <tuxayo> rmaint?
15:13:59 <wahanui> somebody said rmaint was definitely a great job to find all kinds of things to fix and clarify in translations, system requirements, CI among others.
15:14:08 <tuxayo> rmaints?
15:14:08 <wahanui> rmaints is khall, AndrewFH, wainui and tuxayo
15:14:11 <tuxayo> see ↑
15:14:16 <Joubu> and master is failing because of bug 30165
15:14:16 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30165 major, P5 - low, ---, tomascohen, Pushed to master , Several q parameters break the filters
15:14:43 <tuxayo> Good to have the RM assistants :)
15:15:04 <ashimema> hmm, weird
15:16:01 <tuxayo> anything else from RM assists ?
15:16:07 <Joubu> nope
15:16:34 <tuxayo> #topic Updates from the Release Maintainers
15:16:37 <tuxayo> rmaints?
15:16:37 <wahanui> rmaints is, like, khall, AndrewFH, wainui and tuxayo
15:16:59 <tuxayo> Release planned today or tomorrow
15:17:15 <AndrewFH> Hi! nothing special for me, also planning to release today or tomorrow
15:17:20 <tuxayo> Recent security done. See the website and upgrade!
15:17:30 <tuxayo> *security release
15:17:50 <tuxayo> #topic Updates from the QA team
15:17:55 <tuxayo> qa_team?
15:17:55 <wahanui> i guess qa_team is cait, joubu, tuxayo, marcelr, kidclamp, khall, tcohen, ashimema, nugged, kohaputti, petrova
15:18:17 <marcelr> still looking at some Auth stuff ;)
15:19:02 <tuxayo> Even if I'm late to the party, I'm reviewing bug 19532 I found a few things to ask and maybe indices to add. Still need to continue, it's a big one.
15:19:02 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19532 new feature, P1 - high, ---, aleisha, Pushed to master , Recalls for Koha
15:19:07 <Joubu> I have something to say about my QA work. I am playing the "give and take" game but loosing at the moment
15:19:20 <marcelr> i am always loosing that game
15:19:24 * tuxayo doesn't know the give and take game
15:19:29 <Joubu> I may stop QA until I am getting a better the balance
15:19:39 <marcelr> no way Joubu
15:19:47 <Joubu> why not?
15:19:55 <marcelr> you cannot quit
15:20:30 <Joubu> I need attention on some of my stuffs, I am considering important
15:20:35 <ashimema> I've not kept up this month Joubu
15:20:42 <ashimema> apologies
15:20:45 <Joubu> QAing is adding more conflicts
15:20:53 <ashimema> yeah.. know the feeling
15:20:54 <kidclamp> I will respond to direct requests, but have had a hard time getting tot he queue
15:21:04 <ashimema> I'll try hard to get to some of your again asap
15:21:10 <tcohen> hola
15:21:20 <tcohen> #info Tomas Cohen Arazi, Cordoba
15:21:44 * ashimema has a few EDI and SIP bugs in his queue looking for QA attention.. been meaning to poke Kyle for those for a few days.
15:22:18 <ashimema> most of Joubu's I've looked at recently have been discussion points and I've helped them edge forward but not done a full QA on as yet.
15:22:44 <ashimema> as ever, we need more people actively working on the QA queue.. 101 bugs in it at the moment.
15:23:02 <marcelr> it is the same thing as always
15:23:08 <Joubu> and I QAed ~20 yesterday
15:23:23 <marcelr> small stuff
15:23:29 <ashimema> perhaps we need to help some of the newer QA team members know where to start..
15:24:12 <ashimema> like, nugged, perhaps I could give you a quick run through how to find the quick QA's that really help keep the queue at bay whilst at hackfest?
15:24:57 <ashimema> kidclamp, do you guys still have any community time actually set aside or is it all fitted in around the massive todo lists you already have?
15:25:29 <kidclamp> Fridays are intended as QA days - we have just been busy
15:25:39 * ashimema is looking to try and re-introduce a community fridays effort at ptfs-e.. but I've been struggling to get on top of our own queues to free up that time
15:25:45 <ashimema> okies
15:25:52 <kidclamp> Kyle uses that time for RMaint right nowas well
15:26:04 <ashimema> so we're all victims of our own success..
15:26:12 <kidclamp> We intend to be available mornings during hackfest
15:26:16 <ashimema> yeah..
15:26:21 <tcohen> I can organize to QA more
15:26:28 <ashimema> that's part of the problem.. we're pulling from the same very small pool of people
15:26:30 <tcohen> but have had a rough couple months
15:26:30 <tuxayo> kidclamp: that's great
15:26:40 <marcelr> repeat that tcohen
15:27:13 <ashimema> problem is really that's it's always the same small few doing it.. it only takes one or two of us to get busy and the queue quickly rockets up
15:28:02 <ashimema> anywho.. shall we move on
15:28:06 <tcohen> let's have a great QA friday this week to cheer up
15:28:07 <ashimema> not one we're going to resolve here and now
15:29:11 <ashimema> ps, if your submitting patches.. setting patch complexity does help QA people pick their targets..
15:29:48 <tcohen> Joubu's patches require a couple days each :-D
15:30:01 <ashimema> having some trivial and smalls in the queue means it's easy to pick them out in small gaps between other things.. leaving that field empty immediately slows me down as I have to open the bug to know whether it's something I can pick off quickly or not.
15:30:09 <ashimema> haha.. yup
15:30:27 <ashimema> and that's fine too.. just means one has to schedule time for them
15:30:35 <Joubu> it required a couple of hours to write, it sholdn't take a couple of take to review
15:30:38 <tcohen> I'm personally comitted to working on the patron search bugs
15:30:40 <Joubu> neither a couple of years to rebase...
15:30:56 <Joubu> a couple of days*
15:30:58 * ashimema too tcohen
15:31:11 <tcohen> just been busy with the whole JSON::Validator upgrade stuff
15:31:15 <tcohen> which is... solved :-D
15:31:21 <ashimema> tcohen++
15:31:22 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
15:31:25 <ashimema> joubu++
15:31:27 <tcohen> batman++
15:31:29 <tcohen> Joubu++
15:31:31 <ashimema> 🙂
15:31:48 <tuxayo> #topic Actions from last meeting
15:32:07 <tuxayo> #action fridolin checking the GUI tool for alter on AnonymousPatron
15:32:12 <tuxayo> #action fridolin create bug report for skipping AnonymousPatron from delete_patrons.pl
15:32:17 <tuxayo> « tuxayo update wiki to remove ub16.04 support for Koha 21.11 (and check if MariaDB versions should change also) »
15:32:20 <tuxayo> done
15:32:53 <ashimema> I did my draft: https://wiki.koha-community.org/wiki/Coding_Guidelines#PERL30:_Pass_references_when_adding_a_new_plugin_hook
15:32:56 <tuxayo> That's weird, for the release tested against UB 16.04, we only support MariaDB 10.1 when Ubuntu ships 10.1
15:33:05 <tuxayo> *ub 16.04 10.0
15:33:16 <ashimema> nothing too controversial there
15:33:42 <tuxayo> So people using Ubuntu 16.04 must get MariaDB from elsewhere?
15:33:46 <ashimema> oh.. I also updated the dashboard to reflect more of the retired versions after last meeting.
15:34:38 <tuxayo> Ok maybe they don't hit the thing that broke the compat with MariaDB 10.0 (IIUC, there was something)
15:34:44 <ashimema> U16 should be retired on master too right?
15:34:47 <ashimema> not just 'disabled'
15:35:08 <tuxayo> ashimema: thanks for the draft!
15:35:16 <tuxayo> and the dashboard
15:35:17 <wahanui> well, the dashboard is looking lovely
15:35:36 <tuxayo> ^^
15:35:36 <oleonard> Agreed wahanui
15:35:55 <tuxayo> ashimema: retired on master: right!
15:36:03 * ashimema wants to update the dashboard to latest bootstrap and things.. but that's a very long term goal
15:36:50 <tcohen> lunchtime
15:36:53 <tuxayo> It still looks quite nice as of now.
15:36:56 <tcohen> koha++
15:37:18 <tuxayo> #topic General development discussion (trends, ideas, ...)
15:37:33 <tuxayo> «kohastructure.sql sync https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29605#c54»
15:37:33 <huginn> 04Bug 29605: major, P5 - low, ---, jonathan.druart+koha, RESOLVED FIXED, DB structure may not be synced with kohastructure.sql
15:37:50 <cait1> sorry on phone :(
15:38:14 <ashimema> we do seem to get out of sync rather easily
15:38:21 <nugged> catching up above message: ashimema and tuxayo and tcohen and joubu and fridolin - all what you said towards and what will be from me in Marseille - yes, many I plan to agree/coordinate with you. We are thrown a little with this war SERIOUSLY, that's why I dropped out a little. But:
15:38:21 <nugged> yes, I plan in live to coordinate and took some regular load from April on QA + SO tasks, to load people in my small team (NOW YES! I have +1 Perl dev (!) guy in 2 weeks!) and also prepping in my customer librarians volunteers for S.O.,
15:38:21 <nugged> also I need to take part with you ashimema in ILL - part in development for me + my team
15:38:21 <nugged> and with you joubu in ERM - part in development for me + my team
15:38:21 <nugged> more: I have some initiative around Ukraine, I will announce and get your feedback in live meeting on that.
15:39:03 <ashimema> 🙂
15:39:12 <marcelr> we have DBIx for years, we should get rid of kohastructure ?
15:39:17 <ashimema> deffo put life first nugged 🙂
15:39:20 <tuxayo> ashimema: it's about finding what to change in the RM process so kohastructure sync is kept?
15:39:39 <ashimema> it's the whole process really..
15:39:46 <ashimema> RM process and bug submission process
15:39:48 <tuxayo> marcelr: isn't kohastructure what set's up the DB on install?
15:39:59 <ashimema> Joubu suggests it's the atomicupdates that end up out of sync..
15:40:02 <marcelr> yes but the idea was to use DBIx
15:40:12 <ashimema> I found the oposite.. kohastructure got out for me
15:40:34 <ashimema> DBIx doesn't really solve it in itself marcelr
15:40:36 <tuxayo> > the idea was to use DBIx
15:40:36 <tuxayo> oh it could be used for that, that's a lead.
15:40:49 <marcelr> why not ashimema
15:41:01 <Joubu> kohastructure.sql provides us something easy to read, and easy to reset the DB with
15:41:03 <ashimema> one would need some additional modules on top.. which from memory are Moose based
15:41:08 <Joubu> it should be the reference IMO
15:41:32 <ashimema> and.. you have to do clever things to work around the fact you have a class object before and after db change.. so you have to get creative
15:41:40 <ashimema> I don't think the atomicupdate stuff is bad in reality
15:41:47 <ashimema> we just need to continue to refine it a little.
15:42:23 <Joubu> it's not a big deal, really, it's easy to fix
15:42:39 <Joubu> I don't think we should rethink the whole process for that
15:42:50 <Joubu> RM should watch the update process and resync when needed
15:42:54 <marcelr> redundancy creates sync problems
15:43:02 <ashimema> I think writing the update file is more difficult.. thus I'd say if someone write the update correctly and we generate kohastructure from it
15:43:05 <ashimema> indeed
15:43:14 <Joubu> I sent frido the steps but he didn't get back to me
15:44:01 <tuxayo> nugged: hope your team manages to sort out the current mess, glad to see that you have more member!
15:44:07 * ashimema would have said 1) Write and submit atomicupdate only, 2) kohastructure and then dbicdump run automatically on sandboxes and as part of release process
15:44:41 <ashimema> thus we write once and build the rest from it.
15:45:13 <Joubu> people interested in improving the process should come with a proposal
15:45:18 <ashimema> that's basically how DeploymentHandler does it.
15:45:23 <ashimema> yeah
15:45:45 <Joubu> the thing is, now it's not synced and it needs to be fixed asap :D
15:45:46 <ashimema> lets discus at hackfest Joubu.. I'm not wed to any plan.. just noticed it keeps getting out of sync 😉
15:45:52 <ashimema> agreed
15:46:14 <Joubu> I later tell the RM twice already
15:46:17 <Joubu> + email this morning
15:46:44 <ashimema> ERM, Vue, React chat now?
15:46:55 <tuxayo> « ERM Project using Vue (Joubu) »
15:47:03 <tuxayo> > "I played with React" https://lists.koha-community.org/pipermail/koha-devel/2022-February/046926.html
15:47:08 <tuxayo> > Bug 30160 - Rewrite cities admin view in React
15:47:08 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30160 enhancement, P5 - low, ---, jonathan.druart+koha, In Discussion , Rewrite cities admin view in React
15:47:11 <tuxayo> > "I played with Cypress (and ERM and Vue)" https://lists.koha-community.org/pipermail/koha-devel/2022-March/046956.html
15:47:16 <tuxayo> > Bug 30225 - Rewrite cities admin view in Vue
15:47:16 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30225 enhancement, P5 - low, ---, jonathan.druart+koha, In Discussion , Rewrite cities admin view in Vue
15:47:18 <tuxayo> > Remote branch: https://gitlab.com/joubu/Koha/-/commits/erm
15:47:20 <tuxayo> > Sandbox to test: https://staff-erm.sandboxes.biblibre.eu/cgi-bin/koha/erm/agreements.pl
15:47:22 * ashimema hasn't commented on the bugs yet to any real extent.. but has been working through them..
15:47:28 <Joubu> All the useful links are there, there is no much to add.
15:47:30 <ashimema> So far I'm in the Vue camp
15:47:34 <Joubu> People can just read the emails/patchs/discussions.
15:47:42 <Joubu> so far I am "Your branch is ahead of 'origin/master' by 66 commits."
15:47:49 <Joubu> and that's why I am rushing for 30063...
15:47:56 <ashimema> as for Cypress, I'm not at all up to date on testing frameworks and haven't got to that one yet.. it's next in my queue
15:47:59 <tuxayo> bug 30063
15:47:59 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30063 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Make the main patron search use the /patrons REST API route
15:48:04 <Joubu> I will certainly do a demo (show the code) during a hackfest session
15:48:19 <Joubu> But I would like it to be reserved to Koha active devs, the goal is not to demo Vue, but to show a Koha case.
15:48:37 <Joubu> There is a sandbox with the code, I will try to kepe it up-to-date with the remote 'erm' git branch.
15:48:45 <cait1> sandbox sounds great
15:48:46 <Joubu> (sorry for all the typos today)
15:48:51 <cait1> can you make sure the link gets outside of hackfest? :)
15:48:54 <Joubu> It looks very trivial so far, but it's already a big amount of code, as I needed to build the ground.
15:48:59 <nugged> I also want us on hackfest to cover ILL if possible (by latest 2021 ISO), but at least Martin's "taking over me" might be enough too to bootstrap me for that task too
15:49:19 <ashimema> link is already on the mailing list cait1
15:49:23 <ashimema> i believe
15:49:27 <cait1> oh i missed it, ony saw the branch one ok
15:49:36 <cait1> setting it up was a little too scary atm
15:49:43 <Joubu> t
15:49:47 <Joubu> there is a sandbox
15:49:52 <Joubu> there is nothing to setup
15:49:56 <Joubu> (and not much to test anyway)
15:49:59 * ashimema intends to pull tcohen into the ILL chat too nugged
15:50:05 <Joubu> the point is not in testing, but getting feedback on the code
15:50:18 <tuxayo> Joubu: nugged : add topics to the hackfest shared document.
15:50:20 <cait1> Joubu: i am just curious, I can wait
15:50:21 <Joubu> and knowing if I continue that road, or rewrite everything "the old way"
15:50:59 <Joubu> tuxayo: yes, hadn't saw the other tabs of the doc, will add the topics after the meeting
15:51:38 <nugged> tcohen ashimema - any of you but I need someone to get me loaded with dev of that (and my small subteam). Also our library already setting up test server and they want me to set up any "alpha" of that ILL asap and they agree be "hard critics" for us to make it by ISO and test with external tools (so we already, let's say, have good testers!)
15:51:52 <nugged> joubu: thought so, to add to that spreadsheet. Will do.
15:52:42 <tuxayo> Joubu: thanks for your time in making those experiments. Cypress code reads well. Your feedback about writing it is good. The limitations are not enough to block us. So that seems a good way forward :)
15:54:11 <tuxayo> moving on?
15:54:35 <tuxayo> #topic Review of coding guidelines
15:54:42 <tuxayo> > New notices should always be using TT syntax.
15:54:53 <ashimema> +1
15:54:54 <Joubu> #vote yes
15:54:57 <ashimema> good call
15:55:00 <ashimema> #vote yes
15:55:34 <tuxayo> (proposal from cait1 )
15:55:56 <Joubu> she wanted us to agree on it and add it to the guidelines
15:56:16 <marcelr> no need to vote then :)
15:56:28 <ashimema> I can add it
15:56:28 <tuxayo> Because the recalls new notices don't use tt IIRC
15:56:42 <ashimema> recalls still needs allot of work now it's in
15:56:42 <marcelr> they were wriitten in 2010 ?
15:56:55 <ashimema> lots of modernisation and cleaning
15:57:14 <ashimema> it's in though now isn't it..
15:57:22 <cait1> yes, trying to kill the unwritten rule sa bit
15:57:36 <cait1> I wanted to feature that topic in my qa email... but it didn't happen this week
15:57:58 <cait1> I think everytime we encounter something that we assume but haven't documented, a note on agenda would be great
15:58:23 <marcelr> and what about changing an existing notice ?
15:58:37 <cait1> updatng existing noties to TT is kinda hard
15:58:48 <tuxayo> > it's in though now isn't it..
15:58:48 <tuxayo> Yes, it's in. Don't hesitate to write in the ticket (19532) what still needs to be done so it's not forgotten.
15:59:03 <marcelr> we should no longer write to 19532
15:59:05 <cait1> for now we support both syntax and we still lack documentation (and consitency) for fully swiching to TT in my opinion
15:59:08 <marcelr> add it on new reports
15:59:16 <tuxayo> marcelr: ok, link to, then.
15:59:26 <marcelr> that report explodes
15:59:37 <cait1> my main issue is that we need to make this easy to use for libraries
15:59:41 <Joubu> notices for recall must be rewritten using TT syntax before 22.05
15:59:47 <cait1> with the old syntax you can click
16:00:01 <marcelr> the hybrid approach
16:00:02 <cait1> witht he new... you need to know object names and methods and... you know, it#s much harder than knowing the place in the db
16:00:20 <marcelr> this is actually a wider discussion
16:00:23 <cait1> yes
16:00:24 * ashimema worked hard on starting to update notices
16:00:35 <ashimema> but it was a long game and didn't get much support from community
16:00:44 <cait1> just saying, I think we can't be too hard on that rules yet, becasue we make it so hard for libraries still
16:00:51 <ashimema> another one of those.. if it take 2 years to get a simple patch through SO/QA.. I gave up on the wider project
16:00:57 <cait1> :(
16:01:10 <ashimema> as for updating existing defualt notices.. that would be easy..
16:01:17 <ashimema> just don't include an atomicupdate
16:01:25 <cait1> yes agreed
16:01:36 <ashimema> only update the one used at install time
16:01:38 <cait1> but if you want libraries e able to modify, you need to give them docs
16:01:51 <tuxayo> If there is no opposition let's add "New notices should always be using TT syntax" to the guidelines.
16:02:00 <ashimema> well.. my intention was to improve the UI
16:02:03 <tuxayo> #action tuxayo add "New notices should always be using TT syntax" in coding guidelines.
16:02:05 <cait1> i think it's ok, it will hopefully lead to more work in making things better
16:02:12 <cait1> tuxayo++
16:02:23 <ashimema> https://wiki.koha-community.org/wiki/Coding_Guidelines#NOTICE1:_Default_Notices_should_now_be_writing_using_template_toolkit
16:02:23 <ashimema> done
16:02:36 <tuxayo> ashimema++
16:03:01 <cait1> ashimema++
16:03:13 <ashimema> I have a feeling the old roadmaps Joubu did have expired ☹️
16:03:24 <ashimema> but I had a plan in at least 3 of those conseculitively..
16:03:41 <ashimema> and it included making the UI much clearer for TT..
16:04:03 <ashimema> having clear lists of usable variables for each notice rather than the weird sometimes works sometimes doesn't mix we have right now
16:04:32 <ashimema> plan was to use the dbic schema's to generate actually usable variables you could use in a picklist instead
16:04:43 <ashimema> anywho.. that's going a bit off topic
16:04:43 <Joubu> https://annuel.framapad.org/p/koha_21.05_roadmap
16:04:45 <Joubu> still there
16:04:52 <Joubu> Status: Groundwork underway
16:04:56 <ashimema> nice one Joubu
16:05:24 <ashimema> the accounts one's were where I gave up.. I had them waiting on cait for years
16:05:33 <ashimema> and they were never paid for devs in the first place 😉
16:05:52 <ashimema> sorry cait.. know your busy
16:06:04 <ashimema> * your busy too
16:06:25 <cait1> yeah, i keep trying, but there is still not much time for QA and hasn't been for a while, I apologize
16:07:18 <ashimema> from memory this was just first run testing
16:07:33 <ashimema> and they likely need an extensive and difficult rebase now
16:08:13 <ashimema> the other big one I'm keen to get moving at hackgest is AV translations
16:08:28 <ashimema> shall we end the meeting?
16:08:38 <Joubu> yes
16:09:20 <thd> For roadmap I now have a comprehensive fix for a bug which had crept into automated updating of test wiki. PHP composer dependency is often out of phase with MediaWiki and has to be version constrained which I had previously fixed partially. Partial fix with warnings from slogging without enough sleep was not satisfactory.
16:09:22 <tuxayo> ashimema: the PERL30 draf
16:10:11 <reiveune> bye
16:10:12 <ashimema> fire away
16:10:15 <tuxayo> https://wiki.koha-community.org/wiki/Coding_Guidelines#PERL30:_Pass_references_when_adding_a_new_plugin_hook
16:10:38 <tuxayo> let's read that. Any question before voting?
16:11:29 <ashimema> I'm sure wording could be refined.. but it gives us a starting point
16:12:05 <tuxayo> #startvote Validate PERL30 draft? Yes, no, abstain.
16:12:05 <huginn> Begin voting on: Validate PERL30 draft? Valid vote options are Yes, no, abstain, .
16:12:05 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
16:12:17 <tuxayo> #vote yes
16:12:21 <ashimema> #vote yes
16:12:50 <Joubu> #vote yes
16:12:57 <cait1> #vote yes
16:13:10 <tuxayo> Make sense, that could lead to subtle bugs. Any existing hook to rework?
16:13:11 <thd> #vote yes
16:14:03 <tuxayo> #endvote
16:14:03 <huginn> Voted on "Validate PERL30 draft?" Results are
16:14:03 <huginn> Yes (5): Joubu, ashimema, tuxayo, thd, cait1
16:14:21 <tuxayo> #Set time of next meeting
16:15:16 <tuxayo> Shall we aim for oceania + americas next time? Fridolin can't keep coming in the middle of the night.
16:15:45 <ashimema> sounds reasonable to me
16:15:47 <oleonard> Sounds fair to me
16:15:50 <nugged> yeah
16:16:03 * ashimema has leave coming up so I'm not sure if I'll be there.. but will try
16:16:28 <nugged> which new time might be? - few hours from current time or +?
16:16:34 <ashimema> Any existing hook to rework? - I think Kyle already worked through to correct them all
16:16:36 * nugged living on EET
16:17:21 <tuxayo> 6 april. 9am NZ, 17:00 argentina
16:17:58 <tuxayo> We can reach Australia but that would make 19:00 for tcohen
16:17:58 <ashimema> gotta go.. parents evening
16:17:59 <ashimema> bye
16:18:19 <cait1> I have to leave too - if it's not super early in the morning I'll try to catch the meeting
16:18:20 <cait1> bye all
16:19:59 <tuxayo> Let's try to Australia this time.
16:20:18 <tuxayo> #info Next meeting: 6 April 2022, 22 UTC
16:20:49 <tuxayo> 9am AU east, 11am NZ: 19:00 argentina
16:20:55 <tuxayo> #endmeeting