14:01:33 <tuxayo> #startmeeting Development IRC meeting 25 May 2022
14:01:33 <huginn> Meeting started Wed May 25 14:01:33 2022 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:33 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:33 <huginn> The meeting name has been set to 'development_irc_meeting_25_may_2022'
14:01:37 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_25_May_2022 Today's agenda
14:01:47 <tuxayo> #topic Introductions
14:01:49 <ashimema> #info Martin Renvoize, PTFS Europe, UK
14:02:22 <fridolin> #info Fridolin Somers, Biblibre, Tahiti
14:02:24 <khall_> #info Kyle Hall, ByWater Solutions
14:02:44 <Joubu> #info Jonathan Druart
14:02:50 <paulderscheid[m]> #info Paul Derscheid, LMSCloud GmbH, Germany
14:03:14 <thd> #info Thomas Dukleth, Agogme, New York City [high COVID tide lifts all infections]
14:03:37 <tuxayo> #info Victor Grousset, Tuxayo Company, France
14:04:06 <tuxayo> #topic Announcements
14:04:16 <tuxayo> Anything to announce that doesn't fit the other topics?
14:04:54 <liliputech> #info Arthur Suzuki, BibLibre, France
14:05:06 <lukeg> #info Lucas Gass, ByWater Solutions
14:05:20 <Joubu> Yes, maybe, tuxayo
14:05:33 <tuxayo> go ahead Joubu :)
14:05:37 <Joubu> ERM - For those who does not know yet, there is a sandbox I am trying to keep up-to-date
14:05:49 <Joubu> https://staff-erm.sandboxes.biblibre.eu/
14:05:59 <Joubu> you can connect with the usual sandbox's credential
14:06:07 <Joubu> there is also a kanban board at...
14:06:13 <Joubu> https://tree.taiga.io/project/joubu-koha-erm/kanban
14:06:47 <nugged> #info Andrew Nugged, Helsinki
14:06:56 <Joubu> So you can see the "ready to be applied" that will be applied soon. The idea is to have the features there, but with a not-so-good UI to start
14:07:07 <Joubu> and we will improve later, depending on the feedback
14:07:07 <tuxayo> #info sandbox with up to date ERM work: https://staff-erm.sandboxes.biblibre.eu/
14:07:15 <ashimema> Joubu++
14:07:22 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:07:23 <Joubu> Help, feedback, etc. highly welcomed
14:07:25 <tuxayo> #info kanban board to follow the progress https://tree.taiga.io/project/joubu-koha-erm/kanban
14:07:39 <Joubu> branch is always at the same place - https://gitlab.com/joubu/Koha/-/commits/erm
14:08:07 <Joubu> that's all for me
14:08:21 <tuxayo> thanks
14:08:30 <tuxayo> #topic Update from the Release manager (22.05)
14:08:47 <fridolin> yey
14:08:48 <tuxayo> fridolin: 🎙️
14:08:56 <fridolin> Release is coming ...
14:09:04 <fridolin> its the cycle last week
14:09:48 <fridolin> i'm preparing with docs and will have a look at last release commits for release as a checklist
14:10:26 <fridolin> Looks like there is no big bug waiting in queue (22_05_priorities)
14:11:07 <nugged> From my side I have to say something about the Relase:
14:11:07 <nugged> this release is (luckily or because we are improving) is most stable in pre-release phase I ever had in piloting with my customer(s).
14:11:07 <nugged> I installed our Community Master this week on Piloting Customer production - there happened to be NO blockers for them nor even anything bad they found to be the issues!!! Still testing, maybe something deeper, but it's  not like previous releases, when instantly something happened to come :). Really great!
14:11:42 <tuxayo> Great news :D
14:11:44 <tuxayo> team++
14:11:44 <oleonard> Excellent!
14:11:44 <wahanui> darn tootin' it is.
14:11:52 <fridolin> great thanks to you and them
14:12:07 <liliputech> \o/
14:12:37 <nugged> fidolin & mates: I thought we'll bring some quick bad bugs from customer like it was previous releases, but it's just working (argh :) ), ... :). And that's good/great too!
14:13:13 <tuxayo> > but it's just working
14:13:13 <tuxayo> That's even better stuff to bring ^^
14:13:23 <ashimema> nice
14:13:40 <fridolin> 1585 patches pushed at this point, so a nice amount of changes
14:15:03 <nugged> Also I have feedback from Jan (Mojolicious) on topic of Vue3/Svelte discussion.
14:15:04 <nugged> ––quote>>>
14:15:04 <nugged> It’s very simple to me: Svelte is a compiler, while Vue, React and similar tools are frameworks/code that runs in the browser.
14:15:04 <nugged> Being a compiler means that it produces code that is faster (last time I checked) than what Vue does. That’s not a deciding factor for my web apps though, but it’s a bonus. What I like the most is how simple the syntax is. Vue 3 is just recently getting close to the same syntax, but I still prefer Svelte.
14:15:05 <nugged> The cons I can think of is that there’s less libraries written for Svelte and the community is smaller. But it is growing and the library part haven’t stopped me from building my app :)
14:15:07 <nugged> Then I would choose svelte, since it’s also more suitable (imo) for building many small components, instead of moving to a full page webapp
14:15:09 <nugged> Meaning you can swap out pieces of jquery here and there instead of rewriting the whole thing
14:15:11 <nugged> Vue3 is not a bad option though. They simplified a lot of things luckily. It’s still a client side library though.
14:15:13 <nugged> ––<<<quote
14:15:49 <nugged> that is what I had from me for this meeting.
14:15:49 * nugged bowes
14:16:24 <ashimema> interesting
14:16:28 <ashimema> very interesting
14:16:33 <oleonard> Yes
14:18:09 <fridolin> i'm good
14:19:34 <paulderscheid[m]> Svelte would be a great fit but Vue has its merrits too. The community is much larger as you know and therefore it's less likely to phase out of existence eventually which seems important regarding Koha as a project that will hopefully continue in existence over a very long timespan.
14:20:16 <paulderscheid[m]> As great as svelte is from a technical standpoint the adoption isn't there yet.
14:20:49 <paulderscheid[m]> Additionally it's not that hard to migrate from Vue to Svelte.
14:21:40 <liliputech> isn't any of these tool going to make it more difficult for new devs to get in? which of those will?
14:21:57 <paulderscheid[m]> Both have great documentation.
14:22:36 <oleonard> liliputech: Any will, but we have to move forward to make Koha better
14:22:36 <liliputech> hum... but maybe the compilation thing is not something everyone knows how to deal with?
14:22:45 <paulderscheid[m]> Svelte would be easier for new devs and simple stuff but tackling complicated things is much easier with Vue.
14:22:56 <tuxayo> > more difficult for new devs to get in
14:22:56 <tuxayo> One of the arguments for vue is that modern and known frameworks could actually bring devs. I don't know if I understood correctly.
14:23:18 <paulderscheid[m]> > <@tuxayo:matrix.org> > more difficult for new devs to get in... (full message at https://matrix.org/_matrix/media/r0/download/matrix.org/JIiTrHqHkLhGMKmVQayRSwvt)
14:23:39 <paulderscheid[m]> Vue attracts good developers.
14:24:06 <tuxayo> Moving on?
14:24:14 <liliputech> ok for me
14:24:18 <oleonard> Does anyone have feedback specifically about Joubu's branch?
14:24:29 <tuxayo> good point
14:24:29 <ashimema> yeah.. it's more likely to bring devs in than scare new ones away
14:24:41 <liliputech> 2~2~
14:24:44 <ashimema> our existing code scares people away because it doesn't adhere to any frameworks
14:26:11 <tuxayo> #topic Updates from the Release Maintainers
14:26:13 <tuxayo> rmaints?
14:26:13 <wahanui> rmaints is khall, AndrewFH, wainui and tuxayo
14:26:24 <tuxayo> Last 20.11.X release went well
14:27:10 <tuxayo> I don't think other branche's release are ready yet but it should be soon.
14:27:56 <tuxayo> moving on?
14:27:57 <AndrewFH> Hi! Sorry, forgot about this meeting. 21.05.15 will be along shortly, I've been kinda swamped
14:28:17 <tuxayo> thanks for the update AndrewFH :D
14:28:25 <liliputech> khall_: about 21.11?
14:29:26 * liliputech now has access to the git, setup ssh and gpg keys according to the wiki.
14:30:39 <tuxayo> liliputech: don't forget to ask for the website. It's often the one cause delays for new RMaints.
14:30:43 <tuxayo> #topic Updates from the QA team
14:30:45 <tuxayo> qa_team?
14:30:45 <wahanui> qa_team is cait, joubu, tuxayo, marcelr, kidclamp, khall, tcohen, ashimema, nugged, kohaputti, petrova
14:31:25 <ashimema> NSO is high, PQA is building for next cycle already.. NQA is nice and low
14:32:02 <ashimema> we could do with a bit of an audit of Major and Criticals
14:32:13 <tuxayo> what do you mean?
14:33:15 <ashimema> as in, it would be helpful to have a bugwrangler look at all the 129 Majors at the top of the dashboard (in the pop down section).. and categorise them..
14:33:19 <fridolin> ah check if there level is correct
14:33:30 <ashimema> I'm sure not all of them are Majors and having that queue so high makes it hard to see the wood for the trees
14:33:40 * ashimema can't work on all of them ;P
14:33:52 <fridolin> sure
14:34:10 <ashimema> if something really is major, then drumming up some dev support to get it fixed would be beneficial..
14:34:20 <ashimema> it just looks bad as a community that we have so many ;:p
14:34:47 <ashimema> most of which have no code attached
14:35:09 <reiveune> bye
14:35:20 <fridolin> i can give a shot in the coming weeks
14:35:29 <ashimema> 😄
14:35:39 <fridolin> tuxayo: can you write an action pls ?
14:35:43 <ashimema> so yeah.. that's probably it from QA team.. unless cait is around?
14:36:43 <tuxayo> #action fridolin audits major and critical bugs (new, assigned and need signoff)
14:37:08 <tuxayo> fridolin: anyone can use #action, is the above summary correct?
14:38:28 <tuxayo> moving on
14:38:31 <tuxayo> #topic General development discussion (trends, ideas, ...)
14:38:38 <tuxayo> Anything from anyone?
14:38:46 <fridolin> thanks
14:39:01 <ashimema> New cycle soon... lots to come 😛
14:39:56 <ashimema> I've started looking through the GetMarcBiblio removal bug.. it's a great start but I feel we can do better by golfing it together early next cycle
14:40:26 <ashimema> kidclamp has been doing lots of performance piece last couple of weeks.. those are an interesting set of bugs to follow..
14:41:06 <tuxayo> GetMarcBiblio removal bug: this one? Bug 29633
14:41:06 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29633 normal, P5 - low, ---, jonathan.druart+koha, In Discussion , Unecessary GetMarcBiblio call in Koha::UI::Form::Builder::Item (?)
14:41:08 <ashimema> and.. Notices tree is starting to move again with some of those bugs going PQA end of this cycle
14:41:12 <ashimema> nope
14:41:25 <ashimema> bug 29697
14:41:25 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29697 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Replace GetMarcBiblio occurrences with $biblio->metadata->record
14:45:50 <tuxayo> anything else,
14:45:53 <tuxayo> *?
14:46:08 <tuxayo> Review needed on Bug 30733 so it can be merged soon after 22.05 release
14:46:08 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30733 enhancement, P5 - low, ---, victor, Needs Signoff , Simplify translatable strings
14:47:13 <tuxayo> It's more about proof reading that testing the many string changes (adding <span> so the string extractor pick clean strings for translators)
14:47:40 <tuxayo> *than testing
14:48:10 * oleonard promotes Bug 26392 again
14:48:10 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26392 enhancement, P5 - low, ---, julian.maurice, Patch doesn't apply , Wrap all translatable strings in opac-main.tt
14:48:29 <tuxayo> +1
14:49:14 <ashimema> 🙂
14:50:54 <tuxayo> moving on, if something else comes up, say it we come to it after  Set time of next meeting
14:50:55 <tuxayo> #topic Set time of next meeting
14:51:51 <tuxayo> Last meeting with good time for NZ, had a good audience so we can continue to alternate
14:52:28 <tuxayo> And the hours are correct for most part of the Americas also (at bit late for Argentina though)
14:53:20 <tuxayo> So to have 9am at NZ it would be 21:00 UTC
14:54:20 <tuxayo> 17:00 US east cost
14:54:39 <tuxayo> 18:00 argentina.
14:54:43 <lilipute1h> 11pm for france
14:55:04 <tuxayo> As for the date, it would be june 8
14:55:20 <tuxayo> lilipute1h: yes, not great for Europe though.
14:55:53 <tuxayo> #info Next meeting: 8 June 2022, 21 UTC
14:56:02 <lilipute1h> right after koha-us meeting?
14:56:19 <fridolin1> super
14:56:36 <tuxayo> There are a few hours between the koha US meeting and 21UTC right?
14:57:06 <lilipute1h> yes, just a few hours
14:57:44 <tuxayo> Should be good enough if someone wants to attend both
14:58:46 <tuxayo> #endmeeting