22:01:07 <davidnind[m]> #startmeeting Development IRC meeting 26 October 2022
22:01:07 <huginn`> Meeting started Wed Oct 26 22:01:07 2022 UTC.  The chair is davidnind[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:07 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:01:07 <huginn`> The meeting name has been set to 'development_irc_meeting_26_october_2022'
22:01:55 <davidnind[m]> #info Agenda https://wiki.koha-community.org/wiki/Development_IRC_meeting_26_October_2022
22:02:05 <davidnind[m]> #topic Introductions
22:02:14 <davidnind[m]> #info David Nind, New Zealand
22:02:27 <dcook_> Oh been a while since I've done one of these..
22:02:47 <dcook> Do I just do the info thing as well?
22:02:57 <davidnind[m]> Yes please!
22:03:05 <dcook> #info David Cook, Australia
22:03:14 <davidnind[m]> Not sure who is around - it is quite late in Europe!
22:03:39 <thd> #info Thomas Dukleth, Agogme, New York City [wiki change live but DNS change pending]
22:07:13 <davidnind[m]> Shall we defer, or just go through the items quickly - have info on some of the actions so these can be closed off
22:07:26 <davidnind[m]> thd: awesome!
22:07:46 <thd> tcohen had to leave for sport practice with his son.
22:08:23 <davidnind[m]> I think we'll just go through quickly - a short meeting can be a good meeting!
22:08:40 <davidnind[m]> #topic Announcements
22:09:15 <davidnind[m]> #info Roles for 23.05 are now open https://wiki.koha-community.org/wiki/Roles_for_23.05
22:09:48 <lukeg> #info Lucas Gass, ByWater Solutions
22:10:04 <davidnind[m]> Someone needs to send a note to the general and developer mailing lists - I didn't see one go out...
22:10:41 <thd> If anyone needs to add something to the wiki during the meeting until DNS changeover https://wiki2.test.koha-community.org
22:10:58 <thd> I will write a message to lists after DNS changeover.
22:11:19 <davidnind[m]> #action davidnind to send an email to the mailing lists on roles for 23.05
22:11:21 <thd> The old wiki is locked so that we do not loose edits.
22:11:23 <davidnind[m]> thd++
22:11:59 <davidnind[m]> I was going to wait until it is available again to update anything from this meeting
22:12:34 <thd> The wiki is currently available at https://wiki2.test.koha-community.org
22:12:42 <davidnind[m]> #info Wiki upgrade in progress, thd will send a note when DNS changeover is completed and the updated Wiki is available
22:12:50 <thd> It will stop working briefly when we change the DNS.
22:13:46 <thd> After DNS change, the new wiki will be available from the usual subdomain wiki.koha-community.org
22:13:47 <davidnind[m]> #info Updated Wiki available at https://wiki2.test.koha-community.org - there may be a brief outage while DNS is changed
22:15:09 <davidnind[m]> I'll skip Update from the Release manager (22.11), Updates from the Release Maintainers, Updates from the QA team, and Status of roadmap projects - unless anyone has anything to add
22:15:27 <thd> The brief outage will undo access from wiki2 subdomain.
22:16:14 <davidnind[m]> Really good accomplishment getting it over the line thd! Something to celebrate!
22:16:20 <davidnind[m]> confetti
22:16:20 <wahanui> o/`'`'`'`'`'`'`'`'`'`'`'`
22:16:56 <davidnind[m]> #topic Actions from last meeting
22:17:13 <davidnind[m]> I have some updates for these so will post now
22:17:29 <thd> We might have had DNS moved over but I was looking at an error in the logs which seemed to relate to deleted spam accounts.
22:18:51 <aleisha> hello did i miss the meeting?
22:19:01 <davidnind[m]> I will see how the moderation of new account requests goes when things are working - it is very rare for new spam accounts to get through (I hope!)
22:19:06 <davidnind[m]> Hi aleisha
22:19:20 <davidnind[m]> We are still going - great to have  you here
22:19:33 <davidnind[m]> Just working through the action points from the last meeting
22:19:40 <aleisha> phew! sorry am late :)
22:20:14 <davidnind[m]> No problem - there are only a few of us, decided to go through quickly
22:20:36 <thd> New account requests and password changes are broken until the mail server for the system where the wiki is running is fixed.  tcohen should have submitted a request to the relevant maintainer.
22:22:21 <davidnind[m]> #info tcohen will send an email with release dates this week, won't differ from usual release dates: Email sent (https://lists.koha-community.org/pipermail/koha-devel/2022-October/047350.html)
22:22:39 <davidnind[m]> Sorry, just to me a while to find the link
22:22:56 <davidnind[m]> thd: will hold off approving new requests until that is sorted
22:23:22 <davidnind[m]> #info tcohen and thd will arrange a date in the next few days: Wiki migration in progress!!!
22:23:58 <davidnind[m]> thd: do you have anything to add? thanks for all your work on this, it will be great to have an updated and supported Wiki
22:24:04 <davidnind[m]> thd++
22:24:08 * dcook got called away but back now
22:24:42 <davidnind[m]> #info tcohen to schedule/call a "CSRF day" to work on related patches together: the CSRF day didn't have much attention on it, might defer post-release unless people speak up
22:25:07 <dcook> I'm a bit confused there
22:25:08 <davidnind[m]> Not sure what "CSRF day" is...
22:25:12 <thd> Experements should be done on the test wiki which is being reconfigured shortly https://wiki.test.koha-community.org
22:25:20 <dcook> The CSRF patches didn't get much attention...
22:25:28 <thd> s/Experements/Experiments/
22:25:44 <dcook> tcohen is going to be RM for the next cycle too, yeah?
22:26:12 <davidnind[m]> looks like he has put his hat in the ring!
22:26:43 <lukeg> tcohen++
22:27:07 <davidnind[m]> #action tcohen to schedule/call a "CSRF day" to work on related patches together - deferred until after the 22.11 release
22:27:18 <thd> The wiki may need updates from usage edits for better relevance in search queries.
22:27:51 <dcook> I'll be CSRF-proofing 22.11 in early 2023, so if we can agree on a process, I'm happy to do a lot of the authoring...
22:28:09 <dcook> Definitely needs a group effort overall though..
22:28:28 <davidnind[m]> #info cait  to update LTS wiki page with current information from last dev meeting - volunteer required as cait is crazy busy!
22:28:46 <davidnind[m]> dcook++
22:29:29 <davidnind[m]> #info volunteers required for updating info LTS wiki page with info from last meeting
22:30:25 <davidnind[m]> #action davdnind to send  a request to the mailing list for someone to update LTS wiki page (will do if no one else is available)
22:30:32 <davidnind[m]> CSRF?
22:31:26 <davidnind[m]> #action  tcohen [WAIT until after 21.11 release] to draft proposal for master→main change and draft of action list
22:32:01 <davidnind[m]> #action oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.
22:32:40 <davidnind[m]> #info ashimema has started a draft of the style guide (https://annuel.framapad.org/p/koha-styleguide-draft), oleonard will probably be focusing on template fixes until the release
22:33:22 <davidnind[m]> #info khall offered to restore progress bars if people file bugs depending on bug 31666 for that
22:33:22 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31666 enhancement, P5 - low, ---, kyle, Pushed to master , Add job progress bar to stage-marc-import.pl
22:33:44 <davidnind[m]> That's all the action points unless anyone else has anything to add for all of the above!
22:34:32 <davidnind[m]> #topic General development discussion
22:35:42 <davidnind[m]> Has anyone got any updates or things to share on what is happening at the moment - I'll defer the git-bz discussion until the next meeting
22:36:15 <dcook> Not really I suppose.
22:36:38 <dcook> Juggling a number of things at the moment. Focused on security things a bit.
22:36:42 <davidnind[m]> A lot of work going into fixes and refinements for the staff interface change - hopefully it will be nicely polished by release time!
22:37:40 <davidnind[m]> I might send an email to the development list about the git-bz topic and alternatives - that way there may be some things to consider
22:38:33 <davidnind[m]> tcohen has been pushing all the bugs - currently down to 14 passed QA!
22:39:37 <davidnind[m]> the QA Team have been doing a great job as well - trying to keep things under control
22:40:40 <davidnind[m]> lukeg: do you have an release maintainer updates?
22:42:15 <lukeg> 22.05.06 was released yesterday
22:42:32 <lukeg> Things seem to be moving along without issue
22:42:48 <davidnind[m]> excellent!
22:42:49 <wahanui> darn tootin' it is.
22:43:24 <davidnind[m]> I think all the other supported versions have had their releases as well
22:43:37 <davidnind[m]> #topic Review of coding guidelines
22:44:52 <davidnind[m]> I think I will defer SQL8 item, unless anyone wants to say anything about it
22:45:47 <davidnind[m]> #info Agenda item about SQL8 coding guideline deferred until the next meeting
22:46:21 <davidnind[m]> Anything else anyone would like to raise before we set the time for the next meeting?
22:47:36 <thd> Oh yes
22:48:34 <thd> When using the new MediaWiki VisualEditor, it is best to save any changes before switching to the source code editor or vice a versa.
22:49:21 <thd> Switching between the two editing modes without first saving changes might sometimes create a problem even it is just extra white space.
22:50:03 <davidnind[m]> #info When using the new MediaWiki VisualEditor, it is best to save any changes before switching to the source code editor or vice a versa
22:50:54 <davidnind[m]> I like the visual editor - I use it when occasionally editing Wikipedia - it generally works very well
22:51:06 <thd> I have not seen a problem.  Most reported problems from Wikipedia seem to be users switching without realising that they are no longer in the VisualEditor and not knowing what to do.
22:51:50 <davidnind[m]> thd: I'm assuming that if anyone finds any issues they should add then to the bug or reply to your message on the list?
22:51:57 <thd> Users accidentally ending in source code mode may have broken templates unintentionally on some Wikipedia pages.
22:52:15 <thd> Bugs are best in bugzilla.
22:52:30 <thd> Bugs are legion :)
22:52:33 <davidnind[m]> I've not heard of anyone in the New Zealand Wikipedia community having any issues with the VisualEditor, so fingers crossed!
22:53:16 <davidnind[m]> #info Please log any Wiki upgrade issues in Bugzilla
22:53:31 <davidnind[m]> #topic Set time of next meeting
22:53:42 <thd> VisualEditor is not necessarily the problem but confused user and as with any WYSIWIG imperfect code correspondence.
22:53:46 <davidnind[m]> The time of the next meeting was set at the last meeting, so...
22:53:53 <davidnind[m]> #info Next meeting: 9 November 2022, 15:00 UTC
22:55:23 <davidnind[m]> For the one after that for the Oceania/Americas time slot on 26 October is 22:00 UTC OK? (Same time as this one)
22:55:31 <davidnind[m]> Or would you like it earlier or later?
22:56:22 <thd> Or the same?
22:57:17 <thd> Poor attendance may be an especially busy time for many.
22:58:03 <davidnind[m]> We'll leave it the same - otherwise, raise on the development mailing list to propose a new time
22:58:09 <thd> tcohen might have been here later but not earlier for him.  This is commute time for Eastern US.
22:58:33 <thd> The same time will be an hour earlier next time in the US.
22:58:59 <davidnind[m]> Daylight savings ends in Europe (mostly) this weekend, so will be an hour earlier next time for them
22:59:20 <davidnind[m]> thd: that may mean more attendees, so yeah!
22:59:37 <davidnind[m]> #endmeeting