21:08:15 <tuxayo_> #startmeeting Development IRC meeting 28 September 2022
21:08:15 <huginn`> Meeting started Wed Sep 28 21:08:15 2022 UTC.  The chair is tuxayo_. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:08:15 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:08:15 <huginn`> The meeting name has been set to 'development_irc_meeting_28_september_2022'
21:08:20 <tuxayo_> #topic Introductions
21:08:40 <alexbuckley> #info Alex Buckley, Catalyst IT, NZ
21:08:50 <tuxayo_> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_28_September_2022#Agenda Today's agenda
21:09:00 <tuxayo_> Refresh it if you had it open
21:09:01 <davidnind[m]> #info David Nind, NZ
21:09:02 <thd> #info Thomas Dukleth, Agogme, New York City
21:10:03 <tuxayo_> #info Victor Grousset, Tuxayo Empire, France
21:10:14 <fridolin> #info Fridolin Somers, Biblibre, France
21:10:22 * tuxayo_ is starting to get paid for Koha work!
21:10:28 <fridolin> tuxayo : Empire strikes back then ^^
21:10:34 <fridolin> ++
21:12:03 <thd> tuxayo_ Please avoid pay distorting your perspective :)
21:12:15 <tuxayo_> At a 2% growth per year I expect to consume all the visible universe in 2000 years. Exponentials are great
21:13:06 <tuxayo_> #topic Announcements
21:13:16 <tuxayo_> Anything to announce that doesn't fit better in the other topics?
21:13:54 <davidnind[m]> #info Individual videos and slides (where available) are now online! https://koha-us.org/2022/09/27/kohacon22-slides-recordings/
21:14:04 <tuxayo_> great!
21:14:22 <davidnind[m]> #info Thanks to koha-US for organising KohaCon22
21:14:25 <fridolin> super, ill have a look
21:14:35 <tuxayo_> thd: there will be certainly one distorion: now I can stop getting worried about rent and food and fearing to have to stop working on Koha
21:14:42 <tuxayo_> koha-us++
21:14:49 <tuxayo_> community++
21:15:03 <fridolin> food++
21:15:13 <davidnind[m]> From a remote perspective (apart from the timezone 😀) things seem to go really well.
21:15:25 <bag> #info Brendan Gallagher ByWater
21:15:29 <tuxayo_> What do you mean?
21:15:41 <tuxayo_> super cool the page with videos and slides for the conference
21:16:32 <tuxayo_> Anything else to announce?
21:17:47 <thd> Aside from one longish outage using library wifi much better than most conferences at avoiding livestream connection problems.
21:18:02 <tuxayo_> Proposal Website for KohaCon 23 https://www.kiwi.fi/display/KK/KohaCon
21:18:03 <thd> Uses hard wires whenever possible.
21:18:24 <tuxayo_> ethernet++
21:18:25 <tuxayo_> #topic Update from the Release manager (22.11)
21:18:30 <tuxayo_> tcohen: arround?
21:18:35 <tuxayo_> IIUC, no
21:18:47 <fridolin> wires++, only use wireless for the FM radio ;)
21:19:11 <tuxayo_> #topic Updates from the Release Maintainers
21:19:15 <tuxayo_> rmaints?
21:19:15 <wahanui> rmaints are lukeg, liliputech and tuxayo
21:19:52 <fridolin> liliputech told he is on releasing 21.11.12 these days
21:19:59 <tuxayo_> Everything good so far this month.
21:20:02 <tuxayo_> fridolin: ah great
21:20:29 <tuxayo_> lucas release stable today I think
21:20:42 <tuxayo_> #topic Updates from the QA team
21:20:45 <tuxayo_> qa_team?
21:20:45 <wahanui> qa_team is probably cait, marcelr, khall, kidclamp, kohaputti, lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova, Joubu and dcook
21:21:05 <nugged> o/
21:21:11 <tuxayo_> \o
21:21:39 <fridolin> I didnt do much this month sorry
21:21:41 <tuxayo_> I guided another patch testing session with french librarians but this time attendance was very low. It's a bit worrying.
21:21:50 <fridolin> but i try to follow the current mood
21:22:06 <fridolin> i mean the current news
21:22:38 <fridolin> Universities are back on busy time
21:22:47 <fridolin> we see it in our support
21:23:07 <tuxayo_> And monday a patch testing session in english but only people from Germany and Austria came lol Where are english speaking librarians ^^
21:23:30 <tuxayo_> We tested a few patches and extensively walked through the process
21:23:48 <davidnind[m]> tuxayo_++
21:23:55 <tuxayo_> Hopefully it will be a good time investement ^^
21:24:22 <tuxayo_> davidnind: I hope in the end you will have nothing left to test :P
21:24:35 <tuxayo_> But it's harder than I though to get attendance
21:24:55 <nugged> Keep it flowing as it goes, mates! (tuxayo++ tuxayo_++) because -
21:25:08 <davidnind[m]> I don't think that will happen any time soon... 😀
21:25:36 <fridolin> I see there is life in the french translation ML, you may want to go there fishing for testers
21:25:38 <tuxayo_> #info support companies: please relay patch testing sessions to your customers that would be keen to test patch. (announcement in the koha general list)
21:25:41 <davidnind[m]> I feel slightly guilty that the Needs QA queue is so big....
21:25:56 <tuxayo_> fridolin: that's what I do ;)
21:26:05 <fridolin> ah super
21:26:07 <nugged> because don't panic, I (more or less confidently) prognose that all those my and our from-Finland efforts and potentially-to-happen declared things also come into power in upcoming month and this year will be very productive for us in further time - I will have more interest soon from Finnish libraries and some groups will come to help us also because of "KohaCon 2023 and PerlCon which will be all together as one)
21:26:38 <tuxayo_> nugged: that's great! :)
21:27:07 <fridolin> ah what a chance, but i will not be able to be tehre IRL
21:27:24 <fridolin> fetch me a T-shirt of PerlCon please ;)
21:27:48 <tuxayo_> he he
21:27:53 <tuxayo_> moving on
21:28:05 <tuxayo_> #topic Status of roadmap projects
21:28:13 <nugged> this one will be "Perl and Koha Conference" so this is unique something "very new",
21:28:26 <nugged> ah, btw:
21:28:30 <tuxayo_> #info https://annuel.framapad.org/p/koha_22.11_roadmap
21:28:43 <thd> ElasticSearch indexing has been working in MediaWiki Canasta testing for the past two weeks.
21:28:44 <nugged> #info Andrew Nugged, National Library of Finland, HELSINKI
21:28:54 <nugged> (sorry lost my info tag :) )
21:28:58 <tuxayo_> nugged: this is so cool to have both at same time and place
21:29:17 <nugged> yes and it's also now more moves further made now
21:29:18 <tuxayo_> thd: media wiki uses ES now?
21:29:29 <nugged> I actully drowning in this and this is something "massive" to happen, so -
21:29:35 <nugged> fridolin: maybe you reconsider?
21:29:50 <thd> Wikipedia has used ES for a long time.
21:30:10 <tuxayo_> So the ugprade of our wiki will introduce ES?
21:30:13 <thd> Most importantly some extensions are dependent upon ES.
21:30:56 <thd> I had previously told tcohen that we did not need ES quickly but it was too easy and too much depends on it.
21:31:04 <nugged> (sorry for scattering topics, mates, but) btw, link I see posted above, here some updated "few extra info places" - please consider these two:
21:31:06 <nugged> https://bit.ly/PerlKohaCon_welcome
21:31:07 <tuxayo_> Great, it's easy
21:31:11 <nugged> https://intro.perlkohacon.fi/
21:31:17 <tuxayo_> thanks nugged
21:31:32 <tuxayo_> Sorry, I changed topic too fast
21:31:36 <nugged> and I am working now hard to set up all "socicla channels" environment
21:31:43 <nugged> *social
21:31:45 <thd> ES indexing took only 5 min. in 1 GiB RAM.
21:32:13 <thd> with shared single CPU core.
21:32:29 <thd> I had been worried about resource use.
21:32:38 <nugged> and also we have official dates confirmed - from 14 August (premises booked, and lobbies, etc, for 2023 conference)
21:33:17 <nugged> thd: sorry for scattering threads, I'll some later once you tell I can. Let's go under your lead.
21:33:17 <thd> Do not poke this too hard as it has minimal resources: https://koha-mw-canasta-test03.agogme.com/ .
21:33:33 <davidnind[m]> nugged++
21:33:34 <davidnind[m]> thd++
21:33:41 <alexbuckley> nugged++
21:34:38 <thd> I finished VectorMod a modified version of the Vector skin allowing people to use either.
21:34:55 <thd> I plan to set everyone to VectorMod as default.
21:35:00 <tuxayo_> thd: great full scale pictures now work :D
21:35:02 <tuxayo_> thd++
21:35:19 <thd> They always worked in Apache.
21:35:41 <tuxayo_> ah ok
21:35:49 <tuxayo_> nugged++ thanks for the info
21:35:51 <thd> Nginx was always the problem.  The workaround for Nginx requires work.
21:36:22 <tuxayo_> thd: what is left before rolling out the upgrade?
21:36:55 <davidnind[m]> thd: Do you need testers to have a look around? From a quick browse things looked OK to me.
21:37:48 <thd> Essentially nothing but getting together with tcohen who is working on integrating a custom Docker container with Koha container infrastructure.
21:38:04 <davidnind[m]> Excellent!
21:38:04 <wahanui> darn tootin' it is.
21:38:27 <tuxayo_> thd: that's great new
21:38:29 <davidnind[m]> And then it gets switched over?
21:38:36 <thd> davidnind[m] testers should be careful not to poke too hard because of low resources there.
21:38:39 <tuxayo_> thd++ congrats on getting rid of the blockers
21:39:07 <thd> Also much trouble with varnish caching in my testing.
21:39:37 <thd> tcohen said that we probably will not use varnish which is fine.
21:40:23 <thd> Problems are about clearing the varnsih Docker container cache after changing a non-content page feature.
21:41:25 <thd> I modified the AdvancedSearch extension but it would not appear until the cache expired for non-logged in users.
21:42:06 <thd> Similarly changes in the navigation sidebar which gives separate links to current and obsolete content.
21:42:59 <thd> mtj ran some diffs between production and my out of date testing copies of the database.
21:43:08 <tuxayo_> mtj++
21:43:47 <tuxayo_> thd: when can we hope to have the upgrade rolled? Assuming the usual last moment suprises
21:43:51 <thd> The only differences he found in a crawl were obvious updates where content was not current on my testing copy of the database.
21:44:24 <thd> It could be tomorrow if tcohen appears and is ready.
21:44:37 <tuxayo_> wooow
21:44:42 <davidnind[m]> Excellent!
21:44:42 <wahanui> darn tootin' it is.
21:44:43 <thd> More likely next week if I catch him at the right hour.
21:45:01 <tuxayo_> thd: that great!
21:45:05 <tuxayo_> Moving on?
21:45:43 <tuxayo_> #topic Actions from last meeting
21:45:48 <thd> He may honour some holidays around now.  I honour none but do have another surprise job on, in addition to my regular late and early week job.
21:45:57 <tuxayo_> tcohen to schedule/call a "CSRF day" to work on related patches together
21:46:03 <tuxayo_> #action tcohen to schedule/call a "CSRF day" to work on related patches together
21:46:40 <tuxayo_> @later tell tcohen any news about the above? http://irc.koha-community.org/koha/2022-09-28#i_2452788
21:46:40 <huginn`> tuxayo_: The operation succeeded.
21:46:47 <tuxayo_> liliputech (deferred from previous meetingx3) discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.
21:46:51 <tuxayo_> let's drop that
21:46:57 <tuxayo_> Katrin to update LTS wiki page with current information from last dev meeting
21:47:01 <thd> tcohen is probably best reached early in the morning in his time zone when I am often asleep in the same or similar time zone.
21:47:10 <tuxayo_> what is the wiki page again
21:48:29 <tuxayo_> I guess https://wiki.koha-community.org/wiki/LTS_workflow_proposal
21:48:51 <tuxayo_> #action cait /Katrin to update LTS wiki page with current information from last dev meeting
21:49:01 <tuxayo_> ashimema will file a bug making Koha::Object::public_read_list throw an exception
21:49:05 <tuxayo_> I dunno
21:49:08 <tuxayo_> #action ashimema will file a bug making Koha::Object::public_read_list throw an exception
21:49:17 <tuxayo_> tcohen Date proposal for master→main change and draft of action list
21:49:25 <tuxayo_> I think I meant draft
21:49:38 <tuxayo_> #action tcohen draft proposal for master→main change and draft of action list
21:50:06 <tuxayo_> @later tell tcohen any news about the above? http://irc.koha-community.org/koha/2022-09-28#i_2452803
21:50:06 <huginn`> tuxayo_: The operation succeeded.
21:50:18 <tuxayo_> #topic General development discussion (trends, ideas, ...)
21:50:25 <tuxayo_> Bug 31150 - _on or _date for DB date columns?
21:50:25 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31150 enhancement, P5 - low, ---, koha-bugs, In Discussion , _on or _date for DB date columns?
21:50:45 <tuxayo_> «We need to decide a naming for the dates column.»
21:50:53 <tuxayo_> «We have _on and _date:»
21:52:04 <thd> _on is certainly cryptic without context.
21:52:20 <tuxayo_> So contributions needed on bug 31150 to settle the matter
21:53:01 <davidnind[m]> Maybe add as an action for those interested to comment on the bug, and then bring back  to the next meeting?
21:53:52 <tuxayo_> #action thd
21:53:55 <tuxayo_> oops
21:54:36 <thd> ... however, as Joubu identifies _date is problematic when it is not merely a date but actually a date with time.
21:54:58 <tuxayo_> #action thd give their two cents on bug 31150 in order to tilt the scale to on side.
21:55:07 <tuxayo_> @later tell ashimema So in the meeting we just highlighted bug 31150 and called for contributions. If you had something else in mind, feel free to put back on the agenda.
21:55:07 <huginn`> tuxayo_: The operation succeeded.
21:55:43 <tuxayo_> next: Are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL 8 on main/master.
21:55:54 <tuxayo_> Anyone here know something about our DB support?
21:57:31 <tuxayo_> #action tuxayo ask on the mailing list « are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL 8 on main/master. »
21:58:00 <davidnind[m]> System requirements: https://wiki.koha-community.org/wiki/System_requirements_and_recommendations
21:58:05 <davidnind[m]> Doesn't mention MySQL...
21:58:35 <tuxayo_> I'm raising the topic to know if it should mention it
21:59:05 <davidnind[m]> Great!
21:59:21 <tuxayo_> Maybe we dropped strong support for MySQL years ago? And only kept MySQL 8 on master to catch the strict SQL mode issues
21:59:36 <tuxayo_> Because that's mostly how I hear about MySQL
22:00:06 <tuxayo_> And MySQL 5.7 still has the db increment issue I heard on a past meeting
22:02:09 <tuxayo_> Let's see what we will learn when asking on the list
22:02:11 <tuxayo_> next: SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now.
22:03:34 <davidnind[m]> I have no idea... 🙂
22:04:35 <tuxayo_> let's ask on the other meeting slot. It looks straightforward to add that SQL is allowed in DBIC. but «This would mean that SQL in the Koha namespace is allowed» does this mean we should ban SQL from .pm?
22:04:59 <tuxayo_> #action tuxayo postpone «SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now. »
22:05:34 <tuxayo_> Update guidelines with the replacement of jQueryUI Datepicker with flatpickr - introduced in bug 29239. And document the usage in the wiki
22:05:34 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29239 enhancement, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] Replace jQueryUI's timepicker with flatpickr
22:06:14 <tuxayo_> It's hard to get the few people that know the details of flatpickr usage in meeting. Let's move that to the mailing list
22:06:45 <davidnind[m]> +1
22:07:19 <tuxayo_> #action tuxayo can for volunteers on the mailing list to «Update coding guidelines with the replacement of jQueryUI Datepicker with flatpickr - introduced in bug 29239. And document the usage in the wiki. cc Aleisha who had trouble with using flatpickr for the detail of what is missing»
22:07:34 <tuxayo_> Any other topic before closing?
22:07:36 <davidnind[m]> Maybe we should create a bug for that, so that the guidelines are updated - they all mention jQueryUI datepicker..
22:07:52 <davidnind[m]> Nothing from me....
22:10:10 <tuxayo_> #action tuxayo maybe create a ticket for updating the guidelines about flatpickr
22:10:24 <tuxayo_> #topic Set time of next meeting
22:10:37 <tuxayo_> I'll get the time for next meeting in the other time slot
22:11:16 <tuxayo_> For the next meeting in this this timeslot, same hour? When the daylight saving time change in NZ and Australia?
22:11:50 <davidnind[m]> NZ is now in daylight savings time...
22:12:00 <tuxayo_> Oh, it changed?
22:12:12 <tuxayo_> So the meeting didn't that on 9:00 am for you?
22:12:16 <tuxayo_> *didn't start
22:12:26 <davidnind[m]> 10am for us now...
22:13:00 <davidnind[m]> Changed last weekend
22:13:03 <tuxayo_> ok
22:13:32 <tuxayo_> Maybe it changed in Australia
22:13:41 <nugged> 1am in Finland :P )
22:13:44 <tuxayo_> ^^
22:13:54 <tuxayo_> And we might get a nice time for dcook
22:13:54 <nugged> (don't asking for any time slot changes though :) )
22:14:03 <davidnind[m]> nugged++
22:14:36 <thd> Australia changes on 2 October this year.
22:15:21 <tuxayo_> ok thanks
22:15:44 <davidnind[m]> #info Bug 31645 created for updating coding guidelines for flatpickr
22:15:44 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31645 enhancement, P5 - low, ---, koha-bugs, NEW , flatpickr - update coding guidelines
22:16:04 <tuxayo_> Next meeting on this time slot would be 26 october
22:16:13 <tuxayo_> now let's see what it does for Australia
22:18:43 <tuxayo_> At 22 UTC it would be 9:00 in Australia and 11:00 in Aotearoa
22:18:44 <fridolin> this is after DST change in France right ?
22:19:19 <davidnind[m]> Depends what state, https://www.timeanddate.com/worldclock/fixedtime.html?msg=Koha+Developers+IRC+Meeting&iso=20221026T2200
22:19:29 <tuxayo_> fridolin « ends on the last Sunday of October»
22:19:34 <tuxayo_> not yet
22:19:59 <tuxayo_> davidnind[m]: ah yes, I meant the one where dcook it
22:20:00 <tuxayo_> *is
22:20:04 <fridolin> ok
22:20:17 <tuxayo_> new south wales
22:20:26 <davidnind[m]> dcook = Sydney, so during his working day
22:20:27 <thd> 6 am in Perth
22:21:06 <tuxayo_> davidnind[m]: can you chair the 26th of october at 11:00 your time?
22:21:17 <tuxayo_> I can't be sure to chair at 00:00 my time
22:21:18 * fridolin AFK
22:21:25 <tuxayo_> or fridolin !
22:21:29 <davidnind[m]> OK with me
22:21:34 <tuxayo_> thanks a lot
22:21:37 <tuxayo_> davidnind++
22:21:45 <tuxayo_> let's finally end this
22:21:53 <davidnind[m]> I'm sure someone will
22:22:08 <tuxayo_> #info Next meeting: 12 October 2022, 14 UTC
22:22:40 <tuxayo_> ######info Next Oceania-Americas slot meeting: 26 October 2022, 22 UTC
22:22:49 <tuxayo_> #endmeeting