21:00:28 <tuxayo> #startmeeting Development IRC meeting 31 August 2022
21:00:28 <huginn`> Meeting started Wed Aug 31 21:00:28 2022 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:28 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:28 <huginn`> The meeting name has been set to 'development_irc_meeting_31_august_2022'
21:00:42 <tuxayo> #topic Introductions
21:00:46 <tuxayo> #info Victor Grousset, Tuxayo Spa Pty, France
21:01:28 <alexbuckley> #info Alex Buckley, Catalyst IT, NZ
21:04:17 <tuxayo> davidnind , fridolin around?
21:04:55 <fridolin> yep
21:05:08 <fridolin> #info Fridolin Somers, Biblibre, France
21:06:57 <tuxayo> let's chat while waiting for hopefully more people.
21:07:01 <aleisha> hello!
21:07:08 <aleisha> sorry was running late this morning
21:07:08 <tuxayo> hi!
21:07:20 <thd> #info Thomas Dukleth, Agogme, New York City
21:07:30 <tuxayo> alexbuckley , aleisha  at Catalyst, do you have tickets where librarians don't know why a hold is possible or not due to to much rules?
21:07:37 <aleisha> #info Aleisha Amohia, Catalyst IT, Wellington New Zealand
21:08:17 <aleisha> tuxayo: that specifically hasn't been raised, but occasionally we do have people talk about 'bugs' when it's just conflicting or confusing circulation rules
21:11:02 <tuxayo> *advertising music* aleisha I have a patchset for that! I'm rebasing bug 23732 and will finish the last code cleanup before submitting for testing ^^
21:11:02 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23732 enhancement, P5 - low, ---, victor, Patch doesn't apply , Hold rules checker: show matched rules and syspref values to help understand why a hold is possible or not
21:11:23 <tuxayo> We are a decent number, let's start
21:11:35 <aleisha> nice :) anything to simplify the application of circ rules is a good idea
21:11:44 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_31_August_2022 Today's agenda
21:12:19 <tuxayo> aleisha: It's a diagnostic tool to show what is matched and what blocks
21:12:28 <tuxayo> #topic Announcements
21:12:39 <tuxayo> Anything to announce that doesn't fit better in the other topics?
21:12:53 <aleisha> nothing from me
21:13:31 <tuxayo> #topic Update from the Release manager (22.05)
21:13:37 <tuxayo> Some messages from Tomas:
21:13:50 <tuxayo> «Jenkins is back to green»
21:14:12 <tuxayo> «Many refactoring patches pushed, yay»
21:14:14 <tuxayo> team++
21:14:52 <tuxayo> ~«recent focus on stabilizing things, and succeeded»
21:14:57 <tuxayo> tcohen++
21:15:20 <tuxayo> «I'll be out next week»
21:15:23 <tuxayo> «so I won't probably push big things the next days»
21:15:39 <tuxayo> #topic Updates from the Release Maintainers
21:15:41 <tuxayo> rmaints?
21:15:41 <wahanui> rmaints are lukeg, liliputech and tuxayo
21:16:44 <tuxayo> All dependencies to bug 25439 are backported to 21.05.x so it should be compatible with ES 7, more on that latter in the agenda.
21:16:44 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25439 critical, P5 - low, ---, koha-bugs, NEW , [Omnibus] Prepare Koha to ElasticSearch 7 - ES7
21:17:04 <tuxayo> #topic Updates from the QA team
21:17:05 <tuxayo> qa_team?
21:17:05 <wahanui> qa_team is, like, cait, marcelr, khall, kidclamp, kohaputti, lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova, Joubu and dcook
21:17:40 <aleisha> i think cait is not here to give an update
21:17:45 <aleisha> but i can take stuff from her latest email
21:18:01 <tuxayo> For me quite some time spend at the beginning the month on Joubu's refactorings.
21:18:04 <aleisha> #info lots of old bugs that need shifting
21:18:14 <tuxayo> aleisha: good idea, please do!
21:19:00 <aleisha> #info many of the team are on holiday (or will be soon) so community help to clear some old and bad bugs from the list would be much appreciated!
21:19:02 <tuxayo> As for Joubu (away for 2 months) large patches remaining I thing there is
21:19:05 <tuxayo> Bug 27421
21:19:05 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27421 enhancement, P5 - low, ---, jonathan.druart+koha, Failed QA , Porting tools/stage-marc-import.pl to BackgroundJob
21:19:19 <tuxayo> ↑ help needed to fix the issue
21:19:41 <tuxayo> And Bug 30982
21:19:41 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30982 enhancement, P5 - low, ---, jonathan.druart+koha, Signed Off , Use the REST API for background job list view
21:19:41 <fridolin> tuxayo: 21.11 is compatible with ES7+6 or is ES7 mandatory ?
21:20:07 <tuxayo> fridolin: both compatible
21:20:24 <tuxayo> aleisha: anything else?
21:20:27 <fridolin> ahhh great, we should update https://wiki.koha-community.org/wiki/System_requirements_and_recommendations
21:20:52 <tuxayo> fridolin: that's precisely a latter point in the meeting ^^
21:21:30 <tuxayo> moving on then?
21:21:38 <aleisha> nothing else
21:21:46 <tuxayo> #topic Status of roadmap projects
21:22:07 <tuxayo> #link https://annuel.framapad.org/p/koha_22.11_roadmap Roadmap
21:22:28 <fridolin> sorry ^^7
21:22:44 <tuxayo> thd: any news about the wiki upgrades?
21:23:04 <thd> tcohen, ashimema, and I met yesterday about testing the wiki with Canasta MediaWiki Docker image on the Koha Docker infrastructure.
21:23:31 <tuxayo> fridolin: that's okay, you guessed well that we should do something now that all tickets are implemented
21:23:43 <thd> We missed the previous week when we did not have a formal enough appointment and my laptop broke
21:23:54 <tuxayo> ouch
21:24:14 <tuxayo> > Koha Docker infrastructure
21:24:14 <tuxayo> The portainer thing?
21:24:40 <thd> tcohen is working on modifying the Canasta Docker image to have a persistent database reference etc.
21:24:50 <thd> Portainer exactly
21:26:14 <thd> I fixed several bugs for how the Canasta Docker container moved a few things out of LocalSettings.php and broke for the Docker image where everything had worked without Docker.
21:26:45 <tuxayo> thd: Is the plan still to go live very soon? Like after Tomas comes back from next week leave.
21:26:46 <thd> tcohen had a bit of time this week but will be away next week.
21:26:56 <thd> Yes.
21:27:29 <tuxayo> Exiting!
21:27:31 <tuxayo> thd++
21:27:34 <tuxayo> tcohen++
21:27:43 <tuxayo> anything else to add on any project?
21:27:59 <thd> Docker is a slightly different target for which adjustments have been needed.
21:29:06 <thd> I am building some automated code for supporting the Docker image etc. but everything will work without it.
21:30:53 <thd> My broken laptop was no great tragedy.  I had been given the laptop because it had a broken hinge and over time the broken pried the back of the laptop apart because the hinge was stronger than the plastic housing.  The power connector even fell victim.
21:31:13 <tuxayo> :o
21:31:20 <thd> Look after your hinges.
21:32:24 <tuxayo> I have one that broke because I didn't often enough rescrewed it. It's now miraculously held by glue!
21:32:27 <tuxayo> #topic Actions from last meeting
21:33:00 <tuxayo> #action ashimema needs to remove an introduced warning on bug 28854 tests (or test for its existence)
21:33:00 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28854 new feature, P5 - low, ---, martin.renvoize, RESOLVED FIXED, Add ability to create bundles of items for circulation
21:33:19 <tuxayo> « Task queue: marcelr willt take on bugs 27421 and 30718 »
21:33:22 <tuxayo> done
21:33:26 <tuxayo> marcelr++
21:33:52 <tuxayo> « qa_team high priority for bugs 30462 and 30982 »
21:34:14 <tuxayo> One was mentioned earlier and the other might have been in the weekly QA email
21:34:30 <tuxayo> #action liliputech (deferred from previous meetingx2) discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.
21:35:04 <tuxayo> @later tell liliputech any news about this? http://irc.koha-community.org/koha/2022-08-31#i_2447474
21:35:04 <huginn`> tuxayo: The operation succeeded.
21:35:21 <tuxayo> «Katrin to update LTS wiki page with current information from last dev meeting»
21:35:30 <tuxayo> We have any LTS wiki page?
21:35:32 <tuxayo> *an
21:35:41 <tuxayo> Ah, right https://wiki.koha-community.org/wiki/LTS_workflow_proposal
21:35:51 <tuxayo> #action Katrin to update LTS wiki page with current information from last dev meeting
21:35:54 <tuxayo> still todo
21:36:15 <tuxayo> #action tcohen will make a counter proposal about public_read_list()
21:36:37 <tuxayo> @later tell tcohen any news about this? http://irc.koha-community.org/koha/2022-08-31#i_2447483
21:36:37 <huginn`> tuxayo: The operation succeeded.
21:37:03 <tuxayo> #action ashimema will file a bug making Koha::Object::public_read_list throw an exception
21:37:21 <tuxayo> @later tell ashimema Any news about this? http://irc.koha-community.org/koha/2022-08-31#i_2447486
21:37:21 <huginn`> tuxayo: The operation succeeded.
21:37:31 <aleisha> can i add an action?
21:37:34 <tuxayo> Yes!
21:37:54 <aleisha> #action rename the master branch to 'main'
21:38:17 <aleisha> #action document the use of flatpickr in the koha community wiki
21:38:47 <tuxayo> Ah yes renaming_master++
21:39:24 <fridolin> for my projects i prefer 'trunk'
21:39:24 <tuxayo> flatpickr: there is precisely a point about that in "Review of coding guidelines" :D
21:39:37 <tuxayo> #topic General development discussion (trends, ideas, ...)
21:39:42 <tuxayo> Renaming master
21:40:02 <tuxayo> main, trunk, dev, develop, whatever works best
21:40:17 <fridolin> since there are branches ...
21:40:34 <alexbuckley> I love Bug 23732 tuxayo, sorry hexchat disconnected so couldn't reply sooner!
21:40:34 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23732 enhancement, P5 - low, ---, victor, Patch doesn't apply , Hold rules checker: show matched rules and syspref values to help understand why a hold is possible or not
21:40:42 <fridolin> and cherries to pick ^^
21:40:42 <tuxayo> :D
21:41:02 <alexbuckley> I have a query about a bug report: I wrote to the dev mailing list about Bug 25090 (Moderate OPAC self registrations before a patron account is created) and had some very useful responses. I was wondering if anyone here had thoughts/opinions on how it should be implemented and if it is a feature you're in favour of?
21:41:02 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25090 enhancement, P5 - low, ---, alexbuckley, ASSIGNED , Moderate OPAC self registrations before a patron account is created
21:41:22 <tuxayo> alexbuckley: ok, let's see that on next topic
21:41:40 <alexbuckley> sounds good!
21:42:25 <tuxayo> main is the most often used alternative to master. Trunk indeed fits the theme of trees ^^
21:42:31 <tuxayo> Anyone have experience about using main?
21:42:53 <tuxayo> I recall some phrase usage got confusing but I can't find it :(
21:43:15 <aleisha> we use main internally at catalyst, it was an easy switch for us!
21:43:22 <tuxayo> main looks too vague but I can't make a strong case
21:43:29 <tuxayo> aleisha: ah, cool!
21:43:46 <aleisha> i understand the poetry of trunk with branches :) but it might be a bit too abstract?
21:44:09 <aleisha> we should think about the intention of the branch, and name it according to that
21:44:44 <tuxayo> Trunk still looks less abstract than main for a branch.
21:44:44 <tuxayo> So no confusion with main in the daily usage?
21:48:21 <alexbuckley> tuxayo, no we haven't had any confusion switching to using main, it was a smooth change :)
21:48:28 <tuxayo> great :D
21:48:53 <tuxayo> So no reserves anymore from me about main ^^
21:49:26 <tuxayo> How should be proceed? Have a poll for the name on each meeting slot? Have a poll for the name in the koha-devel list?
21:49:48 <thd> main is the latest convention
21:50:19 <tuxayo> indeed
21:51:31 <tuxayo> *we proceed
21:52:23 <thd> Underlying utilities accept main and importantly will accept previous conventions indefinitely so that old code does not break.
21:52:59 <tuxayo> Oh, so there people using tool that work with only either master or main?
21:53:03 <tuxayo> *there are
21:56:07 <thd> The main branch could be named anything but 'main' now has the reserved special meaning in some utilities.
21:58:09 <tuxayo> Ok so we still have the choice IIUC
21:59:45 <tuxayo> Who to take the task to propose the change in the mailing list? (or another preferred strategy)
22:00:36 <thd> There are many people not here presently very much more expert than I about code repository usage.  I pay attention to the language I see particularly when I have some problem.
22:02:03 <tuxayo> #action tuxayo propose change from master branch in the other meeting slot (EU-AM)
22:02:07 <thd> The question should be put to experts on koha-devel and not popular opinion on koha-list where people may not understand what might break with some choice.
22:02:26 <tuxayo> In koha-devel indeed
22:02:48 <tuxayo> alexbuckley: you had something earlier
22:02:53 <alexbuckley> yep!
22:03:01 <tuxayo> «query about a bug report: I wrote to the dev mailing list about Bug 25090 (Moderate OPAC self registrations before a patron account is created) and had some very useful responses. I was wondering if anyone here had thoughts/opinions on how it should be implemented and if it is a feature you're in favour of?»
22:03:01 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25090 enhancement, P5 - low, ---, alexbuckley, ASSIGNED , Moderate OPAC self registrations before a patron account is created
22:05:21 <tuxayo> alexbuckley: So PatronSelfRegistrationVerifyByEmail would not send the link to the patron but to a librarian to aprove?
22:05:41 <tuxayo> Then the email address of the patron won't be verified right?
22:06:03 <tuxayo> Can that be a problem?
22:06:19 <tuxayo> The advantage of the proposal is that it looks simple to implement
22:07:06 <alexbuckley> that would be a problem for sure. I was thinking a workaround could be if PatronSelfRegistrationVerifyByEmail is enabled a librarian still sees a notification on the staff client home page to moderate. if they approve the registration then an email is sent to the patron to verify their email address
22:07:22 <thd> The issue seems to mask a more complex issue of the need for granular access controls to various resources which may be accessed via the OPAC.
22:07:41 <tuxayo> alexbuckley: ah yes it could work!
22:08:17 <tuxayo> thd: «more complex issue of the need for granular access controls to various resources which may be accessed via the OPAC.»
22:08:17 <tuxayo> How much is there a need for that? Hopefully we can get away with simple solutions like the above one
22:09:16 <tuxayo> Anyone else has feedback for Alex?
22:09:20 <thd> The proposed solution is certainly better than not having a solution which would require more work.
22:09:58 <thd> An improvement for the issue of access control does not conflict with the proposed solution.
22:10:10 <tuxayo> indeed
22:10:13 <alexbuckley> yeah :)
22:10:40 <tuxayo> > not having a solution which would require more work.
22:10:40 <tuxayo> That's the less work actually (nothing!) but it leaves the door open for abuse.
22:11:03 <tuxayo> maybe I missunderstood
22:11:43 <thd> The proposed solution includes a nothing option so status quo can be maintained where desired.
22:12:01 <alexbuckley> yeah I thought that would be very important to add
22:12:32 <tuxayo> Ah olk
22:12:33 <tuxayo> *ok
22:12:39 <alexbuckley> it's basically giving libraries the option of moderating new accounts, like they can with patron change requests of existing accounts
22:13:55 <alexbuckley> nice thanks all, I will continue thinking/working on this feature as proposed and we can look at access controls in a separate patch perhaps :)
22:14:35 <tuxayo> And likely you will need to maintain the patron email verification.
22:14:46 <tuxayo> moving on
22:14:47 <alexbuckley> exactly!
22:14:49 <tuxayo> Are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL 8 on Master.
22:15:54 <tuxayo> If the CI on main/main checks it then it should work. But should it be advertised and tested on the stable branches?
22:16:38 <tuxayo> Or is it just so we don't introduce MariaDBisms and there is no need to support MySQL?
22:17:15 <tuxayo> fridolin: heard about that when you were RM?
22:17:39 <tuxayo> aleisha: alexbuckley: any customer using MySQL?
22:18:40 <fridolin> tuxayo: mmm sorry nope
22:18:59 * thd has long thought that we should not be introducing MySQLisms of any sort but database agnostic is too much work hence the problem with the wiki database choice for what was only a testing instance at the time.
22:19:05 <fridolin> we at biblibre are sticked to MariaDB so we are not really aware of that
22:19:33 <alexbuckley> tuxayo, we tend to use mariadb for I think all our clients
22:20:05 <tuxayo> thd: Once the ORM is everywhere shouldn't we be almost database agnostic without effort?
22:20:33 <tuxayo> We might still have handcrafted queries in some places, I don't know
22:21:38 * fridolin AFK
22:21:49 <tuxayo> ok, I'll asking what should we do
22:21:58 <thd> Almost everyone uses MariaDB.  If something would break on MariaDB we should certainly know but that would more likely be caught elsewhere before Koha.
22:22:33 <tuxayo> #action tuxayo defer «Are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL 8 on main/master.»
22:23:25 <tuxayo> Can we claim ES7 support now? And switch default version for KTD to 7.
22:23:33 <thd> The issue may be more of an issue about whether everything can be backported to whatever is being supported for LTS whether MySQL or MariaDB.
22:23:43 <tuxayo> Omnibus dependencies are done. bugg 25439
22:23:47 <tuxayo> *bug 25439
22:23:47 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25439 critical, P5 - low, ---, koha-bugs, NEW , [Omnibus] Prepare Koha to ElasticSearch 7 - ES7
22:24:45 <tuxayo> thd: We do not commit to support unsupported version of the DBMS IIUC. So someone using LTS will have to keep an up to date OS or just the DBMS
22:25:21 <tuxayo> aleisha: alexbuckley : are you using ES in production?
22:25:40 <tuxayo> shoots, fridolin is AFK
22:25:45 <alexbuckley> we are for at least 2 clients, they are loving it!
22:26:03 <tuxayo> Great! ES 6 I guess
22:26:03 <alexbuckley> hopefully shift some over to ES soon :)
22:27:16 <alexbuckley> yep ES 6
22:28:19 <tuxayo> So until now, if there as security vulnerability in ES, like log4J, ES 6 would be unpatched since it's EOL. So we had this Damocles sword over our head. But not anymore it seems.
22:29:26 <alexbuckley> ahh I see
22:29:26 <tuxayo> There are no more known incompatibilities with ES 7. So should be advertise the support?
22:30:25 <alexbuckley> that sounds good from my perspective
22:31:05 <tuxayo> Ok, I'll ask around before changing that
22:31:25 <tuxayo> #action tuxayo defer «Can we claim ES7 support now?»
22:31:45 <alexbuckley> tuxayo++
22:32:04 <tuxayo> alexbuckley: Also, the latest versions of ES 7 and all of ES 8 aren't libre anymore did you heard about that? (not libre according to Debian, Fedora and the Open Source Initiative)
22:32:43 <thd> At some point, ES 8 license change may be an issue even if the company most backing the OpenSearch fork is not your friend.
22:32:43 <tuxayo> And heard about OpenSearch, the fork made mainly by Amazon.
22:33:08 <alexbuckley> I had not heard about that, so thanks for that tuxayo
22:33:14 <alexbuckley> good to know
22:33:14 <tuxayo> Do you have plans to stay on a libre search engine?
22:33:58 <tuxayo> Indeed, it was a quite dramatic change from ElasticSearch
22:34:30 <tuxayo> thd: yes, it really sucks that it's almost only Amazon that is behind the libre fork...
22:34:53 <alexbuckley> hmm at this stage I'm not sure, we'll need a team discussion here to decide the next steps
22:35:12 <tuxayo> Indeed if you just learned about the thing
22:35:18 <tuxayo> Definitly worth having that in the agenda
22:35:23 <alexbuckley> yeah!
22:35:27 <tuxayo> OpenSearch support is on the way
22:35:42 <tuxayo> Most work has been done to have it usable on KTD and the CI
22:36:18 <tuxayo> So we will see if our tests pass and if basic usage work
22:36:34 <tuxayo> It should, since OpenSearch 1.x is a drop in replacement for ES 7
22:37:00 <tuxayo> Since some time there is OpenSearch 2.x so the project is getting mature.
22:37:07 <tuxayo> Moving on
22:37:13 <tuxayo> #topic Review of coding guidelines
22:37:24 <tuxayo> « SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now. »
22:37:26 <thd> Amazon services have been outcompeting many companies for commercial business using cross subsidies for online computing services but the better way for business may the NextCloud libre way and just forgo the business which was never the core business which Amazon has captured.
22:37:52 <aleisha> #info using and configuring flatpickr needs to be documented
22:38:06 <tuxayo> That's the next point
22:38:51 <tuxayo> «This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now.»
22:38:52 <tuxayo> So it's about updating the guideline to allow SQL in DBIC schema files?
22:39:49 <tuxayo> (The generated clases for the ORM that have a non generated part where we can put custom queries)
22:41:17 <tuxayo> I'll ask in the other meeting slot.
22:41:32 <tuxayo> #action defer coding guideline «SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now.»
22:41:40 <tuxayo> #action tuxayo defer coding guideline «SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now.»
22:41:53 <tuxayo> now for «Update guidelines with the replacement of jQueryUI Datepicker with flatpickr»
22:42:01 <aleisha> ah sorry thanks tuxayo :)
22:42:28 <tuxayo> aleisha: so it's just about replacing the mention of jQueryUI Datepicker and flatpickr?
22:42:33 <tuxayo> It's as simple as that?
22:42:43 <aleisha> yes making sure the coding guidelines reflect how to implement the flatpickr
22:42:51 <aleisha> its very slightly different to using datepicker
22:43:05 <aleisha> i had to learn how to implement it by looking at other cases in the code
22:43:10 <tuxayo> Ah ok, so just a search and replace in the coding guidelines isn't enough ^^"
22:43:11 <thd> Yay but neither works with lynx :(
22:44:41 <tuxayo> aleisha: If you had to recently learn about this, are you up to draft how the guidelines should be updated?
22:45:02 <aleisha> hmmm i dont think id be comfortable doing that because im not sure if what ive figured out is 'best practice'!
22:45:10 <aleisha> whoever first implemented flatpickr would be better placed for that
22:45:51 <tuxayo> It would of course be reread before added to the wiki page
22:46:53 <tuxayo> thd: If someone has the time to make and test patches to improve command line browser support, I guess they could be merged if that doesn't add complexity.
22:47:48 <tuxayo> aleisha: What is the patch that introduced flatpickr?
22:47:56 <tuxayo> To find who to reach for documenting the usage
22:47:58 <aleisha> im not sure i'd have to search for it
22:48:02 <aleisha> i'll see if i can find
22:48:12 <tuxayo> can't find it
22:48:18 <thd> console browsing is dying with all the JavaScript and screen scraping is more difficult :(
22:48:56 <aleisha> bug 29239
22:48:56 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29239 enhancement, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] Replace jQueryUI's timepicker with flatpickr
22:49:47 <tuxayo> aleisha++
22:50:57 <tuxayo> I'll call for people who know about flatpickr usage
22:51:30 <tuxayo> #action tuxayo defer QA guidelines: «Update guidelines with the replacement of jQueryUI Datepicker with flatpickr - introduced in bug 29239»
22:51:31 <aleisha> thanks tuxayo !
22:51:53 <tuxayo> #topic Set time of next meeting
22:52:15 <tuxayo> Next meeting in the time slot, same time the 29th?
22:52:24 <tuxayo> *this time slot
22:53:39 <tuxayo> #info Next meeting: 14 September 2022, 14 UTC
22:53:52 <tuxayo> This if for EU-Americas timeslot
22:54:02 <tuxayo> And for Oceania-Americas:
22:54:22 <tuxayo> #info Next Oceania-Americas meeting: 29 September 2022, 21 UTC
22:54:30 <tuxayo> #endmeeting