21:09:54 <davidnind[m]> #startmeeting Development IRC meeting 3 August 2022
21:09:54 <huginn`> Meeting started Wed Aug 3 21:09:54 2022 UTC. The chair is davidnind[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:09:54 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:09:54 <huginn`> The meeting name has been set to 'development_irc_meeting_3_august_2022'
21:09:58 <aleisha> kia ora!
21:10:18 <davidnind[m]> #topic Introductions
21:10:36 <davidnind[m]> #info David Nind, New Zealand
21:10:45 <alexbuckley> #info Alex Buckley, Catalyst IT NZ
21:10:47 <aleisha> #info Aleisha Amohia, Catalyst IT NZ
21:10:53 <thd> #info Thomas Dukleth, Agogme, New York City
21:10:56 <rangi[m]> #info Chris Cormack, Catalyst IT NZ
21:11:08 <davidnind[m]> #chair tuxayo
21:11:09 <huginn`> Current chairs: davidnind[m] tuxayo
21:13:53 <davidnind[m]> I'll give it another couple of minutes, not sure where everyone is today...
21:14:03 <cait> here
21:14:04 <rangi[m]> i think katrin is on the way
21:14:11 <rangi[m]> hehe see
21:15:14 <cait> what a coincidence, noone told me to come here
21:15:22 <rangi[m]> heh
21:15:43 <davidnind[m]> #topic Announcements
21:16:09 <davidnind[m]> Any announcements/events anyone is aware of?
21:16:24 <rangi[m]> not from me
21:16:52 <cait> oh did we info already?
21:17:02 <cait> #info Katrin Fischer, BSZ, Germany
21:17:02 <rangi[m]> we did
21:17:26 <davidnind[m]> #info Closing date for registrations for KohaCon22 is 31 August 2022
21:17:36 <davidnind[m]> #link https://koha-us.org/events/conferences/kohacon22/
21:18:16 <davidnind[m]> #info Closing date for KohaCon23 proposals is 6 September 2022 (none yet) https://wiki.koha-community.org/wiki/KohaCon23_Proposals
21:18:57 <davidnind[m]> I'll send out a reminder about KohaCon23 proposals this week
21:19:00 <davidnind[m]> #topic Update from the Release manager (22.05)
21:20:06 <rangi[m]> i need to convince frido to propose tahiti for kohacon23 :)
21:20:18 <davidnind[m]> +1
21:20:54 <davidnind[m]> Not sure whether tcohen is around, so will skip
21:21:18 <rangi[m]> maybe they all turned up yesterday like I did when i read the time wrong :)
21:22:32 <cait> I think we messed up the calendar entry a little
21:22:37 <cait> so some migh tnot have seen it
21:22:49 <davidnind[m]> oops - that is probably my fault...
21:23:15 <cait> no, I think we missed that the script didn't work right
21:23:26 <cait> not your fault at all
21:24:13 <davidnind[m]> I think we should carry on then, anyone got some radical proposals? 🙂
21:24:20 <davidnind[m]> #topic Updates from the Release Maintainers
21:24:42 <cait> ... I am trying, but too tired to come up with something
21:25:07 <davidnind[m]> Are any of the release maintainers around, otherwise will skip
21:26:30 <davidnind[m]> #info Maintenance releases were released for all supported versions, was also a security release as well
21:27:08 <davidnind[m]> #topic Updates from the QA team
21:28:03 <cait> oh sorry
21:28:21 <cait> not much new, just the usual: numbers in the queues are a bit high, but we are working on it an dther ehas been movement
21:28:30 <cait> we had some big patches pushed
21:28:44 <cait> item bundles, curbside pickups, patrons being able to cancel waiting holds
21:29:10 <rangi[m]> oh cool
21:29:12 <davidnind[m]> nice!
21:29:23 <cait> summer holidays on this half of the globe and Joubu leaving very soon now will mean less QA'ers for quite a while
21:29:36 <cait> hope the remaining can step up their game a bit (including me) :)
21:29:51 <cait> join the QA team, we have cookies!
21:30:01 <cait> (ok... the cookies are jus software cookies... but join anyway!)
21:30:36 <davidnind[m]> 🍪
21:30:45 <cait> that's it from me, any questions? :)
21:31:24 <davidnind[m]> thanks cait!
21:31:47 <rangi[m]> you should make a proposal that people have to send the qa team cookies
21:31:51 <rangi[m]> ill vote for it
21:32:49 <cait> :)
21:32:49 <davidnind[m]> #topic Status of roadmap projects
21:33:56 <thd> Wiki now restoring in pg_restore with no errors by using Debian 8 for restore and DB migration.
21:34:06 <rangi[m]> cool
21:34:11 <davidnind[m]> No release manager, so deferred unless anyone has an update on specific items https://annuel.framapad.org/p/koha_22.11_roadmap
21:34:28 <cait> thd: is end of August still the goal?
21:34:58 <thd> The further from Debian the more errors reported by pg_restore.
21:35:15 <thd> We might start migrating next week.
21:35:42 <cait> awesome
21:35:52 <davidnind[m]> thd++
21:36:00 <thd> The pg_restore errors were probably false warnings but were scary.
21:36:04 <cait> thd++
21:36:24 <thd> https://koha-mw-pg-test02.agogme.com/wiki/Main_Page Postgres restore in Debian 8 pg_restore no errors.
21:36:24 <thd> https://koha-mw-my-test02.agogme.com/wiki/Main_Page MySQL migration in Debian 8
21:37:20 <thd> https://koha-mw-my-test00-upgr.agogme.com/wiki/Main_Page Upgraded to LTS Debian 10 but not currently built from error free pg_restore.
21:37:55 <davidnind[m]> Sandbox available for ERM module using Vue - https://staff-erm.sandboxes.biblibre.eu/cgi-bin/koha/erm/erm.pl
21:38:07 <thd> Debian 10 was easy. Debian 8 was tricky.
21:38:27 <tuxayo> aaaaah there is a meeting!!!!
21:38:29 <thd> tcohen found a good Docker container to use.
21:38:41 <cait> you are just in time
21:38:51 <thd> https://github.com/CanastaWiki/Canasta/blob/master/Dockerfile
21:38:55 <rangi[m]> ohh the ERM module is looking good
21:39:02 <davidnind[m]> plus a nice sneak preview https://bywatersolutions.com/education/monday-minutes-sneak-peek-erm
21:39:06 <tuxayo> #info Victor Grousset, Tuxayo IT, France
21:39:53 <cait> Joubu said he pushed some more updates/enh just today
21:39:58 <cait> so might be worth haveing another look
21:40:00 <cait> (ERM)
21:40:12 <davidnind[m]> excellent!
21:40:12 <wahanui> darn tootin' it is.
21:41:30 <davidnind[m]> I haven't had a chance to look at the staff interface redesign recently, but I think good progress is being made - some recent discussion on the mailing list
21:41:49 <cait> there also is a sandbox now
21:41:59 <cait> dedicated, so everyone can have a look
21:42:01 <davidnind[m]> cool
21:42:08 <aleisha> it looks very cool!
21:42:36 <alexbuckley> yes very impressive :)
21:42:43 <aleisha> we had some thoughts about the icons in the search bar (i.e. search patrons, check out etc) being a bit ambiguous. it would be cool if the text changed when you hovered on them, rather than just having alt text, otherwise you're required to click
21:42:54 <cait> i think the search bar is the most dicussed feature
21:43:02 <aleisha> understandably
21:43:06 <cait> there have been accessibility concerns
21:43:20 <tuxayo> #info dedicated sandbox to view the staff interface redesign: https://sandboxes.biblibre.eu/
21:43:21 <davidnind[m]> #link https://staff-bug30952.sandboxes.biblibre.eu/
21:43:26 <cait> and I think it might clash with soem of our 'sysprefed' features that go there
21:43:36 <cait> so that is probably the area that needs the most work an dmaybe some ideas still
21:43:39 <aleisha> true true
21:45:55 <cait> move on?
21:45:58 <cait> so quiet :)
21:46:02 <davidnind[m]> #info Thanks for those reviewing the staff interface redesign, please continue to provide feedback on bug 30952 and can preview at https://staff-bug30952.sandboxes.biblibre.eu/
21:46:02 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30952 enhancement, P5 - low, ---, julian.maurice, ASSIGNED , New interface for staff client
21:46:13 <davidnind[m]> #topic Actions from last meeting
21:47:15 <davidnind[m]> Extended support/LTS release is the on the agenda for voting, postpone the other items?
21:48:10 <cait> ok for me
21:48:20 <davidnind[m]> #action liliputech (deferred from previous meeting) discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.
21:48:24 <tuxayo> yes
21:48:35 <davidnind[m]> tuxayo?
21:48:35 <wahanui> tuxayo is on a role
21:48:50 <tuxayo> «postpone the other items?» it was about that ^^"
21:48:51 <davidnind[m]> sorry, meant any update on your action point?
21:48:55 <tuxayo> ah
21:49:13 <tuxayo> i moved it to the coding guidelines section of the agenda
21:49:21 <tuxayo> (I just did that ^^")
21:49:26 <tuxayo> So we will get to it
21:49:37 <davidnind[m]> thanks!
21:49:50 <davidnind[m]> #topic General development discussion (trends, ideas, ...)
21:50:12 <davidnind[m]> #topic Vote on LTS version
21:50:31 <davidnind[m]> Who would like to summarise the proposal?
21:50:47 <davidnind[m]> Then we can vote, if we think there are enough people here...
21:51:24 <cait> it's a little late here, but I can try
21:51:34 <tuxayo> I can get stuff from the tickets
21:51:39 <davidnind[m]> thanks cait
21:51:43 <tuxayo> https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31008#c1
21:51:43 <huginn`> 04Bug 31008: new feature, P5 - low, ---, koha-bugs, NEW , Long Term Support (LTS) version of Koha
21:51:52 <cait> we have worked out some models for how an LTS could work
21:52:02 <cait> the main differences are in overlap time and maintainers required
21:52:08 <cait> could someone post the link?
21:52:23 <tuxayo> #info graph of LTS proposal https://lite.framacalc.org/29o8a7mlwc-9v57
21:52:32 <cait> we ended up mostly agreeing that we will need 4 rmaints, to ensure that the normal versions are ther elong enough, overlap is long enough etc.
21:52:57 <rangi[m]> yeah
21:53:03 <cait> so we should decide what we want - each mode is summarized on the right of the example
21:53:11 <cait> mode = model
21:53:37 <cait> and then the next question would be to name the first (second if you count 19.11) LTS
21:53:46 <cait> I think at the moment it's only a quesiton between 22.05 and 22.11
21:54:17 <cait> the older ones are probably too late
21:54:26 <cait> tuxayo: anything to add?
21:55:27 <tuxayo> Mandate = security + things that are broken (APIs (external), dependencies (such as Elasticsearch), etc) + essential backports only once past oldoldstable
21:55:37 <tuxayo> Irregular release - only when something is needed once past oldoldstable
21:56:17 <rangi[m]> i think irregular release makes sense to me
21:56:24 <rangi[m]> for an lts
21:57:05 <tuxayo> With the last info, most of the proposal should be here and in the table link
21:57:11 <davidnind[m]> I'm just formatting the 2 questions for voting - hope I get it right!
21:57:47 <cait> thx davidnind[m]
21:58:04 <davidnind[m]> #startvote Which Koha version will be the first LTS version? 22.05, 22.11
21:58:04 <huginn`> Begin voting on: Which Koha version will be the first LTS version? Valid vote options are 22, 05, 22, 11.
21:58:04 <huginn`> Vote using '#vote OPTION'. Only your last vote counts.
21:58:06 <tuxayo> > i think irregular release makes sense to me
21:58:06 <tuxayo> That's what makes it doable to find a 4th RMaint otherwise it would be too much of a commitment for limited value.
21:58:11 <cait> the idea is to ensure we have a version that can be used by people who don't manage to update that often and still have security patches
21:58:34 <cait> i think sticking ot scheudle might be nice as long as you still have bug fixes... but when it dwindles you can skip
21:58:48 <cait> up to the rmaint then in the later phase of maintenance
21:58:57 <davidnind[m]> argh, formatted wrong will try again..
21:59:02 <davidnind[m]> #endvote
21:59:02 <huginn`> Voted on "Which Koha version will be the first LTS version?" Results are
21:59:28 <davidnind[m]> #startvote Which Koha version will be the first LTS version? 22-05, 22-11
21:59:28 <huginn`> Begin voting on: Which Koha version will be the first LTS version? Valid vote options are 22-05, 22-11.
21:59:28 <huginn`> Vote using '#vote OPTION'. Only your last vote counts.
22:00:01 <tuxayo> #vote abstain
22:00:01 <huginn`> tuxayo: abstain is not a valid option. Valid options are 22-05, 22-11.
22:00:02 <tuxayo> I have no idea what is best
22:00:06 <tuxayo> i know!
22:00:10 <davidnind[m]> #vote 22-11
22:00:23 <rangi[m]> #vote 22-11
22:00:29 <thd> #vote 22-11
22:00:49 <cait> #vote 22-11
22:00:55 <cait> I'll just vote what everyone else voted :P
22:01:00 <alexbuckley> #vote 22-11
22:01:07 <fridolin> #info Fridolin Somers, Biblibre, Tahiti
22:01:11 <thd> tuxayo: the latter option gives more time to approach the issue.
22:01:16 <fridolin> #vote 22-11
22:01:50 <fridolin> sorry, i was too focused did not trick time
22:01:51 <tuxayo> Is there any difference on which of XX.05 or XX.11 tends to be most stable when reaching oldstable?
22:01:53 <fridolin> trask
22:01:55 <fridolin> track
22:02:00 <cait> yeah, I'd have preferred 22-05 a little, but it's ok as long as we get the ball rolling :)
22:02:17 <cait> tuxayo: not really... depends on a lot of things
22:02:22 <tuxayo> ok
22:02:43 <fridolin> we use xx-11 at biblibre but it is hazard
22:02:55 <fridolin> from first version 16.11 i bet
22:03:11 <rangi[m]> i picked 22.11 cos we just have more time to get sorted out :)
22:03:20 <thd> :)
22:03:21 <tuxayo> fridolin: I don't think so, it's because you are on the north hemisphere and libraries prefer major upgrades in summer. Isn't it that?
22:03:32 <fridolin> ahhh maybe
22:03:35 <cait> yeah, it got too late for 22.05 probably
22:03:46 <davidnind[m]> you have one minute to cast/change your vote
22:03:56 <fridolin> using xx.05 woould be too fresh for july in deed
22:04:01 <cait> I stand with my vote :)
22:04:11 <tuxayo> But for LTS the hemisphere thing doesn't change anything if we choose to have a year of overlap (4 RMaint constantly)
22:05:03 <fridolin> we just need good brain hemispheres ^^
22:05:12 <davidnind[m]> #endvote
22:05:12 <huginn`> Voted on "Which Koha version will be the first LTS version?" Results are
22:05:12 <huginn`> 22-11 (6): cait, rangi[m], fridolin, alexbuckley, davidnind[m], thd
22:05:21 <tuxayo> 🎉
22:05:29 <cait> I love decisions
22:05:32 <cait> next! :)
22:05:39 <davidnind[m]> #agreed The first LTS/extended support version will be 22.11
22:05:47 <davidnind[m]> not sure how to phrase the next question - can anyone help
22:05:50 <tuxayo> So how many RMaint?
22:06:30 <cait> I think maybe... sec
22:07:15 <cait> 1-3-1, 1.5-3-1, 1.5-3.5-1.5
22:07:29 <tuxayo> 👀
22:07:39 <fridolin> !bingo
22:07:40 <cait> that's regular regular releases, LTS release, overlap of LTS
22:07:58 <cait> or...1 2 and 3 from the calc document
22:08:02 <cait> but that might go away some day
22:08:13 <tuxayo> > but that might go away some day
22:08:13 <tuxayo> indeed
22:08:50 <tuxayo> Ah I get it
22:10:06 <cait> I lean towards the last at the moment
22:10:23 <cait> every 4th release is an LTS
22:10:37 <tuxayo> 1-3-1, 1.5-3-1, 1.5-3.5-1.5
22:10:37 <tuxayo> length of support for regular releases - length of support for LTS - duration of LTS overlap(the 1st 6months are when the release is "stable" so not stable enough for migration, subtract 6mo to get the safe overlap)
22:10:40 <cait> and you have 1.5 overlap.. which should work with all seasons
22:11:09 <cait> do people have an idea what they want?
22:11:48 <tuxayo> certainly not 1-3-1 because it's not possible to upgrade every year and choose when to do so. You are forced
22:12:00 <thd> 4 years is not in the spreadsheet is it?
22:12:27 <tuxayo> 1.5-3.5-1.5 (the last) works better no matter when they want to upgrade
22:13:05 <tuxayo> > 4 years is not in the spreadsheet is it?
22:13:05 <tuxayo> Was a 4years proposal made?
22:13:11 <thd> sorry 4 releases is not in the spreadsheet.
22:13:35 <cait> I meant evey 4th is an lts
22:13:43 <cait> what do you mean by 4 releases?
22:13:57 <cait> we'll always maintain 4 parallel
22:14:02 <thd> Ah ok
22:14:06 <tuxayo> 1.5-3-1 and 1.5-3.5-1.5 (proposal 2 and 3) have 4 un parallel
22:14:48 <davidnind[m]> So question would be: Use every 4th version as the LTS/extended support version of Koha (see https://lite.framacalc.org/29o8a7mlwc-9v57 for details)? Yes, No
22:15:19 <tuxayo> That doesn't discriminate between the 3 proposals
22:15:43 <tuxayo> They all work with LTS being one of every 4th release
22:16:06 <cait> yes
22:16:15 <cait> the difference is the overlap time
22:16:26 <cait> in general the mainenance times and such
22:16:30 * fridolin goes to lunch will read the logs
22:16:47 <cait> I know i prefer the 3rd
22:16:58 <cait> tuxayo persuaded me
22:17:12 <cait> and it#s the same amount of maintainers, only difference is that it's always 4 people to the second model
22:17:13 <tuxayo> So hard to phrase concisely the proposals
22:17:21 <cait> it's why I needed to draw it
22:17:30 <davidnind[m]> We have 3 options - if someone can give me a short description for each one I'll run the vote and then end the meeting
22:18:10 <cait> hm I tried :)
22:18:17 <davidnind[m]> How about: What maintenance model will we use for LTS/extended support version of Koha? Option 1, Option 2, Option 3 (every 4th version)
22:18:31 <cait> The short description is either 1-3-1, 1.5-3-1, 1.5-3.5-1.5
22:18:36 <cait> or what is written next to the tables
22:18:49 <cait> for model 3: 4 RMaints
22:18:49 <cait> 1.5 years maintenance for regular releases
22:18:49 <cait> 3.5 years maintenance for LTS release
22:18:49 <cait> 1.5 year overlap
22:19:18 <cait> all are every 4th, so I think we can leave that off :)
22:19:27 <tuxayo> Format of the proposals: N1-N2-N3
22:19:27 <tuxayo> N1: length of support for regular releases - N2: length of support for LTS - N3: duration of LTS overlap (including the first 6 months of lifecycle that aren't well suited for upgrade)
22:19:34 <cait> but yes, 1 2 or 3 migh work best
22:20:13 <tuxayo> 3 RMaints vs 3.75 RMaints vs 4 RMaints
22:21:33 <cait> maybe we should just decide between 2 and 3 to make it easier
22:21:47 <cait> I tihnk people might agree that having to update every year of they are not on LTS is not enough time
22:22:15 <thd> ++
22:22:27 <tuxayo> They can't even do when they want
22:22:49 <cait> and the only differnce between 2 and 3 is that we have no cycle where we only need 3 rmaints
22:22:53 <cait> we always need 4
22:22:53 <tuxayo> 2 RMaint for regular releases gives a constraint to do that in winter or summer (depending of when we start)
22:22:57 <cait> but we get 1.5 years overlap
22:23:10 <cait> so... I think maybe we just vote if 3 is ok :)
22:23:18 <tuxayo> ^^
22:23:35 <cait> This would be:
22:23:49 <cait> 4 RMaints constantly
22:23:49 <cait> 1.5 years maintenance for regular releases
22:23:49 <cait> 3.5 years maintenance for LTS release
22:23:49 <cait> 1.5 year overlap between LTS releases
22:24:18 <davidnind[m]> Nearly there...
22:24:24 <cait> ok
22:24:39 <tuxayo> proposal 1: keep 3 RMaints and shorten support of regular releases
22:24:39 <tuxayo> proposal 2: 4 RMaints (1 out of every 4 cycles, only 3 RMaints) and same support of regular releases. 6 months of effective overlap between LTS
22:24:39 <tuxayo> proposal 3: 4 RMaints always and same support of regular releases. 12 months of effective overlap between LTS
22:24:47 <tuxayo> Can't make it much sorter
22:25:18 <davidnind[m]> #Info Option 3 for voting = 4 RMaints constantly, 1.5 years maintenance for regular releases, 3.5 years maintenance for LTS release, 1.5 year overlap between LTS releases
22:25:38 <davidnind[m]> #vote Use option 3 as maintenance model for LTS/extended support version of Koha (see https://lite.framacalc.org/29o8a7mlwc-9v57 for details)? Yes, No
22:25:46 <davidnind[m]> #vote Yes
22:25:52 <tuxayo> #vote yes
22:25:59 <cait> #vote yes
22:26:01 <rangi[m]> #vote Yes
22:26:07 <thd> # vote Yes
22:26:13 <thd> #vote Yes
22:26:26 <davidnind[m]> one minute to go..
22:27:14 <davidnind[m]> #endvote
22:27:18 <alexbuckley> #vote yes
22:28:24 <tuxayo> It was #startvote !
22:28:26 <davidnind[m]> #agreed To use option 3 (see details in comments) as the maintenance model for the LTS/extended support version of Koha (see https://lite.framacalc.org/29o8a7mlwc-9v57 for details)
22:28:35 <tuxayo> anyway we can manually do it
22:28:47 <davidnind[m]> I won't rerun - it was unanimous!
22:28:53 <davidnind[m]> #info All other agenda items deferred to the next meeting
22:28:57 <cait> yes and it's soo olate :)
22:28:58 <davidnind[m]> #topic Set time of next meeting
22:29:04 <cait> here at least
22:29:17 <tuxayo> same time? (for the meeting in 4 weeks)
22:29:35 <tuxayo> The one it two week has been decided 2 weeks ago, let me find it
22:30:05 <tuxayo> #info see bug 31008 for other details about how the LTS should be handled (scope of what to include, regularity of releases)
22:30:05 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31008 new feature, P5 - low, ---, koha-bugs, NEW , Long Term Support (LTS) version of Koha
22:30:52 <tuxayo> #info Next meeting: 17 August 2022, 14 UTC
22:31:10 <davidnind[m]> thanks tixayo
22:31:17 <davidnind[m]> tuxayo even
22:31:21 <tuxayo> For meeting in 4 weeks the 31th then?
22:31:22 <davidnind[m]> #endmeeting