15:00:52 <tuxayo> #startmeeting Development IRC meeting 5 January 2022
15:00:52 <huginn`> Meeting started Wed Jan  5 15:00:52 2022 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:52 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:52 <huginn`> The meeting name has been set to 'development_irc_meeting_5_january_2022'
15:01:10 <tuxayo> #topic Introductions
15:01:28 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_5_January_2022 Today's agenda
15:01:37 <cait1> #info Katrin Fischer, BSZ, Germany
15:01:52 <tuxayo> #info Victor Grousset, Tuxayo GmbH, France
15:01:57 <fridolin> #info Fridolin Somers, Biblibre, France
15:02:09 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
15:02:21 <Joubu> #info Jonathan Druart
15:02:35 <AndrewFH> #info Andrew Fuerste-Henry, ByWater Solutions
15:02:37 <thd> #info Thomas Dukleth, Agogme, New York City [major COVID-19 centre take care]
15:03:28 <kidclamp> #info, Nick Clemens, ByWater Solutions
15:03:38 <cait1> happy new year all :)
15:03:56 <tuxayo> #topic Announcements
15:04:08 <tuxayo> Any announcement that doesn't fit another topic?
15:04:15 <tuxayo> happy new year indeed!
15:04:16 <Joubu> #info Enjoy 2022!
15:04:39 * thd after a period of extra work in a retail environment has tested positive for the virus of the day despite vaccinations, extra ventilation, barriers, and 95% mask filtering.  I may be past my infectious period but please keep a safe distance.  Remember a virus is merely a bundle of information with replication instructions.
15:05:32 <tuxayo> thd: best wishes for remission (if that's the right word). Thankfully, nothing to be worried over IRC :)
15:06:13 <tuxayo> #topic Update from the Release manager (21.11)
15:06:15 <tuxayo> fridolin?
15:06:15 <wahanui> fridolin is, like, indeed, but maybe not on Rmain 18.11
15:06:23 <tuxayo> lol
15:06:43 <cait1> wahanui forget fridolin
15:06:43 <wahanui> cait1: I forgot fridolin
15:06:44 <koha-jenkins> Project Koha_21.05_U21 build #63: SUCCESS in 56 min: https://jenkins.koha-community.org/job/Koha_21.05_U21/63/
15:06:47 <tuxayo> :o
15:06:51 <cait1> wahanui: fridolin is RM for 22.05
15:06:51 <wahanui> OK, cait1.
15:07:01 <cait1> just fixing...
15:07:04 <fridolin> yey
15:07:24 <fridolin> I've starting again after a few hollidays
15:07:35 <thd> Seems mild so far but was hoping that symptoms were a less troublesome infection with more decades of experience for management.
15:07:35 <fridolin> Kids have 4 weeks here
15:07:58 <tuxayo> It's summer after all
15:08:06 <fridolin> indeed :)
15:08:24 <fridolin> Nothing special for RM
15:08:53 <tuxayo> #topic  Updates from the Release Maintainers
15:08:53 <nugged> #info Andrew Nugged, National Library of Finland, HELSINKI
15:09:18 <tuxayo> As koha-jenkins just said, 21.05 builds ^^
15:09:58 <tuxayo> Nothing unusual for the 1st release of 20.05 this cycle
15:10:24 <AndrewFH> yeah, nothing to report on 21.05 at this time
15:11:40 <AndrewFH> Oh! except we're off of the usual point release numbering. Kyle did two releases in November 2021, so December was 21.05.08 rather than the standard 21.05.07. just FYI
15:12:12 <tuxayo> Nothing to worry about. Urgent security releases do that.
15:12:37 <AndrewFH> Yeah, I didn't see how it would cause trouble aside from mild confusion :)
15:12:57 <fridolin> this month 22 is on a weekend, we may release on next monday
15:13:17 <cait1> rmaints++
15:13:24 <tuxayo> Right! Last month we forgot to coordinate to confirm the release date ^^"
15:13:58 <tuxayo> moving on?
15:14:57 <tuxayo> #topic Status of roadmap projects
15:16:35 <tuxayo> Anything on something?
15:16:39 <fridolin> it has been calm
15:16:46 <thd> Fixed some bugs in rsync copying of binary and other non-version control files for wiki.  I should be able to restart commits to version control again soon.
15:16:54 <Joubu> don't worry fridolin, I am back :D
15:17:03 <thd> s/wiki/wiki migration/
15:17:05 <fridolin> cool B)
15:17:56 <thd> I will not be running down my health point with all night sessions at least until I am clear from the virus.
15:18:49 <tuxayo> wise decision, even without sickness
15:18:54 <tuxayo> #topic Actions from last meeting
15:19:06 <tuxayo> > fridolin asks general ML about the discussed KohaCon22 bidding changes and announcement them at the beginning of January if there was not opposition.
15:19:15 <fridolin> done
15:19:32 <fridolin> there have been a few answers that agree
15:20:26 <cait1> i was the one who put that up actually
15:20:27 <cait1> the suggestions
15:20:33 <cait1> and there was a misunderstanding actually .)
15:20:52 <fridolin> I also have contacted Stockholm University because they made a candidature in KohaCon19
15:20:57 <cait1> I didn't mean to make the past continents valid again, but to give people the chance to host an online only meeting without losing the chance to host an in person conf the next 3 years
15:21:09 <fridolin> but they decline for 2022
15:21:12 <cait1> i think some possible candidates might be holding back
15:21:18 <cait1> becuse they hope to have a "real one"
15:21:38 <cait1> that is close by, like all the european ones
15:21:59 <fridolin> i like the idea
15:22:37 <tuxayo> cait1: I don't remember if it was misunderstood of it inspired a similar proposal on the last meeting.
15:22:42 <tuxayo> Definitely related though
15:22:42 <fridolin> saying full-online can always propose is the same no ? th
15:22:56 <cait1> I think it probably got lost in translation
15:23:06 <cait1> I had to miss the last meeting, so couldn't explain it
15:23:29 <cait1> i think yoru email only made past ones 'valid'
15:23:37 <cait1> not talking about not losing the continents psot for the 23 one
15:23:41 <cait1> not the same
15:23:47 <fridolin> ah i get it
15:24:00 <fridolin> ok to add this phrase, better be explicit
15:24:42 <fridolin> i hope we will have a proposal ...
15:24:55 <cait1> yeah me too
15:25:17 <cait1> the suggestions came from trying to attract more bids really
15:25:40 <cait1> because we are running out of time... but an online conf might be something people might take on
15:25:43 <tuxayo> +1 it's better lossen up further more the rules with that.
15:26:05 <cait1> oleonard: kidclamp: could you help phrasing? I failed already once :)
15:26:52 <thd> Do we have a scheme of preference for both in person with online component as opposed to online only?
15:26:58 <cait1> Maybe: If an online only conference is proposed, the same continent will still be possible to hold KohaCon in the folling year not being removed from rotation?
15:27:11 <cait1> we have asked for bids for either hybrid or online only
15:27:23 <cait1> a sole in-person is not an option for this year
15:27:38 <cait1> if we get more than one bid, we can hold a vote and people can factor in their preferences
15:27:51 <kidclamp> An online conference will not make a continent ineligible for future in-person conferences
15:29:03 <cait1> oh or that
15:29:19 <fridolin> So action = I will make announcement and edit wiki page
15:29:25 <cait1> maybe we should clarify timeframe?
15:29:31 <cait1> thx frido
15:29:42 <cait1> ineligible (forever... bidding next year)
15:30:15 <tuxayo> What was the chances about the timeframe again?
15:30:51 <oleonard> "An online conference bid will not make a continent ineligible for hosting an in-person conference the following year"
15:30:58 <cait1> +1
15:31:07 <cait1> tuxayo: hm?
15:31:17 <tuxayo> *changes
15:31:17 <tuxayo> oops
15:31:31 <cait1> i think we said end of feb? or middle of feb?
15:31:46 <fridolin> wiki page says we add 4 weeks
15:32:00 <cait1> can you share the link?
15:32:00 <fridolin> so end of feb
15:32:07 <fridolin> https://wiki.koha-community.org/wiki/Processes_for_KohaCons#Continent_rotation
15:32:21 <fridolin> If there is no bid after the deadline that meets the rules, there will  be a 4 weeks extension to the deadline. If there is still no bid after  the extension period, exceptions from the rules are possible.
15:32:38 <cait1> ah, i was not aware of that passus, thx!
15:32:55 <cait1> i think w don't hae to stick strictly ot that as we are already so late this year
15:33:07 <cait1> I mean we can change the rules/exceptions right away with the extension
15:33:40 <cait1> ... and pester every big library we know about hosting KohaCon
15:34:28 <fridolin> ++
15:34:43 <fridolin> but OK with end of Feb ?
15:35:06 <fridolin> not sure we will have several proposals to vote for
15:35:48 <tuxayo> # actionDRAFT fridolin announces timeframe extension (end of feb) and for this one allow proposals outside eligible continents, keeping priority to actual ones
15:35:58 <tuxayo> ##actionDRAFT fridolin chances wiki page with "An online conference bid will not make a continent ineligible for hosting an in-person conference the following year". And announcement de change
15:36:09 <cait1> having one would be good
15:36:10 <cait1> :)
15:36:15 <tuxayo> yes ^^
15:36:23 <tuxayo> ok for end of february
15:36:27 <cait1> yes
15:36:37 <cait1> i think it might take a little to dicsuss in institutions, so should not be too short
15:36:54 <tuxayo> So let's write the action and move on
15:36:57 <cait1> yep
15:37:03 <cait1> you already did :)
15:37:06 <tuxayo> #action fridolin announces timeframe extension (end of feb) and for this one allow proposals outside eligible continents, keeping priority to actual ones
15:37:12 <tuxayo> #action fridolin chances wiki page with "An online conference bid will not make a continent ineligible for hosting an in-person conference the following year". And announcement de change
15:37:22 <tuxayo> s/chances/changes
15:37:29 <tuxayo> >_<
15:37:44 <tuxayo> > fridolin bring back the topic of keeping or not marcflavour a param for: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29652#c1
15:37:44 <huginn`> 04Bug 29652: enhancement, P5 - low, ---, koha-bugs, NEW , Move Koha::Biblio->get_marc_* to Koha::Biblio::Metadata
15:38:23 <fridolin> this is just to share the decision, any reason to keep this ?
15:38:32 <fridolin> looks like a very old code
15:39:18 <fridolin> without answers i'll remove it
15:39:19 <cait1> it hink we need it still
15:39:35 <cait1> in some form
15:39:42 <cait1> there are some display things that also check for marcflavor
15:39:46 <cait1> we are not always delaing with the records
15:40:09 <cait1> oh, i think i misunderstood... we arenot taking about removing the pref...right?
15:40:18 <fridolin> noooo
15:40:26 <cait1> ok, withdraw! :)
15:40:58 <Joubu> fridolin: yes, remove it
15:41:07 <fridolin> oki thanks
15:41:19 <cait1> what Joubu says
15:42:37 <fridolin> action = new bug report to remove it, Bug 27268 dependency
15:42:37 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27268 enhancement, P5 - low, ---, aleisha, Pushed to master , Move C4::Biblio::GetMarcNotes to Koha namespace
15:44:09 <fridolin> tuxayo:  ?
15:44:17 <tuxayo> #action fridolin open ticket about removing marcflavour as a param in context of bug 29652. Add it a dependency of bug 27268.
15:44:17 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29652 enhancement, P5 - low, ---, koha-bugs, NEW , Move Koha::Biblio->get_marc_* to Koha::Biblio::Metadata
15:44:35 <tuxayo> > tuxayo inform mtj about the minor release (and no big deal if packages come after, no hurry for this one)
15:44:43 <tuxayo> Was done, mtj++ thanks for the packages
15:44:50 <tuxayo> > fridolin open a ticket for qa-test-tools about using _() or __() in the right context. .tt files vs .js files
15:44:57 <fridolin> done
15:45:10 <fridolin> we can discuss details in this ticket
15:45:13 <tuxayo> #link https://gitlab.com/koha-community/qa-test-tools/-/issues/55
15:45:22 <tuxayo> > tuxayo calls for volunteers to work on ES 7 support in the koha-devel mailing list
15:45:23 <tuxayo> dono
15:45:27 <tuxayo> *done
15:45:31 <fridolin> https://gitlab.com/koha-community/qa-test-tools/-/issues/55
15:46:16 <fridolin> your call have been eard at Biblibre, we plan to put some dev workers on it
15:46:42 <tuxayo> biblibre++
15:47:59 <tuxayo> For anyone interested in submitting patches or testing/reviewing , see bug 25439.
15:47:59 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25439 enhancement, P5 - low, ---, koha-bugs, NEW , [Omnibus] Prepare Koha to ElasticSearch 7 - ES7
15:47:59 <tuxayo> Some look like trivial patches about default values
15:48:17 <tuxayo> #topic General development discussion (trends, ideas, ...)
15:48:41 <cait1> biblibre++
15:48:50 <fridolin> I'd like to point Bug 29672
15:48:50 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29672 enhancement, P5 - low, ---, julian.maurice, Needs Signoff , Increase performance of Koha::Plugins->call
15:49:09 <fridolin> performance of plugins is really important, like for intranet_js hook ie
15:49:38 <fridolin> Joubu: could you continue on it please ?
15:50:07 <Joubu> continue what?
15:50:23 <fridolin> Bug 29672
15:50:24 <Joubu> add a reply, a follow-up? Wait for QA?
15:50:31 <fridolin> discuss with how to do it good
15:50:47 <Joubu> ok, will have a look at it again
15:50:49 <fridolin> followup id need
15:50:55 <fridolin> thanks a lot
15:51:24 <fridolin> we notices performance gap is more important when DB server is remote
15:51:24 <Joubu> I don't think something is needed, I was discussing with Julian and he told me I was wrong
15:51:39 <fridolin> ah
15:52:26 <fridolin> but there is a benchmark Comment 3
15:53:17 <tuxayo> You mean it needs a second run from someone else?
15:54:24 <fridolin> any help is welcome
15:55:05 <fridolin> lets move on
15:55:47 <tuxayo> Any other pressing general development discussion?
15:56:21 <Joubu> yes
15:56:30 <Joubu> have a look at bug 29746, it's great
15:56:30 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29746 enhancement, P5 - low, ---, tomascohen, Passed QA , Add a handy Koha::Result::Boolean class
15:56:31 <Joubu> that's all :)
15:56:34 <tuxayo> go :)
15:56:37 <cait1> :)
15:56:48 <Joubu> (no, that was not a discussion)
15:57:29 <tuxayo> moving on then :)
15:57:32 <tuxayo> #topic Review of coding guidelines
15:57:47 <tuxayo> > fridolin  : Remove the deprecated text parts in J5 ?
15:58:03 <tuxayo> #link https://wiki.koha-community.org/wiki/Coding_Guidelines#JS5:_Enabling_translation_of_language_strings_in_linked_JavaScript
15:58:23 <fridolin> its confusing
15:58:47 <fridolin> related to qa tools issue
15:59:15 <oleonard> The examples for how to leverage 21156 could be expanded, but removing the DEPRECATED information makes sense
15:59:27 <cait1> yes, remove DEPRECATED
15:59:42 <cait1> i mean everything that is deprecated...
15:59:47 <fridolin> it is since 19.11.04
16:00:30 <fridolin> i'll leave the reference to 21156
16:01:42 <tuxayo> So just removing everything from DEPRECATED to the end of  JS5?
16:01:51 <fridolin> yep
16:02:19 <tuxayo> no objections or amendments?
16:02:37 <fridolin> RIP ☠️
16:03:06 <tuxayo> #action tuxayo Update coding guideline JS5 to removed everything from DEPRECATED to the end of JS5.
16:03:18 <tuxayo> next
16:03:19 <tuxayo> >  Perltidy config ? There is xt/perltidyrc (untouched since 2008)
16:04:20 <cait1> i think it was hard to agree on things back then
16:04:27 <fridolin> I have always use default config, but it may be wrong
16:05:27 <cait1> what are the differences to default config?
16:06:12 <fridolin> i mean what are other dev using ?
16:06:56 <fridolin> ahhh https://wiki.koha-community.org/wiki/Coding_Guidelines#PERL1:_Perltidy
16:06:57 <tuxayo> The only uncommented stuff is
16:06:57 <tuxayo> --cuddled-else    --maximum-line-length=178     --opening-brace-always-on-right   --paren-tightness=1   --vertical-tightness=2
16:06:57 <tuxayo> 
16:08:54 <tuxayo> http://perltidy.sourceforge.net/
16:08:57 <tuxayo> > The default parameter settings approximately follow the suggestions in the Perl Style Guide.
16:09:00 <tuxayo> https://perldoc.perl.org/perlstyle.html
16:09:54 <fridolin> ah ok, so maybe juste remove xt/perltidyrc
16:10:22 <cait1> maybe we should write it down then
16:10:26 <cait1> that the standard is used?
16:10:56 <tuxayo> Is it actually used by the related test?
16:11:18 <cait1> also a good question
16:11:22 <cait1> i tmigh tbe needed for the test
16:12:39 <oleonard> We seem to be slowing down...
16:12:44 <tuxayo> And maybe we keep it empty to have it ready for adding non default value? Or do we expect to unlikely something else than the default?
16:13:32 <fridolin> we may postpone this
16:14:02 <tuxayo> #action tuxayo check if xt/perltidyrc is used to see if we currently rely on it's values
16:14:12 <tuxayo> last!
16:14:14 <tuxayo> > Avoid formatting single words within sentences to ease translation (example: Bug 29589)
16:14:14 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29589 minor, P5 - low, ---, jonathan.druart+koha, Passed QA , Translation issue with formatting in MARC overlay rules page
16:14:27 <fridolin> i mean create a new guide line to explain that
16:15:03 <oleonard> I find that restriction to be be unreasonable, and I wish we could come up with a solution.
16:15:12 <Joubu> I reused the pattern on bug 29602 as well
16:15:12 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29602 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , We must be nicer with translators
16:15:40 <fridolin> oleonard: how is it a restriction ?
16:16:03 <oleonard> I want to be able to use markup in the middle of a sentence.
16:16:15 <cait1> i think there have beens ome solutions proposed
16:16:20 <cait1> but I don't remember exactly where .(
16:16:22 <fridolin> i mean the guide line can advice not to use it for translation
16:16:27 <cait1> basically it was using a TT plugin i think
16:16:44 <cait1> because TT stuff gets parsed into a sentence, we have issues with html elements
16:16:44 <Joubu> yes but it only adds a span
16:17:01 <Joubu> oleonard: do you mean you would like to use <b> for instance in a sentence?
16:17:04 <Joubu> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=128698
16:17:07 <cait1> it might be on the old bugs of mveron, when he cleaned up a lot of those
16:17:09 <Joubu> +                    The [%  pref_MARCOverlayRules_link | $KohaSpan %] preference is not set, don't forget to enable it for rules to take effect.
16:17:27 <Joubu> we could have [% string | KohaTab tag => 'b' %]
16:17:36 <Joubu> /KohaTab/KohaTag
16:17:48 <cait1> I believe that should work with the tools
16:17:52 <cait1> for translation
16:17:55 <oleonard> Joubu: Yes I would like to be able to <em>emphasize</em> words, for example.
16:18:06 <cait1> i agree, it shoudl be possible
16:18:10 <fridolin> ah sure
16:18:17 <cait1> woudl the proposed solution work oleonard?
16:18:23 <Joubu> no
16:18:29 <cait1> hm?
16:18:38 <Joubu> it won't work I think
16:18:46 <Joubu> the [% string %] won't be translatable
16:19:00 <cait1> hm right
16:19:14 <cait1> can we assign text in TT varialbes that is translatable?
16:19:31 <Joubu> [% SET string = t("translate_me") %]
16:19:55 <Joubu> The [% string | $KohaTag tag => 'em' %] stuff blabla
16:20:01 <Joubu> but it will end up weirdly in the po
16:20:33 <fridolin> the purpose is to have in PO : The %s stuff blabla
16:20:42 <fridolin> right ?
16:20:44 <Joubu> you will have translate_me in one string, and the other "The %s blabla" in another one
16:20:47 <cait1> i'll give an example i was working on today sec
16:21:04 <Joubu> BUT
16:21:06 <oleonard> I don't think we have to solve this problem now, but I wanted to express that I don't think a coding guideline is a long-term solution.
16:21:14 <cait1> (Requires above, does not work during self-registration if PatronSelfRegistrationVerifyByEmail is set.)
16:21:27 <Joubu> [% SET string = ("The <em>Translate me</em> stuff blabla"); %]
16:21:28 <Joubu> will work
16:21:29 <cait1> so the PatronselfRegistrationbyEmail is a link
16:21:43 <cait1> and self-registration is too
16:21:50 <Joubu> missing t()
16:21:52 <cait1> that makes to translate: if
16:21:54 <Joubu> [% SET string = t("The <em>Translate me</em> stuff blabla"); %]
16:21:59 <Joubu> ^^ that will work, problem fixed
16:21:59 <cait1> is set.
16:22:04 <cait1> which is... hard
16:22:34 <cait1> Joubu++
16:22:38 <cait1> so... who is going to try it out? :)
16:22:45 <Joubu> cait1: your version can be fixed using the other version, from 29602
16:22:55 <cait1> yes and no, self registration is no pref
16:23:03 <cait1> in that case
16:24:09 <cait1> should we try it and make the coding guideline up next time?
16:24:16 <cait1> the string on patron attributs config might be a good case
16:24:24 <Joubu> [% SET PatronSelfRegistrationVerifyByEmail_link = '<a href="/cgi-bin/koha/admin/preferences.pl?op=search&searchfield=PatronSelfRegistrationVerifyByEmail">PatronSelfRegistrationVerifyByEmail</a>' %]
16:24:48 <Joubu> [% SET self_registration_link = '<a></a>' %] #Same as before
16:25:01 <Joubu> ha
16:25:11 <Joubu> yes, ok, will think about that
16:25:13 <Joubu> move on :)
16:25:56 <fridolin> oki
16:26:02 <tuxayo> #action tuxayo postpone "Avoid formatting single words within sentences to ease translation (example: Bug 29589)" to wait for test results
16:26:02 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29589 minor, P5 - low, ---, jonathan.druart+koha, Passed QA , Translation issue with formatting in MARC overlay rules page
16:26:16 <tuxayo> #topic Set time of next meeting
16:26:38 <tuxayo> The 19th at the same hour then
16:27:02 <fridolin> sounds good
16:27:05 <cait1> tuxayo++
16:27:15 <fridolin> tuxayo++
16:27:35 <tuxayo> #info Next meeting: 19 January 2022, 15 UTC
16:27:46 <tuxayo> #endmeeting