22:01:44 <tuxayo> #startmeeting Development IRC meeting 6 April 2022
22:01:44 <huginn> Meeting started Wed Apr  6 22:01:44 2022 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:44 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:01:44 <huginn> The meeting name has been set to 'development_irc_meeting_6_april_2022'
22:02:16 <rangi[m]> #info Chris Cormack, Catalyst IT
22:02:20 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_6_April_2022 Today's agenda
22:02:26 <hayley> #info Hayley Pelham, Catalyst IT
22:02:27 <tuxayo> #topic Introductions
22:02:30 <alexbuckley> #info Alex Buckley, Catalyst IT
22:02:38 <aleisha> #info Aleisha Amohia, Catalyst IT, Wellington NZ
22:02:51 <cait> #info Katrin Fischer, Germany
22:03:03 <tuxayo> #info Victor Grousset, Tuxayo & Co., France
22:03:10 <cait> not sure I'll be around to the end, a little late here
22:03:12 <fridolin> #info Fridolin Somers, Biblibre, France
22:03:17 <tuxayo> woohoo, so much people :D
22:03:56 <rangi[m]> you're still in france fridolin ? travelling home soon?
22:04:09 <hayley> hello all!
22:04:16 <fridolin> yep, return in 10 days
22:04:30 * fridolin enjoys cheese and wine
22:05:09 <tuxayo> #topic Announcements
22:05:24 <tuxayo> #info KohaCon22 website live! https://2022.kohacon.org
22:05:42 <cait> and with a nice logo too
22:05:45 <cait> koha_us++
22:05:48 <rangi[m]> wainui is recovering from eye surgery, so I am filling in as rmaint just for the april release
22:06:16 <fridolin> super
22:07:00 <tuxayo> thanks for the help, best wishes to Wainui for recovery
22:07:28 <rangi[m]> thanks tuxayo[m] , ill pass that on
22:07:29 <tuxayo> Anything else to announce that doesn't fit the other topics of the agenda?
22:07:49 <tuxayo> thanks rangi
22:08:16 <tuxayo> #topic Update from the Release manager (22.05)
22:08:28 <tuxayo> fridolin, the mic is yours
22:08:45 <fridolin> yey
22:08:58 <fridolin> hackfest was great
22:09:11 <rangi[m]> the pictures looked great!
22:09:13 <fridolin> so lots of passed QA
22:09:35 <cait> it looked like you al lhad a good time for sure :)
22:09:35 <tuxayo> ^^
22:09:40 <fridolin> I've discussed about end of cycle => do as usual
22:09:52 <rangi[m]> ahh yep
22:10:03 <fridolin> and next release => i'm not presenting for it
22:10:26 <fridolin> i will send email on ML about milestones for 22.05 release soon
22:11:16 <fridolin> there is one action I need to do : synch between DBIC and kohastructure.sql
22:12:00 <tuxayo> + DBRevs? All this looks though
22:12:08 <rangi[m]> thanks fridolin
22:12:16 <tuxayo> *tough
22:12:32 <fridolin> yep DBRevs also
22:12:54 <fridolin> the Recalls dev has an impact there
22:13:33 <fridolin> i am good
22:13:38 <aleisha> :)
22:13:50 <tuxayo> #topic Updates from the Release Maintainers
22:13:52 <tuxayo> rmaints?
22:13:52 <wahanui> hmmm... rmaints is khall, AndrewFH, wainui and tuxayo
22:14:33 <rangi[m]> nothing from me
22:14:42 <tuxayo> So much happened during Hackfest, I forgot what's up about RMaint ^^ I guess all good, nothing special
22:15:11 <tuxayo> #topic Updates from the QA team
22:15:13 <tuxayo> qa_team?
22:15:13 <wahanui> i think qa_team is cait, joubu, tuxayo, marcelr, kidclamp, khall, tcohen, ashimema, nugged, kohaputti, petrova
22:15:44 <cait> I am happy that we have mostly caught up on the older bugs waiting in the queue now
22:15:54 <cait> still a lot to do and bottleneck is currenlty maybe in NSO
22:16:23 <cait> it's at almost 300 - so getting sign-offs up again would probably be good
22:16:35 <cait> and... QA team: do QA!
22:16:50 <aleisha> cool! can looking into doing more testing
22:17:19 <fridolin> same for me
22:17:21 <cait> lots of bugs waiting in there too, according to dashboard
22:17:30 <tuxayo> I still have a lot to review on recalls but I already have some notes to open potential followups. Maybe some DB indexes are needed for example.
22:17:38 <fridolin> yep priority to bugfixes
22:17:50 <aleisha> tuxayo: feel free to add me to cc list for any recalls bugs
22:18:03 <tuxayo> ok :)
22:18:43 <tuxayo> moving on?
22:18:50 <cait> yes please
22:19:10 <tuxayo> #topic Actions from last meeting
22:19:16 <tuxayo> « fridolin checking the GUI tool for alter on AnonymousPatron x
22:19:25 <tuxayo> *»
22:19:28 <tuxayo> « fridolin create bug report for skipping AnonymousPatron from delete_patrons.pl »
22:19:34 <tuxayo> «     2 above actions are obsolete, there is already a test from Bug 14708: Skip AnonymousPatron in GetBorrowersToExpunge »
22:19:34 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14708 normal, P5 - low, ---, kyle.m.hall, RESOLVED FIXED, The patron set as the anonymous patron should not be deletable
22:19:41 <fridolin> all good
22:19:47 <tuxayo> #topic General development discussion (trends, ideas, ...)
22:20:30 <rangi[m]> nothing from me here too :)
22:21:37 <fridolin> at hackfest we have seen use of a replacement for Selenium
22:21:48 <tuxayo> Cypress
22:21:53 <rangi[m]> oh i would be interested in that
22:21:54 <rangi[m]> cool
22:22:15 <tuxayo> Joubu experience in writing the tests what better than with Selenium.
22:22:38 <tuxayo> experience as it how it felt. Not about existing knowledge
22:22:59 <rangi[m]> ah yep
22:23:40 <fridolin> In case you missed it : Great dev has been pushed Bug 30063
22:23:40 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30063 enhancement, P5 - low, ---, jonathan.druart+koha, Pushed to master , Make the main patron search use the /patrons REST API route
22:24:03 <fridolin> this needed ugrading some libs
22:24:04 <tuxayo> I was able to make Joubu's test on ERM run easily on my machine.
22:24:50 <rangi[m]> oh that is good news!
22:25:47 <fridolin> We start building CI for Ubuntu 22.04 Jammy
22:26:05 <tuxayo> great!
22:26:12 <fridolin> thats why we droppped Ubuntu 16.04 Xenial
22:26:26 <fridolin> Jammy is my actual OS :D
22:26:38 <fridolin> the beta is OK
22:27:02 <tuxayo> I did an attempt to run cypress via koha-testing-docker but didn't get far. I was trying to use the existing docker image for cypress&browsers the wrong way it seems. I have to ask stuff in Cypress's chat or forum about how to do it right
22:28:17 <tuxayo> It's the right meeting to see what can be learned from the recall submission. aleisha and all that followed recalls, what do you think could be done by submitters of larger patchsets such as this one and the rest of the community to make it easier?
22:29:03 <tuxayo> *all people that followed the recalls ticket
22:29:20 <aleisha> less scope creep :)
22:30:02 <rangi[m]> i think thats the main one, get in the MVP (as they say in the agile world) (minimum viable product) then add to it
22:30:06 <aleisha> it was a much smaller patchset years ago when i started, but it was being developed for the company that sponsored it
22:30:09 <tuxayo> How did that happen? The first ticket message what already warning against scope creep.
22:30:39 <tuxayo> *was already warning
22:30:45 <aleisha> i also could've created additional bug reports for the follow-ups, but it wouldve been too hard to rebase many separate bug reports
22:31:02 <tuxayo> yes, that would be a mess
22:31:16 <aleisha> tuxayo: people had different ideas of how recalls should look and couldnt agree, so the feature got blocked
22:31:32 <cait> I think tht was a part of it, managing different expectations
22:31:55 <fridolin> mmm some dev like patrons search via API are a large graph of bugs, it worked
22:32:22 <cait> which then scope creeps... I am not sue what can be done, breaking into smaller bits would make it easier to get the base in for sure, but that means we need to ensure it's not sitting for too long iwth a bigger tree to work through
22:32:31 <aleisha> exactly cait
22:32:45 <cait> i think that's waht helped with patron search
22:32:49 <cait> people sitting together working through it
22:33:45 <cait> we tried to organize something similar for Recalls - but it was hard to find time. I am really glad marcelr++ took it on
22:34:06 <aleisha> yes thanks marcel, it was good to not be the only person getting stuck in recalls land
22:34:17 <fridolin> ^^
22:34:34 <cait> we have other big patches still stuck
22:34:38 <cait> marc holding records comes to mind
22:35:25 <tuxayo> > could've created additional bug reports for the follow-ups
22:35:25 <tuxayo> Also the thing is that internally you have to develop the whole thing for your clients. In the case the MVP doesn't get merged quickly you end up with having the have a minimal version and a larger version for your customers. is that an actual issue or extracting part of a dev to submit it in various ticket (and handling the change feedback) is not that bad?
22:35:27 <cait> or the work on attempting to merge tables
22:36:04 <aleisha> tuxayo: that's exactly what happened - developing for clients while the upstream version was blocked by scope creep and differing expectations. extracting part of a dev is really hard and messy
22:36:45 <fridolin> we have the same pb for bundle of items, your libraries use it already
22:37:24 <cait> sometimes the solution is not easy
22:37:35 <cait> something htat is developed specifically for one library, might not be the best of doing things
22:37:52 <cait> the idea of QA is to get eyes on things... librarian eyes too
22:38:07 <cait> I don't have a solution for it
22:38:11 <aleisha> ive been maintaining different versions of recalls for 3 different libraries :)
22:38:17 <cait> ouch
22:38:25 <aleisha> because youre right, solutions differ between libraries
22:38:37 <fridolin> same here 3 versions of bundle of items ^^
22:38:56 <tuxayo> So you submit an MVP and then it gets scope creeped (and also needs rightfull changes to be able to be generalized) while your customer's version gets scope creeped too in a diverging way. Is that something like that?
22:38:56 <fridolin> but now in 20.11 there all use the one proposed in Bugzilla
22:39:10 <aleisha> they all have the ability to configure those things that make the way they use recalls different but it would be nice if upstream could be the base we branch off from
22:40:25 <aleisha> i think the issue is partly scope creep, partly the community being busy with other priorities
22:42:26 <cait> we have alot of projects going on
22:42:53 <fridolin> it is great to see the product is alive
22:42:53 <cait> we tried to get groups together for certain projects to put more focus on things, but it didn't quit ework out yet
22:43:08 <cait> yes :) just a lot of building sites it sometimes feels like!
22:43:34 <tuxayo> These kind of developments seem inherently deemed to be a mess to manage but we can certainly mitigate the thing.
22:43:34 <tuxayo> - resist scope creep to ask only for necessary changes for inclusion
22:43:34 <tuxayo> - bring the development as a topic in meetings and QA team discussion to focus on it (it seems to have helped)
22:43:34 <tuxayo> - anything else to try to do in the future?
22:44:25 <aleisha> i would add to that, when bringing different expectations, make suggestions for the developer
22:44:50 <tuxayo> I don't get it
22:44:54 <cait> same
22:44:56 <cait> blame the time
22:45:06 <cait> can you rephrase a little maybe?
22:45:09 <aleisha> sure!
22:46:02 <rangi[m]> i have to duck out for an in real life meeting, nice to see you all!
22:46:27 <tuxayo> Nice to have seen you rangi o/
22:46:36 <fridolin> _o/
22:46:38 <aleisha> i was just meaning that sometimes too much discussion blocks development
22:47:21 <cait> I guess it's always some way of finding the middle ground?
22:47:57 <tuxayo> So we could ask to focus discussions on concrete actions for the dev to reach an acceptable MVP?
22:48:00 <cait> so not something we can solve easily, just something to continously work on
22:48:13 <aleisha> yes i think that's it tuxayo
22:48:21 <cait> yeah, that makes sense
22:49:46 <cait> I have to duck out too - have a great day nz and good night!
22:49:55 <tuxayo> And note somewhere all the potential follow ups idea so that they don't get lost and it easier to move on knowing they are somewhere?
22:50:04 <aleisha> good idea tuxayo
22:50:05 <aleisha> night cait
22:50:21 <tuxayo> see ya cait
22:50:48 <tuxayo> any other guideline that could help?
22:50:56 <aleisha> thats it frome me
22:52:37 <tuxayo> #action tuxayo send ideas to have an easier time with big changes to koha-devel to get more of them and document them
22:53:00 <tuxayo> So we can build on experience
22:53:19 <tuxayo> Any other general discussion?
22:53:37 <nugged> oh... Nighty night )))
22:53:57 <tuxayo> hi nugged :)
22:54:22 <nugged> o/ tuxayo
22:54:51 <tuxayo> Moving on to next topic
22:54:56 <tuxayo> #topic Review of coding guidelines
22:54:59 <tuxayo> «Terminology: use restriction, not debar/debarment, see Bug 5268 »
22:54:59 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5268 minor, PATCH-Sent (DO NOT USE), ---, nengard, CLOSED FIXED, Language Issue: Debarred
22:55:45 <tuxayo> Is debarment still used in the UI?
22:56:58 <tuxayo> It doesn't seem to be in the strings
22:57:16 <fridolin> indeed
22:57:39 <tuxayo> Looks like in the past is was made and unofficial terminology change.
22:57:46 <tuxayo> *an unofficial
22:59:18 <tuxayo> Any objection on setting that in stone?
22:59:34 <aleisha> nope
22:59:37 <tuxayo> Should I also ask in koha-devel to be sure?
23:00:24 <aleisha> i don't think it's needed but up to you!
23:02:07 <tuxayo> #action tuxayo add to terminology "use restriction, not debar/debarment" and notify koha-devel in case that wasn't a good idea.
23:02:53 <tuxayo> #topic Set time of next meeting
23:03:09 <fridolin> at 15:00 UTC as usuall
23:03:17 <fridolin> ok ?
23:03:44 <aleisha> today's time was great for us
23:03:45 <tuxayo> Or 14:00 to compensate for daylight saving time?
23:03:55 <aleisha> 14:00 would be great too
23:04:10 <fridolin> ok
23:04:54 <tuxayo> fridolin: if you can attend from Tahiti, which one will be less terrible?
23:05:09 <aleisha> surely not much is terrible from Tahiti :)
23:05:10 <fridolin> equal, but dont worry
23:05:30 <fridolin> ^^
23:05:46 <tuxayo> aleisha: it's 14 UTC to alternate and aim for work hours for europe and the americas. So for NZ 14UTC should be in the middle of the night ^^"
23:06:11 <nugged> it's 2am here in Helsinki v;)
23:07:08 <nugged> you just summoned me by nick from my WC night trip ;))))
23:07:17 <aleisha> ohhh kidding tuxayo do whatever is usual
23:07:19 <tuxayo> LOL
23:07:39 <tuxayo> nugged: I though it was the same time as france, I need to add Finland to my command with zdump to display a lot of timezones ^^
23:08:03 <tuxayo> I double check, ok for 14 UTC
23:08:25 <tuxayo> And 20 april
23:08:47 <fridolin> just before release, great
23:09:02 <nugged> ... now I meat 2am ;)
23:09:18 <tuxayo> The release is in may right?
23:09:29 <fridolin> i mean stable releases
23:09:37 <nugged> but fir France we are just 1 hour ahead
23:09:43 <nugged> *for
23:09:52 <tuxayo> ok fridolin
23:09:52 <wahanui> fridolin is RM for 22.05
23:09:58 <tuxayo> LOL
23:10:17 <tuxayo> #info Next meeting: 20 April 2022, 14 UTC
23:10:27 <tuxayo> #endmeeting