21:00:38 <tuxayo> #startmeeting Development IRC meeting 6 July 2022
21:00:38 <huginn> Meeting started Wed Jul  6 21:00:38 2022 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:38 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:38 <huginn> The meeting name has been set to 'development_irc_meeting_6_july_2022'
21:00:47 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_6_July_2022 Today's agenda
21:00:59 <tuxayo> #topic Introductions
21:01:01 <aleisha> #info Aleisha Amohia, Catalyst IT, Wellington New Zealand
21:01:02 <tcohen> #info Tomas Cohen Arazi, Theke Solutions, Argentina
21:01:04 <hayley> #info Hayley Pelham, Catalyst IT, NZ
21:01:19 <cait> #info Katrin Fischer, BSZ, Germany
21:01:27 <tuxayo> #info Victor Grousset, Tuxayo Inc., France
21:01:34 <rangi[m]> #info Chris Cormack, Catalyst IT, NZ
21:01:45 <thd> #info Thomas Dukleth, Agogme, New York City
21:02:18 <davidnind[m]> #info David Nind, NZ
21:03:49 <tuxayo> #topic Announcements
21:04:09 <tuxayo> Anything to announce that doesn't fit in the other topics better?
21:04:26 <ashimema> #info Martin Renvoize, UK
21:04:55 <davidnind[m]> Programme for KohaCon 2022 is now available
21:05:00 <cait> good one
21:05:21 <davidnind[m]> #link https://koha-us.org/events/conferences/kohacon22/#tab3
21:05:43 <aleisha> exciting!
21:05:44 <tuxayo> great :D
21:06:21 <tuxayo> ยซSaving kittens and supporting Kohaยป
21:06:24 <tuxayo> aleisha++
21:06:32 <aleisha> :D
21:06:34 <davidnind[m]> #info Schedule for KohaCon 2022 (in person and virtual) is now available https://koha-us.org/events/conferences/kohacon22/#tab3
21:07:15 <tuxayo> Anything else?
21:07:15 <wahanui> i heard Anything else was necessarily going to be incremental.
21:07:40 <tuxayo> maybe wahanui
21:07:56 <cait> move on :)
21:08:04 <tuxayo> #topic  Update from the Release manager (22.05)
21:08:23 <tuxayo> tcohen: ๐ŸŽ™๏ธ
21:08:58 <tcohen> Hi, it's been a busy begining
21:09:08 <tcohen> lots of bugfixes to push
21:09:20 <tcohen> I have started pushing enhancements and some features last week
21:09:25 <koha-jenkins> Project Koha_Master_D9 build #2041: UNSTABLE in 1 hr 25 min: https://jenkins.koha-community.org/job/Koha_Master_D9/2041/
21:09:26 <tcohen> or this one
21:09:26 <rangi[m]> cool
21:09:26 <wahanui> this one is on oleonard
21:09:34 <tcohen> heh
21:09:46 <tuxayo> koha-jenkins: not now for the bad news!
21:09:46 <koha-jenkins> tuxayo did you mean me? Unknown command 'not'
21:09:46 <koha-jenkins> Use '!koha-jenkins help' to get help!
21:09:58 <tcohen> we had a minor storm with jenkins going nuts yesterday
21:10:01 <tcohen> but thanks to
21:10:03 <tcohen> mtj++
21:10:05 <tcohen> ashimema++
21:10:09 <tcohen> things are calm now
21:10:27 <tcohen> I haven't heard from people that added to the roadmap
21:10:44 <tcohen> I guess it is summer/vacation for many
21:10:58 <tcohen> but it is time to focus on big things so we have
21:11:06 <tcohen> time enough for having a great and stable release
21:11:16 <tuxayo> > I guess it is summer/vacation for many
21:11:16 <tuxayo> Is that the same in the south hemisphere?
21:11:21 <aleisha> yes i'd really love to get back into helping - it's been hectic since VALA
21:11:38 <tcohen> we have winter holidays (for the kids) next two weeks
21:11:44 <tcohen> but that's it
21:11:46 <rangi[m]> same here
21:12:08 <tuxayo> ok so it's not usual to have most people 1 month off.
21:12:08 <tcohen> #link https://annuel.framapad.org/p/koha_22.11_roadmap
21:12:20 <rangi[m]> no, we do that in summer
21:12:21 <tuxayo> So organizing stuff could work :)
21:12:29 <tcohen> not in july, tuxayo
21:12:56 <tcohen> I had the intention to resume work on the new 'holds' table
21:13:11 <tcohen> if anyone is interested on helping there, just ping me
21:13:17 <cait> we also have an unusual amount of bad bugs still
21:13:32 <cait> so we also need to take care of those
21:13:36 <tcohen> some of them are long standing/just ones, but yeah
21:13:42 <cait> (not only the new and shiny stuff, please)
21:13:43 <fridolin> #info Fridolin Somers, Biblibre, Tahiti
21:13:46 <fridolin> sorry i'm late
21:13:52 <cait> the list of recent ones has grown too
21:14:04 <cait> but that#s for my slot possibly :9
21:14:26 <tcohen> master has 342 commits on top of 22.05.00
21:14:50 <tcohen> from which a not much is new stuffs
21:14:54 <ashimema> I'm game for holds again tcohen
21:15:00 <tcohen> thanks, ashimema
21:15:04 <cait> was not directed at you, more at devs and qa :)
21:15:14 <tcohen> yeah, just sharing numbers
21:15:18 <ashimema> Also keen to continue of task queue refinements including the api and management page improvements
21:15:28 <tcohen> devs are working on fixing things, some enh are really bugfixes
21:15:37 <tcohen> probably not the urgent ones you point, cait
21:15:41 <tcohen> thanks for that
21:16:13 <tcohen> yeah, some big ones are about the task queue, and I'm waiting for lucas to help backporting things
21:16:16 <ashimema> I started working through the QA queue again today after a week of concentrating on bugfixing
21:17:06 <tcohen> thanks cait
21:17:12 <ashimema> Apologies, not been as good at replying to QA manager emails this cycle so far
21:17:25 <ashimema> cait++ for continuing those
21:18:02 <davidnind[m]> I'll add some comments on the majors that need sign-off - I had no luck (or couldn't work out) how to test most of them
21:18:07 <tcohen> so, that's it. ping if you're working on something and need help, guidance or just want to share ideas. Also, type qa_team here to get a list of people you can nudge
21:19:29 <ashimema> Thanks davidnind, your signoffs and comments are always welcome.. they really help in keeping things moving
21:19:31 <koha-jenkins> Project Koha_Master_D11_My8 build #901: UNSTABLE in 42 min: https://jenkins.koha-community.org/job/Koha_Master_D11_My8/901/
21:19:42 <aleisha> yes agreed
21:19:48 <aleisha> davidnind[m]++
21:19:55 <cait> davidnind[m]++
21:19:57 <tcohen> davidnind++
21:20:04 <cait> so-hero
21:20:04 <tuxayo> davidnind++
21:20:25 <davidnind[m]> ๐Ÿ˜Š
21:20:52 <tcohen> jenkins is doing funny things... I think it is related to some tasks using github which could not be synced?=
21:21:18 <tcohen> moving on tuxayo?
21:21:38 <tcohen> oh
21:21:40 <tcohen> wait
21:21:42 <tuxayo> k
21:22:17 <tcohen> I wanted to mention Mason (mtj) added some ES-specific tasks so and isolated the search-related tests so they can be run for each search engine
21:22:24 <tcohen> mtj++
21:22:33 <tcohen> OpenSearch is failing BTW
21:22:53 <tcohen> that's it
21:23:28 <tuxayo> oh, E7 passes but nor OpenSearch :o
21:23:38 <tcohen> worth checking
21:23:41 <tuxayo> mtj++
21:23:45 <tuxayo> #topic Updates from the Release Maintainers
21:23:48 <tuxayo> rmaints?
21:23:48 <wahanui> rmaints are lukeg, liliputech and tuxayo
21:24:13 <cait> tcohen++ mtj++
21:25:07 <davidnind[m]> tcohen++ mtj++
21:25:15 <tuxayo> 1st 21.05.x release was fine, caught up with the late backports. Had the chance to work next to liliputech for their 1st release, it helped with the usual quirks of 1st release.
21:25:27 <tuxayo> #topic Updates from the QA team
21:25:30 <tuxayo> qa_team?
21:25:30 <wahanui> i heard qa_team was cait, marcelr, khall, kidclamp, kohaputti, lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova and Joubu
21:25:35 <tcohen> tuxayo++
21:25:57 <cait> as pointed out earlier, I am worried about the numbers in QA queue rising and also especially the bad bugs number rising
21:26:17 <cait> there is not only old stuff in that list and the list of recent ones I list in the QA mail has also grown
21:26:29 <cait> new stuff is great but we need to figure out those as well
21:26:52 <tcohen> do you have a link to the list?
21:26:56 <tcohen> its the SO queue?
21:26:57 <cait> we've had an unusual high number of update issues this time around
21:27:18 <cait> yes, the "waiting for QA queue"
21:27:34 <cait> we had it down to oldest bug less than 2 weeks old
21:27:41 <cait> now we are at... oldest bugs are from May
21:28:00 <cait> so 2 monts waiting, not quite where we want to be
21:28:37 <cait> I feel we need to check the database updates more maybe
21:28:49 <davidnind[m]> #link Signed Off https://bugs.koha-community.org/bugzilla3/buglist.cgi?bug_status=Signed%20Off&known_name=Signed%20Off&list_id=416322&query_based_on=Signed%20Off&query_format=advanced
21:28:53 <cait> and unrelated to QA: there have been people stuck with their updates on the mailing list
21:29:45 <cait> and it would be great to see more help with this very technical questions
21:30:25 <cait> a lot of people have reported the API not working (missing the instructions about packages for older Linux versions)
21:30:34 <ashimema> I think perhaps this is more apparent now because we no longer quietly continue when things go wrong.. we instead stop the uodate
21:30:39 <cait> there are some reoccurring issues we like that we could do better about
21:30:48 <ashimema> But yes, we should get better at spotting and fixing these issues
21:30:49 <cait> it's possible
21:31:13 <cait> but people get stuck and don't know how to continue - so they'll need help
21:31:30 <ashimema> And even better at catching cases at QA.. it's not simple though.. those dB issues often happen when there's a totally unexpected state the dB is in
21:31:43 <cait> I know
21:31:56 <cait> so first step: please help people on the mailing list fix their installations when you are able to
21:32:17 <cait> second step: let's try to avoid these bugs
21:32:43 <cait> ... also second step: maybe be 'louder' about them doing proper backups before updates... and what they can do if there are errors
21:33:38 <cait> that's all from me... please do more QA! :)
21:34:00 <tuxayo> #topic Status of roadmap projects
21:34:03 <tuxayo> any news?
21:34:23 <thd> I have update the bug report for the wiki.
21:34:54 <tuxayo> bug 23073
21:34:54 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23073 normal, P2, ---, td-koha-bugs, NEW , wiki.koha-community.org needs updating to a later version
21:35:35 <aleisha> #info shoutout to those working on the recalls follow-up bugs, very exciting that the community is finally sharing that work and we are improving the feature collectively :)
21:35:35 <thd> I reloaded git with hyphens or dashes instead of underscores in filenames so that version control works even after that change.
21:36:00 <tcohen> thd++
21:36:46 <thd> The wiki/File:some_image 404 bug is Nginx configuration.
21:36:59 <thd> Works fine in Apache
21:37:30 <thd> The test wiki instances in Apache can be seen on port 9443
21:37:37 <koha-jenkins> Project Koha_Master_U20 build #472: UNSTABLE in 47 min: https://jenkins.koha-community.org/job/Koha_Master_U20/472/
21:38:05 <huginn> News from kohagit: Bug 31067: Fixing missing permission check <https://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=e3faa4d66ba281125be437a971d1549ba8179ec3>
21:38:06 <huginn> News from kohagit: Bug 30769: Typo fix in request.tt <https://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=8a78666fd0dfeb946082e8e81c08bed2dc2c7d90>
21:38:07 <huginn> News from kohagit: Bug 31001: Fix "CGI::param called in list context" warning in basket.pl <https://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=096fd4acfa360e450e9d6a1a37a96f7eb8d848c8>
21:38:22 <tcohen> thd: can you share that information on the list?
21:38:24 <cait> thd: I still owe some testing, hope to do it till beginning of next week
21:38:44 <cait> ssh huginn, we are in a meeting!
21:39:05 <thd> I am going to test putting at least the current 1.35 LTS on Debian 10.
21:39:20 <tcohen> we need to move that to koha-ci
21:39:30 <tuxayo> *#koha-bots
21:39:34 <thd> Yes, I will send a message to the mailing list about testing.
21:39:40 <tuxayo> > ssh huginn, we are in a meeting!
21:39:40 <tuxayo> that's tcohen sneaking commits in master ^^
21:39:41 <tcohen> thanks!
21:39:55 <tuxayo> hope to go undetected but no!
21:40:32 <tcohen> need an #action for thd
21:40:40 <thd> mtj may be providing a VPS for testing database migration on Debian 8
21:40:56 <thd> Previous testing has been Debian 9
21:41:18 <cait> have their been problems with Debian 9 or hwy test with an older verson?
21:41:44 <tuxayo> #action thd sends a message to the mailing list about testing the wiki upgrade
21:41:46 <tuxayo> like that?
21:41:55 <tcohen> thd will send I'd say, but yes
21:42:01 <koha-jenkins> Project Koha_Master_D10 build #719: UNSTABLE in 57 min: https://jenkins.koha-community.org/job/Koha_Master_D10/719/
21:42:17 <tcohen> I need to put updates on the roadmap
21:42:18 <tuxayo> ah I conjugated send ^^"
21:42:23 <thd> A significant issue is that sury.org just dropped support for PHP LTS for Debian 9 which is old old stable.
21:42:33 <tcohen> before I leave to have a life with the family :-D
21:43:23 <thd> My test instance of Debian 9 still works fine and PHP LTS from sury.org or Debian 9 is archived.
21:43:56 <tcohen> - Task queue streamlining: Joubu has worked on the API and streamlining things. dcook has provided insights on things
21:44:01 <thd> I tested in Debian 9 because everything old and new works there.
21:44:20 <tcohen> - ERM: jonathan has a demo sandbox on biblibre's, and progress is taking place
21:44:43 <thd> We may have to divide old for database migration from new upgrade to MediaWiki 1.35 LTS.
21:45:31 <tcohen> - Vue: so far only the cities admin page uses it, and the ERM. multiple enhancements are required to streamline the integration for Vue. We have many things solved that need to be redone. Jonathan worked on the date/date-time handling stuff, help is welcome
21:45:40 <thd> The intention was always to put the production system on Debian 10 or 11.
21:46:05 <tcohen> - Continued API refinements: Things are in the SO queue!
21:46:25 <tcohen> and I need to leave now!
21:46:26 <thd> Old versions of Debian are necessary to avoid breaking the wiki when migrating the database.
21:46:29 <tcohen> bye!
21:46:38 <thd> bye tcohen
21:46:52 <cait> thx thd
21:47:39 <tuxayo> Anything else?
21:47:39 <wahanui> well, Anything else is necessarily going to be incremental.
21:47:51 <tuxayo> wahanui forget anything else
21:47:51 <wahanui> tuxayo: I forgot anything else
21:49:11 <tuxayo> #topic Actions from last meeting
21:49:19 <tuxayo> cait try to draw how extended support/LTS would work (https://lite.framacalc.org/29o8a7mlwc-9v57)
21:49:19 <tuxayo> cait++
21:49:45 <cait> I did my homework
21:49:51 <davidnind[m]> cait++
21:50:08 <fridolin> cait++
21:50:17 <cait> the basic quesiton is... how many versions can we maintain?
21:50:22 * fridolin sends a big smelling cheese
21:50:26 <cait> at the same time
21:51:05 <cait> and which version will be the LTS now
21:51:27 <tuxayo> What is the scenario for which we need 5 rmaints?
21:51:27 <cait> if we cut maintenance short on regular releases to 1 year... we can do with 3 people
21:51:36 <cait> if we want to have 1.5, we need at least 4
21:51:51 <cait> tuxayo: that's the past
21:51:52 <tuxayo> oh
21:51:52 <davidnind[m]> should we only have one LTS release at a time (if that is possible)?
21:51:59 <cait> we did have 5 rmaints for 21.11
21:52:10 <cait> now we got only 3 for this
21:52:25 <cait> this cycle
21:52:28 <tuxayo> *4 there was hole
21:52:31 <tuxayo> In the previous cycles
21:52:32 <cait> so the blue line is what we currnelty maintain
21:52:42 <koha-jenkins> Project Koha_Master_D9 build #2042: STILL UNSTABLE in 1 hr 5 min: https://jenkins.koha-community.org/job/Koha_Master_D9/2042/
21:53:01 <cait> the first table is "if we make 21.11 LTS"
21:53:11 <cait> the second table is "if we make 22.05 an LTS"
21:53:14 <tuxayo> > should we only have one LTS release at a time (if that is possible)?
21:53:14 <tuxayo> It's possible to have two while the next LTS in stable, oldstable or oldoldstable IIUC
21:53:28 <cait> ashimema suggested there shoudl be an overlap
21:53:34 <cait> you still want to give people time for the update
21:53:56 <cait> this model has a year long overlap, it could be half a year
21:54:16 <cait> then the next lts would be one version later
21:55:00 <cait> but it makes things a little less predictable
21:55:27 <tuxayo> If we only have regular support for 1 year to have 3 rmaints in total, then people can't jump from .11 to .11 and .05 to .05
21:55:43 <cait> yeah, so we'd need 4 rmaints
21:55:47 <tuxayo> Yes
21:55:49 <cait> it's my feeling too actually
21:56:08 <cait> feel free to add your own drawings too
21:56:40 <cait> 1.5 would be better than a year for regular
21:57:03 <cait> what do others think?
21:57:38 <tuxayo> > yeah, so we'd need 4 rmaints
21:57:38 <tuxayo> With the LTS RMaint only doing releases for security or dependency breakage or other critical stuff. So it seems manageable to find someone for that.
21:59:18 <tuxayo> > feel free to add your own drawings too
21:59:18 <tuxayo> Someone is doing it now at J18 :)
21:59:32 <tuxayo> spread sheet is a great idea
21:59:50 <cait> yeah i just tried with half a year overlap
21:59:53 <koha-jenkins> Yippee, build fixed!
21:59:53 <koha-jenkins> Project Koha_Master_D12 build #195: FIXED in 40 min: https://jenkins.koha-community.org/job/Koha_Master_D12/195/
21:59:54 <wahanui> Congratulations!
21:59:55 <cait> and 1.5 for regular
22:00:10 <davidnind[m]> is the end result that you only have one extended support/LTS version at a time?
22:00:29 <cait> you'd have an overlap of half a year
22:00:41 <cait> if you only have one at a time, people have no time for updating
22:00:58 <cait> so this model is that we announce what version will be LTS at its release
22:01:08 <cait> and people will have 6 months to move to it
22:01:26 <davidnind[m]> +1
22:02:02 <tuxayo> and people can move when it's already oldstable. So it's okay for stability
22:02:11 <cait> so the parameters of how big the overlap and of how long we maintain regular effect the number of rmaints
22:02:42 <cait> I am not sure how to progress from here
22:02:48 <cait> should we have a vote next meeting?
22:03:17 <tuxayo> Looks good to move forward
22:03:34 <tuxayo> how do we handle that we have two meeting slots with different people ? ^^"
22:03:43 <cait> I initially thought about making 21.11 LTs... but feel now that we might want to choose 22.05 instead
22:04:39 <davidnind[m]> I agree - gives time to make sure we have everything set up, without being a rush
22:05:01 <cait> well, ideal might be even 22.11...
22:05:02 <tuxayo> > we might want to choose 22.05 instead
22:05:02 <tuxayo> I don't get what that changes except have the LTS effective sooner?
22:05:31 <cait> just maybe a bit unusual to announce an already old release.. .might be more effective if we do with the current stable
22:05:49 <cait> but that's maybe something we could finally decide on next meeting
22:05:55 <cait> 1) which version will be LTS
22:06:11 <cait> 2) overlap time (half year or year)
22:06:19 <cait> 3) regular maint time (1 year, 1.5 years...)
22:06:33 <davidnind[m]> +1
22:06:33 <tuxayo> good finding cait that in some cycle we don't need an LTS RMaint
22:07:08 <tuxayo> So we can choose do we always need 4 or sometimes need only 3
22:07:29 <davidnind[m]> Those not able to attend next meeting - add apologies and record votes in advance (if questions added to the agenda)
22:07:32 <cait> with the shorter overlap it gets a bit more 'irregular' yes
22:07:46 <cait> i can add the questions to agenda
22:07:55 <tuxayo> > Those not able to attend next meeting - add apologies and record votes in advance (if questions added to the agenda)
22:07:55 <tuxayo> Good idea and call for vote in the devel list
22:08:39 <cait> i can also polish the table/drawing a bi tmore of the last iteration, but first need to sleep
22:09:00 <davidnind[m]> cait++
22:09:21 <tuxayo> > 2) overlap time (half year or year)
22:09:21 <tuxayo> It chances for libraries that are more confortable doing major upgrade for summer. So that changes with hemispheres
22:10:25 <cait> yeah, I'd be a little more comfortable with a year
22:10:36 <cait> you can also give it half a year to get more stable then
22:10:40 <cait> before updating
22:11:15 <tuxayo> Hopefully or oldstable is good enough so that it's not really a factor
22:11:44 <cait> listen to your QAM about fixing bugs! ;)
22:11:44 <tuxayo> A year overlap might be best so libraries can choose to upgrade every X years at the middle of the year or in the beginning/end of the year.
22:11:55 <tuxayo> QAM?
22:12:03 <cait> i'll let you ponder that
22:12:11 <cait> i think it's most ly us discussing, maybe move on?
22:12:23 <tuxayo> https://en.wikipedia.org/wiki/Quadrature_amplitude_modulation
22:12:25 <tuxayo> ok moving on
22:13:31 <davidnind[m]> #action Extended support/LTS release - vote at the next meeting with questions added to the agenda, those unable to attend (time zone challenges) can add their votes to the agenda
22:13:34 <tuxayo> So cait you finish the drawing with 4 rmaints and sometimes 3 and we discuss that in two weeks?
22:13:59 <cait> yep
22:14:19 <cait> it'd be great if someone else could send something to mailng list
22:14:20 <tuxayo> #action cait finish the LTS drawing example with 4 rmaints and sometimes 3
22:14:44 <davidnind[m]> #action davidnind Extended support/LTS release - send notice to mailing list
22:14:51 <tuxayo> Thanks
22:15:01 <cait> thanks :)
22:15:13 <alohabot> ๐ŸŽ ๐Ÿฆ„ Koha 'master' packages pushed to 'koha-staging' repo  ๐Ÿ๐Ÿฅญ๐Ÿ”
22:15:20 <tuxayo> #topic General development discussion (trends, ideas, ...)
22:16:10 <cait> could we maybe discuss kohacon first?
22:16:17 <tuxayo> ok
22:16:26 <tuxayo> what's up with KohaCon?
22:16:31 <cait> I just wanted to ask if we shoudl put up the bidding page before next General meeting
22:16:51 <davidnind[m]> I would suggest discussing KohaCon23 first then deferring anything else to the next meeting
22:16:55 <cait> because the next General is already in September and that makes it harder for countries that would like to host at an earlier time of the year
22:17:10 <cait> yes, sorry, I meant KohaCon23
22:17:11 <tuxayo> Indeed!
22:17:51 <cait> if we have multple applications and need to organize voting etc. it could get quite late otherwiese
22:18:19 <davidnind[m]> agree
22:18:42 <cait> ok, so are we still happy with hybrid or online only?
22:19:00 <cait> if so, we could just add the bidding page and send out, the question si really if we want to change things around again
22:19:04 <davidnind[m]> I'm happy to setup the Wiki page and draft a message for the mailing lists
22:19:12 <cait> +1
22:20:02 <cait> is 2 months enough? then we could set deadline to next general meeting
22:20:29 <davidnind[m]> I think hybrid is the way to go for the future - the tools for doing this are getting better, but does take more effort to do both and make it a good experience for all attendees
22:20:30 <tuxayo> > are we still happy with hybrid or online only
22:20:30 <tuxayo> Maybe a priority to a hybrid bid over an online only bid?
22:21:10 <cait> I think tha tmight happen in voting
22:21:30 <tuxayo> > I think tha tmight happen in voting
22:21:30 <tuxayo> right$
22:21:31 <cait> if we have multiple bids - more asking what types of conference is eligible for applying
22:21:33 <tuxayo> *right
22:21:58 <rangi[m]> yeah
22:22:11 <rangi[m]> i think getting the bids out soon is a good idea
22:22:16 <cait> half asleep, hope i make sense
22:22:18 <davidnind[m]> I think 2 months is enough (open to that though) - would be ideal to vote at the general meeting
22:22:27 <davidnind[m]> we can always extend...
22:22:34 <tuxayo> yes
22:22:40 <cait> yes
22:23:36 <tuxayo> #action davidnind setup the KohaCon23 bid Wiki page and draft a message for the mailing lists
22:23:44 <davidnind[m]> you are too dedicated cait - nearly 12:30 am for you (I think) ๐Ÿ™‚
22:24:02 <tuxayo> cait++
22:24:13 <aleisha> cait++
22:24:14 <tuxayo> anything else about KohaCon23?
22:24:23 <cait> i should have not put that last on the agenda :)
22:24:44 <cait> same for tuxayo btw
22:24:51 <cait> nothing else from me
22:25:28 <tuxayo> I'm usually awake at this hour and don't start my work day a 9am so that not an issue ^^
22:25:28 <koha-jenkins> Project Koha_Master_U22 build #122: STILL UNSTABLE in 47 min: https://jenkins.koha-community.org/job/Koha_Master_U22/122/
22:26:03 <tuxayo> #info GitLab policy changes: registering Koha as an Open Source project (see May email discussion + see June email discussion)
22:26:05 <tuxayo> #info https://lists.koha-community.org/pipermail/koha-devel/2022-May/047081.html
22:26:05 <tuxayo> #info https://lists.koha-community.org/pipermail/koha-devel/2022-June/047134.html
22:26:26 <tuxayo> #info GitLab change to free tier SASS user limit for namespace: change from 15 September 2022 https://docs.gitlab.com/ee/user/free_user_limit.html
22:26:52 <tuxayo> So that was some info left in the agenda to keep everyone informed about the change in GitLab.com
22:27:14 <tuxayo> That we use for building our docker image and the manuals
22:27:30 <tuxayo> Anything else before setting time for the next meeting?
22:28:59 <fridolin> You can note i've change a bit https://wiki.koha-community.org/wiki/System_requirements_and_recommendations#General
22:29:06 <davidnind[m]> nothing from me that can't wait until the next meeting
22:29:14 <davidnind[m]> fridolin++
22:29:58 <fridolin> KohaCon23 in Tahiti maybe ? \o/
22:30:05 <tuxayo> I forgot
22:30:10 <tuxayo> action: liliputech discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.
22:30:34 <tuxayo> fridolin: can you ping liliputech about this?
22:30:41 <tuxayo> #action liliputech discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.
22:31:00 <tuxayo> #topic Set time of next meeting
22:31:05 <tuxayo> #info Next meeting: 20 July 2022, 14 UTC
22:31:10 <rangi[m]> id come fridolin !
22:31:12 <fridolin> sure
22:31:25 <fridolin> yep only 5000Km from NZ
22:31:41 <fridolin> and we will comme to KohaCon25 in NZ \o/
22:31:45 <davidnind[m]> I would too!
22:31:46 <tuxayo> So for next meeting for Oceania and Americas, same hours I guess? 21 UTC
22:32:03 <davidnind[m]> +1
22:32:09 <fridolin> +1
22:32:12 <tuxayo> And the date would be the 3rd of August
22:32:42 <tuxayo> UTC so the 4th of August for NZ IIUC
22:32:53 <tuxayo> double check the calendar as usual
22:33:10 <tuxayo> So it's noted unless the date is problematic.
22:33:14 <tuxayo> And we can end
22:33:36 <davidnind[m]> +1
22:33:48 <tuxayo> #endmeeting