20:59:53 <tuxayo> #startmeeting Development IRC meeting 8 June 2022
20:59:53 <huginn> Meeting started Wed Jun  8 20:59:53 2022 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:59:53 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:59:53 <huginn> The meeting name has been set to 'development_irc_meeting_8_june_2022'
21:00:00 <tuxayo> #topic Introductions
21:00:16 <cait> #info Katrin Fischer, BSZ, Germany
21:00:48 <tuxayo> #info Victor Grousset, Tuxayo VoG, France
21:00:57 <tcohen> #info Tomas Cohen Arazi, Cordoba, Argentina
21:01:04 <liliputech> #info Arthur Suzuki, BibLibre, France
21:01:10 <cait> hm if there are on more people we should decide something radical again :)
21:01:13 <tuxayo> rmaints?
21:01:13 <wahanui> rmaints are lukeg, liliputech and tuxayo
21:01:25 <tuxayo> qa_team?
21:01:25 <wahanui> qa_team is, like, cait, marcelr, khall, kidclamp, kohaputti, lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova and Joubu
21:01:57 <mtj> #info mason james, nz
21:02:21 <mtj> hi peeps
21:02:26 <tuxayo> hi ^^
21:02:48 <tuxayo> cait: what was the last radical decision? ^^
21:02:50 <thd> #info Thomas Dukleth, Agogme, New York City
21:02:55 <cait> version numbering
21:03:06 <tuxayo> :o
21:03:59 <liliputech> any link to last meeting's minutes? :-'
21:04:02 <tcohen> rewrite the project in Rust
21:04:20 <tuxayo> RM said it, let's do it!
21:04:33 <liliputech> Whut?! ><'
21:04:34 <tuxayo> https://www.arewewebyet.org/
21:04:39 <thd> #info Thomas Dukleth, Agogme, New York City
21:05:26 <tuxayo> liliputech: meetings.koha-community.org/2022/development_irc_meeting_25_may_2022.2022-05-25-14.01.log.html
21:05:37 <tuxayo> https://meetings.koha-community.org/2022/development_irc_meeting_25_may_2022.2022-05-25-14.01.html
21:05:44 <liliputech> thx tuxayo!
21:06:10 <liliputech> oh, I was there :)
21:06:12 <davidnind> #info David Nind, New Zealand
21:06:49 <tuxayo> #topic Announcements
21:07:03 <tuxayo> Anything to announce that doesn't fit the other points in the agenda?
21:07:47 <tuxayo> #link https://koha-community.org/koha-22-05-released Koha 22.05 released
21:07:54 <tuxayo> 🎉
21:08:03 <liliputech> BibLibre is having a internal camp last week of june, hopefully a good time to make a bugsquashing day with french librarians ?
21:08:27 <liliputech> from 27 of june up to 1st of july
21:09:19 <cait> no bad times for bug squashing
21:09:28 <cait> and early enough in the release for some big bugs too :)
21:09:39 <liliputech> tuxayo: if you're around, you should come over to Breteuil I guess :)
21:09:55 <liliputech> cait: any bugs you can think of?
21:09:57 <tuxayo> I wanted to do patch-testing sessions with french librarian like they do for translations. Great you had the same idea at BibLibre :D
21:10:01 <cait> #info Biblibre is having an internal camp from  27 of june up to 1st of july
21:10:30 <tuxayo> #info Need signoff queue is 250, help needed
21:10:34 <davidnind> #info Call for proposals for KohaCon22 closed on Friday 3rd June https://koha-us.org/events/conferences/kohacon22/#tab2 - approximately 21 submissions received
21:10:40 <tuxayo> liliputech: many ideas ↑
21:10:55 <cait> liliputech: if you ask me when the date is closer, i can probably give some hints
21:11:26 <davidnind> NSO queue at 243 at the moment...
21:11:38 <cait> thanks to you in large parts :)
21:11:52 <tuxayo> > 21 submissions
21:11:52 <tuxayo> cool
21:11:53 <fridolin> #info Fridolin Somers, Biblibre, Tahiti
21:11:59 <liliputech> cait: I know we are interested in community work on grouped-holds and calendar holds at BibLibre, and other contributors also have solutions on this.
21:12:13 <davidnind> I had it down to 235, but it has no crept up (better than the over 300 it was a few months ago I think...)
21:12:27 <tuxayo> davidnind++
21:13:08 <davidnind> but everyone has been signing off on things, we keep adding things to it :-D
21:13:24 <fridolin> it is alive ! ^^
21:13:31 <liliputech> davidnind: that's a good thing!
21:13:38 <tuxayo> anything else to announce?
21:14:15 <tuxayo> #topic Update from the Release manager (22.05)
21:14:27 <tuxayo> tcohen: 🎙️
21:14:56 <tuxayo> *22.11
21:16:29 <tuxayo> It's after work hours in Argentina I guess, so tcohen might not be available continuously. Maybe they will come back latter in the meeting.
21:16:36 <tuxayo> #topic Updates from the Release Maintainers
21:16:42 <tuxayo> rmaints?
21:16:42 <wahanui> rmaints are lukeg, liliputech and tuxayo
21:18:12 <liliputech> lukeg: you go first maybe since u'r the upest-stream?
21:18:48 <tuxayo> #info last release of 20.11 went well. I haven't touched 21.05, I will have some catch up on it.
21:19:07 <tuxayo> Likely lukeg isn't there so go liliputech
21:20:09 <liliputech> #info keeping up with 22.05.x branch, first time doing a release. hope all is going to be well.
21:20:53 <fridolin> We see a few backports on https://git.koha-community.org/Koha-community/Koha/commits/branch/22.05.x
21:21:13 <liliputech> #info I will be afk for the whole next week, 21.11.07 might be a little delayed.
21:21:34 * tuxayo sent a last minute meeting reminder to the folks at Catalyst, last time it worked (last time I forgot to tell them in the 1st place there was a meeting at a good time for Oceania ^^")
21:22:17 <tuxayo> liliputech: thanks for the info, no problem, the release can wait a few days.
21:22:45 <tuxayo> Did you check you have all the accesses though? Like on the website to post the release announcement.
21:23:39 <liliputech> tuxayo: verified my access to git repo (working) and manage the backports so far but may need some training on other tasks
21:23:48 <tuxayo> That + ssh for download.koha-community.org
21:24:46 <liliputech> is that in the wiki? didn't read all through maybe. seen that string freeze is on 15 and release on 22 (generally speaking).
21:24:57 <liliputech> (or forgot...)
21:25:04 <tuxayo> liliputech: https://wiki.koha-community.org/wiki/Release_maintenance#Initial_setup
21:25:34 <rangi[m]> sorry, sorta here
21:25:45 <tuxayo> hi :)
21:26:08 <tuxayo> liliputech: Follow this to be sure you have the right access. Because some can take a few days because only one person has the rights.
21:26:33 <fridolin> liliputech: we can meet to see how goes the backport and also for first release
21:26:46 <tuxayo> #action tuxayo add requesting access for ssh access for download.koha-community.org in Initial_setup of rmaint doc
21:26:54 <liliputech> focused on git, got to catchup my training on everything else. thx for the alert tuxayo! thx fridolin for the meeting proposal :)
21:27:26 <tuxayo> moving on?
21:27:39 <tuxayo> yw liliputech
21:28:02 <tuxayo> #topic Updates from the QA team
21:28:05 <tuxayo> qa_team?
21:28:05 <wahanui> i guess qa_team is cait, marcelr, khall, kidclamp, kohaputti, lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova and Joubu
21:28:29 <cait> QA queue is a little high right now, focusing on bugs right now
21:28:39 <alexbuckley> #info Alex Buckley, Catalyst IT
21:28:44 <alexbuckley> apologies for the late arrival!
21:28:50 <cait> 17 bugs waiting for QA atm
21:28:53 <tuxayo> hi :)
21:29:20 <alexbuckley> :)
21:29:26 * fridolin made its first passed QA and first failed QA
21:29:40 <fridolin> still warming up
21:29:42 <cait> we have a great team for this cycle and looking forward to see things moving smoothly
21:29:47 <tuxayo> Ah yes, focusing on bugs and not enhancements.
21:29:54 <fridolin> sure
21:29:57 <cait> yes, fridolin++ and aleisha++ too
21:29:58 <tuxayo> (17 bugs waiting)
21:30:11 <cait> for being 'new' on the team and QA'ing patches
21:30:25 <fridolin> focus on Recalls children bugs
21:31:37 <tuxayo> anything else?
21:31:37 <wahanui> anything else is necessarily going to be incremental.
21:32:16 <tuxayo> wise words about recalls indeed wahanui
21:32:18 <cait> hm nope
21:32:34 <liliputech> :)
21:33:10 <davidnind> #info Omnibus bug for recalls: Bug 29734 - [OMNIBUS] Recalls for Koha
21:33:33 <tuxayo> thanks
21:33:45 <tuxayo> #topic Status of roadmap projects
21:34:12 <tuxayo> #link https://annuel.framapad.org/p/koha_22.11_roadmap Roadmap
21:35:19 <thd> Finishing some scripts for wiki update testing.
21:35:38 <fridolin> cool
21:36:03 <tuxayo> #info Tomas in an email: «Feel free to comment there or add the things you plan to work on during this cycle. If there are already bugs filed, please add links to them as well.»
21:36:35 <thd> Difficult to catch two days of concentrated time with extra work.
21:37:31 <mtj> hi thd, shall we colab via irc to work on the wiki project?
21:39:08 <aleisha> sorry im so late!!
21:39:22 <tuxayo> no problem, hi :)
21:39:24 <aleisha> #info Aleisha Amohia, Catalyst IT Wellington New Zealand
21:39:34 <fridolin> great to see you ;)
21:40:10 * fridolin waves across ocean in direction to NZ
21:40:13 <thd> Sure mtj
21:40:20 <aleisha> :D
21:40:43 <tuxayo> #topic Actions from last meeting
21:40:53 <tuxayo> «fridolin audits major and critical bugs (new, assigned and need signoff) »
21:41:00 <tuxayo> I guess that was for the release ^^
21:41:11 <tuxayo> #topic General development discussion (trends, ideas, ...)
21:41:33 <cait> mtj++
21:41:46 <tuxayo> #info «Status of the LTS release: It looks like we are no longer supporting 19.11, does this mean we have a new "LTS" version now or has the idea been dropped? (LTS workflow proposal)»
21:42:15 <cait> that one was from me
21:42:19 <tuxayo> 19.11 was never declared LTS last cycle, it's was like bonus ^^
21:42:30 <cait> we had it as lts on the docs page
21:42:32 <mtj> thd, we have an element/matrix gateway to koha-irc too (if prefered)
21:42:35 <cait> and maybe some othe rspots
21:42:38 <tuxayo> :o
21:42:44 <cait> i noticed when updating
21:42:46 <aleisha> catalyst isn't maintaining it anymore
21:42:51 <cait> yes, that's ok
21:42:54 <liliputech> #info BibLibre deploys 21.11 to it's clients lately.
21:42:54 <davidnind> #info LTS workflow proposal https://wiki.koha-community.org/wiki/LTS_workflow_proposal
21:43:22 <cait> I think we had discussed to do 3 years and it was now 2.5 which is still pretty good. I liked the idea of an LTS and maybe we could decide what the next LTS to be would be?
21:43:42 <tuxayo> I advanced quite a bit on that document but at some point my brain exploded trying to find all the posibilites.
21:43:59 <cait> same here
21:44:04 <fridolin> we may define 21.11 as LTS if someone stiks to it
21:44:10 <cait> I fail to see which would be hte logical next one for an LTS
21:44:22 <cait> I think the oldstable would make sense
21:45:03 <liliputech> cait: oldstable is now 21.11?
21:45:12 <tuxayo> I having an LTS with 3 RMaint and leaving the possibility to upgrade every year. From XX.11 to XX.11 or XX.05 to XX.05 isn't possible
21:45:17 <cait> because stable is 22.05
21:45:26 <aleisha> i agree 21.11 would be a good one
21:45:47 <tuxayo> There need to be some restriction in the posibilites for instances admins
21:45:47 <cait> i think bws is also updating to 21.11 or preparing for it?
21:46:21 <liliputech> fridolin: when you mean getting someone stix to it, you mean the Rmaint should be same for the 3 coming years?
21:46:26 <davidnind> so maintained for 2.5 years, then oldstable at that time becomes the next LTS? Should be a specific role for LTS version?
21:46:51 <cait> i think you'd be Rmaint LTS :)
21:47:15 <fridolin> liliputech: its a discussion to have on how/who indeed
21:47:39 <cait> i think 2.5 would be ok too if that is how it comes out now
21:47:41 <liliputech> cait: who's that "you" you're talking about?
21:47:54 * liliputech looking other his shoulder, seeing no one ^^
21:48:01 <fridolin> maybe  a specific role that takes action when version is older than oldoldstable
21:48:04 <davidnind> liliputech: I don't think it means it should be the same person for 3 years - just that someone fills the role each cycle
21:48:14 <fridolin> +1 ^
21:48:15 <liliputech> ok :)
21:48:21 <cait> ah :) we already have a 21.11 maint now
21:48:31 <cait> if no one signs up, I might be willing to put my hat in later on
21:48:46 <davidnind> over time, there should be fewer and fewer items to backport - apart from security bugs
21:49:03 <tuxayo> > specific role for LTS version
21:49:03 <tuxayo> Maybe that should be the way. Having a role because we struggle to find 3 Rmaints but actually LTS RMaint is much lighter than stable and oldstable
21:49:11 <cait> yes, I think in a year it's mostly watching for security bugs
21:49:54 <liliputech> i think it's good to have rolling roles for each individuals to get better overall knowledge and thoughts on the global process
21:49:54 <cait> I tihnk waht I meant to say is that it's an RMaint role like the others, but a little lighter as we gt more and more careful with the older versions
21:49:55 <fridolin> https://hea.koha-community.org/systempreferences show 21.11 has more than 2000
21:50:26 <tuxayo> > it's mostly watching for security bugs
21:50:26 <tuxayo> That and big tickets about compatibility, like to still work with a sported ElasticSearch version for example.
21:50:46 <tuxayo> In a sense, it's security also.
21:50:57 <cait> 19.11 has some 'peek' in the data too
21:51:12 <cait> yes
21:51:14 <tuxayo> peak?
21:51:19 <cait> api stuff like that, breaking changes
21:51:23 <cait> maybe peak
21:51:53 <liliputech> cait
21:52:00 <cait> yes?
21:52:00 <wahanui> yes is something different :)
21:52:06 <liliputech> breaking changes? in an LTS?!
21:52:25 <cait> someone makes a change in an api we support
21:52:29 <cait> so it stops working in the version
21:52:45 <rangi[m]> ie amazon change their bookcovers
21:52:49 <cait> yes
21:52:51 <tuxayo> Could the LTS have an irregular release schedule? Otherwise, most of the work is making releases empty of commits but with just translation update.
21:52:52 <rangi[m]> then yeah we would have to backport it
21:52:54 <liliputech> cait: ok, that kind of breaking change (not on our side that means :))
21:53:02 <cait> i think if there is nothing, you don't release that month
21:53:21 <cait> maybe just put a note up in the wiki
21:53:23 <liliputech> rangi[m]: +1
21:53:35 <rangi[m]> 19.11 could still be lts if someone else wanted to take it over, there was nothign to release this month
21:53:44 <cait> and urgent security woudl trigger an out of schedule release as well
21:53:51 <tuxayo> Ah yes
21:54:59 <tuxayo> So LTS RMaint could be a very little commitment if one sticks only to security and big breaking issues and releases only when needed.
21:55:20 <cait> a watching role and maybe triggering devs to make patches fit the old version yes
21:56:15 <fridolin> like a wine-maker, looking at good millesimes ^^
21:56:22 <cait> heh
21:56:34 <davidnind> so, (1) LTS = 2.5 to 3 years (2) oldstable (which is now 21.11) or 19.11? (3) LTS role for each cycle (4) Mandate = security + things that are broken (APIs (external), dependencies (such as Elasticsearch), etc) (5) Irregular release - only when something is needed
21:56:41 <cait> so... do we agree on making 21.11 the next one labelled LTS?
21:56:49 <tuxayo> Yes, there is this more spread out commitment that for the few patches, it might be more effort to backport so far in time.
21:56:51 <liliputech> agreed
21:57:12 <cait> devs should help with that, but RMaint can alert
21:57:17 <davidnind> cait: +1
21:57:52 <cait> for onw 21.11 will still be a normally maintained release... and it will age like good wine :)
21:57:55 <tuxayo> Yes, spread out as in falling to other people, the devs of the most critical patches
21:58:08 <tuxayo> that looks a great summary  davidnind
21:58:27 <liliputech> davidnind: +1
21:58:42 <cait> mayve #info it?
21:58:58 <liliputech> #info Hello,
21:58:58 <liliputech> Les requêtes sont toujours de la forme :
21:58:58 <liliputech> https://websvc.afi-sa.net/afi_opac_services/main.php?auteur=Thom+Yorke&width=492&src=c4c56f81d3a566e7c11bf99f78591edc&api=2.0&action=7
21:59:01 <liliputech> Pour la table de correspondance entre la valeur du paramètre action et le type de donnée demandée au serveur de cache (vignette, bande-annonce, etc...):
21:59:04 <liliputech> https://git.afi-sa.net/afi/websvc/-/blob/master/php/fonctions/_define_services.php
21:59:06 <liliputech> Pour celle correspondant au types de doc (Document vidéo, livre, périodique), le README indique la correspondance :
21:59:07 <tuxayo> he he
21:59:09 <liliputech> https://git.afi-sa.net/afi/websvc/-/blob/master/README.md
21:59:13 <liliputech> yups...
21:59:29 <tuxayo> no objections to the summary, then:
21:59:40 <cait> maybe just to remove the19.11
21:59:46 <tuxayo> Ah
21:59:50 <cait> i think moving up now would be good
22:00:09 <tuxayo> Maybe we could call on koha-devel if someone would like to continue 19.11 following the above guidelines?
22:00:43 <tuxayo> Or just moving up
22:00:47 <fridolin> and at the same time recrute for 21.11 LTS
22:01:02 <davidnind> and add to mandate: only essential backports after it reaches ololdstable?
22:01:15 <fridolin> or we could fill that role in 1 year
22:01:17 <cait> but... we already have a recruit for 21.1
22:01:17 <cait> 1
22:01:24 <cait> no need now :)
22:01:29 <fridolin> yep i mean for 21.11 LTS
22:01:46 <liliputech> fridolin: time to choose when it becomes LTS :)
22:01:48 <cait> i think in one year, we just need to make sure, we continually have an Rmaint for it
22:01:50 <tuxayo> > and at the same time recrute for 21.11 LTS
22:01:50 <tuxayo> I guess you mean to advertise that in 11 months, it will be a need?
22:01:55 <liliputech> (that means, in a yr)
22:02:11 <fridolin> people maybe want now to know if it will be an LTS
22:02:17 <cait> I said I'd do it if needed, but secretly I hope it won't be much of an issue
22:02:24 <fridolin> like we know it for Ubuntu LTS
22:02:34 <cait> yes, advertise now
22:02:46 <cait> but i think we don't need to worry about having the RMaint for the full cycle righ tnow
22:02:48 <fridolin> they may choose this version instead of 22.05
22:03:15 <cait> we have liliputech for the next 6 months and then we go from there
22:03:18 <tuxayo> No need for 19.11, good, there are some changes with updatedabase format that could be tedious anyway
22:04:15 <cait> it's just a feeling - announcing a newer version LTS now might also give this some momentum
22:04:30 <tuxayo> Should we already mark on the website that 21.11 is LTS with the expected support timeframe?
22:04:42 <cait> I'd like that
22:04:49 <cait> not sure wher eto put it on the website...
22:04:53 <liliputech> I'll do my best :) I'll see if I'm willing to continue RMaint on LTS or oldstable later. have to discuss also within BibLibre what's best for us
22:05:12 <cait> at the moment it shows up here: https://koha-community.org/documentation/
22:05:38 <davidnind> so TS version summary so far, (1) LTS = 2.5 to 3 years (2) Start with oldstable (which is now 21.11)  (3) LTS role for each cycle (4) Mandate = security + things that are broken (APIs (external), dependencies (such as Elasticsearch), etc) + essential backports only once past oldoldstable (5) Irregular release - only when something is needed once past oldoldstable (6) Let everyone know what LTS is and what we mean for support (website, mail
22:05:38 <davidnind> ing list, manual section on supported versions, etc)
22:05:45 <cait> liliputech: sure! didn't meant ot tie you to it forever :)
22:06:04 <davidnind> so for such a long summary, hope haven't confiused things by adding oldoldstable
22:06:07 <liliputech> cait: maybe when i next release 21.11 i can advertise for this?
22:06:17 <cait> +1
22:06:36 * liliputech will try to keep that in mind
22:07:12 <tuxayo> So you will call it append LTS to 21.11 in the few relevant places?
22:07:39 <liliputech> tuxayo: +1
22:07:55 <davidnind> so for (3) to add LTS maintainer commitment is for the currently 6 monthly cycle
22:08:24 <tuxayo> I guess we can keep that
22:09:17 <cait> I think it doesn<'t need to be the same person all the tieme
22:09:25 <davidnind> shall I open a bug and include the summary and things we need to do, get feedback (for a short period) to refine, complete actions, and then update in the relevant places including sending to mailing list?
22:09:42 <davidnind> cait: that was what I was trying to reflect :)
22:09:53 <cait> sorry, late :)
22:10:01 <cait> it's late...
22:10:17 <tuxayo> davidnind: yes :D
22:10:22 <davidnind> cait++
22:10:26 <cait> a bug might be a starting poitn for changing the wiki and such
22:10:31 <cait> and the website
22:10:31 <wahanui> i heard the website was updated
22:10:38 <cait> so this is an agreed right?
22:10:49 <davidnind> wahanui: LOL
22:10:49 <wahanui> davidnind: sorry...
22:10:52 <tuxayo> +1 to ask if there are eventual objections/amendements in the list
22:10:54 <davidnind> +1
22:10:54 * fridolin has to leave in 10min
22:10:58 <cait> .... does that count as a radical decision being made? :)
22:11:12 <cait> probably not
22:11:13 <tuxayo> yes, I was thinking about that XD
22:11:33 <davidnind> #action davidnind to create bug to summarise discussions and next steps for LTS version of Koha
22:11:35 <tuxayo> So no changes in the website and wiki for now
22:11:51 <cait> if we want to ask for objections it needs to be via mailing list
22:11:54 <cait> bugs don't get seen
22:11:57 <tuxayo> #info LTS version summary
22:12:03 <tuxayo> #info (1) LTS = 2.5 to 3 years (2) Start with oldstable (which is now 21.11)  (3) LTS role for each cycle (4) Mandate = security + things that are broken (APIs (external), dependencies (such as Elasticsearch), etc) + essential backports only once past oldoldstable
22:12:21 <tuxayo> #info (5) Irregular release - only when something is needed once past oldoldstable (6) Let everyone know what LTS is and what we mean for support (website, mailing list, manual section on supported versions, etc)
22:12:32 <liliputech> shall i still advertise in next release?
22:12:35 <cait> so we should either ask on ML or make the changes
22:12:56 <tuxayo> davidnind: also advertise the ticket you open in the mailing list?
22:13:04 <davidnind> will do
22:13:36 <liliputech> we have to fix a deadline for NOGO response, otherwise you may get some late NOGO's (too bad for them?)
22:14:37 <liliputech> or mail is for advertisement, not for a vote?
22:14:41 <tuxayo> People are starting to get their annual leave so wait a few weeks if we want to be conservative?
22:14:45 <cait> deadlines always help to not have things get stuck
22:14:45 <davidnind> maybe for next 21.11 release indicate that it is proposed that 21.11 becomes the first(next?) LTS release - confirm or otherwise at next development meeting?
22:15:16 <cait> we can announce and deadline would be next dev meeting?
22:15:23 <davidnind> +1
22:15:27 <liliputech> ok for me
22:15:40 <cait> ook all mapped out:)
22:16:05 <cait> time to sleep :)
22:16:12 <liliputech> yup
22:16:17 <tuxayo> see ya
22:16:20 <cait> bye #koha :)
22:16:26 <tuxayo> #action davidnind request feedback for the above on the mailing list with next dev meeting (two weeks from now) as a deadline
22:16:47 <tuxayo> LTS topic wrapped up, right?
22:16:52 <liliputech> yep
22:16:54 <davidnind> yep
22:17:23 <davidnind> ...until the next time we discuss it
22:17:54 <liliputech> next time meeting?
22:18:01 <tuxayo> #topic Gitlab policy changes, register Koha as an Open Source project proper?
22:18:09 <tuxayo> no over yet ^^"
22:18:27 <tuxayo> #info see email discussion: https://lists.koha-community.org/pipermail/koha-devel/2022-May/047081.html
22:18:50 <fridolin> i bet we need Tomas for that
22:19:00 <davidnind> Defer to next meeting or go with consensus from mailing list discussion - which seemed to be apply
22:19:34 <tuxayo> #action tuxayo postpone topic Gitlab policy changes
22:19:48 <tuxayo> #topic bug Some highlights
22:20:02 <tuxayo> #topic Some bug highlights
22:20:13 <tuxayo> bug 28267
22:20:13 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28267 critical, P1 - high, ---, koha-bugs, NEW , Koha-common package upgrade problem from 20.05.xx to 20.11.04-1
22:20:26 <tuxayo> Oh, I should looks at that
22:20:31 <tuxayo> bug 30907
22:20:31 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30907 critical, P5 - low, ---, koha-bugs, NEW , List of checkouts won't load if item is recalled
22:20:33 <fridolin> the number of >= major is huge
22:20:40 <liliputech> from what i read : it can't be any of the koha service provider doing the action (non-profit). +do we actually use features advertised by gitlab in this program?
22:20:41 <aleisha> i can try and prioritise some
22:20:46 <fridolin> i've higlighted some critical ones
22:21:03 <tuxayo> bug 30899
22:21:03 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30899 critical, P5 - low, ---, m.de.rooy, Pushed to master , Upgrade sometimes fails at "Upgrade to 21.11.05.004"
22:21:09 <fridolin> if anyone can also walk to double check
22:21:46 <liliputech> that last one i will definitly have to backport
22:21:52 <tuxayo> liliputech: 30899 might be for interest for you
22:22:10 <liliputech> that's what he said :)
22:22:12 <fridolin> yep its a hot backport one ;)
22:22:43 <tuxayo> «it can't be any of the koha service provider doing the action (non-profit)»
22:22:43 <tuxayo> I feel we don't belong in the non-profit program, I'll say in the list.
22:22:50 <davidnind> liliputech: I think it is mainly the CD/CI minutes that we need, it would be the Koha Community applying
22:23:02 <tuxayo> thanks aleisha
22:23:03 <liliputech> davidnind: ok
22:23:28 <tuxayo> «do we actually use features advertised by gitlab in this program?»
22:23:28 <tuxayo> All our docker images are built by that IIUC
22:23:49 <fridolin> liliputech: looks like you may cherry-pick the commits from 22.05.x, they look identic to patches
22:23:54 <tuxayo> On every push on a stable branch, all the images for many OSes are built
22:23:55 <liliputech> davidnind: isnt the ci/cd handled by jenkins?
22:24:10 * fridolin has to go, have a nice day/night/between
22:24:16 <tuxayo> see ya
22:24:24 <liliputech> fridolin: waves
22:24:37 <tuxayo> liliputech: jenkins runs the tests but it uses the image built by GitLab CI
22:24:51 <liliputech> tuxayo: ok
22:25:40 <davidnind> liliputech: don't know, the manual needs the minutes (takes about 45 mins to 1 hour for each commit, unless we change to doing at set times)
22:25:59 <liliputech> 'kay
22:25:59 <tuxayo> Ah I forgot the manual
22:26:19 <davidnind> unless someone wants to setup and maintain a gitlab stack!
22:27:37 <tuxayo> Or find and instance that has CI and that could accept us for some money each month.
22:27:41 <tuxayo> *an instance
22:27:47 <liliputech> actually, some BibLibre's partner do host a gitlab instance :) and they use ci/cd. I don't know if they pay smthg for it though.
22:27:53 <liliputech> (AFI)
22:28:14 <tuxayo> that could be plan!
22:28:41 <tuxayo> Or hopefully hosting the CI isn't as hard as hosting a whole GitLab and we still have the repos on gitlab.com and the CI runs elsewhere.
22:28:53 <davidnind> should we set the time for the next meeting, and continue the discussion about GitLab on the mailing list until the next meeting?
22:28:57 <tuxayo> I think you can host your own running.
22:28:59 <tuxayo> ok
22:29:07 <tuxayo> #Set time of next meeting
22:29:09 <liliputech> hum. that must be discussed internally + that would make Koha depends on a single service provider...
22:29:37 <liliputech> I will discuss the matter with the team :)
22:29:53 <liliputech> (I mean the team hosting the gitlab instance)
22:30:13 <davidnind> I think the Koha Communities approach is to generally use free and open source software, or be able to "easily" run it ourselves if things "turn to custard"
22:30:29 <davidnind> ..Community's
22:30:42 <tuxayo> About the meeting in two week for Europe and Americas work hours, let's do the 22th then?
22:30:50 <davidnind> liliputech++
22:30:53 <davidnind> +1
22:30:58 <liliputech> Being part of gitlab opensource program may also bring some visibility and new fellow devs :)
22:31:24 <liliputech> er... can't be there on the 22th... will be in my afk week :(
22:31:34 <tuxayo> About the meeting in 4 weeks for Oceania and Americas work hours, the 6th of july and same hour? (21 UTC)
22:31:49 <liliputech> ok for the one on 6th july
22:32:10 <thd> Be careful that Gitlab service can bring in some features which are not free software when you do not self host Gitlab.
22:32:17 <tuxayo> +1
22:32:23 <liliputech> +1
22:32:28 <tuxayo> gitlab.com isn't the libre version
22:33:08 <tuxayo> #info Next meeting: 22 June 2022, 14 UTC
22:33:10 * liliputech keep in mind to discuss koha hosting on gitlab instance provided by BibLibre's partner AFI.
22:33:21 <davidnind> apart from the CD/CI minutes, I don't think we use any of the subscription only features
22:33:52 <tuxayo> #action liliputech discuss koha CI (docker image built + manuall build) hosting on gitlab instance provided by BibLibre's partner AFI.
22:34:34 <tuxayo> I've noted to set the same hour for meeting in 4 weeks.
22:34:37 <tuxayo> So we are done :)
22:34:43 <tuxayo> #endmeeting