10:01:15 <tuxayo> #startmeeting Development IRC meeting 9 March 2022
10:01:15 <huginn> Meeting started Wed Mar  9 10:01:15 2022 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:01:15 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:01:15 <huginn> The meeting name has been set to 'development_irc_meeting_9_march_2022'
10:01:33 <tuxayo> #topic Introductions
10:02:36 <tuxayo> #info Victor Grousset, Tuxayo Company Limited, France
10:03:02 <tuxayo> qa_team?
10:03:05 <tuxayo> qa_team is cait, joubu, tuxayo, marcelr, kidclamp, khall, tcohen, ashimema, nugged, kohaputti, petrova
10:03:08 <tuxayo> rmaints?
10:03:26 <tuxayo> i heard rmaints was khall_  , AndrewFH, wainui and tuxayo
10:03:48 <ashimema> sorry, just come out of another meeting
10:03:51 <Joubu> #info Jonathan Druart
10:03:54 <fridolin> #info Fridolin Somers, Biblibre, France
10:03:58 <ashimema> #info Martin Renvoize, PTFS Europe, UK
10:05:07 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_9_March_2022 Today's agenda
10:06:37 <tuxayo> #topic Announcements
10:07:00 <ashimema> hackfest?
10:07:14 <Joubu> refresh the meeting page, I've added some bullets
10:07:14 <fridolin> yey
10:07:25 <fridolin> Paul sent a mail about it
10:08:09 <Joubu> I've got permission from organiser to bring some homemade beers to drink after the work day ;)
10:08:22 <tuxayo> ^^
10:08:28 <fridolin> woooo coooool
10:08:29 <Joubu> I think that's the most important thing I had to say today
10:08:42 <ashimema> πŸ™‚
10:08:46 <fridolin> ;)
10:09:48 <cait1> #info Katrin Fischer, BSZ, Germany
10:09:50 <fridolin> So HackFest in Marseille is confirmed, see email from Paul and inscriptions doc
10:10:01 <fridolin> welcome cait1
10:10:06 <koha-jenkins> Project Koha_Master_U21 build #110: STILL UNSTABLE in 1 hr 1 min: https://jenkins.koha-community.org/job/Koha_Master_U21/110/
10:10:26 <tuxayo> #info Hackfest registration: email paul.poulain AT biblibre DOT com
10:10:50 <fridolin> i'll be there :D
10:11:15 <tuxayo> #info KohaCon 2022: In Lawrence, Kansas by koha-US. Please fill survey for attendance to help pick venue size
10:12:09 <cait1> do we have a link for the survey yet? I thought it was not published
10:12:10 <tuxayo> #info it should be (or should come) in the general mailing list
10:12:14 <cait1> ah :)
10:13:04 <tuxayo> #info KohaCon: the selected dates are September 20-23, 2022
10:13:31 <koha-jenkins> Project Koha_Master_U20 build #323: STILL UNSTABLE in 32 min: https://jenkins.koha-community.org/job/Koha_Master_U20/323/
10:14:39 <tuxayo> #info Koha Community Challenge https://runsignup.com/Race/CA/anywhere/KohaCommunityChallengeSpringintoFitness
10:14:59 <tuxayo> #info Bug Squashing Event in May: https://bywatersolutions.com/education/celebrate-open-source-with-this-bug-squashing-event
10:15:18 <tuxayo> #info In France there will be the a meeting event in May in OrlΓ©ans https://koha-fr.org/symposium-2022
10:15:29 <tuxayo> I think that's all!
10:15:42 <cait1> that's a lot :)
10:15:43 <ashimema> πŸ™‚
10:15:54 <fridolin> yep nice to see movement
10:15:55 <tuxayo> #topic Update from the Release manager (22.05)
10:15:55 <cait1> community++
10:15:59 <fridolin> and IRL events
10:16:04 <fridolin> ok me
10:16:06 <tuxayo> yes :D
10:16:19 <fridolin> Behavior with AnonymousPatron Bug 30007
10:16:19 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30007 enhancement, P5 - low, ---, tomascohen, RESOLVED FIXED, Make ->anonymize methods throw an exception if AnonymousPatron is not set
10:16:34 <tuxayo> fridolin: the mic is your's, you can use #info
10:16:45 <fridolin> just to expose that this means no anonymise with NULL as borrowernumber anymore
10:16:57 <cait1> I am not sure that worked in all places beore
10:17:12 <fridolin> indeed, tomas said that
10:17:18 <cait1> there are several older bugs dealing with problems with the anon-user not being set and we have added a warning on System information tab
10:17:27 <fridolin> i'm ok with the change but we must alert admin on that
10:17:31 <alohabot> 🎁 πŸ¦„ Koha 'master' packages pushed to 'koha-staging' repo  πŸ™πŸŒΆπŸ₯­
10:17:41 <tuxayo> mtj++
10:18:20 <fridolin> #info Beware behavior around AnonymousPatron with Bug 30007 pushed
10:18:33 <cait1> for everything user side a message would be nice - I thik we do that for the checkout privacy feature in OPAC and probably other places
10:19:18 <fridolin> yep it will be more for cronjob batch_anonymise.pl so admins
10:19:21 <fridolin> sys admins
10:19:24 <cait1> so in theory hopefully the exception would not happen?
10:19:31 <cait1> ok
10:19:33 <fridolin> indeed
10:19:47 <cait1> I am not sure, but i think the gui anonymize tool already had a warning
10:19:54 <fridolin> and when syspref fixed the missing are done
10:20:24 <fridolin> if every one agrees its cool
10:20:50 <fridolin> long live the Anonymous ;)
10:20:55 <cait1> might be worth checking the GUI tool for the functionlity does give some nice info
10:21:36 <fridolin> ok i'll test
10:21:53 <cait1> bug 6756 suggests it did indeed use to workw ithout the anon user
10:21:53 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6756 major, P5 - low, ---, jonathan.druart+koha, CLOSED FIXED, Patron anonymizing tool reports false success in anonymous patron not defined
10:22:54 <fridolin> #action fridolin checking the GUI tool for alter on AnonymousPatron
10:23:16 <fridolin> about https://wiki.koha-community.org/wiki/System_requirements_and_recommendations
10:23:35 <fridolin> i see we have Ubuntu 16.04. But there is no Jenkins.
10:23:38 <ashimema> I kinda feel like we aught to be setting up such a user on install automagically
10:23:42 <tuxayo> For 21.11
10:23:49 <fridolin> may we drop for this cycle ?
10:23:51 <ashimema> but hey, that would be too easy right πŸ˜›
10:23:59 <Joubu> 6756 is an old one :)
10:24:16 <fridolin> ashimema: indeed, we must have a user that will not be deleted
10:24:39 <Joubu> you cannot remove it already I think
10:25:06 <fridolin> with delete_patron.pl you can if its not a librarian
10:25:22 <fridolin> and expired
10:25:28 <koha-jenkins> Project Koha_Master_D9 build #1893: STILL UNSTABLE in 1 hr 16 min: https://jenkins.koha-community.org/job/Koha_Master_D9/1893/
10:25:29 <Joubu> "Unable to delete patron that is set as AnonymousPatron"
10:25:33 <Joubu> on the UI you cannot
10:25:53 <fridolin> good
10:26:31 <fridolin> maybe we should skip it in delete_patron.pl
10:26:58 <Joubu> we shouldn't deal with incorrect configuration, I thought we agreed on that already
10:27:02 <koha-jenkins> Project Koha_Master build #1939: STILL UNSTABLE in 1 hr 17 min: https://jenkins.koha-community.org/job/Koha_Master/1939/
10:27:25 <Joubu> if anonpatron is not set correct you get a warning on the about page, and it can explode elsewhere
10:27:57 <fridolin> but if its defined but not in staff and expired ?
10:27:57 <cait1> i like it better when things not explode, but I undertand it being easier
10:28:10 <Joubu> we should continue the discussion later, and move one. Or the meeting won't fit in 1h...
10:28:14 <cait1> ok
10:28:16 <fridolin> we should not delete it with CLI script
10:28:26 <Joubu> yes, I agree with that fridolin
10:28:29 <cait1> +1
10:28:39 <fridolin> ok i create a bug report
10:29:01 <fridolin> #action fridolin create bug report for skipping AnonymousPatron from delete_patrons.pl
10:29:18 <fridolin> tuxayo: "for 21.11" ?
10:29:28 <tuxayo> great thanks fridolin
10:29:41 <tuxayo> only 21.11 doesn't have CI for Ubuntu 16.04
10:29:48 <tuxayo> And master
10:29:50 <ashimema> we throw an exception in the object.. so it must be direct SQL somewhere if it's getting deleted
10:29:51 <ashimema> https://git.koha-community.org/Koha-community/Koha/src/branch/master/Koha/Patron.pm#L375
10:29:53 <ashimema> anywho
10:29:56 <fridolin> ok so drop support >= 21.11 ?
10:30:43 <fridolin> ahhh ashimema that must be new , thanks
10:30:45 <tuxayo> I guess we could
10:31:30 <ashimema> πŸ™‚
10:31:54 <fridolin> we at Biblibre have mandatory upgraded to Bionic 20.04 for 20.11
10:32:12 <fridolin> an 22.04 is comming (actually beta exists)
10:32:22 <ashimema> right.. so do we need a few more 'retired' logos on https://dashboard.koha-community.org/
10:32:48 <ashimema> as well as the wiki getting updated of course πŸ™‚
10:34:00 <fridolin> ah we dont have OS in HEA ?
10:34:06 <tuxayo> no
10:34:11 <fridolin> that would be usefull
10:34:29 <fridolin> at least perl version
10:34:31 <tuxayo> #action tuxayo update wiki to remove ub16.04 support for Koha 21.11 (and check if MariaDB versions should change also)
10:35:14 <ashimema> wowsers LTS really is L in Ubuntu land
10:35:58 <tuxayo> I'm not sure 16.04 is publicly supported. (their extended security maintennace) It might actually be EOL.
10:36:11 <ashimema> indeed
10:36:27 <ashimema> I agree we should officially remove our support though πŸ™‚
10:36:31 <tuxayo> fridolin: anything else from you?
10:36:43 <fridolin> nope continue
10:36:45 <koha-jenkins> Project Koha_Master_D12 build #94: SUCCESS in 45 min: https://jenkins.koha-community.org/job/Koha_Master_D12/94/
10:37:03 <tuxayo> Support might have been a copy paste from 21.05
10:37:11 <tuxayo> #topic Updates from the Release Maintainers
10:37:18 <tuxayo> rmaints?
10:37:23 <ashimema> I'm surprised we're supporting D9 still to honestly
10:37:29 <tuxayo> i heard rmaints was khall_ , AndrewFH, wainui and tuxayo
10:37:50 <tuxayo> ashimema: Koha_19.11_D8 is still enabled :P
10:38:01 <ashimema> lol
10:38:11 <fridolin> i've thought dropping also D9, but it is OEL in june 2022
10:38:11 <tuxayo> 20.11.x: nothing to report
10:38:34 <ashimema> LTS is, yes
10:38:47 <Joubu> 22.05 will drop D9, see bug 30194
10:38:48 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30194 enhancement, P5 - low, ---, tomascohen, Needs Signoff , Update required JSON::Validator version
10:38:49 <ashimema> standard EOL was 07/07/2020
10:39:00 <ashimema> excellent
10:39:15 <fridolin> mtj whas speaking reverting Bug 29881 in stable
10:39:15 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29881 blocker, P1 - high, ---, mtj, RESOLVED FIXED, Remove SQLite2 dependency
10:39:47 <fridolin> maybe include in this month release
10:40:24 <fridolin> we should reopen the bug and confirm RMaints
10:41:23 <tuxayo> Don't hesitate to email all of us RMaints for these kind of patches to be sure it's not missed if it's for this month's release
10:41:43 <tuxayo> moving on?
10:41:54 <ashimema> go for it
10:41:56 <tuxayo> #topic Updates from the QA team
10:41:58 <tuxayo> qa_team?
10:42:03 <ashimema> cait still here?
10:42:04 <tuxayo> qa_team is cait, joubu, tuxayo, marcelr, kidclamp, khall, tcohen, ashimema, nugged, kohaputti, petrova
10:42:16 <ashimema> grr.. I really wish we had the bots still
10:42:26 <ashimema> tuxayo++ for standing in for them :P#
10:42:35 <tuxayo> XD
10:42:38 <fridolin> tuxayo+++
10:42:49 <ashimema> QA numbers feel low to me this month so far
10:43:07 * ashimema hasn't managed to spend much time
10:43:17 <tuxayo> @later tell rangi we miss wahanui <3
10:43:17 <huginn> tuxayo: The operation succeeded.
10:44:31 <tuxayo> last call to review Bug 19532 , it will be pass QA this week if no one find anything off.
10:44:31 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19532 new feature, P1 - high, ---, aleisha, Needs Signoff , Recalls for Koha
10:44:48 * ashimema sits on hands
10:45:04 <tuxayo> aleisha++
10:45:04 <tuxayo> marcelr++
10:45:12 <koha-jenkins> Project Koha_Master_D10 build #549: STILL UNSTABLE in 31 min: https://jenkins.koha-community.org/job/Koha_Master_D10/549/
10:45:40 <tuxayo> moving on?
10:45:47 <ashimema> yup
10:45:55 <tuxayo> #topic Actions from last meeting
10:46:01 <tuxayo> Β«shall we share the slides with Koha General? Β»
10:46:03 <tuxayo> ???
10:46:15 <fridolin> Staff interface work ?
10:46:16 <tuxayo> Ah, GUI design?
10:46:19 <ashimema> this was the UX work
10:46:21 <ashimema> yup
10:46:34 <ashimema> did they not get shared already?
10:47:05 <cait1> i think only here
10:47:26 <cait1> Or I am not sure actually - there were a lot of comments from different peopl eon the slides, but I don't remember an email
10:47:43 <cait1> and sorry, got called away!
10:47:56 <fridolin> i dont see it in ML
10:48:10 <ashimema> me either now I look
10:48:10 <tuxayo> fridolin: "mediawiki blame" (tool doesn't exists) points to you for the addition of the topic to the agenda :P
10:48:16 <Joubu> https://lists.katipo.co.nz/pipermail/koha/2022-February/057429.html
10:48:35 <ashimema> aha, well found
10:48:54 <fridolin> ok thanks Joubu ^
10:49:46 <fridolin> next
10:49:47 <tuxayo> great thanks
10:49:55 <tuxayo> #topic General development discussion (trends, ideas, ...)
10:50:05 <tuxayo> We have anonymize/anonymise ; missing in https://wiki.koha-community.org/wiki/Terminology
10:50:51 <ashimema> We user american spelling right.. so it should be z
10:50:55 <cait1> i think that is covered by standardizing on AE
10:51:03 <fridolin> there is batch_anonymise.pl
10:51:08 <ashimema> mm
10:51:08 <tuxayo> rg --glob '!{*.po}' -i "anonymise" | wc -l
10:51:08 <tuxayo> 60
10:51:09 <cait1> no need to list all of those
10:51:11 <tuxayo> rg --glob '!{*.po}' -i "anonymize" | wc -l
10:51:11 <tuxayo> 163
10:51:28 <cait1> some of those might be file names
10:51:31 <fridolin> and since tehre is pseudonymize
10:51:51 <tuxayo> batch_anonymise.pl is the only find with "anon" in the name
10:51:59 <ashimema> I see no problem adding it to that list.. but I also agree it's covered by AE rules
10:52:11 <ashimema> QA spell checks should be spotting it.. shouldn't they
10:52:25 <ashimema> (though I found my spelling stuff wasn't working the other day and never got to the bottom of it)
10:52:50 <tuxayo> pseudonymize: good catch. Only the "ze" ending is used
10:53:28 <fridolin> it iz ze good form then ;)
10:53:54 <fridolin> create a bug report as start point ?
10:54:11 <tuxayo> yep
10:54:24 <Joubu> is that really high priority?
10:54:31 <fridolin> nope
10:54:43 <tuxayo> Ah, it's about terminology
10:54:46 <tuxayo> right
10:55:04 <fridolin> but i was puzzled when searching for anonymize and seeing i dont find the script
10:55:10 <Joubu> people will have to update their cronjob, etc.
10:55:26 <Joubu> it's work for us, for sysops, etc. What is the win here?
10:55:26 <tuxayo> Yes, renaming the cronjob might not be worth it
10:55:27 <fridolin> upgrade can do that no ?
10:55:41 <tuxayo> It's manual work
10:56:13 <fridolin> ok so just add to Terminology
10:56:15 <tuxayo> To renamed in the system cron config
10:56:18 <tuxayo> *to rename
10:56:28 <tuxayo> no objection to add it to Terminology?
10:56:37 <Joubu> it's handled in the Terminology already
10:56:47 <Joubu> "American English"
10:56:58 <cait1> fridolin: no
10:56:59 <Joubu> we won't list all the s/z words
10:56:59 <tuxayo> LOL it is indeed already
10:57:27 <tuxayo> Ah It's just ashimema that added it now
10:57:45 <fridolin> cool, so closed
10:58:04 <tuxayo> next
10:58:06 <tuxayo> Bug 30063 - Make the main patron search use the /patrons REST API route
10:58:06 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30063 enhancement, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Make the main patron search use the /patrons REST API route
10:58:24 <Joubu> from me, I have added 3 topics here
10:58:27 <cait1> I haven't had time for testing bigger patches lately :(
10:58:32 <Joubu> I have been working on the rewrite of *all* patron searches we have in Koha.
10:58:43 <Joubu> They are now using the REST API route and the different features brought by the DT wrapper.
10:58:46 <Joubu> bug 30063
10:58:56 <fridolin> i just pushed the on on reserves, its great
10:58:57 * ashimema aims to get back to that, and would love to see it finalised at or before hackfest
10:59:04 <Joubu> there is a remote branch for this last bug report, with all the children applied
10:59:13 <Joubu> I will try to maintain it up-to-date
10:59:29 <cait1> I hope to make some time during hackfest to virtually join you all
10:59:34 <Joubu> It's a goal we have been aiming for years, I really would like to see it receive the love it deserves :)
10:59:40 * ashimema needs to submit a list of stuff I want to get done and how I intend to do it to the boss for my hackfest submission
10:59:43 <ashimema> that one is on the list
10:59:49 <Joubu> There is one known bug, but it's an existing bug already
10:59:51 <cait1> but we have big migration going live next week, so not sure yet
10:59:52 <fridolin> Joubu++
10:59:55 <Joubu> which is not trivial to fix
11:00:15 <Joubu> The patch tree is quite huge but it's easy to test, and the code is much easier to read after than before (it's getting rid of C4::DT::Members!)
11:00:28 <Joubu> Any questions?
11:00:53 <Joubu> the known-bug-tricky-to-fix is bug 30165
11:00:53 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30165 major, P5 - low, ---, tomascohen, NEW , Several q parameters break the filters
11:01:18 <tuxayo> in the patch message: Β«* sticky header - Does not work (?)Β»
11:01:26 <fridolin> do you need big db tests ?
11:01:27 <Joubu> it's fixed later
11:01:40 <Joubu> no
11:01:48 <ashimema> I've been working with tcohen on the API q param related stuff
11:01:52 <ashimema> He's done some awesome work
11:01:54 <tuxayo> fixed: ok, no question then ^^
11:02:00 <Joubu> ha, and I wrote plenty of tests btw
11:02:07 <tuxayo> yay
11:02:14 <fridolin> marvelous
11:02:35 <Joubu> ok, next then
11:02:53 <ashimema> Great work Joubu
11:02:55 <ashimema> Joubu++
11:02:58 <Joubu> * React vs Vue vs nothing
11:03:09 <Joubu> I wrote two versions of the admin (CRUD) cities view, in React and Vue.
11:03:14 <Joubu> bug 30225
11:03:14 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30225 enhancement, P5 - low, ---, jonathan.druart+koha, In Discussion , Rewrite cities admin view in Vue
11:03:18 <Joubu> bue 30160
11:03:22 <Joubu> bug 30160
11:03:22 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30160 enhancement, P5 - low, ---, jonathan.druart+koha, In Discussion , Rewrite cities admin view in React
11:03:33 <Joubu> The idea was to provide an overview of what is possible and what is the minimum code required to make them work
11:03:40 <Joubu> I would like to use one of them to start the ERM project
11:03:50 <Joubu> It would be nice to integrate a new tech, and it will be easier as we are starting "from scratch"
11:04:03 <Joubu> However the sponsors are a bit reluctant if we don't reach a consensus (very) soon
11:04:05 <tuxayo> (30063 has UI tests, great!)
11:04:16 <ashimema> That's another on my hackfest list.. would like to sit down together and review it with the intention of making a decision there
11:04:18 <Joubu> So basically it's either now or never.
11:04:24 <tuxayo> ERM?
11:04:38 <ashimema> Electronic resource management
11:04:39 <Joubu> next topic
11:04:45 <ashimema> Like coral, but in koha
11:04:53 <tuxayo> :o
11:04:54 <Joubu> I am all for Vue now i think
11:05:01 <Joubu> questions?
11:05:02 <ashimema> oh cool
11:05:04 <Joubu> action?
11:05:36 <ashimema> I know vue better than I know react at this point.. but I don't know either well enough to really advocate
11:05:50 <ashimema> I want a feel for 'How quick can I, and therefore hopefully others, get up to speed and productive with it'
11:06:12 <Joubu> there are plenty of great tutorials, videos, etc.
11:06:17 <Joubu> web is full of examples
11:06:26 <Joubu> and I wrote examples with code you know, Koha
11:06:29 <ashimema> it's all about learning curve and productivity to me.. rather than getting bogged down in the gory technical details... certainly for Koha anyways
11:06:31 <ashimema> yeah..
11:06:33 <Joubu> so it's just a matter of time
11:06:44 <tuxayo> any takeaway on vue vs react from bug 15522 ?
11:06:44 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15522 enhancement, P5 - low, ---, koha-bugs, Patch doesn't apply , New interface for revamped circulation rules
11:06:53 <cait1> I thnk maybe we could give a strong recommendation from hackfest
11:06:59 <ashimema> do we think we have enough core devs at hackfest to make a decision there?
11:07:01 <cait1> and put it to official vote after?
11:07:35 <cait1> and also please thnk about starting dev documentation early on and keep it updated
11:07:36 <Joubu> I need to start to code now actually
11:07:45 <Joubu> so I am going to start with Vue
11:07:52 <Joubu> and come with a plan at the hackfest
11:08:01 <Joubu> but the decision will be made on my side already
11:08:05 <ashimema> excellent
11:08:08 <cait1> i thnk that would work but for moving it into a coding guideline that it is allowed/can be used it ight be nice to have a meeting vote on
11:08:17 <Joubu> and nobody is against one or the other anyway
11:08:26 <cait1> i don't think we wil get a veto
11:08:36 <cait1> as long as we don't seay we rewrite everthing to it tomororw :)
11:08:45 * ashimema can sway the sponsors in either direction Joubu.. I trust your knowledge, especially now you've clearly dug into both options
11:09:01 <Joubu> cait1: that's the thing, cait1. It will only be used for totally new code here
11:09:12 <Joubu> using full REST API routes for CRUD operations
11:09:22 <Joubu> and a framework to make thing smooth on the UI
11:09:22 <fridolin> makes sens
11:09:46 <Joubu> existing code won't be touched, and nobody will be forced to use/read/write code in this new module
11:10:04 <Joubu> ok, so, ERM
11:10:07 * ashimema throws full weight behind Joubu here.. we have all the right people on side I feel
11:10:17 <Joubu> Not much to say yet
11:10:24 <Joubu> but code has been written already, and more are coming
11:10:38 <Joubu> We will certainly communicate more about it in the next weeks. If you want to join us, just drop us an email!
11:10:45 <tuxayo> > and nobody is against one or the other anyway
11:10:45 <tuxayo> I don't remember something blocking for one or another in the previous Vue vs React talk when following 15522
11:10:47 <ashimema> is there a branch?
11:10:53 <Joubu> https://lists.katipo.co.nz/pipermail/koha/2022-February/057447.html
11:10:58 <Joubu> ashimema: nothing pushed yet
11:11:04 <Joubu> it's all dirty locally
11:11:16 <Joubu> and that's the thing.
11:11:17 <ashimema> I think the biggest block has generally been a lack of knowledge tuxayo
11:11:19 <ashimema> all good
11:11:28 <ashimema> just poke me when you want someone to look
11:11:37 <Joubu> to explain a bit, I have started with the "agreements", that can have several periods, users, etc.
11:11:58 <Joubu> I have started written the "old way", with jQuery ugly code to add/remove/modify the block
11:12:05 <Joubu> it's just crazy to continue like that
11:12:39 <cait1> Joubu: i know, sorry, getting distracted: I just want to add it to guidelines too and agree we can do that after you started/not epecting issues
11:12:42 <Joubu> so I am rewriting everything now using Vue, and we will see if it's a win, or if we don't continue
11:12:58 <cait1> it#s just somethign we chould also communicate/document - that's all )
11:13:19 <Joubu> yes
11:13:28 <Joubu> that's all from me
11:14:28 <fridolin> tanks for the news
11:14:48 <tuxayo> So the plan is no issues for Joubu to experiment. And with the feedback propose a guideline that any completely new interactive UI must be with Vue?
11:14:49 <ashimema> there is a wiki page for anyone interested https://wiki.koha-community.org/wiki/ERM
11:15:02 <ashimema> and specs are being written and refined regularly by the sponsors
11:15:24 <tuxayo> interactive UI => dynamic UI, i don't know how to say it well
11:15:38 <cait1> i thik we can cross the 'all have to' bridge a little later
11:16:05 <tuxayo> #info plan for and ERM in Koha https://wiki.koha-community.org/wiki/ERM https://lists.katipo.co.nz/pipermail/koha/2022-February/057447.html
11:16:15 <cait1> for now it's important we'll accept the Vue based code
11:16:21 <tuxayo> ok
11:16:33 <tuxayo> right because it's a big dep
11:17:23 <tuxayo> So, good for this topic?
11:17:37 <ashimema> I reckon so
11:17:42 <tuxayo> #topic Review of coding guidelines
11:17:47 <tuxayo> https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30072#c16
11:17:47 <huginn> 04Bug 30072: enhancement, P5 - low, ---, tomascohen, Pushed to oldstable , Add more holds hooks
11:18:23 <fridolin> "This works well and uses the reference passing style we now require (Is there a coding guideline for this yet?)" sais ashimema
11:18:23 <tuxayo> Is that about "reference passing style" ?
11:18:34 <ashimema> ah yes
11:18:36 <ashimema> I didn't check
11:18:37 <koha-jenkins> Project Koha_Master_D10 build #550: STILL UNSTABLE in 33 min: https://jenkins.koha-community.org/job/Koha_Master_D10/550/
11:18:59 <fridolin> is there an existing guide line, do we need one ?
11:19:36 <koha-jenkins> Project Koha_Master_D11_MDB_Latest build #816: STILL UNSTABLE in 54 min: https://jenkins.koha-community.org/job/Koha_Master_D11_MDB_Latest/816/
11:19:38 <ashimema> I reckon so..
11:19:59 <ashimema> after a whole series of bugs we settled on passing references to the hook calls
11:20:21 <ashimema> so that plugins run in a loop that use the same hook can get the relevant updated data
11:20:23 <Joubu> code won't work anyway, not sure it needs a coding guideline then
11:20:26 <fridolin> ah in order to do recursive call
11:20:54 <ashimema> we need to ensure, as QA people, that we catch cases where we're not passing a reference
11:20:56 <Joubu> or maybe it does I don't know, I wasn't in the loop
11:20:57 <ashimema> don't we
11:21:19 <fridolin> ok and hooks are not very often added
11:21:20 <koha-jenkins> Project Koha_Master_U_Stable build #397: UNSTABLE in 44 min: https://jenkins.koha-community.org/job/Koha_Master_U_Stable/397/
11:21:29 <ashimema> it works either way.. it's when you have multiple plugins it can cause issues without it being a reference
11:21:30 <ashimema> I think
11:21:32 <ashimema> indeed.. they're not often added
11:21:39 <ashimema> it's just something to be aware of in QA
11:22:04 <Joubu> so yes we need a guideline
11:23:02 <ashimema> https://git.koha-community.org/Koha-community/Koha/src/branch/master/Koha/Plugins.pm#L69
11:23:04 <fridolin> sorry i have to go, i'll read the end. Thanks a lot tuxayo for chairing
11:23:11 <ashimema> so there's already a note in the codebase about it
11:23:24 <ashimema> we just need to add that note to the guidelines I reckon to make sure we're all on the same page πŸ™‚
11:23:32 <ashimema> I can draft it up
11:24:00 <Joubu> it's more something for the "how to write plugins" page, if we have one
11:24:18 <tuxayo> But QAer might miss it then
11:24:18 <ashimema> well.. ish
11:24:21 <ashimema> probably both
11:24:32 <ashimema> how to write plugins and how to add hooks to core
11:25:16 <tuxayo> # action ashimema draft coding guideline about reference passing for plugins
11:25:29 <ashimema> πŸ™‚
11:25:33 <tuxayo> is that how I should write it?
11:25:54 <Joubu> without space
11:26:03 <tuxayo> (lol I work markdown syntax and the text is gigantic)
11:26:08 <tuxayo> #action ashimema draft coding guideline about reference passing for plugins
11:26:20 <tuxayo> ok it what to check the phrasing
11:26:24 <tuxayo> *it was
11:26:37 <tuxayo> no more topics?
11:27:02 <tuxayo> #topic  Set time of next meeting
11:28:28 <tuxayo> shoots, we don't know from Fridolin about the time.
11:28:50 <tuxayo> Let's assume same time then
11:29:00 <tuxayo> No issues?
11:29:14 <Joubu> in my understanding we were suppose to switch
11:29:31 <tuxayo> Alternate from this time to 15 UTC?
11:30:04 <tuxayo> *and
11:30:17 <tuxayo> date would be the 23th, the week before the hackfest
11:31:46 <tuxayo> Let's switch for the time.
11:31:49 <tuxayo> #info Next meeting: 23 March 2022, 15 UTC
11:32:30 <tuxayo> Might change if needed, don't forget to check the calendar or the dev mailing list the day before the next meeting
11:32:38 <tuxayo> #endmeeting