10:03:29 <Brooke> #startmeeting Development Meeting
10:03:29 <huginn> Meeting started Wed Feb 16 10:03:29 2022 UTC.  The chair is Brooke. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:03:29 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:03:29 <huginn> The meeting name has been set to 'development_meeting'
10:03:52 <ashimema> Development IRC meeting 16 February 2022
10:03:58 <Brooke> Welcome everyone, time for #Introductions
10:04:02 <ashimema> #link agenda https://wiki.koha-community.org/wiki/Development_IRC_meeting_16_February_2022
10:04:04 <Brooke> #topic introductions
10:04:17 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
10:04:17 <ashimema> #info Martin Renvoize, PTFS Europe, UK
10:04:18 <fridolin1> #Fridolin Somers, BibLibre, France
10:04:26 <ashimema> only partially here I'm afraid
10:04:37 <ashimema> fridolin1, do you still count as 'in france' ๐Ÿ˜‰
10:04:44 <Brooke> ashimema, you're surely functioning better than I ;)
10:05:03 <davidnind> #info David Nind, New Zealand
10:05:09 <fridolin1> I mean BibLibre is in France ^^
10:05:29 <oleonard> it's okay fridolin1 we won't come looking for you
10:05:36 <fridolin1> Katrin apologies (in wiki page)
10:05:37 <sodesvaux> Solene Desvaux, Biblibre intern, France
10:05:56 <fridolin1> salutation collรจgue
10:07:03 <Brooke> #info Announcements
10:07:14 <Brooke> it looks like we've a proposal from Koha-US for Conference
10:07:25 <fridolin1> great news indeed
10:07:32 <Brooke> https://wiki.koha-community.org/wiki/KohaCon22_Proposals#koha-US_Proposal
10:07:33 <fridolin1> https://wiki.koha-community.org/wiki/KohaCon22_Proposals#koha-US_Proposal
10:07:48 <fridolin1> There is still a vote running
10:08:00 <fridolin1> to decide full online or hybrid
10:08:11 <fridolin1> result 1 march
10:08:44 <fridolin1> Event for end septembre
10:09:02 <davidnind> Excellent!
10:09:25 <fridolin1> i'd love to travel to US again
10:09:55 <Brooke> #topic Koha Conference
10:10:12 <oleonard> The proposed location, Lawrence KS, is where I grew up! And it's the absolute middle of nowhere.
10:10:12 <Brooke> anything else for the record for the US Conference bid?
10:10:47 <oleonard> It's a lovely little university town, though
10:11:29 <Brooke> #topic RM's update
10:11:38 <fridolin1> yey
10:12:09 <fridolin1> i try to keep pushing rythme
10:12:22 <fridolin1> Jenkins should come green right now
10:12:40 <fridolin1> Work in staff interface to replace jQueryUI with Bootstrap, see Bug 29222 and children
10:12:40 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29222 enhancement, P5 - low, ---, oleonard, NEW , OMNIBUS: Replace the use of jQueryUI
10:12:46 <fridolin1> oleonard++
10:13:16 <ashimema> ๐Ÿ™‚
10:13:25 <oleonard> This will go more slowly than the datepicker replacement
10:13:31 <Brooke> #help UI replacement of jquery with Bootstrap
10:14:02 <fridolin1> I point it so new enhancements take this into acount
10:14:05 <ashimema> load me up for testing/qaing those oleonard
10:14:11 <ashimema> I'm on board with that project
10:14:15 <oleonard> I'm working on testing out an autocomplete replacement which should be ready to show soon.
10:14:20 <Brooke> ashimema++
10:14:31 <Brooke> oleonard++
10:14:54 <oleonard> #link Autocomplete library: https://tarekraafat.github.io/autoComplete.js/
10:15:42 <fridolin1> great, UI changes are always a good sign for a new version
10:16:02 <alohabot> ๐ŸŽ ๐Ÿ™Š Koha 'master' packages pushed to 'koha-staging' repo ... ๐Ÿฑ ๐Ÿ  ๐Ÿ’
10:16:09 <fridolin1> but underground changes are also important
10:16:42 <fridolin1> i see a line in wiki : Share proposal for staff interface redesign (oleonard, paul_p, lukeg, caroline, etc.)
10:16:50 <fridolin1> not from me i think
10:17:00 <Brooke> #topic Staff UI redesign
10:17:11 <Brooke> take it away Owen
10:17:21 <oleonard> I added that at the last minute yesterday
10:17:38 <fridolin1> ah ok
10:18:01 <oleonard> As I hope you all know, Paul has proposed a redesign of the staff interface, and has hired a designer to do the work
10:18:05 <Brooke> the committee is trying to walk the fine line betwixt having something to share and not sharing too much too soon
10:18:21 <oleonard> A group of us has been meeting to talk about the designer's proposals
10:18:44 <fridolin1> I see there is a mail in koha-devel "Staff interface redesign: Update"
10:19:12 * oleonard is looking for the links...
10:19:34 <Brooke> #info Thibault Petit has been recruited to assist with the redesign
10:19:50 <oleonard> Ah, here: https://docs.google.com/presentation/d/10f17dQiuyDKLlYfWy_cIAl_oNubCghh9q746LeEPVy0/edit#slide=id.g1155f3a071f_0_43
10:19:53 <Brooke> #info Biblibre is generously paying for at least a portion of the effort
10:20:08 <Brooke> #link https://docs.google.com/presentation/d/10f17dQiuyDKLlYfWy_cIAl_oNubCghh9q746LeEPVy0/edit#slide=id.g1155f3a071f_0_43
10:20:35 <fridolin1> We french like fashion ;)
10:20:49 <oleonard> Solene  (sodesvaux here) will be working on the implementation
10:21:15 <Brooke> sodesvaux++
10:21:21 <ashimema> ๐Ÿ™‚
10:21:23 <oleonard> The scope of the redesign is limited to *mostly* style changes
10:22:01 <oleonard> Global include files are included in possible structural changes, but other templates are not because of the extensive revisions required
10:22:12 * fridolin1 says wahoooo
10:23:15 <oleonard> We're bringing this particular design proposal because we (me, Brooke, paul_p, caroline, sodesvaux, lukeg) think this is the best option we've seen.
10:23:22 <ashimema> are there plans to create a style guide to adhere to ?
10:23:32 <Brooke> uniformity and consistency of the interface during implementation might be a bit of a sticky wicket
10:23:36 <ashimema> I'd love some additional clear guidance for devs
10:23:58 <Brooke> that is an excellent point, ashimema
10:24:27 <oleonard> ashimema: We are expecting some visual documentation from Thibault
10:24:35 <ashimema> okies
10:25:11 <oleonard> ashimema: Does Mark Gavillet have an irc username? He's been in the meetings as well.
10:25:13 <ashimema> anywhere we can de-duplicate/simplify UI elements is a win to me...
10:25:42 <ashimema> he's not around here much
10:25:57 <ashimema> he was velvetanchovy once upon a time
10:26:06 <ashimema> but I don't think he's really an irc person
10:26:29 <oleonard> I hope you all are looking through those slides right now.
10:26:49 * ashimema is
10:27:04 <oleonard> Besides color changes, one of the biggest differences in the proposal is the collapsing of the resident search header tabs into a smaller area in the header menu
10:27:29 <oleonard> Slide 11 shows the default and "clicked" state of that
10:27:46 <fridolin1> great
10:28:09 <fridolin1> (I have  a very small screen)
10:28:48 <Brooke> (but very large impact)
10:29:21 <oleonard> Our tentative plan, if there are no objections here, is to share these slides with the koha general mailing list next
10:30:08 <fridolin1> no objection
10:30:32 <Brooke> #action shall we share the slides with Koha General?
10:30:59 <davidnind> Looking very positive!
10:31:01 <ashimema> I'd say go for it
10:31:02 <Brooke> tapez maintenant or forever hold your peas ;)
10:31:03 <oleonard> We are trying to bring a strong proposal as an "official" recommendation to get feedback that hopefully won't devolve into endless nitpicking.
10:31:35 <oleonard> BUT we also want to hear any objections, because we know we are a small committee
10:31:49 <Brooke> It is safe to say that we welcome feedback but we do not welcome hair splitting
10:32:15 <davidnind> +10
10:32:32 <ashimema> silly question.. has RTL been considered?
10:32:37 <Brooke> I can speak for myself in saying that I am more than happy to have folks approach me with comments either here or over email or another forum
10:33:11 * ashimema isn't sure how that might affect things like 'readability of the all screen from the top-left to bottom right'
10:33:16 <oleonard> There are a lot of implementation decisions still to be made, and as Brooke mentioned the process of getting these changes approved will result in interface inconsistencies as patches are pushed gradually
10:33:26 <ashimema> indeed
10:33:40 <ashimema> I really like what you've brought to the table here
10:33:57 <ashimema> and I think the right core group is involved.. great work :0
10:34:17 <Brooke> It's hard to go wrong when Owen and Paul have joined forces
10:34:45 <oleonard> Would y'all like to have a round of discussion on the devel list before taking it to koha-general?
10:34:55 <Brooke> so I haven't heard any objections so far. Is that a fair characterisation?
10:35:21 <oleonard> I think at least a message to koha-general should wait a day or 3 while others who might have been at this meeting get a look at the slides.
10:35:30 <Brooke> aye
10:36:03 <Brooke> I was going to suggest that we send a mail to the list, stew until Saturdayish, then close by Tuesday so we can have summat for the next meeting Tuesday
10:36:27 <ashimema> sounds good to me
10:36:39 <davidnind> +1
10:36:46 <fridolin1> +1
10:37:26 <oleonard> Great, thanks everyone!
10:37:37 <davidnind> very exciting!
10:37:42 <Brooke> #info Next step: Send a message to General, wait 'til Saturday, return feedback to Committee by Tuesday
10:37:51 <Brooke> #topic Release Maintainer update
10:38:45 <fridolin1> rmaints
10:39:04 <oleonard> All sleeping?
10:39:26 <fridolin1> tuxayo is not a morning-fan
10:40:06 <fridolin1> This month release should by around 22 since its in the middle of the week
10:40:11 <koha-jenkins> Yippee, build fixed!
10:40:11 <koha-jenkins> Project Koha_Master_D11_CPAN build #533: FIXED in 37 min: https://jenkins.koha-community.org/job/Koha_Master_D11_CPAN/533/
10:41:15 <fridolin1> For 21.05 there is Bug 28832 to pick
10:41:15 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28832 major, P5 - low, ---, nick, Passed QA , [21.05] Batch modification always clears permanent_location if it is mapped in frameworks
10:43:12 <Brooke> beurk!
10:43:15 <fridolin1> we may continue
10:43:36 <Brooke> #topic QA Team update
10:44:11 <fridolin1> cait1: a quick message ?
10:44:28 <Brooke> she has a meeting conflict, alas
10:44:35 <ashimema> I've been concentrating on testing/qaing some of the bigger things this week
10:44:41 <ashimema> will get back to moving the queue next week
10:45:14 <ashimema> as ever, we need more people to keep on top of the queues.. ๐Ÿ˜‰
10:45:53 <ashimema> we're not in a terrible place.. 88 in the queue, 26 of which are bugs
10:45:56 <Brooke> #help More bug testers are always welcome
10:46:04 <ashimema> the NSO queue is high though.. 276
10:47:20 <Brooke> okay then moving along
10:47:23 <ashimema> Joubu is working on some fun things right now.. lots of API based improvements
10:47:45 <Brooke> joubu++
10:48:32 <Brooke> shall we do the roadmap project update then?
10:49:15 <Brooke> #topic Roadmap Projects Status Update
10:49:53 <koha-jenkins> Project Koha_Master_U21 build #90: STILL UNSTABLE in 46 min: https://jenkins.koha-community.org/job/Koha_Master_U21/90/
10:49:57 * ashimema hasn't been following the roadmap yet this cycle
10:49:57 <ashimema> oops
10:50:17 <fridolin1> ich i've not yet build something
10:50:35 <fridolin1> topics from previous cycle are still on the table
10:52:04 <fridolin1> i'll soon work on roadmap cause we are around midtime of release
10:53:37 <Brooke> wonderful.
10:53:56 <Brooke> there's no olde business excepting myself
10:54:13 <Brooke> #topic General Development Discussion
10:55:08 <Brooke> any cool ideas?
10:55:11 <koha-jenkins> Yippee, build fixed!
10:55:12 <koha-jenkins> Project Koha_Master_D11_MDB_Latest build #797: FIXED in 54 min: https://jenkins.koha-community.org/job/Koha_Master_D11_MDB_Latest/797/
10:55:25 <fridolin1> rewrite in PHP ?
10:55:29 <fridolin1> XD
10:56:03 * oleonard doesn't even know what the new hotness is, but knows it isn't PHP
10:56:20 <fridolin1> NodeJS ?
10:56:44 <davidnind> rust, possibly not python..
10:56:46 <ashimema> Rust
10:56:49 <ashimema> hehe
10:56:53 <fridolin1> We skipped several revolution
10:58:08 <Brooke> does anyone have a burning desire to discuss development trends?
10:58:32 <davidnind> at work they recently tuned off the mainframe, everything was written in cobol (nearly a 30 year old system)
10:58:51 <Brooke> better than high performance FORTRAN I suppose ;)
10:59:28 <fridolin1> RIP
10:59:46 <Brooke> #topic Review of Coding Guidelines
11:00:05 <davidnind> they did spend 1.5 ish billion (NZ dollars) though...
11:01:49 <fridolin1> Add a rule for Bug 29844
11:01:49 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29844 enhancement, P5 - low, ---, tomascohen, RESOLVED FIXED, Remove uses of wantarray in Koha::Objects
11:01:49 <ashimema> ?
11:01:57 <ashimema> nice
11:02:02 <fridolin1> I mean more Bug 29859
11:02:02 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29859 enhancement, P5 - low, ---, jonathan.druart+koha, RESOLVED FIXED, Favor iterators over as_list
11:02:11 <ashimema> excellent, thanks
11:02:32 * ashimema just mis-read that
11:02:40 <ashimema> yes.. we should add one
11:02:50 <fridolin1> add use get_column
11:02:54 <ashimema> also perhaps one for the wantarray removal too.. to make sure new one's don't creep in
11:03:30 <fridolin1> this could be in QA tools ?
11:03:34 <ashimema> we should also document, from tcohens email probably, when to use as_list and how the change affects how you can use variables in notices and other templates
11:03:42 <tcohen> good morning
11:03:58 <fridolin1> tcohen: welcome
11:04:16 <tcohen> I thought the meeting was 3 hours ago
11:04:21 <Brooke> good morning
11:04:32 <tcohen> Brooke!
11:04:32 <Brooke> there was a change of meeting time
11:05:14 <fridolin1> tcohen: ah but previous time was in 4 hours
11:05:24 <fridolin1> now your there ;)
11:05:29 <tcohen> I guess I got it all wrong ha
11:05:50 <fridolin1> we talk guide lines with Bug 29859
11:06:09 <koha-jenkins> Yippee, build fixed!
11:06:09 <koha-jenkins> Project Koha_Master_U_Stable build #379: FIXED in 1 hr 4 min: https://jenkins.koha-community.org/job/Koha_Master_U_Stable/379/
11:06:12 <fridolin1> could you write something ?
11:06:26 <ashimema> we agreed to re-write koha in rust tcohen
11:06:26 <tcohen> anyone raised concerns about calling .count many times on tmeplates?
11:06:44 <ashimema> I haven't here
11:06:50 <ashimema> but there is my bug about that for discussion
11:06:55 * ashimema is back to juggling meetings
11:07:40 <tcohen> ok, I can write some thing, fridolin
11:07:48 <fridolin1> thanks a lot
11:07:49 <Brooke> tcohen++
11:08:08 * ashimema can't find the bug number.. grr
11:09:25 <Brooke> okay last item on the agenda is to set a time for next meeting
11:09:36 <Brooke> #topic Next Meeting
11:10:00 <ashimema> bug 30017
11:10:00 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30017 enhancement, P5 - low, ---, oleonard, NEW , Should we prefer `loop.first` and `loop.last` over calling `variable.count` to reduce our DB hits
11:10:07 <ashimema> that was it.. but it can wait for next meeting at this point..
11:10:14 <fridolin1> there is general meeting on March 2
11:11:17 <fridolin1> do we add dev meeting also ? else it is March 16
11:11:57 <oleonard> Not the 9th?
11:12:33 <fridolin1> ok 9th is good
11:12:42 <ashimema> sounds ok to me
11:12:59 <Brooke> any conflicts with 9 March?
11:13:01 <ashimema> oh, we didn't mention hackfest.. hopefully some people will be there
11:13:20 <fridolin1> mmm no it is end march
11:13:34 <fridolin1> starts on March 28
11:13:41 <ashimema> sorry.. yes.. not a clash
11:13:47 <fridolin1> ah sure
11:13:55 <fridolin1> I'll be there !
11:14:02 <Brooke> specific time for 9 March anyone?
11:14:24 <fridolin1> i'd like to keep 10AM
11:14:35 <oleonard> Whose? :)
11:14:48 <ashimema> utc
11:14:49 <ashimema> I think
11:14:57 <fridolin1> general meeting is kept at 15PM
11:15:13 <fridolin1> yep UTC
11:15:17 <Brooke> so we're settled for 9 Mar 10 UTC
11:15:25 <Brooke> ?
11:15:26 <ashimema> perfec
11:16:14 <fridolin1> super giga
11:16:19 <Brooke> #info Next Meeting is 9 Mar 10 UTC
11:16:23 <Brooke> #endmeeting