15:04:07 <caroline> #startmeeting Documentation IRC meeting 2022-12-09
15:04:07 <huginn> Meeting started Fri Dec  9 15:04:07 2022 UTC.  The chair is caroline. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:07 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:07 <huginn> The meeting name has been set to 'documentation_irc_meeting_2022_12_09'
15:04:20 <caroline> #topic Introductions
15:04:29 <caroline> (please use "#info" in front of your introduction to have it show up in the automatic minutes)
15:04:42 <caroline> #info Caroline Cyr La Rose, inLibro, Quebec, Canada
15:04:49 <marie-luce> #info Marie-Luce Laflamme, inLibro, Montreal
15:05:26 <davidnind> #info David Nind, New Zealand
15:06:14 <caroline> ashimema, I think Aude is with you, rught? do you want to ping her?
15:06:15 <cait1> #info Katrin Fischer, BSZ, Germany
15:06:27 <ashimema> She is indeed
15:07:05 <ashimema> as is Lucy
15:07:08 <ashimema> I've just pinged them both
15:07:16 <caroline> thanks!
15:07:19 <ashimema> they were certainly intended to attend
15:07:26 <ashimema> probably just lost trck of time
15:07:45 <caroline> Yeah I saw Aude's message earlier, that's why I pigned you
15:07:50 <cait1> Aude was here earlier askign about the meeting, but I missed her
15:08:00 <caroline> me too :(
15:08:31 <caroline> I'll go on but they can join any time
15:08:40 <ashimema> hmm, neither of them are responding..
15:08:49 <ashimema> so yeah, go on without them
15:08:52 <ashimema> they'll join when they can
15:08:52 <caroline> #topic Review of action points
15:09:20 <caroline> Since there hasn't been a meeting in a while, we're starting over
15:09:29 <caroline> Thanks davidnind++ for organising this one!
15:09:50 <caroline> #info No action points, starting over!
15:10:07 <caroline> #topic Project updates
15:10:07 <davidnind> sorry about the late notice!
15:10:35 <caroline> I don't know If anyone wanted to take on a big project?
15:11:02 <caroline> I'm working on moving stuff from tools to cataloging to follow the new structure in Koha
15:11:30 <caroline> #info Caroline is moving cataloging tools from the tools chapter to the cataloging chapter
15:11:37 <ashimema> hugs caroline... apologies for doing that one and making docs a bit of a pain 😜
15:11:50 <cait1> be right with you - finishing a phone call
15:12:08 <caroline> I have been a bit busy with upgrades and migrations lately so I haven't been able to work on it, much, but I'm getting there
15:12:32 <davidnind> I've (finally!) been working on a couple of projects - have added updates to the agenda
15:13:01 <davidnind> Automated screenshots: have something working, now just a case of adding "tests" to generate screenshots
15:13:19 <caroline> #info David is working on automated screenshots
15:13:29 <davidnind> Happy to demonstrate at the next meeting - once I've added a few more, and written some example tests for common types of screenshots
15:13:58 <caroline> #info David is also working on a manual reorganization
15:13:59 <wahanui> okay, caroline.
15:14:20 <caroline> oops, you will be forever working on reorganizing the manual it seems
15:14:29 <caroline> David?
15:14:39 <aude_c> Hello, sorry for being late
15:14:49 <caroline> no, ok lol! I thought wahanui would answer me
15:14:51 <davidnind> Have also started some work on reorganising the contents - see bug 32391 - just added a screenshot, will shared a copy of the site for feedback
15:14:51 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32391 enhancement, P1 - high, ---, david, ASSIGNED , [DOCS] Reorganise the manual contents
15:15:02 <davidnind> hi aude_c!
15:15:13 <marie-luce> Do you have suggestions on where I could help?
15:15:22 <caroline> wow that is very nice davidnind!
15:15:57 <davidnind> is it a bit too radical?
15:16:15 <caroline> No!! I love it
15:16:26 <cait1> i haven't looked, just keep in mind that we need to link from Koha :)
15:16:48 <caroline> I think the modules will stay the same from what I understand?
15:17:13 <davidnind> Yes - I haven't changed the underlying pages
15:17:15 <ashimema> looks lovely
15:17:19 <davidnind> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=144530
15:17:37 <ashimema> I really like that
15:18:17 <davidnind> Also just noticed all my spelling errors!
15:19:06 <caroline> what would be the next steps to get this into the real manual?
15:19:46 <caroline> Think we could get it ready for 23.05?
15:19:53 <cait1> +1
15:21:12 <davidnind> Not too much more to do - just adding some text for the landing pages, and putting the contents under the right areas
15:22:18 <davidnind> I'll finish what I'm doing and then send around a message to the mailing list for feedback, if that would work?
15:22:43 <cait1> sounds good
15:22:48 <aude_c> sure
15:22:53 <cait1> davidnind++
15:22:55 <cait1> :)
15:23:00 <davidnind> Some work to do on the areas where we don't have any content - like the What's new and Getting started
15:23:03 <caroline> Would it impact other modifications that we do? Like if I push my big move from tools to cataloging, will it impact how I should do it?
15:23:11 <ashimema> davidnind++
15:23:21 <caroline> yep davidnind++ definitely!
15:24:13 <davidnind> No - as I'm just basically changing the index page at the moment and adding some new pages that don't exist
15:24:16 <cait1> if this affects mostly the contents page, that might not be a problem?
15:24:22 <cait1> :)
15:24:22 <caroline> alright!
15:25:13 <caroline> Ok well, keep us updated and let us know if/how we can help
15:26:08 <caroline> I think automated screenshots will be a big plus too, especially with the interface change
15:26:26 <davidnind> action David to finish work on reorganizing the manual and adding a landing page - send out to the mailing list for feedback (expect it to be iterative)
15:26:36 <caroline> #action David to finish work on reorganizing the manual and adding a landing page - send out to the mailing list for feedback (expect it to be iterative)
15:26:47 <davidnind> oops!
15:26:54 <caroline> #chair davidnind
15:26:54 <huginn> Current chairs: caroline davidnind
15:27:01 <cait1> I have a translation issue i'd like to discuss... if that could go on agenda somewhere?
15:27:08 <caroline> not sure if you needed that...
15:27:23 * ashimema thinks you could branch early this cycle and then publish your work in progress manual early too..
15:27:32 <davidnind> no, I didn't put in a #
15:27:43 <caroline> cait1, maybe in the Content development guidelines (..items for discussion, including any work flow issues..
15:27:43 <caroline> )?
15:27:50 <ashimema> thus you could merge that re-organisation nice an early to get feedback without affecting the stable manual
15:28:04 <cait1> let me know when it's a good moment? :)
15:28:05 <caroline> I also wanted to talk about branching
15:28:08 <lucyvh> Hi docs people - sorry I'm late
15:28:23 <davidnind> hi lucyvh!
15:28:40 <cait1> it's all good, you can #info yourself still if you want
15:29:32 <caroline> Ok I added a couple of thing to the agenda...
15:29:35 <caroline> moving on?
15:29:51 <cait1> do we have a link to agenda?
15:29:58 <caroline> crap sorry
15:30:00 <caroline> #link https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_2022-12-09
15:30:03 <lucyvh> #info lucy vaux-harvey PTFS Europe
15:30:14 <caroline> #topic What's been done so far
15:30:41 <caroline> A couple of months (?) ago we changed the system preference links
15:31:14 <caroline> We now have to link to the label, we can't link to the system preference itself
15:32:04 <caroline> iirc, the reason is that having headers as link targets made a bunch of errors when building the manual
15:32:18 <aude_c> #info Aude Charillon, PTFS Europe
15:32:37 <caroline> cait1, davidnind is this correct, do you remember?
15:33:25 <cait1> sorry, was just editing the agenda
15:33:43 <ashimema> ho.. did I break something with the sysprefs stuff
15:33:50 <ashimema> I thought I'd made the situation better rather than worse?
15:33:51 <cait1> it did resolve the errors, but I thinkt here was also a configuration change associated?
15:34:18 <cait1> ashimema: this is a different thing, not what you did with the direct link to pages
15:34:24 <ashimema> phew
15:34:39 <cait1> but you can no longer do ref::"prefname"
15:34:41 <cait1> or shoudl not
15:34:44 <caroline> I'm looking for the gitlab issue, just a sec
15:35:17 <cait1> I think we used some type of setting that auto-generated 'labels' for headings, but we had issues with translations and error handling
15:35:42 <caroline> this is what I'm talking about https://gitlab.com/koha-community/koha-manual/-/issues/18
15:35:42 <davidnind> that sounds right - you found a solution to getting rid of the duplicate label warning messages when buidling the manual
15:36:18 <cait1> ah right, so if you had a heading like "summary" that appeared in mulitple places, it created an error too
15:36:27 <cait1> because the headings and the auto-generated labels weren't unique then
15:36:32 <caroline> I also updated the reference guide on the wiki on how to link https://wiki.koha-community.org/wiki/ReStructuredText_-_Tips_and_Tricks#Internal_links
15:36:47 <davidnind> caroline++
15:36:58 <cait1> caroline++
15:37:23 <cait1> btw always happy to help with such clean-up tasks - if you have something similar let me know :)
15:37:32 <caroline> davidnind++ and cait++ for doing it so quickly! We managed to change all links to system preferences in an afternoon between the trhee of us
15:37:55 <caroline> (or in an evening, or morning)
15:37:59 <cait1> loved the interaction
15:38:16 <marie-luce> davidnind++, cait++ and caroline++
15:38:16 <caroline> It was great teamwork!
15:38:45 <cait1> and the manual now builts without errors!
15:38:49 <caroline> I haven't tried it recently, but it is now so much easier to see the "real" errors when building
15:39:02 <ashimema> nice
15:39:19 <caroline> #info links to system preferences have been changed in the manual
15:39:34 <ashimema> do let me know if you want ptfs-e help on those things too... lucyvh and aude don't lurk so much, but I can always poke them 😜
15:39:58 * ashimema just added a topic to the agenda after this one
15:39:59 <caroline> #info links to system preferences must now have the same format as links to everything else :ref:`SysPrefName <sysprefname-label>`
15:40:37 <cait1> in the process we also found and fixed other errors like broken links, so overall a good thing
15:40:37 <caroline> #info this change, related to gitlab issue 18, resolved a lot of errors when building the manual
15:40:53 <aude_c> yes, we can easily be found ;-) Very happy to help, just need clear instructions as I'm not very comfortable using the gitlab web interface yet
15:41:16 <caroline> tbh, I'm not comfortable with the gitlab interface either lol
15:41:31 <aude_c> haha, that re-assures me a lot! Thank you
15:41:33 * ashimema noticed there's considerations on using markdown later and was going to talk about making contributing easier then too
15:41:37 <cait1> with our big files it's often esier to edit locally - maybe that can be fixed as we go along with new toc etc
15:42:08 <davidnind> there isn't an easy way to keep your fork up-to-date now, as mirroring is now a paid feature
15:42:14 <cait1> davidnind: about your earlier topic: i think there is tons of screenshots to do... if this is something you could teach me and it makes sense, I'd be happy to help
15:42:22 <cait1> i just have no idea about Cypress etc right now
15:42:27 <ashimema> tl:dr I think we should stop encouraging use of gitlab editors and start advocating local more using nicer clear tools instead
15:42:33 <davidnind> so basically, you would have to fork each time, if you didn't want to set things up locally
15:42:53 <ashimema> indeed
15:42:58 <caroline> I think ashimema and I managed to get our mirrors going no?
15:43:01 <ashimema> vscode has some nice options for rst too
15:43:30 <ashimema> it's something you can still do if you forked before they changed their policies caroline.. but I don't know how long that will last
15:43:51 <aude_c> erm... what do you mean by setting things up locally?
15:43:56 <caroline> ok, ok... I have my setup made so that I don't need it
15:44:15 <ashimema> editing a copy of the manual on your own PC aude_c
15:44:20 <aude_c> does that mean Martin will have to spend some time with Lucy and I again to sort us out? :D
15:44:22 <ashimema> and then posting the change up
15:44:27 <cait1> then you can use your favourite editor basically
15:44:29 <ashimema> instead of trying to use the gitlab editor..
15:44:31 <aude_c> ok
15:44:33 <caroline> aude_c, https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual#Editing_the_manual_-_using_a_local_repository_and_editor
15:44:41 <ashimema> I find the gitlab editor changes too quickly and is rather difficult to use
15:44:53 <cait1> ashimema: I am sure ashimema would be happy to spend time with you ;)
15:45:04 <ashimema> yup
15:45:04 <caroline> But yeah, if ashimema could set you up, after that it's a couple of simple commands
15:45:10 <davidnind> I have experimented with using "GitPod" - basically gives you VSCode in the browser (don't have to install anything locally), you still have to use git though... (and is not quite open source - you get 50 free hours of editing)
15:45:13 <aude_c> thanks
15:45:20 * ashimema is actually going to get the new dev team here to start contributing too..
15:45:31 <ashimema> aim being all submissions from ptfs-e come with docs submissions included
15:45:46 <davidnind> ptfs-e++
15:45:52 <caroline> ptfs-e++ ashimema++ for ambition!
15:45:57 <cait1> if someone write docs and just needs help shaping them up for a git submittion, I am happy to help too
15:46:12 <cait1> I am not the best "writer" myself, but know the technical bits
15:46:27 <ashimema> I also now have a process that can take a google doc and turn it into rst without too much extra manual interaction in between
15:46:35 <ashimema> that is soooooooo much easier to work with
15:46:41 <cait1> oh that's is interesting
15:46:46 <cait1> coudl you share?
15:46:54 <cait1> caroline: be ready to action him ;)
15:46:54 <ashimema> once I write it up, sure
15:47:09 <ashimema> that's how we did ERM and Bundles submissions
15:47:19 * cait1 might have had to many meetings today already, sorry if I am being a little silly today
15:47:38 <caroline> lol!
15:47:54 <ashimema> what topic are we on.. I've lost strack
15:48:04 <cait1> Waht's been done so far
15:48:12 <cait1> but we moved into making it easier to edit I guess?
15:48:24 <caroline> yeah, I'm a bit lost to... bad chair!
15:48:25 <cait1> so maybe we shoudl move on officially .)
15:48:40 <caroline> alight https://dashboard.koha-community.org/ ? ashimema I think?
15:48:45 <cait1> caroline: I think we are to blame
15:48:49 <ashimema> I added 'dashboard' to the agenda very late.. you may have missed it..
15:48:52 <davidnind> I'll have a go at updating/finishing the Git guide - may need some help from the Git Gurus though
15:48:58 <ashimema> in short.. I added a documentation team leaderboard the other day..
15:49:22 <ashimema> it needs a little more work though as currently it only picks from the status change
15:49:28 <cait1> ashimema++
15:49:30 <ashimema> and doesn't know about the 'docs' section of bugzilla
15:49:43 <caroline> #info Martin added Documentation leaderboard to https://dashboard.koha-community.org/
15:49:52 <ashimema> but it's a start.. hopefully it'll encourage a bit of gamification of manual editing
15:50:27 <cait1> it also helps make people's work visible, love it
15:50:28 <ashimema> it rewards even just going through the 'Needs documentation' queue and triaging.. i.e. deciding it doesn't need a change so marking as RESOLVED
15:50:57 <ashimema> if you want to appear, when you do a docs thing, remember to update the bugzilla status to show it's been submitted 🙂
15:51:04 <ashimema> happy to accept any idea's on how to improve that process.. reduce the pain in any way
15:51:09 <ashimema> that's all i had to say
15:51:43 <caroline> #info to appear on the board, you need to change the status from Needs Documenting to RESOLVED
15:52:30 <caroline> Cool! Thanks ashimema++ !
15:52:40 <davidnind> ashimema++
15:52:40 <caroline> You do so many things behind the scenes
15:53:13 * ashimema might be a bit addicted to Koha ;P
15:53:18 <caroline> #topic Content development guidelines
15:53:40 <caroline> davidnind, Any interest in being able to use Markdown to make it easier to contribute (for new sections anyway) - have been experimenting locally using the MyST parser
15:54:08 <cait1> how would that work? would we need to make changes to the build process?
15:54:21 <cait1> also translations scripts etc.?
15:54:36 <ashimema> honestly.. I love markdown.. but I don't think it's different enough to rst to really warrant it..
15:54:54 <cait1> hm it's a point
15:55:11 <cait1> i think markdown is also more a thnk devs know already, but others might still have to learn
15:55:21 <davidnind> it basically lets you use Markdown (with some constraints) for new pages - basically a package like the theme - was really simple to setup
15:55:23 <ashimema> personally I'd stick with rst and instead of trying to introduce markdown, focus on what editors can do to help people..
15:55:37 <ashimema> like using google docs and then running it through a script to convert to RST..
15:55:50 <ashimema> or using a more wysiwyg editor for rsy in vscode.
15:56:46 * ashimema has been experimenting a little with vscode plugins and they do make the process a little simpler.. not quite WYSIWYG yet.. but closer
15:57:33 <cait1> It woudl be nice, but wonder if it coudl also be confusing to someone
15:57:36 <ashimema> google docs is by far the easiest for end users.. but the little fixes required after using pandoc to convert it to rst are vaguely erksome.. but not terrible
15:57:41 <cait1> you'd have to learn 2 syntax depending on what you want to edit
15:57:56 <ashimema> cait1++
15:57:57 <davidnind> I personally think it is easier using markdown than rst, headings are a lot easer - but apart from links/references pretty much similar
15:57:58 <ashimema> that's my thoughts too
15:58:11 <cait1> but if we want to do it, i'd love a test run with the tarnslation tools done first
15:58:16 <cait1> because they can be finicky too
15:58:47 <cait> woudl be switching the whole manual be an option?
15:58:58 <cait> are there rst features that don't transport to markdown?
15:59:17 <davidnind> hadn't thought of that for translation - happy to see what is required
15:59:45 <cait> like... creating our labels or so? I don't really know, just wondering what we should check on for a switch
16:00:08 <caroline> What is the + of a switch? Is it just the headers?
16:00:44 <davidnind> I've had a couple of goes at converting using command line tools - seemed pretty straight forward
16:01:18 <luvyvh> I find rst fine for the small edits I usually do
16:02:42 <davidnind> I just think it is a bit more straight forward, one less thing to learn - headers, paragraphs, links/refers/images/notes/warnings etc
16:03:03 <davidnind> Happy to leave for the moment if you are okay with rst
16:03:05 <cait> I think using both in parallel... might not be ideal, but I'd be open for switching to markdown for the whole manual
16:03:06 <caroline> Do we have a consensus that rst is not that bad and a switch would require a lot of tweaks?
16:04:15 <davidnind> I'll do some more work - and share a copy - no real tweaks required 🙂
16:04:17 <caroline> We are already overboard on time, but I think since this is the first meeting in a while, it's ok to go over?
16:04:30 <cait> ok for me
16:04:44 <davidnind> I'm OK
16:04:51 * ashimema will be around a little longer too
16:04:59 <luvyvh> I can stay for another 10 mins
16:05:14 <caroline> ok, so is there a decision about markdown?
16:05:48 <cait> maybe revisit?
16:06:51 <davidnind> Happy to revisit once I've done some more work, but consensus seems to be to stay with rst
16:06:55 <caroline> #action davidnind to check scripts and translations tweaks for a switch to markdown and report back
16:07:03 <caroline> is that ok?
16:07:13 <davidnind> caroline++
16:07:26 <caroline> Next is Translation issues for system preferences - Bug 29063 cait?
16:07:26 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29063 major, P5 - low, ---, david, ASSIGNED , [DOCS] Manual: Translation issue with repeated strings in system preferences
16:07:35 <cait> Right, maybe this is a Gemran issue
16:07:52 <cait> So we have something like: Asks: ___ cash registers with the accounting system to track payments.
16:08:00 <cait> with ___ being Don't use, Use
16:08:22 <cait> I can't change where the ___ goes in Koha, so I often don't do a literal translation of use/don't use
16:08:27 <cait> to make the grammar work
16:08:47 <cait> that's means... my Don't use/Use translate to a lot of different things
16:09:07 <cait> but... in the manual translations, they only show up one time for all preferences...
16:09:21 <cait> so I am stuck
16:09:29 <cait> which is the main reason we haven't finished the manual translation to German yet
16:09:34 <cait> it just doesn't work for the preferences
16:09:35 <caroline> Hm... it's a bit tricky
16:09:44 <cait> are we stuck on how we format those?
16:09:56 <cait> I mean... could we imagie doing something like...
16:10:22 <cait> [Use|Don't Use] cash registers with the accounting system to track payments. Default: Use or so?
16:10:27 <cait> instead of the multi-line thing?
16:10:49 <caroline> mkay, what about those with more options thatn two?
16:10:58 <cait> good question
16:11:07 <caroline> like opac|staff interface|staff interface and opac|none
16:11:15 <cait> I am happy to rewrite to whatever... but I need the strings to differentiate more
16:11:44 <cait> and hoped you'd have ideas...
16:11:56 <cait> for Koha the po files are built in a way that allows it, but the manual doesn't reflect that
16:12:10 <cait> the pref strigs for one pref are all separate, even same strings are not mixed together
16:12:19 <cait> because I believe not only German had that issue...
16:12:38 <caroline> I understand the problem, I'm just not sure how to go about solving it
16:12:41 <aude_c> no, I can imagine it happening in many languages
16:13:05 <cait> is there a way to add context maybe?
16:13:10 <cait> like we started to do in koha?
16:13:27 <caroline> We could ask julian maybe?
16:13:41 <caroline> I think he was the one who did the context in Koha
16:13:53 <cait> it might be tied to TT
16:14:27 <cait> as said, I'd be happy to take on the task to update the manual for all the prefs - but I need some help figuring out a solution
16:14:51 <caroline> #info The problem in bug 29063 is that while in Koha strings for each syspref are separate and can be translated differently, in the manual, they are all bunched together
16:14:51 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29063 major, P5 - low, ---, david, ASSIGNED , [DOCS] Manual: Translation issue with repeated strings in system preferences
16:14:52 <davidnind> so we need to indicate that the option values should be translated individually, so they can be done in context?
16:15:12 <cait> if we want to keep the current format I think so
16:15:18 <cait> #link https://koha-community.org/manual/22.11/en/html/accountspreferences.html for an example
16:15:37 <cait> every line goes in po, lines that are exactly the same, can only be tranlstaed ones
16:15:39 <cait> once
16:16:09 <cait> Example: CheckPrevCheckout - Do, Do not ...
16:16:27 <cait> a Do without context... is hard, can be mulitple things really
16:17:05 <cait> the context also need to be visible in the po of course... so you see which pref you are trnslating it for
16:17:22 <caroline> #info current options 1) write the system preference descriptions as "[Use|Don't use] blah blah" 2) somehow add context to the strings like we do in Koha 3) somehow change how the strings are extracted so that each syspref is extracted individually like in Koha
16:17:34 <caroline> does that summarized it?
16:17:38 <cait> yep
16:17:40 <cait> nicely
16:17:59 <cait> as said, happy to volunteer for the foot work... but need help :)
16:18:07 <caroline> We can do 1) on our own, but we need dev for 2 and 3
16:18:34 <caroline> I'll add the options to the bz
16:18:42 <cait> thank you
16:18:49 <cait> maybe it will trigger some ideas/attention too
16:19:05 <reiveune> bye
16:19:46 <cait> ok to move on
16:19:59 <caroline> Branching was my topic
16:20:08 <caroline> I know we have this debate every cycle
16:20:16 <cait> heh
16:20:40 <caroline> Do we branch right away at the same time as Koha, even if the manual doesn't reflect that version of Koha, or do we wait later?
16:21:09 <cait> wodners if the manual link still works without branching
16:21:15 <cait> I'll quickly check in oe of the demos
16:21:15 <caroline> I said before that we don't have the (wo)manpower to cherry-pick everything like they do in Koha
16:22:26 <caroline> So branching early would mean that the manual for that version would not reflect 100% the functionalities in Koha, this is already the case however since we are so behind
16:22:35 <cait> 22.11 links to the manual nicely it looks like: https://koha-community.org/manual//22.11/en/html/ works
16:22:53 <caroline> wasn't it for translations that you wanted to branch?
16:23:08 <davidnind> There are about 90 odd bugs in the needs documenting queue, so I would suggest leaving for a little
16:23:10 <cait> hm yes, that's a thing
16:23:16 <cait> there are no translated manuals before branching
16:23:23 <davidnind> My focus for the next little while will be working through these
16:23:52 <cait> bit, this appears to still work at least: https://koha-community.org/manual//22.11/de/html/serials.html
16:24:04 <caroline> pros of branching early: access to translations
16:24:29 <caroline> pros of branching late: more functions are documented
16:24:56 <davidnind> I'm still confused about how things should happen https://wiki.koha-community.org/wiki/Documentation_management#Translating_the_manual
16:24:59 <caroline> cons of branching early: little chance of every functionality being cherry-picked for each version
16:25:02 <cait> we also need to push po files to the repo again - those you see above should have been mostly translated actually :(
16:25:42 <cait> looking at the wiki link davidnind posted:
16:25:48 <cait> 4. Translation files and preview versions of manual updated each night  > this is no longer happening
16:26:13 <cait> the latest versions have no nightly preview - the last is 21.05 https://translate.koha-community.org/manual/
16:26:25 <cait> so at the moment... if people translate, there is nowhere they can see their translations
16:26:45 <cait> and the website manuals are terribly out of date - not reflecting the work doen at all
16:26:55 <caroline> We need to tell bernardo about this one?
16:27:00 <cait> i did
16:27:06 <caroline> ok
16:27:14 <cait> I don't think it#s going ot happen/be fixed soon
16:27:44 <cait> maybe translations shoudl go on agenda for next time
16:28:00 <caroline> when you say the website manuals are out of date, you mean on translations or on actual content?
16:28:05 <cait> but we shoudl refresh po files on the different branches (will add to agenda as a topic for next time)
16:28:11 <cait> translations
16:28:11 <wahanui> translations is another endpoing IMO
16:28:25 <caroline> ok
16:28:32 <cait> they are build from the manual repo, so the contents are correct
16:28:42 <cait> but we don't transfer the translation work into the manual repo
16:28:50 <caroline> #action add manual translations on agenda for next meeting
16:30:00 <caroline> still no decision on branching though... we can do like this meeting and start fresh for this cycle with a new branch and try to stay up-to-date?
16:30:17 <cait> maybe a month would be ok
16:30:47 <cait> but if there is not much action on catching up on features, better to branch maybe
16:30:53 <caroline> I can try to cherry-pick if it's clear in the merge message, but I can't guarantee I will always do it, especially if there are a lot and/or conflicts
16:31:08 <cait> that's fair
16:31:10 <davidnind> I'll make a concerted effort to get the needs documenting queue down from 90 - all of these relate to 22.11
16:31:36 <caroline> Ok maybe we can branch in January?
16:32:02 <caroline> There isn't anything being pushed in Koha for 23.05 now anyway
16:32:05 <davidnind> OK with me, if everyone else is OK with that?
16:32:05 <caroline> that I know of
16:32:11 <cait> +1
16:32:15 <caroline> yup of let's go with that
16:32:19 <cait> are we aiming for monthly meetings?
16:32:30 <cait> so we could put a reminder for nex
16:32:30 <cait> t
16:32:30 <caroline> #agreed branching for 23.05 will happen in January 2023
16:32:51 <caroline> #action caroline needs to branch manual in january
16:32:58 <cait> heh
16:33:18 <caroline> I think we should do more frequent meetings so that we don't do 2hour meetings each time lol!
16:33:47 <davidnind> +10
16:33:53 <caroline> #topic Next steps
16:34:12 <caroline> #link General documentation tasks https://bugs.koha-community.org/bugzilla3/buglist.cgi?bug_status=NEW&bug_status=REOPENED&bug_status=ASSIGNED&f1=keywords&f2=component&j_top=OR&known_name=Documentation%20To-do&list_id=394372&o1=allwords&o2=equals&query_based_on=Documentation%20To-do&query_format=advanced&v1=Manual&v2=Documentation
16:34:28 <caroline> #link Needs documenting https://bugs.koha-community.org/bugzilla3/buglist.cgi?bug_status=Needs%20documenting&columnlist=product%2Ccomponent%2Cassigned_to%2Cbug_status%2Cshort_desc%2Cchangeddate%2Cbug_severity&known_name=Needs%20documenting&list_id=434435&query_based_on=Needs%20documenting&query_format=advanced
16:34:59 <caroline> #info priority should be on the "needs documenting" status for bugs pushed in 22.1
16:35:49 <caroline> So if you're not sure what to do , go to that second link :)
16:36:39 <caroline> #topic Set time of next meeting
16:37:01 <caroline> Is this a good day? friday?
16:37:16 <cait> friday is not ideal at this time
16:37:25 <cait> at least here people often leave early
16:38:04 <caroline> I don't see the dev and general meetings in the agenda, what day are they on?
16:38:13 <cait> wednesdays usually
16:38:14 <caroline> just to avoid conflict and meeting-itis
16:38:32 <davidnind> I think it was "Friday" because I made a mistake..., so maybe the Thursday?
16:38:38 <caroline> ok so thursday?
16:38:43 <cait> +1
16:38:59 <caroline> second week of january? or is that too early?
16:39:04 <caroline> maybe third week?
16:39:12 <caroline> Jan 19?
16:39:19 <cait> +1
16:39:42 <caroline> this time is good for me, what about europe?
16:39:53 <caroline> and NZ, I guess this is the middle of the night?
16:40:01 <cait> 4pm works for me - I think anything arlier is too hard to nz (even this is bad)
16:40:21 <cait> 4 am for davidnind i think?
16:40:22 <davidnind> I'm happy to get up early once every month, so not na issue for me
16:40:48 <davidnind> it is
16:40:52 <caroline> ok sorry about that davidnind! :( You are way more dedicated than I am
16:41:14 <davidnind> as long as the time works for you all, I'm OK
16:41:44 <cait> might need to see how things change with daylight savings again, but we should be good for a while now then
16:42:17 <caroline> #info Next meeting: 19 January 2023, 15 UTC
16:42:55 <caroline> #endmeeting