16:00:48 <davidnind> #startmeeting Documentation IRC meeting 6 January 2022
16:00:48 <huginn`> Meeting started Thu Jan  6 16:00:48 2022 UTC.  The chair is davidnind. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:48 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:48 <huginn`> The meeting name has been set to 'documentation_irc_meeting_6_january_2022'
16:01:03 <davidnind> #info Agenda https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_6_January_2022
16:01:13 <davidnind> #topic Introductions
16:01:23 <davidnind> #info David Nind, New Zealand
16:01:48 <caroline> #info Caroline Cyr La Rose, inLibro, Quebec (Canada)
16:01:58 <aude_c> #info Aude Charillon, PTFS Europe, UK
16:01:59 <kellym> #infor Kelly McElligott, ByWater Solutions
16:02:01 <cait> #info Katrin Fischer, BSZ, Germany
16:02:02 <marie-luce> #info marie-luce, inlibro Montreal, Canada
16:02:14 <lucyvh> #info Lucy Vaux-Harvey, PTFS Europe
16:03:11 <davidnind> Great to have so many people here!
16:03:24 <davidnind> and Hi everyone
16:03:30 <caroline> davidnind++ for reigniting this :)
16:04:01 <marie-luce> davidnind++
16:04:01 <davidnind> I eventually get there, sometimes...
16:04:12 <davidnind> #topic Review of action points
16:05:25 <davidnind> Not too many so far, I've addressed tow of mine but one still to do
16:05:44 <davidnind> #action davidnind to look at previous meetings and add any current or still relevant items as tasks to Bugzilla
16:06:16 <davidnind> ashimema is not here I think to update us on his one, so I will carry forward
16:06:45 <davidnind> #action ashimema to look at adding docs tasks to the dashboard https://dashboard.koha-community.org/ (bug 29752)
16:06:45 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29752 enhancement, P3, ---, martin.renvoize, ASSIGNED , [DOCS] Look at adding documentation tasks to the dashboard
16:07:40 <davidnind> #topic Project updates
16:08:34 <davidnind> Nothing from me to report on any of the projects, still adding as tasks to Bugzilla
16:08:44 <davidnind> #link https://wiki.koha-community.org/wiki/Koha_Documentation_Team#Projects
16:09:51 <davidnind> #topic What's been done so far
16:10:30 <davidnind> It's been pretty quite of the holiday period, so not too much to report in the way of updates
16:11:18 <davidnind> congratulations to aude_c - first change pushed to the manual!
16:11:29 <davidnind> aude_c++
16:11:32 <aude_c> Haha, thank you!
16:11:33 <lucyvh> aude_c++
16:11:37 <cait> aude_c++
16:11:42 <marie-luce> aude_c++
16:11:51 <caroline> aude_c++ welcome!
16:11:59 <davidnind> hope the process wasn't too daunting and that there will be more! :)
16:12:13 <aude_c> Thanks; lucyvh picked a very easy one for me to start with.
16:12:29 <davidnind> lucyvh++
16:12:36 <lucyvh> I'm good at spotting the easy ones!
16:12:45 <davidnind> Thanks lucyvh!
16:12:46 <cait> lots of small steps are great :)
16:13:00 <aude_c> I tried to follow your instructions from the last meeting's agenda too davidnind (regarding Bugzilla); hope that's how you thought it should work
16:14:05 <davidnind> it was mostly there - I ended up merging all the commits into one and changing the commit message slightly
16:14:40 <davidnind> thanks for updating the bug as well, I think that is the first using the new way!
16:15:04 <cait> could yo ushare the bug number as an example?
16:15:17 <aude_c> Should I be merging all the commits into one before creating the merge request, then?
16:15:44 <cait> I think there is a checkbox on gitlab that might achieve that when doing the merge request
16:15:55 <cait> i have set it a few times, but didn't check the outcome
16:16:01 <davidnind> Anyone got anything else to share on what they've been working opn - nothing from me (apart from everything seems to be work in progress, and nothing finalised)
16:16:02 <aude_c> cait: Bug 29180
16:16:02 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 normal, P5 - low, ---, jonathan.druart+koha, RESOLVED FIXED, System preference RequestOnOpac should be renamed
16:16:12 <aude_c> I used your new keyword!
16:16:38 <cait> :)
16:17:05 <aude_c> cait: thanks for the gitlab tip
16:17:33 <davidnind> cait: there is in GitLab, it is a tick box to say merge the commits so that there is just one commit for the history  - it made it much easier than doing manually from the command line
16:18:10 <cait> I tihnk it might be on both sies then - when making the merge request and when merging it?
16:18:17 <cait> the tickbox
16:18:31 <lucyvh> Will do that in future too
16:18:48 <lucyvh> We were not sure what needed going regarding the google spreadsheet?  It's read only, so will you update that davidnind?
16:18:50 <aude_c> is it called squashing or is that something else? (Sorry, not used to the terminology!!)
16:19:37 <davidnind> I will have a look and document it next time I do a change
16:19:50 <aude_c> thanks
16:20:01 <cait> aude_c: couldn't find a picture yet, sorry
16:20:06 <lucyvh> thanks davidnind
16:20:19 <caroline> is there a link with the new procedure? Some of these things are new to me
16:20:23 <davidnind> the spreadsheet should be writable, so I will check that out
16:20:46 <lucyvh> davidnind++
16:20:48 <cait> hm so should we update bugzilla and spreadsheet then?
16:21:15 <davidnind> #action davidnind make sure spreadsheet for release changes (22.05 and 21.110 is editable by others
16:22:14 <davidnind> #action davidnind to write up changed workflow processes on the Wiki - using bugzilla for managing documentation tasks
16:24:07 <davidnind> just trying to find where we discussed this
16:24:12 <davidnind> one sec...
16:24:29 <aude_c> I used https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_2021-12-16
16:24:40 <davidnind> aude_c++
16:24:41 <davidnind> thanks
16:25:58 <aude_c> I'm afraid I have another "newbie" question... Will the updates to the manual be in previous versions too?
16:26:12 <reiveune> bye
16:26:33 <aude_c> Like, for the one I did the sys pref name changed in 21.11 - so will the 21.11 manual be updated?
16:27:09 <davidnind> I generally try to - master is updated, then I "cherry pick" the change for the previous version
16:27:36 <aude_c> Ah, great :)
16:28:29 <davidnind> mostly that works okay, but h=if there are a lot of other changes it may need to be done manually..
16:28:36 <cait> not sure if this topic will still come up - is there any progress on translations, more so updating the po files for 21.11?
16:29:29 <davidnind> It's on the agenda so will cover next
16:29:36 <cait> sorry ok
16:30:45 <davidnind> no problem!
16:31:35 <davidnind> was trying to add a summary of the workflow change...
16:35:05 <davidnind> summary of work flow change- using Bugzilla for managing documentation changes:
16:35:06 <davidnind> 1. Bugzilla task for release change has 'Manual' keyword added
16:35:06 <davidnind> 2. When the manual is updated: add a note to the bug saying the change to the manual was made, here it is for review, and that comments are welcome
16:35:06 <davidnind> 3. Add Manual-updated keyword (and remove Manual keyword)
16:35:27 <davidnind> I hope I've got that right!
16:36:56 <davidnind> Also, there are queries for Bugzilla for 22.05 and 21.11 to list items for a release with the 'Manual' keyword = see the agenda for the link
16:37:06 <davidnind> #topic Content development guidelines
16:37:53 <davidnind> Not too much here, I will cover the translation issue first
16:38:37 <davidnind> #link Process for translating the manual: https://wiki.koha-community.org/wiki/Documentation_management#Translating_the_manual
16:39:05 <davidnind> I've documented the process, so any any comments welcome
16:40:07 <davidnind> the only think I'm not sure of is updating the strings on Pootle - I think I need to send a message to the Translation Manager (Bernado)
16:40:38 <cait> on first glance the docs look good - some details like updating the po on pootle I don't know about either
16:41:28 <cait> it doesn't seem to have happended in a while
16:41:29 <davidnind> I haven't sent a message to the translation manager (Bernardo) yet, so I will do that after this meeting
16:41:40 <cait> recent changes didn't shop up for translatoin on the olders ones
16:43:20 <davidnind> I think the other change I was going to make was to get the strings updated once a month - see bug 29647
16:43:21 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29647 enhancement, P5 - low, ---, david, ASSIGNED , [DOCS] Update po files in manual repository
16:44:29 <davidnind> #action davidnind to work on getting the po files for the manual updated (bug 29647)
16:44:36 <cait> +1
16:45:42 <davidnind> anything else on translation - the mystery bit for me is how Pootle gets updated with the recent manual changes
16:46:14 <davidnind> apologies, am a bit slow this morning...
16:46:15 <cait> i think we need Bernardo to clear up some steps of th eprocess ultimately
16:47:38 <davidnind> hopefully we can get it fixed up reasonably quickly, so those who translate can translate!
16:48:59 <davidnind> I added commit messages as an agenda item, does anyone have any questions about this?
16:50:48 <davidnind> The main thing (and an update to https://wiki.koha-community.org/wiki/Git_guide_for_documentation#Commit_messages is required) is to used the format:
16:50:48 <davidnind> - Title = Bugzilla number: Short title
16:50:48 <davidnind> - Description: Explain briefly what has changed and why
16:51:35 <davidnind> This is basically similar to how Koha does things
16:51:43 <davidnind> Any comments/questions?
16:51:58 <aude_c> not from me
16:52:31 <davidnind> If we do it this way then the commit history should be relatively clean, see https://gitlab.com/koha-community/koha-manual/-/commits/master
16:52:51 <lucyvh> Is it useful to know which versions the change is for?
16:53:14 <lucyvh> To help with cherry picking to previous versions?
16:53:30 <lucyvh> Or does that overcomplicate things
16:54:15 <davidnind> If it helps you can add it to the commit message, otherwise add as a comment to the merge request
16:55:34 <lucyvh> Will do, thanks
16:55:38 <davidnind> so either add something along the lines that "This change was made in Koha XX.XX", which will act as a prompt for me
16:56:03 <davidnind> I normally try and check, for release related changes, which version I need to go back to
16:56:40 <davidnind> #topic Next steps
16:57:46 <davidnind> I'm still updating Bugzilla with the manual keyword for 21.11 release changes, 22.05 was up-to-date last week...
16:58:59 <davidnind> I don't have any particular priorities at the moment
16:59:22 <davidnind> I will update the list of easy, medium and hard tasks (https://wiki.koha-community.org/wiki/Koha_Documentation_Team#Easy.2C_medium_and_hard_tasks)
16:59:56 <davidnind> feel free to add anything you would like there
17:00:35 <davidnind> if anything the priority should be on updating new features for past releases
17:01:16 <davidnind> If anyone would like something to work on, using the manual keyword Bugzilla queries would be the place to start, and pick something
17:01:29 <davidnind> Otherwise, I'm, happy to suggest something
17:01:56 <davidnind> Do any of you have any particular areas you want to work on?
17:02:40 <davidnind> Also, where has the last hour just gone! :-D
17:03:44 <lucyvh> I'm still finding that I can't edit some of the larger rst files using gitlab in a browser - the edit page just hangs.  Not sure if anyone else finds this or has any advice?
17:03:53 <aude_c> No particular areas I want to work on; but certainly some I'll try to avoid!!
17:04:54 <marie-luce> :)
17:05:57 <davidnind> lucyvh: I think the only solution there is to work on them locally (which is a more complicated work flow intially) until  we can break things up into smaller files
17:06:26 <davidnind> I think I try to avoid cataloging (and MARC things) :-D
17:06:53 <cait> I hope to just get sth done right now tbh
17:07:08 <cait> but it's also good to keep docs in mind when doing QA
17:07:22 <lucyvh> Thanks davidnind  - 'complicated workflow' sounds bad!!
17:07:26 <cait> lucyvh: which are the files most problematic right now?
17:07:33 <davidnind> cait++
17:07:59 <cait> lucyvh: not super bad, but involving git instead of only the gilab website
17:08:13 <davidnind> it's not too bad, once you get the hand of it - clone the repository locally,
17:08:14 <lucyvh> I haven't been doing much lately but tried circpreferences.rst this afternoon and couldn't work with it
17:08:31 <cait> :( we had already split that one up
17:08:46 <cait> i was hoping it would be enough
17:08:53 <lucyvh> cait: I know sorry!!
17:08:58 <cait> not your fault at all
17:09:07 <cait> just was hoping it was something that I had an idea abou thow to solve :)
17:09:57 <davidnind> OI'll have a think about how to organise the system preferences section a bit better - am open to ideas if anyone has any...
17:10:20 <davidnind> and my spelling is atrocious this morning!
17:10:25 <lucyvh> I'll look into the local repository approach
17:11:19 <lucyvh> No worries if it's only me - I probably need a new laptop :)
17:11:35 <caroline> the thing is that when we split sections, they are also split as different pages in the manual, so we have to be mindful of that
17:12:06 <cait> yes, best is to make the split 'logical' in some way...
17:12:16 <cait> so it also caters to the structure of the manual
17:12:43 <caroline> I know we're way overtime, but do we still have plans of going in a less linear manual?
17:12:50 <davidnind> its not you, just a limitation using GitLab and large rst files  - you can generally click on the raw link
17:13:05 <davidnind> I do
17:13:16 <cait> we also had discussed having a video meeting - maybe that could be a first topic to gather ideas?
17:13:40 <davidnind> excellent idea cait!
17:13:49 <lucyvh> cait++
17:14:24 <davidnind> I will add a Bugzilla task for reorganising the manual, and add some ideas there as a starting point - everyone is welcome to comment
17:14:31 <cait> just glad the video meeting was not today, but wlil be ready next time :)
17:15:05 <davidnind> #action davidnind to add a Bugzilla task for reorganising the manual so that it is less linear
17:15:25 <davidnind> I was going to test Jitsi, but will leave to next time..
17:15:53 <aude_c> I've used Jitsi before; very easy to use
17:16:56 <davidnind> Is everyone okay to make the next meeting a video conference one?
17:17:07 <lucyvh> Yes sure
17:17:10 <aude_c> sure
17:17:18 <marie-luce> +1
17:17:41 <davidnind> #topic Set time of next meeting
17:18:00 <cait> +1
17:18:08 <davidnind> Okay we will go with having a video conference meeting for the next meeting
17:19:06 <davidnind> Same time if that suits everyone, and the first week of the month?
17:19:20 <aude_c> yes
17:19:26 <davidnind> which would be 3 February 2022, 16:00 UTC
17:19:56 <davidnind> #info Next meeting: 3 February 2022, 16:00 UTC
17:20:06 <davidnind> #endmeeting