#koha: Development IRC Meeting 11 January 2023

Meeting started by tuxayo at 15:03:24 UTC (full logs).

Meeting summary

    1. https://wiki.koha-community.org/wiki/Development_IRC_Meeting_11_January_2023 Today's agenda (tuxayo, 15:03:48)

  1. Introductions (tuxayo, 15:03:56)
    1. Martin Renvoize, PTFS Europe, UK (ashimema, 15:05:04)
    2. Paul Derscheid, LMSCloud GmbH, Germany (paulderscheid[m], 15:05:08)
    3. Lucas Gass, ByWater Solutions (lukeg, 15:05:37)
    4. Emily Lamancusa, MCPL, USA (emlam, 15:05:44)
    5. Katrin Fischer, BSZ, Germany (cait1, 15:08:34)
    6. Nick Clemens, ByWater Solutions (kidclamp, 15:08:34)
    7. Security releases were accounced today! (cait1, 15:09:19)
    8. Jonathan Druart (Joubu, 15:09:49)

  2. Announcements (tuxayo, 15:09:54)
  3. Updates from the Release Maintainers (tuxayo, 15:12:57)
    1. Kyle M Hall, ByWater Solutions (khall, 15:14:30)
    2. update your installation, see https://koha-community.org/ for infos about the security release. (tuxayo, 15:16:54)
    3. Security releases have gone out, but it was a challenge to co-ordinate release over xmas period. (ashimema, 15:18:32)
    4. https://gitlab.com/koha-community/koha-misc4dev/-/issues/58 - this will help. Before it's done you need to replicate ktd/run.sh (Joubu, 15:23:09)
    5. ACTION: cait add to RMaint documentation to run the test suite locally for security release (tuxayo, 15:26:07)
    6. Thomas Dukleth, Agogme, New York City (thd, 15:42:00)
    7. ACTION: tuxayo reach wainui about the broken 21.05 release and investigate the failures. (tuxayo, 15:46:42)

  4. Updates from the QA team (tuxayo, 15:49:40)
    1. Queues are quite full right now, I am pushing for the bad bugs and the old bugs... need more hands - please QA! (cait1, 15:50:21)
    2. Work ongoing for rabbitMQ and bakground job improvements and fixes (cait1, 15:51:21)

  5. Status of roadmap projects (tuxayo, 15:57:09)
    1. roadmap: https://annuel.framapad.org/p/Roadmap_for_Koha_v23.05 (tuxayo, 15:57:47)

  6. Actions from last meeting (tuxayo, 15:59:33)
    1. ACTION: tcohen To schedule/call a "CSRF day" to work on related patches together (previously deferred until after the 22.11 release). (tuxayo, 16:01:06)
    2. ACTION: tcohen To draft proposal for master→main change and draft of action list (previously deferred until after the 22.11 release). (tuxayo, 16:01:28)
    3. ACTION: oleonard ashimema Draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside. Update: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft (previously deferred until after the 22.11 release). (tuxayo, 16:03:37)

  7. General development discussion (trends, ideas, ...) (tuxayo, 16:03:49)
    1. https://github.com/penpot/penpot (paulderscheid[m], 16:09:56)
    2. https://penpot.app (tuxayo, 16:10:32)
    3. ACTION: tuxayo forward to the Forgejo/Gitea news and question to koha-devel (tuxayo, 16:19:48)

  8. Review of coding guidelines (tuxayo, 16:22:42)
    1. https://wiki.koha-community.org/wiki/Coding_Guidelines «Other than those 2 cases, all SQL must be in the C4/xxxx.pm or Koha/xxxx.pm (xxxx being the module your SQL refers to) » (tuxayo, 16:25:14)
    2. ACTION: tuxayo try to sum up ideas about guideline for SQL and sent to koha-devel for completion, rephrasing and terminology fixing. (tuxayo, 16:48:58)

  9. ACK pre vs post processing for background jobs (tuxayo, 16:54:25)
  10. Set time of next meeting (tuxayo, 16:56:17)
    1. Next meeting: 25 January 2022, 23 UTC (tuxayo, 16:57:21)


Meeting ended at 16:59:20 UTC (full logs).

Action items

  1. cait add to RMaint documentation to run the test suite locally for security release
  2. tuxayo reach wainui about the broken 21.05 release and investigate the failures.
  3. tcohen To schedule/call a "CSRF day" to work on related patches together (previously deferred until after the 22.11 release).
  4. tcohen To draft proposal for master→main change and draft of action list (previously deferred until after the 22.11 release).
  5. oleonard ashimema Draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside. Update: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft (previously deferred until after the 22.11 release).
  6. tuxayo forward to the Forgejo/Gitea news and question to koha-devel
  7. tuxayo try to sum up ideas about guideline for SQL and sent to koha-devel for completion, rephrasing and terminology fixing.


Action items, by person

  1. ashimema
    1. oleonard ashimema Draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside. Update: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft (previously deferred until after the 22.11 release).
  2. tuxayo
    1. tuxayo reach wainui about the broken 21.05 release and investigate the failures.
    2. tuxayo forward to the Forgejo/Gitea news and question to koha-devel
    3. tuxayo try to sum up ideas about guideline for SQL and sent to koha-devel for completion, rephrasing and terminology fixing.
  3. UNASSIGNED
    1. cait add to RMaint documentation to run the test suite locally for security release
    2. tcohen To schedule/call a "CSRF day" to work on related patches together (previously deferred until after the 22.11 release).
    3. tcohen To draft proposal for master→main change and draft of action list (previously deferred until after the 22.11 release).


People present (lines said)

  1. tuxayo (120)
  2. cait1 (70)
  3. ashimema (51)
  4. Joubu (36)
  5. paulderscheid[m] (16)
  6. mtj (8)
  7. huginn (8)
  8. thd (6)
  9. wahanui (6)
  10. emlam (5)
  11. lukeg (4)
  12. kidclamp (3)
  13. caroline (2)
  14. khall (1)


Generated by MeetBot 0.1.4.