22:03:33 <davidnind> #startmeeting Development IRC meeting 22 February 2023
22:03:33 <huginn> Meeting started Wed Feb 22 22:03:33 2023 UTC.  The chair is davidnind. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:03:33 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:03:33 <huginn> The meeting name has been set to 'development_irc_meeting_22_february_2023'
22:03:53 <davidnind> #info Agenda https://wiki.koha-community.org/wiki/Development_IRC_meeting_22_February_2023
22:04:41 <davidnind> #chair cait tuxayo
22:04:41 <huginn> Current chairs: cait davidnind tuxayo
22:04:44 <davidnind> #topic Introductions
22:04:45 <davidnind> #info David Nind, New Zealand
22:04:45 <cait> #info Katrin Fischer, BSZ, Germany
22:04:46 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
22:05:26 <tuxayo> #info Victor Grousset, Tuxayo-Bibliotheksservice-Zentrum, France
22:05:52 <tuxayo> dcook sent apologies, can't be here due to schedule conflict.
22:05:54 <cait> tuxayo: new place of work? :)
22:06:08 <tcohen> <.<
22:06:42 <tuxayo> cait: I got subsidiaries everywhere and of all the legal kinds ;)
22:07:05 <davidnind> #topic Announcements
22:07:14 <davidnind> #chair tcohen
22:07:14 <huginn> Current chairs: cait davidnind tcohen tuxayo
22:08:13 <davidnind> #info Swedish Koha network user meeting 28-30 March 2023 https://koha.se/koha-i-sverige/inbjudan-till-svenska-kohanatverkets-tionde-anvandarmote-28-mars-30-mars-2023-i-vasteras-med-biblioteken-i-vastmanland/
22:08:16 <tcohen> tuxayo has a new job
22:08:42 <tuxayo> XD
22:09:05 <davidnind> tuxayo++
22:09:12 <tcohen> I need to leave soon, anyone else has announcements to make
22:09:17 <tcohen> tuxayo++
22:09:23 <cait> not me
22:09:42 <davidnind> #topic Update from the Release manager (22.11)
22:09:53 <tcohen> Hi all :-D
22:10:29 <davidnind> We'll get straight into it 8-) (I have to leave 10 minutes before the scheduled end time, and it is late for some)
22:10:37 <tcohen> #info there are failing selenium tests in master. Please take a look and help fixing them. I've exhausted my bandwidth and I'm
22:10:50 <tcohen> #info behind my schedules with all the things :-D
22:11:12 <tcohen> #info There's been a recent push of breaking changes in how we handle compiled assets
22:11:34 <tcohen> #info it includes both the koha codebase, but also koha-misc4dev and ktd
22:11:49 <tcohen> make sure you are up to date with ktd and the codebaes
22:12:45 <tcohen> #info khall put together some cool stuff we published as koha-dpkg-docker
22:13:07 <tcohen> #info mtj is looking and working towards integrating package building in the test pipeline
22:13:19 <tcohen> that's all I had
22:13:36 <davidnind> #action There are failing Selenium tests in master, please take a look at fixing
22:13:43 <davidnind> thanks tcohen
22:14:19 <davidnind> #info koha-dpkg-docker https://gitlab.com/koha-community/koha-dpkg-docker
22:15:00 <davidnind> A lot of things happening, thanks everyone for making things happen!
22:15:02 <davidnind> #topic Updates from the Release Maintainers
22:15:08 <tcohen> :-D
22:15:12 <tcohen> davidnind++
22:15:36 <davidnind> Not sure we have any Release Maintainers around, so moving on...
22:15:48 <davidnind> #topic Updates from the QA team
22:16:56 <davidnind> over to you cait
22:17:09 <cait> hm I'll cite the RM
22:17:20 <cait> #info  behind my schedules with all the things
22:17:32 <cait> #info queues are full, we need to find the time to process and test
22:17:43 <cait> Joubu communicated that there is a backlog for the ERM module that is kinda urgent
22:18:03 <cait> but there is also a lot of bugfixes waiting for stable, including some bad bugs as always
22:18:10 <cait> please make time to QA and sign off
22:18:39 <cait> things are never hopeless, but it's 3 months to release... so we need to get up to speed a bit more
22:18:57 <cait> #info queues are full, please all hands on deck - do QA!
22:19:02 <cait> done
22:19:21 <davidnind> thanks cait!
22:20:18 <davidnind> #topic KohaCon 2024 - start bidding process
22:20:40 <davidnind> Anyone here willing to do, or should I just ask on the mailing list for a volunteer?
22:20:44 <cait> tuxayo: you asked on the mailing list for a volunteer to manage the next steps, have you had any replies
22:20:46 <cait> ?
22:21:02 <cait> tuxayo already did that, but there wer eno replies on the list
22:21:03 <tuxayo> nope! :o
22:21:35 <tuxayo> I might have only asked on koha-devel!
22:21:48 <tuxayo> indeed :/
22:21:51 <cait> i think you did only koha-devel - was just looking for the mail in the koha archive
22:21:58 <cait> so shoudl we give it anothre go?
22:22:10 <tuxayo> Yes, I'll send to Koha general
22:22:11 <cait> and add to agenda in 2 weeks as well to make sure we have somene then?
22:22:23 <tuxayo> And resent to koha-devel
22:22:29 <davidnind> +1
22:24:05 <davidnind> #action tuxayo to post request for volunteer to organise the call for bids for KohaCon 2024
22:24:14 <davidnind> thanks tuxayo
22:24:27 <davidnind> #topic Status of roadmap projects
22:24:27 <cait> shoudl we jump over roadmap tonight?
22:24:57 <cait> #link https://annuel.framapad.org/p/Roadmap_for_Koha_v23.05
22:25:01 <davidnind> Happy to so we can get through the actions from previous meetings....
22:25:19 <tuxayo> action done :P
22:25:30 <davidnind> #topic Actions from last meeting
22:26:00 <cait> I didnt find a good spot for the note yet
22:26:29 <cait> i'll add it to my todo now so I'll remember to do it until next time
22:26:38 <davidnind> cait++
22:26:46 <davidnind> #action cait add info about the 'important' tag to RMaint documentation
22:27:05 <davidnind> tcohen?
22:27:05 <wahanui> tcohen is DO IT WITH THE REST API!
22:27:13 <tuxayo> lol
22:27:18 <davidnind> lol
22:27:30 <tcohen> not much to add about the roadmap
22:27:39 <tuxayo> API++
22:27:51 <tcohen> there's been a positive call betwen the RM and InLIbro to unlock some dev
22:28:00 <cait> that's cool :)
22:28:05 <davidnind> excellent
22:28:05 <wahanui> darn tootin' it is.
22:28:05 <tuxayo> oh, nice
22:28:10 <cait> tcohen++ inlibro++
22:28:16 <tuxayo> tcohen++ inlibro++
22:28:19 <tcohen> the bug tree is exciting for the 23.05 release
22:28:26 <cait> tcohen To schedule/call a "CSRF day" to work on related patches together (previously deferred until after the 22.11 release). ?
22:28:39 <tcohen> Theke has provided a lot of items/biblios/authorities endpoints for the next release
22:28:47 <tcohen> and InLibro had shared interests
22:29:10 <tcohen> about CSRF, ashimema and I need to talk  about it and set a time and dat efor that
22:29:22 <tcohen> hopefully before the hackfest so we can focus on other things in Marseille
22:29:43 <cait> tcohen To draft proposal for master→main change and draft of action list (previously deferred until after the 22.11 release).
22:29:50 <davidnind> #action tcohen To schedule/call a "CSRF day" to work on related patches together
22:31:08 <cait> any update on the main/master change?
22:32:01 <cait> I think oleonard's and joubu's need to get postponed for next time too
22:32:10 <cait> ok?
22:32:11 <davidnind> #action tcohen To draft proposal for master→main change and draft of action list
22:32:26 <tuxayo> #action oleonard ashimema Draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside. Update: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft (previously deferred until after the 22.11 release).
22:32:41 <davidnind> beat me to it!
22:32:50 <tuxayo> #action tuxayo postpone to next meeting "Joubu we need to vote on forgejo move at some point"
22:33:09 <davidnind> Thanks!
22:33:21 <tuxayo> yw :)
22:33:25 <davidnind> #topic General development discussion
22:33:57 <cait> anyone knows about the "security releases" agenda item?
22:34:07 <davidnind> Anyone able to talk to the security releases item?
22:34:10 <davidnind> Otherwise, I will add to the next agenda
22:34:12 <tcohen> mtj had an idea
22:34:15 <tcohen> mtj: around?
22:34:41 <tuxayo> mtj said they were close to getting it working a few weeks ago
22:35:33 <tuxayo> That's the only factor: having someone managing to do it, otherwise it's 100% needed.
22:35:54 <davidnind> Without knowing any details, I would say go for it if it helps minimise issues/improve things (and if the release manager is OK with it!)
22:36:41 <tuxayo> That's always a stress and a technical hassle to get all RMaints to run locally the test suite
22:37:12 <tcohen> I can explain
22:37:13 <tuxayo> And last time it wasn't done and some branch had a major breakage
22:37:28 <tcohen> the thing is, when we are about to make a security release
22:37:49 <tcohen> rmaints push to a secure (i.e hidden from public scruntiny) repository
22:38:15 <tcohen> the problem mtj proposes to solve is that we really want to run the full test suite on those hidden branches
22:38:45 <tcohen> but we cannot leak the commits until we announce the release (i.e. packages are built, announcement made, etc)
22:39:18 <tcohen> we really need to build the same we have for the rest of the branches but on ly visible for some selected users (rmaints, QA team maybe)
22:39:35 <tcohen> so we are sure the security release doesn't introduce regressions
22:39:53 <tcohen> so, yeah
22:39:59 <tcohen> we need to define where, how
22:40:07 <tcohen> and we've got mtj volunteer
22:40:23 <cait> mtj++
22:40:28 <davidnind> mtj++
22:40:36 <tcohen> mtj++
22:40:41 <tuxayo> and who already explored the thing a long time ago, mtj++
22:41:22 <tuxayo> But I didn't got to know what were the last blockers.
22:41:46 <davidnind> #info mtj to add security builds to Jenkins so that the full test suite is run, to help avoid regressions and issues with security releases - to work through details with tcohen, Release Maintainers, and others interested
22:41:57 <davidnind> Is that an OK summary?
22:42:39 <tuxayo> from what I undestand of the topic, yes :)
22:43:13 <davidnind> Thanks tcohen for the update and explanation!
22:43:31 <davidnind> Anyone on Perltidy, or shall we defer that one? I did see some discussion, but it is over my head..
22:43:54 <cait> I added it, but maybe easier with some more peopl earound
22:44:14 <cait> we ask people to perltidy things, but have some conflicting information about which perltidy config to use
22:44:22 <tcohen> yeah, I think we need to come up with something to put on the guidelines
22:44:43 <tuxayo> #action tuxayo postpone perltidy agenda item and mention bug 30002 for context
22:44:43 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30002 enhancement, P5 - low, ---, koha-bugs, NEW , Remove unused xt/perltidyrc
22:45:46 <davidnind> #info Perltidy - need to resolve conflicting information about what to do and put in guidelines
22:46:45 <davidnind> caroline around to talk to the terminology item, unless anyone else wants to comment?
22:46:52 <caroline> I'm here
22:47:28 <tuxayo> hi!
22:47:30 <caroline> I thought I remembered we changed the terminology for fines to 'Charge', but it seems I imagined it
22:47:54 <cait> no you are right
22:48:04 <cait> we renamed in the OPAC too
22:48:09 <caroline> I talked about it here earlier this morning, and people who were around seemed to agree that 'fine' is a type of 'charge'
22:48:17 <cait> I think fine is only used for 'punishing' things
22:48:20 <cait> charges is more neutral
22:48:30 <cait> so charges cover fines and all other things
22:48:40 <cait> like a hold fee
22:48:43 <caroline> This is an example where I would think it should be changed to charge (or fee) https://snipboard.io/jsbBt3.jpg
22:48:48 <cait> fines and fees = charges ? davidnind?
22:49:16 <caroline> a lot of libraries are moving away from fines too, so it would make sense to change the terminology
22:49:52 <cait> i think it's not about renaming fines to charges
22:49:56 <davidnind> yes, I agree - charges is the "higher" term, fines and fees are a subset of these
22:50:00 <cait> but everywhere we have displays that are for both, use charges
22:50:08 <caroline> yes this ^
22:50:11 <davidnind> +1
22:51:41 <caroline> it seems to be a consensus, to we need to vote?
22:51:56 <cait> i think we can do without
22:52:03 <cait> but maybe someone to add it to terminology?
22:52:14 <caroline> you can action me, I'll do it tomorrow
22:53:26 <davidnind> #action caroline Update/add terminology guidelines for usgage of charges and fees as discussed
22:53:40 <davidnind> Thanks everyone!
22:53:43 <davidnind> caroline++
22:53:45 <caroline> thanks davidnind!!
22:53:45 <davidnind> cait++
22:53:52 <caroline> thanks davidnind++ (it's late)
22:53:56 <tcohen> davidnind++
22:54:01 <davidnind> any other items before we close?
22:54:19 <caroline> see you all tomorrow/later!
22:54:28 <davidnind> #topic Set time of next meeting
22:54:52 <davidnind> It's already set, so will just add...
22:55:10 <tuxayo> "09 March 2023, 15 UTC"
22:55:15 <tuxayo> from the logs
22:55:36 <tuxayo> #info Next meeting: 09 March 2023, 15 UTC
22:55:50 <davidnind> thanks tuxayo!
22:55:54 <tuxayo> so now for this time slot, in 4 weeks
22:56:22 <davidnind> as we don't seem to have much attendance, shall we give it one last shot?
22:56:33 <tuxayo> Same time? (dcook confirmed it worked for them (9am local))
22:56:55 <davidnind> OK with me
22:57:00 <cait> it's late here - so I am biased :)
22:57:02 <cait> 11pm
22:57:27 <davidnind> cait++ for staying up so late to attend!
22:57:45 <tcohen> 8pm here, but the kids are demanding :-D
22:57:46 <tuxayo> "shall we give it one last shot"
22:57:46 <tuxayo> Good question to continue with this time slot. yes, at least once. It's odd we don't have people from north america. Because the other timeslot it out of workhours for them.
22:58:36 <tuxayo> I'll retry to directly advertise the meeting to people at bywater.
22:58:40 <cait> I am owl... 6 am would be worse :)
22:58:50 <davidnind> OK, will see how we go next time
22:58:54 <davidnind> Thanks tuxayo
22:58:56 <davidnind> #endmeeting