14:31:28 <tcohen> #startmeeting Development IRC Meeting 26 April 2023
14:31:28 <huginn> Meeting started Wed Apr 26 14:31:28 2023 UTC.  The chair is tcohen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:28 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:28 <huginn> The meeting name has been set to 'development_irc_meeting_26_april_2023'
14:31:47 <tcohen> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_26_April_2023 Today's agenda
14:32:01 <tcohen> #topic Introductions
14:32:07 <tcohen> #info Tomas Cohen Arazi
14:32:14 <cait> #info Katrin Fischer, BSZ, Germany
14:32:24 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:32:38 <thd> #info Thomas Dukleth, Agogme, New York City
14:32:50 <tcohen> hi thd, nice to see you around (and everyone else of course)
14:32:57 <ashimema> #info Martin Renvoize, PTFS Europe
14:33:16 <tcohen> 10 more seconds
14:33:34 <tcohen> #topic Announcements
14:33:52 <tcohen> #info KohaCon23 Update:
14:34:19 <tcohen> #info Call for talks closes April 30th
14:34:33 <tcohen> can anyone send a reminder to the lists?
14:34:46 <tcohen> say, tomorrow?
14:35:06 <cait> sorry not volunteering this time
14:35:56 <cait> too much this week and next week I'll have more time but too late
14:36:23 <tcohen> #info Andrii sent a reminder to the lists
14:36:32 <tcohen> #action tcohen will reinforce it tomorrow
14:37:19 <tcohen> #info 'Spring into Fitness: Koha Community Challenge 2023 (koha-US and ByWater Solutions)'
14:37:29 <tcohen> #info Join at https://koha-us.org/2023/04/06/spring-into-fitness-koha-community-challenge-2023/
14:37:36 <tcohen> moving on
14:37:42 <cait> tcohen++
14:37:46 <tcohen> #topic Update from the Release Manager (23.05)
14:38:16 <tcohen> #info Lots of things pushed, several interesting ones to get in in the next weeks. Hurry!
14:38:35 <tcohen> #info Looking closely to a design discussion on Vue-land
14:39:14 <tcohen> #info Contact tcohen if you really want your stuff pushed, so we have a clear understanding of the steps that follow and the chances they have to get pushed
14:39:26 <tcohen> moving on? questino?
14:40:14 <cait> I'll have if you fail things :)
14:40:15 <tcohen> #info tcohen asked the Translation Manager to hand us the commands that are used in Pootle to update things, so we have more hands able to do it
14:40:49 <tcohen> #info Email sent to koha-translate to start the conversation about switching to another tool begining next cycle
14:41:08 <tcohen> #topic Updates from the Release Maintainers
14:41:14 <tcohen> rmaints?
14:41:26 <tcohen> Skipping
14:41:38 <tcohen> #topic Updates from the QA Team
14:41:38 <ashimema> #info 22.11.x is behind on this months release whilst we try to get strings sorted
14:41:45 <ashimema> just made it 😛
14:41:48 <tcohen> hehe
14:42:12 <ashimema> I've not been on QA much this month.. trying desperately hard to keep up on other commitments
14:42:54 <tcohen> #topic Status of roadmap projects
14:43:07 <tcohen> #link https://annuel.framapad.org/p/Roadmap_for_Koha_v23.05
14:43:37 <tcohen> #info Lots of things done or almost done
14:44:00 <tcohen> #info Generic solution for CSRF delayed for early next cycle, unfortunately
14:44:05 <khall> #info Kyle M Hall, ByWater Solutions
14:44:33 <tcohen> #info ILL backends into core delayed for next cycle
14:44:39 <cait> oh
14:44:41 <cait> i missed my topic
14:44:58 <tcohen> #info Great work from PedroAmorim[m] to speed up the ILL requests page
14:45:09 <cait> yes, QA is too low... I have asked QA team to fix it...
14:45:35 <tcohen> #info kudos to oleonard for his intensive work on streamlining the UI and normalizing the way we do things
14:45:44 <cait> oleonard++
14:46:00 <cait> PedroAmorim++
14:46:00 <oleonard> I'm making good progress! Thanks to all for testing and QA
14:46:20 <ashimema> oleonard++
14:46:30 <tcohen> Maybe we finish the FA upgrade next cycle
14:46:48 <tcohen> #topic Updates from the QA Team
14:46:55 <tcohen> your turn, cait
14:47:02 <tcohen> don't get distracted :-P
14:47:07 <cait> again? :)
14:47:30 <cait> #info Need more action from the whole QA team to fix the QA queue
14:48:00 <tcohen> cait++
14:48:45 <tcohen> [off] Bernardo has fired the update script
14:48:46 <cait> #info Numbers are constantly above 100, I hope we can push down some more, lots of bugs (faulty behaviour) ones too
14:48:55 <tcohen> [off] and I've got the command
14:49:14 <cait> [off] ashimema: can you give me a go at transaltions still? I can finish tonight
14:49:26 <cait> I also put up the roles page for 23.11
14:49:33 <tcohen> I don't think it has finished yet
14:49:37 <cait> please sign up for QA if you can - need more hands always
14:49:38 <ashimema> I'm not releasing you give me the go cait
14:49:45 <cait> but if you do.. please also DO QA :)
14:49:56 <cait> thank you
14:49:57 <tcohen> moving on?
14:50:00 <cait> yep
14:50:07 <tcohen> #topic Actions from last meeting
14:50:45 <tcohen> #info Selenium and Cypress tests are passing already
14:51:05 <tcohen> #info CSRF day postponed for after the release
14:51:30 <tcohen> I'd skip the next ones today
14:51:45 <tcohen> #topic General development discussion (trends, ideas, ..
14:52:15 <tcohen> #info Roles for 23.11 are open. Please put your name here: https://wiki.koha-community.org/wiki/Roles_for_23.11
14:52:33 <cait> would someone send to the mailing list please?
14:52:51 <tcohen> #action tcohen to send email about roles for 23.11
14:54:03 <cait> thank you
14:54:09 <tcohen> done
14:54:49 <tcohen> #info We need to agree on a default Perltidy configuration. See bug 30002. To be voted next meeting.
14:54:49 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30002 enhancement, P5 - low, ---, jonathan.druart+koha, ASSIGNED , Add project-level perltidyrc
14:55:24 <tcohen> #info We need to upgrade Gitea, and move to Forgejo. Anyone willing to spend time on that please contact tcohen
14:55:50 <tcohen> Do we know who maintains perldoc.koha-community.org?
14:56:51 <tcohen> [off] Bernardo says the commands are erroring and that's why strings haven't got updated yet. HE's working on it right now
14:57:08 <cait> i think gmcharlt_
14:57:26 <cait> [off] that makes snse, but hope it's not a hard fix
14:57:40 <tcohen> [off] he blames constant nodejs dependencies changes
14:58:51 <tcohen> #info perldoc.k-c is outdated, we need to investigate and have it update more frecquently
14:59:48 <tcohen> #info Development documentation (from the hackfest): nothing to discuss here. People do their best. If you want to spend time on documenting the listed things, and need guidance, contact us by any means
15:00:03 <cait> we shoudl save the list
15:00:09 <cait> maybe as a todo in the wiki?
15:00:20 <tcohen> are you volunteering?
15:00:26 <cait> I#ll try
15:00:31 <cait> can you action me plz?
15:00:32 <ashimema> I made notes
15:00:39 <cait> yep,t hey are on the agenda
15:00:41 <ashimema> action cait, and she can grab me if needed
15:00:46 <cait> i just don't want them to get lost there
15:02:03 <tcohen> #action cait and ashimema will put together the TODO notes from the hackfest on the Wiki
15:02:11 <tcohen> #topic Set time of next meeting
15:03:18 <reiveune> bye
15:03:19 <thd> The issue of DMARC compaitibility for the mailing list needs input from Katipo.  MIME nesting seems not to be a serious choice as no one seems to have notice of implementing that.
15:03:44 <tcohen> thd: we don't have quorum to decide anything on that today
15:03:52 <thd> Certainly,
15:04:05 <tcohen> I'd say defer to next meeting
15:04:15 <thd> but we need input from Katipo to consider properly.
15:04:21 <tcohen> and we might need to advertise the topics on the list so interested people are around
15:04:28 <tcohen> can you contact them?
15:05:42 <thd> Them is perhaps the Koha founders who once worked there.
15:06:14 <cait> thd: I think biblibre mostly
15:06:26 <cait> they host all mailing lists but Koha
15:06:43 <thd> The general mailing list is still Katipo about which the issue was raised.
15:06:46 <cait> koha-devel etc.
15:06:58 <cait> is ist not also present for theothers?
15:07:00 <tcohen> #info Next meeting: 10 May 2023, 14:00 UTC
15:07:32 <thd> The same problem is present for all the lists but no one has raised the issue in relation to the other lists.
15:07:51 <thd> Better to start with one and learn something.
15:07:52 <cait> I think if we start this proces, we should fix for all
15:08:02 <cait> ok
15:08:11 <tcohen> thanks everyone
15:08:16 <tcohen> #endmeeting