14:02:49 <tcohen> #startmeeting Development IRC Meeting 7 June 2023
14:02:49 <huginn> Meeting started Wed Jun  7 14:02:49 2023 UTC.  The chair is tcohen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:49 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:49 <huginn> The meeting name has been set to 'development_irc_meeting_7_june_2023'
14:03:09 <tcohen> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_7_June_2023
14:03:17 <cait> #info Katrin Fischer, BSZ Germany
14:03:19 <tcohen> #topic Introductions
14:03:26 <tcohen> #info Tomas Cohen Arazi
14:03:39 <tcohen> #info Katrin Fischer, BSZ Germany
14:04:14 <kidclamp> #info Nick Clemens, ByWaterSolutions
14:04:25 <thd> #info Thomas Dukleth, Agogme, New York City
14:04:43 <Joubu> #info Jonathan Druart
14:05:08 <Joubu> qa_team?
14:05:08 <wahanui> well, qa_team is cait, marcelr, khall, kidclamp,  lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova, Joubu and dcook
14:05:20 <cait> RMaints?
14:05:20 <wahanui> somebody said RMaints was liliputech, wainui, lukeg and ashimema
14:05:26 <cait> needs updating :)
14:05:54 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:06:00 <lauraesca[m]> #info Laura Escamilla, ByWaterSolutions
14:08:27 <cait> moving on?
14:08:46 <tcohen> yes
14:08:46 <ashimema> #info Martin Renvoize, PTFS Europe (Half here and in another meeting)
14:08:53 <tcohen> #topic Announcements
14:09:25 <tcohen> Anyone?
14:09:25 <wahanui> Anyone is free to give it a shot :-)
14:09:27 <cait> Is there any news on KohaCon?
14:09:46 <Joubu> did we get the info we were supposed to get end of May?
14:09:58 <cait> Hotels - not yet I think
14:10:19 <oleonard> I didn't see any end-of-May updates
14:10:20 <cait> nugged: around maybe?
14:11:42 <cait> #info German speaking Koha user meeting is scheduled for December 5th - CfP is open (see Koha calendar and koha-dach.eu)
14:13:35 <Joubu> can we make this faster maybe?
14:13:41 <tcohen> @later tell nugged: please show up and give us info
14:13:41 <huginn> tcohen: The operation succeeded.
14:13:53 <tcohen> #topic Update from the Release Manager (23.11)
14:14:23 <tcohen> #action tcohen will send a roadmap page for 23.11 today
14:14:38 <tcohen> #action tcohen will send a call for testing CSRF fixes
14:15:04 <tcohen> I wanted to mention that I'll propose we use Zoom or similar for the next dev meeting
14:15:15 <cait> about the roadmap
14:15:17 <cait> could we move it to the wiki?
14:15:27 <tcohen> cait: yeah, excellent idea
14:15:29 <ashimema> +1
14:15:29 <cait> I think the framapad is a little chaotic and it's another tool/somethign that is not found
14:15:42 <tcohen> thanks cait
14:15:57 <tcohen> no need to action or announce on that, the link will be to a wiki page
14:16:16 <cait> about Zoom: let's try it
14:16:26 <tcohen> I've started pushing
14:16:29 <tcohen> things to master
14:16:32 <cait> shoudl we still use IRC for the minutes?
14:16:45 <tcohen> I decided to push early, things we always say we shuold push early
14:16:45 <tcohen> :-P
14:16:57 <tcohen> cait: yes, we will still use IRC for logging
14:17:09 <thd> We should still use IRC for freedom.
14:17:12 <tcohen> and I'm proposing this for the dev meetings
14:17:56 <tcohen> thd: we will give it a try
14:18:08 <tcohen> and see how it goes
14:18:32 <tcohen> when I said Zoom or similar
14:18:40 <tcohen> I meant whatever tool we prefer
14:18:46 <tcohen> we should probably use Jitsi
14:19:27 <tcohen> ok moving on
14:19:39 <tcohen> #topic Updates from the Release Maintainers
14:19:46 <tcohen> rmaints?
14:19:46 <wahanui> well, rmaints is liliputech, wainui, lukeg and ashimema
14:19:56 <tcohen> wahanui forget that
14:19:56 <wahanui> tcohen: I forgot that
14:20:06 <Joubu> :D
14:20:35 <ashimema> 22.11.x is catching up.. don't think I've seen anything hit 23.05 from Frido yet
14:20:53 <tcohen> yeah
14:21:06 <ashimema> ooh.. I have seen a few now
14:21:07 <tcohen> anyone from biblibre around today?
14:21:18 <ashimema> or was that you tcohen
14:21:26 <tcohen> ashimema: I pushed a couple things
14:21:29 <Joubu> no rmaints is fridolin (23.05), PedroAmorim[m] and MatthewBlenkinsop[m] (22.11), lukeG (22.05) and Danyon (21.11)
14:21:35 <ashimema> coolios
14:21:43 <oleonard> Joubu++
14:21:44 <cait> no rmaints?
14:21:44 <wahanui> somebody said no rmaints was fridolin (23.05), PedroAmorim[m] and MatthewBlenkinsop[m] (22.11), lukeG (22.05) and Danyon (21.11)
14:21:45 <Joubu> and I have no idea who is Danyon
14:21:48 <tcohen> Joubu++
14:21:52 <cait> not sure that worked like you wanted :)
14:21:53 <Joubu> rmaints?
14:21:54 <wahanui> rmaints is probably liliputech, wainui, lukeg and ashimema
14:21:56 <ashimema> He's new from Catalyst
14:21:57 <ashimema> I asked that
14:21:58 <cait> forget rmaints
14:21:58 <wahanui> cait: I forgot rmaints
14:22:07 <ashimema> either an intern or brand new staff
14:22:10 <Joubu> no wahanui, rmaints is fridolin (23.05), PedroAmorim[m] and MatthewBlenkinsop[m] (22.11), lukeG (22.05) and Danyon (21.11)
14:22:13 <Joubu> rmaints?
14:22:13 <wahanui> rmaints is fridolin (23.05), PedroAmorim[m] and MatthewBlenkinsop[m] (22.11), lukeG (22.05) and Danyon (21.11)
14:22:14 <tcohen> forget no rmaints
14:22:14 <wahanui> tcohen: I forgot no rmaints
14:22:19 <ashimema> he's being backed up with Wanui I think?
14:22:26 <cait> yes, that#s what the wiki says
14:22:36 <Joubu> could be good to have them on IRC sometimes
14:22:39 <ashimema> I added it when i asked them
14:22:43 <ashimema> yeah
14:23:08 <tcohen> #actions tcohen will update the koha-release-team@theke.io email alias
14:23:20 <tcohen> Joubu: lol
14:23:24 <ashimema> ++
14:23:45 <tcohen> #actions tcohen will update the koha-qa-team@theke.io email alias
14:23:47 <Joubu> what about post release actions?
14:24:04 <Joubu> https://tree.taiga.io/project/koha-ils/us/19
14:24:21 <cait> Bugzilla update is pending, but I'll get to it
14:24:38 <Joubu> I stil need to update the gitea access
14:24:41 <cait> We need Liz to update the front page with the new version (bug in website templates)
14:24:42 <tcohen> I wasn't able to access Gitea when was willing to update permissiosn
14:25:00 <cait> and I think manuals might need changes at some point
14:26:39 <tcohen> liz already updated the frontpage
14:26:52 <tcohen> but there's some caching she's not solving yet
14:26:54 <cait> it still says 22.11
14:26:57 <cait> aaah ok
14:27:13 <tcohen> ok, moving on
14:27:16 <tcohen> wait
14:27:26 <tcohen> does anyone have DAnyon's email address?
14:27:50 <cait> in good news: i updated the demo page, we have a first 23.05 demo from Admin Kuhn
14:27:55 <cait> tcohen: i thin it's n bugzilla already
14:28:08 <tcohen> cait: Xercode's is 23.05 as wel
14:28:09 <cait> I'll pm you
14:28:29 <cait> it's was master when I last checked
14:28:40 <tcohen> @later tell fridolin let's talk about the post-release actions that involve 23.05
14:28:40 <huginn> tcohen: The operation succeeded.
14:28:44 <cait> 23.06 - listed as development
14:28:50 <tcohen> ok
14:29:29 <tcohen> #topic Updates from the QA Team
14:29:32 <oleonard> Danyon's contact can be found on Bug 24401
14:29:32 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24401 new feature, P5 - low, ---, danyonsewell, Needs Signoff , REST API: Check-in
14:29:54 <cait> pm'd you the email address tcohen
14:29:58 <tcohen> thanks
14:30:05 <tcohen> oleonard++
14:30:08 <tcohen> cait++
14:30:13 <cait> Otherwise, I asked the QA team about some lessons learned and will respont to emails soon :)
14:30:16 <tcohen> the stage is yours
14:30:54 <cait> As always, we need more hands and brains than we have available, but I think we did a good job for 22.11 in keeping the old ones out of the list
14:31:52 <cait> the number... have been a bit too high at times for my liking, but something we can work on
14:32:01 <cait> qa_team++
14:32:17 <cait> join QA, it's fun and we like people who know how to break stuff :)
14:33:24 <cait> nothing more from me
14:33:29 <tcohen> ok, moving on, will skip KohaCon and roadmap
14:33:54 <tcohen> #topic Actions from last meeting
14:33:58 <tcohen> cait?
14:33:58 <wahanui> i guess cait is looking at the smaller enh still as they can still go in until next week
14:35:09 <Joubu> which agenda are we following exactly?
14:35:20 <tcohen> https://wiki.koha-community.org/wiki/Development_IRC_meeting_7_June_2023
14:35:21 <tcohen> ?
14:35:43 <oleonard> I think Joubu means we skipped roadmap and KohaCon24?
14:36:01 <cait> I think only KohaCon24
14:36:05 <oleonard> (no KohaCon23 update forthcoming obviously)
14:36:06 <Joubu> ha, you said skipping KohaCon, but what next for KohaCon24?
14:36:15 <Joubu> sorry, lagging...
14:36:21 <cait> we could start asking the user groups again
14:36:33 <tcohen> #topic KohaCon24
14:36:47 <Joubu> there is "Extend to all continents?"
14:36:48 <cait> but we need to extend the deadline for sure, it says April 4
14:37:04 <cait> yes, we also could do that
14:37:23 <cait> it would mean adding back US and Europe to the list of eligible continents
14:37:50 <ashimema> ha..
14:37:59 <caroline_crazycatlady> extend to all continent was my idea since no one volunteered from the eligible continents... But it can be as a last resort
14:38:19 * ashimema votes InLibro hosts
14:38:21 <ashimema> 😉
14:38:29 <oleonard> +1 !
14:38:31 <tcohen> inlibro++
14:38:38 <tcohen> let's vote
14:38:39 <ashimema> never been to your neck of the woods
14:38:46 <caroline> lol! I can ask, but we have to extend to all continents ;)
14:38:48 <ashimema> 😂
14:38:55 <cait> deal
14:39:21 <oleonard> I don't think we should hesitate to extend to all continents after giving everyone a chance to volunteer
14:39:30 <tcohen> yeah
14:39:34 <ashimema> +1
14:39:35 <tcohen> we should set a rule
14:39:41 <tcohen> if deadline passes
14:39:46 <thd> I thought we had a rule.
14:39:49 <caroline> [off] I keep thinking about it bc our new office has a really nice venue, and I'd love to have you all here
14:39:50 <tcohen> the limit is lifted
14:40:47 <cait> caroline: action you to update the wiki page? :)
14:40:55 <cait> or is that a conflict of interest now?
14:40:59 <tcohen> I think KohaCon24 should be discussed on a general meeting
14:41:08 <cait> we only have 4 nowadays
14:41:17 <oleonard> Yes, with details of Inlibro's proposal ;)
14:41:35 <caroline> the last general meeting was missed and I don't think any was scheduled after
14:42:06 <tcohen> let's schedule one?
14:42:28 <cait> so we are not lifting the limit or just to discuss proposals?
14:42:44 <tcohen> we lift the limit
14:42:57 <tcohen> and we schedule a general meeting, to consider inlibro's proposal
14:43:09 <oleonard> :D
14:43:13 <cait> ok
14:43:15 <cait> when?
14:43:24 <cait> caroline: how much time do you need? ;)
14:44:10 <tcohen> #info The 'different continent' rule for KohaCon24 is lifted as there were no elegible proposals
14:44:34 <oleonard> caroline: Just tell the boss we came to a binding agreement without them
14:45:01 <caroline> lol! He's out for the week, but I can bring the idea to him next week
14:45:09 <Joubu> time to vote then!
14:45:13 <tcohen> hahaha
14:45:19 <tcohen> inlibro++
14:45:31 <tcohen> moving on hten?
14:45:46 <tcohen> #topic Roles for 23.11
14:46:04 <tcohen> [off] I need to hurry because kid's lunch is approaching
14:46:14 <tcohen> do we have all roles filled?
14:46:26 <tcohen> #link https://wiki.koha-community.org/wiki/Roles_for_23.11
14:46:56 <oleonard> Nothing under meeting facilitator, translation manager, packaging team...
14:47:01 <cait> https://wiki.koha-community.org/wiki/KohaCon24_Proposals updated the wiki page with a note, please check
14:47:20 <tcohen> mtj: are you willing to continue packaging Koha?
14:47:24 <Joubu> "cait and ashimema will put together the TODO notes from the hackfest on the Wiki"
14:47:30 <Joubu> has this been done?
14:47:36 <cait> i forgot which notes
14:47:39 <tcohen> Joubu: they skipped my question about it
14:47:39 <Joubu> lol
14:47:44 <ashimema> ha.. I thought we had
14:47:48 <cait> was that the missing docs notes?
14:47:52 <ashimema> but my brain is all fluff right now
14:48:07 <Joubu> we need to prepare meetings :D
14:48:12 <cait> yes
14:48:13 <Joubu> or that's messy
14:48:13 <ashimema> https://wiki.koha-community.org/wiki/Release_Teams will need further updates (and the bug too) if we change the team more
14:48:23 <tcohen> Joubu: are you also FQA our meetings? LOL
14:48:27 <cait> I saw the note earlier, but didn't remember, so wanted to ask (was prepared to ask ;) )
14:48:28 <Joubu> yes, definitelly
14:48:35 <tcohen> :-P
14:48:48 <cait> anyway, maybe remove it for now
14:49:40 <tcohen> #action everyone should sign for 23.11 roles
14:49:54 <cait> we are missing an IRC meeting facilitator actually
14:50:02 <cait> Translation and Packaging
14:50:06 <tcohen> we have the RM improvising
14:50:12 <cait> and Newsletter editor
14:50:29 <cait> I can ask our current newsletter editor
14:50:36 <Joubu> there is a list there - https://wiki.koha-community.org/wiki/Development_IRC_meeting_26_April_2023
14:50:45 <cait> #link https://wiki.koha-community.org/wiki/Roles_for_23.11
14:51:17 <cait> which list?
14:51:22 <tcohen> oh, right
14:51:27 <tcohen> the TODO from the hackfest
14:51:46 <cait> ah right, I'l do that this week
14:52:19 <cait> what are we doing about the missing roles?
14:52:45 <cait> I'd love to recruit and Accessibility Advocate too
14:53:00 <tcohen> I don't think there's anything we can do
14:53:13 <thd> Vote for press gangs.
14:53:21 <tcohen> about translations... bgkriegel will keep doing what he does
14:53:30 <tcohen> and we don't have volunteers
14:53:43 <tcohen> luckily we've got some documentation on the things we need to run
14:54:32 <cait> We need to find a time to fix the manuals
14:54:40 <tcohen> who?
14:54:44 <cait> still no po files for the LTS manual
14:54:59 <cait> 22.11
14:55:04 <cait> I've emailed many times
14:55:15 <tcohen> yeah, we need someone to volunteer
14:55:49 <cait> I am happy to test, but I think I can't do the technical part
14:57:13 <tcohen> can we jump to the codign guidelines review?
14:57:21 <cait> yes
14:57:32 <cait> I emailed for newsletter editor
14:57:59 <tcohen> I will ask rangi about the perldoc site, maybe we can build it automatically as we do with the api docs. Happy to take on that
14:58:19 <cait> I am nto sure if he runs that, used to be gmcharlt
14:58:20 <tcohen> and gitea, Joubu and I will upgrade it to latest Forgejo any time soon
14:58:27 <tcohen> ok
14:58:40 <gmcharlt> yep
14:58:54 <gmcharlt> happy to enterain discussing of moving it
14:59:02 * cait jumps
14:59:18 <tcohen> gmcharlt: do you have a script to build that?
14:59:24 <tcohen> or any docs?
14:59:39 <tcohen> we should make a gitlab project for it if possible
14:59:42 <cait> gmcharlt: sorry, but as you are here... can we have recent years? :) https://meetings.koha-community.org/
15:00:12 <cait> newsletter editor is filled now :)
15:00:39 <tcohen> gmcharlt: can we schedule a call to talk about those services
15:00:51 <tcohen> wiki, meetings, perldoc
15:01:48 <tcohen> I ask because I need to leave soon
15:01:59 <tcohen> and I'm interested to talk now we have you here
15:02:46 <tcohen> ok moving on
15:02:53 <tcohen> #topic Review of coding guidelines
15:03:23 <tcohen> Any objections to adopt a perltidyrc for the project?
15:03:33 <Joubu> nope, push it :D
15:03:35 <tcohen> (once it is approved by devs on the bug)
15:03:39 <tcohen> yeah, of course
15:03:42 <ashimema> go for it
15:03:45 <tcohen> I'm using it already
15:03:50 <Joubu> me too
15:03:51 <tcohen> ok, stamp your signature ashimema
15:03:59 <Joubu> we should all set it up for a month and agree with it
15:04:12 <tcohen> I've been using it on VSCode
15:04:13 <ashimema> I think I already did
15:04:24 <ashimema> though actually.. I raised some concerns I think
15:04:30 <cait> updating the notes on how to use it with different editors would be nice
15:04:41 <tcohen> let's discuss the perltidyrc on the bug
15:05:01 <tcohen> #action Joubu will document on the wiki how to set the perltidyrc on vim
15:05:04 <cait> https://wiki.koha-community.org/wiki/Perltidy
15:05:15 <tcohen> #action tcohen will document on the wiki how to set perltidyrc on vscode
15:05:34 <tcohen> #link https://wiki.koha-community.org/wiki/Perltidy
15:05:37 <cait> I can try for Geany (might be the only one using it) when I see how you do it :)
15:05:46 <tcohen> excellent cait
15:05:47 <tcohen> cait++
15:05:47 <Joubu> I've added it already to the suggestion for the guideline, but yes I can add it there as well
15:06:13 <cait> the wiki page says we don't use one, so should change that for sure, maybe with link to coding guidelines
15:06:13 <tcohen> About password field treatment
15:06:40 <Joubu> @later tell mtj please have a look at bug 30002 comment 23
15:06:40 <huginn> Joubu: The operation succeeded.
15:07:49 <tcohen> anyone volunteers to document how password fields should be handled?
15:08:16 <cait> what's the problem?
15:08:16 <oleonard> That sounds like my department, I'll have to review the bug to get up to speed
15:08:16 <wahanui> the problem is probably time travel hasn't been invented.
15:08:32 <cait> quck, action oleonard :)
15:08:49 <tcohen> oleonard++
15:08:53 <Joubu> there is nothing to do, add autocomplete="off"
15:08:55 <tcohen> excellent
15:08:55 <wahanui> darn tootin' it is.
15:09:06 <tcohen> there are a couple new attributes
15:09:07 <Joubu> looks like more that we need tests to catch regression
15:09:17 <tcohen> new-password or similar
15:09:46 <Joubu> indeed, I hadn't seen that one
15:09:58 <tcohen> ok, oleonard will look at it
15:10:13 <tcohen> #topic Set time of next meeting
15:10:19 <tcohen> I remembered this time
15:10:56 <tcohen> can we agree on 21 June?
15:11:32 <thd> +1
15:12:06 <oleonard> +1
15:12:14 <tcohen> at 18 UTC so fridolin can join??
15:13:58 <tcohen> #info Next meeting: 21 Jun 2023, 14:00 UTC
15:14:08 * thd might be more awake.
15:14:10 <cait> tcohen++
15:14:12 <tcohen> #endmeeting