15:01:29 <tuxayo> #startmeeting Development IRC meeting 8 February 2023
15:01:29 <huginn> Meeting started Wed Feb  8 15:01:29 2023 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:29 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:29 <huginn> The meeting name has been set to 'development_irc_meeting_8_february_2023'
15:01:47 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_8_February_2023 Today's agenda
15:01:52 <tuxayo> #topic Introductions
15:02:08 <tuxayo> rmaints?
15:02:08 <wahanui> it has been said that rmaints is liliputech, wainui, lukeg and ashimema
15:02:11 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
15:02:17 <tuxayo> qa_team?
15:02:17 <wahanui> qa_team is cait, marcelr, khall, kidclamp,  lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova, Joubu and dcook
15:02:19 <tcohen> #info Tomas Cohen Arazi
15:02:39 <AgustinMoyano[m]> #info Agustin Moyano
15:02:47 <Joubu> #info Jonathan Druart
15:02:48 <khall_> #info Kyle Hall, ByWater Solutions
15:02:49 <paulderscheid[m]> #info Paul Derscheid, LMSCloud GmbH, Germany
15:02:57 <ashimema> #info Martin Renoize, PTFS Europe, UK
15:03:17 * ashimema will need to duck out at some point for school runs etc.. and is a bit distracted with another ongoing meeting
15:03:20 <lauraesca[m]> #info Laura Escamilla, ByWater Solutions
15:03:32 <thd> #info Thomas Dukleth, Agogme, New York City
15:03:38 <cait> #info Katrin Fischer, BSZ, Germany
15:03:43 <tuxayo> #info Victor Grousset, Tuxayo Antartica, France
15:04:05 <emlam> #info Emily Lamancusa, MCPL, USA
15:06:22 <tuxayo> #topic Announcements
15:06:22 <tuxayo> Anything to announce that doesn't fit better the other topics?
15:07:52 <tuxayo> #topic Update from the Release manager (22.11)
15:07:59 <tuxayo> tcohen: 🎙️
15:08:32 <cait> over 50 registrations for hackfest in Marseille .)
15:09:25 <Joubu> Can we make this meeting a bit more... dynamic?
15:09:27 <tcohen> Not many updates
15:09:31 <Joubu> so we don't spend 2h :)
15:09:40 <tcohen> sorry, I was answering something personal
15:09:41 <thd> :)
15:09:52 <tuxayo> #topic Updates from the Release Maintainers
15:09:52 <tuxayo> rmaints?
15:09:53 <wahanui> rmaints is probably liliputech, wainui, lukeg and ashimema
15:09:53 <tcohen> Not many updated, worked on wiki update this morning
15:09:56 <cait> and I was in the wrong topic - too slow
15:10:02 <tcohen> and resumed pushing.
15:10:18 <tcohen> looking closely at the conversations about compiled assets in the source tree
15:10:20 <ashimema> Likewise, we're bashing through the queue
15:10:27 <tuxayo> oops, go on tcohen, rmaints can give info also
15:10:28 <tcohen> we are removing them soon, updates to come
15:10:40 <ashimema> nice to have tcohen back and pushing to master.. my team are getting into the groove now
15:10:53 <cait> tcohen++ koha++ :)
15:10:57 <ashimema> rmaint scripts are getting refined and improved with each new member on my team taking things on
15:11:14 <ashimema> tcohen++ for all his work dockerising the release-tools
15:11:20 <tuxayo> nice
15:11:30 <ashimema> awesome on the compiled assets front tcohen
15:11:36 <ashimema> I'm excited to get that one pushed
15:11:41 <cait> also tcohen++ for the ktd updates - with the last batch of changes I am much faster because not constantly struggling permission errors
15:12:15 <tcohen> help with the README is welcome
15:12:30 <tcohen> I'm training a junior dev
15:12:40 <tcohen> and the first portion he could follow
15:12:49 <emlam> I would love to help with the README if I can ask a million questions...
15:12:49 <tcohen> but things need a tidy
15:13:06 <tcohen> emlam: I love answering things
15:13:09 <tcohen> so, go ahead :-D
15:13:12 <emlam> I'm just getting the hang of using it so the perspective on what's helpful for a new user is fresh for me
15:13:17 <emlam> Awesome! :0
15:13:20 <emlam> :)
15:13:27 <cait> I think it's great - we need to take that feedback and make things better
15:14:45 <tuxayo> emlam: if you have ideas, find some stuff confusing or find issues, you can open a ticket here: https://gitlab.com/koha-community/koha-testing-docker/-/issues
15:14:59 <tuxayo> anything else to add?
15:15:22 <tcohen> only
15:15:23 <emlam> got it - will do
15:15:38 <tcohen> that you all can contact me if you need to talk about your devs
15:15:45 * ashimema is cleaning up readme's for some of our other infrastructure
15:15:56 <ashimema> so I can look at ktd too
15:15:58 <tcohen> it is better to do it like that, specially if some dev is stuck and imporant for you
15:16:07 <ashimema> it's already on the list to slim it down a bit and clarify some points
15:16:30 <tcohen> ashimema: I'd like to have a separate 'advanced' file for tricks and stuff
15:16:42 <ashimema> yeah.. I was thinking along those line
15:16:48 <ashimema> or maybe even a gitlab wiki site
15:16:56 <ashimema> there's in the repo in another branch if I remember correctly
15:16:58 <tcohen> \o/
15:18:02 <tuxayo> moving on?
15:18:17 <tcohen> yes please
15:18:21 <tuxayo> #topic Updates from the QA team
15:18:25 <tuxayo> qa_team?
15:18:25 <wahanui> qa_team is, like, cait, marcelr, khall, kidclamp,  lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova, Joubu and dcook
15:19:23 <tuxayo> There was testing sessions spread over 3 days as part of the hackathon of KohaLa (french Koha users association).
15:19:24 <tuxayo> 3 attendants, 2 new people trained on patch testing. Results for attendants: 11 tickets out of the Needs Signoff queue: 5 signoffs and 6 failed QA. And 2 attempts with a comment let on the ticket to ask for more details about how to test.
15:20:13 <ashimema> tuxayo++
15:21:10 <ashimema> really happy these sessions are happening.. and glad to hear they're slowly picking up attendance a bit
15:21:39 <cait> oh sorry
15:22:01 <cait> I am also happy to see some movement on the queue and hope we'll get below 100 soon
15:22:01 <wahanui> okay, cait.
15:22:03 <cait> and then even lower
15:22:22 <cait> the number of bad bugs is a little worrying, to we shoudl focus on those to get stable more stable
15:22:34 <cait> and then there are some bugs sitting since December I'd like to see moving
15:22:56 <cait> but overall, we seem to pick up speed, which is good and please continue :)
15:23:11 <tuxayo> ashimema: it being part of another even helps a lot to have people planning time for it. Otherwise it's tough to get people ^^
15:23:42 <tuxayo> moving on?
15:23:53 * ashimema has been trying.. but you keep filing it back up again cait ;P
15:24:36 <tuxayo> #topic Status of roadmap projects
15:24:43 <cait> sorry, not sorry :)
15:25:07 <tuxayo> «ERM/Vue/Cypress »
15:25:11 <tuxayo> - Run yarn build commands after reset_all (waiting for approval) https://gitlab.com/koha-community/koha-misc4dev/-/issues/60
15:25:14 <tuxayo> - Issue #60 - Run build_js if available otherwise build (waiting for approval) https://gitlab.com/koha-community/koha-misc4dev/-/merge_requests/58
15:25:17 <tuxayo> - Issue #62 - Run cypress tests with --run-all-tests (waiting for approval) https://gitlab.com/koha-community/koha-misc4dev/-/merge_requests/59
15:25:21 <tuxayo> - Bug 32609 - Remove compiled files from src (waiting for QA)
15:25:21 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32609 enhancement, P5 - low, ---, jonathan.druart+koha, Signed Off , Remove compiled files from src
15:25:24 <tuxayo> - Bug 32806 - Some Vue files need to be moved for better reusability (In discussion!)
15:25:24 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32806 enhancement, P5 - low, ---, jonathan.druart+koha, In Discussion , Some Vue files need to be moved for better reusability
15:25:28 <tuxayo> - Bug 32898 - Cypress tests are failing (Waiting for SO)
15:25:28 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32898 major, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Cypress tests are failing
15:25:45 <tuxayo> lots of stuff going on! :)
15:26:01 <Joubu> lot of help needed
15:26:03 <tuxayo> comments from people involved?
15:26:17 <Joubu> we need more help to make them move forward
15:26:34 <Joubu> it's all related to removing the compiled files, js and css
15:26:53 <Joubu> different layers need to be adjust to prevent crashes, so misc4dev and ktd, and finally koha
15:27:09 <Joubu> there 2 follow-ups to improve the current situation 32806 and 32898
15:27:27 <Joubu> and I forgot https://gitlab.com/koha-community/koha-testing-docker/-/issues/311
15:27:37 <Joubu> we don't run cypress tests, and we missed regressions
15:27:58 <Joubu> there is code in all of that, all we need to testing
15:28:58 <Joubu> I will continue with the other topics, just raise hand if you have question
15:29:06 <Joubu> * git hooks
15:29:25 <Joubu> I sent an email to the list, we now have pre-commit hook that will installed automagically for ktd users
15:29:34 <Joubu> currently it's broken, so don't pull your ktd images!
15:29:40 <Joubu> but it will get fixed very soon
15:29:47 <Joubu> * ktd DB persistency (waiting for approval)
15:30:00 <Joubu> several people asked that, it will allow to keep the DB from one run to another
15:30:12 <cait> i like that
15:30:16 <Joubu> code is there, just need to be tested and merged
15:30:20 <cait> but haven# thad time to test
15:30:31 <Joubu> * CI/Jenkins
15:30:44 <Joubu> I sent an email to the QA team already, nothing new here
15:30:48 <Joubu> Clean of the job list (done)
15:31:00 <Joubu> it was messy, not it's a bit better. Less jobs, better coverage
15:31:01 <tcohen> about the git hooks, https://gitlab.com/koha-community/koha-testing-docker/-/pipelines/771428468
15:31:05 <Joubu> Test of Pipeline (https://jenkins.koha-community.org/job/test_pipeline/) (to improve later)
15:31:11 <ashimema> I can work through testing that lot tomorrow..
15:31:15 <ashimema> someone remind me 😜
15:31:32 <Joubu> I had a try at testing pipeline's jenkins. The idea is to not run all the jobs at first, but only if the big one succeeds
15:31:33 <tcohen> leaving to feed the little beasts, sorry
15:31:38 <Joubu> run_tests.pl (done, can be used from ktd!)
15:31:41 <Joubu> https://gitlab.com/koha-community/koha-testing-docker/-/issues/320 https://gitlab.com/koha-community/koha-misc4dev/-/issues/58
15:31:52 <tuxayo> Joubu++
15:31:52 <Joubu> there is an awesome new script in ktd, run_tests.pl
15:32:03 <Joubu> use --help and it will tell you all what it can do
15:32:13 <Joubu> run_tests.pl --run-all-tests
15:32:22 <Joubu> and you will run all tests like you are jenkins
15:32:38 <Joubu> (this is pushed already, you can enjoy it now)
15:32:44 <Joubu> * RabbitMQ/worker (waiting for something)
15:32:53 <Joubu> several things pushed, but more are coming, and need help for those
15:32:59 <Joubu> Bug 32305 - Background worker doesn't check jobs receive from rabbitmq are in 'new' state
15:32:59 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32305 major, P5 - low, ---, jonathan.druart+koha, Signed Off , Background worker doesn't check jobs receive from rabbitmq are in 'new' state
15:33:02 <Joubu> Bug 32395 - Why do we send jobs params to the broker
15:33:02 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32395 enhancement, P5 - low, ---, koha-bugs, In Discussion , Why do we send jobs params to the broker
15:33:04 <Joubu> Bug 32594 - Add a dedicated ES indexing background worker
15:33:05 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32594 critical, P5 - low, ---, nick, Needs Signoff , Add a dedicated ES indexing background worker
15:33:22 <Joubu> The last one has code and need to be tested. I think it's a great improvement for production system
15:33:28 <Joubu> * Bugzilla
15:33:33 <Joubu> Bug 32614 - Highlight important comments
15:33:33 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32614 enhancement, P5 - low, ---, jonathan.druart+koha, In Discussion , Highlight important comments
15:33:53 <Joubu> If a comment has the "important" tag, the comment will be highlighted. No excuse to not read a comment
15:34:15 <Joubu> that will be useful for QAers, RM and RMaints. No need to read all the comments, the important ones should have the info you need to know!
15:34:18 <Joubu> that's all for me
15:34:35 <AgustinMoyano[m]> Joubu++
15:34:45 <emlam> Joubu++
15:34:59 <tuxayo> important tag is very nice, will avoid some issues we ran in the past
15:35:23 <tuxayo> #topic Actions from last meeting
15:35:53 <tuxayo> «cait add to RMaint documentation to run the test suite locally for security release»
15:35:53 <tuxayo> Done, if I recall correctly
15:36:00 <cait> yes
15:36:03 <cait> but can we add another?
15:36:09 <cait> we shoudl add the important tag to the wiki
15:36:16 <cait> it's a koha specific Bugzilla thing
15:36:39 <cait> and it hink we have another custom tag... obsolete?
15:36:56 <tuxayo> Like a category to some pages in the wiki?
15:37:23 <tuxayo> would having them listed as such in the homepage be enough?
15:39:28 <Joubu> I think cait wants to add a note about the 'important' tag, to the RMaint doc
15:39:57 <Joubu> we should move on
15:40:14 <tuxayo> ok
15:40:39 <tuxayo> I needed to find a link:
15:40:42 <Joubu> #action cait add info about the 'important' tag to RMaint documentation
15:40:42 <tuxayo> «Please reply to the mailing list about Forgejo/Gitea fork and what we should do»
15:40:43 <tuxayo> see and previous month for the begininng https://lists.koha-community.org/pipermail/koha-devel/2023-February/thread.html
15:41:13 <tuxayo> «Guidelines for SQL - please provide feedback on the mailing list https://lists.koha-community.org/pipermail/koha-devel/2023-January/048016.html»
15:41:22 <tuxayo> #action tcohen To schedule/call a "CSRF day" to work on related patches together (previously deferred until after the 22.11 release).
15:41:29 <tuxayo> #action tcohen To draft proposal for master→main change and draft of action list (previously deferred until after the 22.11 release).
15:41:38 <tuxayo> «oleonard ashimema Draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside. Update: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft (previously deferred until after the 22.11 release).»
15:41:51 <tuxayo> Anything new about the previous item?
15:41:54 <ashimema> sorry. was distrected
15:42:12 <ashimema> nope.. not managed to move that forward yet
15:42:23 <ashimema> but it's still on the list and is an open tab in my browser
15:42:32 <ashimema> https://annuel.framapad.org/p/koha-styleguide-draft
15:42:36 <Joubu> IMO we should move to forgejo in a couple of months
15:42:37 <tuxayo> #action oleonard ashimema Draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside. Update: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft (previously deferred until after the 22.11 release).
15:42:48 <ashimema> would love some input on the questions etc there
15:42:59 <ashimema> forgejo would be good
15:43:08 <paulderscheid[m]> Is self-hosted imperative here?
15:43:12 <Joubu> yes
15:43:17 <Joubu> I think so
15:43:18 <paulderscheid[m]> Alright
15:43:26 <Joubu> it has always been
15:43:39 <Joubu> and we have a server already, there is nothing to do
15:43:45 <paulderscheid[m]> The forgejo ftw
15:43:51 <Joubu> *almost* nothing
15:43:53 <paulderscheid[m]> *Then
15:44:18 <Joubu> we need to vote that at some point however
15:44:21 <tuxayo> Migration from gitea to forgejo shouldn't be much trouble. Still some work for the person doing it.
15:45:04 <tuxayo> Has the dust settled enough on the fork between the two projects?
15:45:33 <cait> oh i got actioned... was htinking about the Bugzilla docs... but maybe both?
15:45:33 <Joubu> one is transparent, the other is not
15:46:29 <tuxayo> > was htinking about the Bugzilla docs
15:46:29 <tuxayo> So updating the wikipage about using bugzilla to mention the important tag?
15:47:08 <Joubu> #action Joubu we need to vote on forgejo move at some point
15:48:47 <tuxayo> People that haven't done it (including me) go to the koha-devel topic and give feedback on the proposal to moving to Gitlab, it's a completely different plan
15:49:19 <Joubu> it's not a proposal :D
15:49:40 <Joubu> It misses the "why" we would need to migrate to gitlab
15:50:03 <Joubu> we did change the git hosting to something more modern already few years ago
15:50:12 <Joubu> anyway, I don't have the energy for that right now :D
15:50:13 <tuxayo> Me too, there would be reasons but they are not mentioned in the discussion so I'm not sure why
15:50:23 <tuxayo> #info opinions needed to decide the future of our git hosting https://lists.koha-community.org/pipermail/koha-devel/2023-February/thread.html
15:50:24 * ashimema runs off for the school run/parents evening
15:50:29 <tuxayo> moving on?
15:50:48 <tuxayo> #topic General development discussion (trends, ideas, ...)
15:50:52 <tuxayo> «ACK pre vs post processing for background jobs »
15:50:59 <tuxayo> «    Bug 32573 - background_jobs_worker.pl should ACK a message before it forks and runs the job suggests we should ACK of STOMP messages before we begin processing which would avoid the issue 30 minute time issue among other problems. It appears that the STOMP documentation and the RabbitMQ documentation do not agree. We should have a vote if needed.»
15:50:59 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32573 normal, P5 - low, ---, kyle, Pushed to oldstable , background_jobs_worker.pl should ACK a message before it forks and runs the job
15:51:03 <Joubu> it's pushed
15:51:09 <tuxayo> lol
15:51:23 <tuxayo> good then ^^"
15:51:39 <khall_> indeed!
15:51:40 <thd> tcohen has updated test.wiki.koha-community.org to MediaWiki Canasta 1.22.  I have not found any new bugs.  People should look and remember that the test database is not current.
15:51:50 <tuxayo> Anything else to discussion before closing?
15:52:19 <oleonard> Anyone know what happened with Catalyst Academy?
15:52:28 <oleonard> They announced it but then I didn't hear anything more
15:53:00 <tuxayo> :o
15:53:21 <paulderscheid[m]> Server for penpot is already running, hadn't had the time to set it up, though.
15:53:46 <paulderscheid[m]> If anyone knows a way around unprivileged docker containers, hit me up.
15:53:56 <paulderscheid[m]> *his way around
15:54:24 <tuxayo> paulderscheid++
15:55:07 <paulderscheid[m]> or her way, of course :D
15:55:19 <AgustinMoyano[m]> There is a rule in qa scripts that don't allow for backticks be used in js files
15:55:47 <AgustinMoyano[m]> That was reported in bug 24725
15:55:47 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24725 normal, P5 - low, ---, jonathan.druart+koha, CLOSED FIXED, xgettext does not support (yet) ES template literals
15:55:55 <paulderscheid[m]> template literals much o.o
15:56:51 <AgustinMoyano[m]> To test if it works you can:
15:56:51 <AgustinMoyano[m]> git clone --depth 1 --branch import_source_vue git@gitlab.com:thekesolutions/Koha.git
15:57:08 <AgustinMoyano[m]> sorry
15:57:28 <AgustinMoyano[m]> https://gitlab.com/thekesolutions/Koha.git
15:57:32 <AgustinMoyano[m]> run qa where it will tell you that it has backticks
15:57:44 <AgustinMoyano[m]> and then run
15:57:44 <AgustinMoyano[m]> /kohadevbox/koha/misc/translator$ perl translate update es-ES
15:57:53 <AgustinMoyano[m]> you will see that it runs ok
15:57:55 <paulderscheid[m]> AFAIK support was added. Only doesn't work in JSX.
15:58:13 <paulderscheid[m]> AgustinMoyano[m]: Yes, that
15:59:08 <Joubu> AgustinMoyano[m]: let remove it and see if it causes troubles..
16:00:10 <Joubu> https://savannah.gnu.org/bugs/?50920
16:00:13 <Joubu> The fix is contained in gettext 0.20.2.
16:00:16 <AgustinMoyano[m]> Joubu: Ok, later I'll ask you how we cand do it
16:01:08 <Joubu> AgustinMoyano[m]: https://gitlab.com/koha-community/qa-test-tools/-/blob/master/QohA/File/JS.pm#L19
16:01:21 <Joubu> it's there, just remove check_ES_template_literals and related code from qa-test-tools
16:01:34 <AgustinMoyano[m]> great!
16:02:18 <tuxayo> Nice! so let's close?
16:02:45 <Joubu> yes
16:02:55 <Joubu> ktd is fixed, you can pull now!
16:02:57 <tuxayo> #topic Set time of next meeting
16:02:58 <tuxayo> #info Next meeting: 22 February 2023, 22 UTC
16:03:18 <tuxayo> As for next meeting on this timeslot: Thursday 9 march? Because March 8 (International Women's Day) is a public holiday in several countries according to Wikipedia.
16:03:18 <tuxayo> And as for France, I see on walls in Marseille calls for women to be on strike that day. And I know there will be big demonstrations open to anyone.
16:05:00 <paulderscheid[m]> LGTM
16:05:31 <tuxayo> #info for this time slot, next meeting is: 09 March 2023, 15 UTC
16:05:34 <tuxayo> #endmeeting