12:07:50 <cait> #startmeeting Development Meeting 18 October 2023
12:07:50 <huginn> Meeting started Wed Oct 18 12:07:50 2023 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:07:50 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:07:50 <huginn> The meeting name has been set to 'development_meeting_18_october_2023'
12:08:00 <cait> #chair tcohen
12:08:00 <huginn> Current chairs: cait tcohen
12:08:04 <cait> #info Introductions
12:08:28 <cait> #topic Introductions
12:08:35 <tcohen[m]> #info Tomas Cohen Arazi
12:08:54 <thd> #info Thomas Dukleth, Agogme, New York City
12:09:03 <cait> #info Katrin Fischer, BSZ, Germany
12:09:14 <paulderscheid[m]> #info Paul Derscheid, LMSCloud GmbH, Germany
12:09:17 <marcelr> #info Marcel de Rooy, Rijksmuseum
12:09:24 <MatthewBlenkinsop[m]> #info Matt Blenkinsop, PTFS Europe, UK
12:10:08 <cait> #topic Announcements
12:11:04 <cait> #info User meeting for German speaking Koha users on 5th December, see https://koha-dach.eu
12:11:16 <cait> #topic Update from the Release Manager
12:11:42 <cait> #info QA has been filling up RM's queue - tcohen is trying to catch up.
12:11:57 <cait> #info Please react fast if there are any questions, doesn't apply, follow-ups required etc.
12:12:09 <cait> #info deadlines are approaching fast
12:12:46 <cait> bug 29523
12:12:46 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29523 major, P5 - low, ---, martin.renvoize, Signed Off , Add a way to prevent embedding objects that should not be allowed
12:15:31 <cait> #info Preservation module and ERM usage  were also mentioned explicitly
12:18:19 <cait> #info discussed possible transcription of meetings, resurrecting the meeting factilitator as a Release Team role
12:19:13 <cait> #topic Update from the Release Maintainers
12:20:16 <cait> #info 22.11 in string freeze now
12:20:46 <cait> #action MatthewBlenkinsop to get in touch with bgkriegel
12:21:05 <cait> #action tcohen to publish freeze dates via mailing list
12:24:08 <cait> #info there was an error in 21.11 that was fixed by tcohen (update issue)
12:24:33 <cait> #topic Update from the QA team
12:24:56 <ashimema> #info Martin Renvoize, PTFS Europe
12:28:59 <cait> #info QA queue is shrinking, but still too big - hopefully we will be able to shrink it some more and get the older bugs out soon
12:29:10 <cait> #topic Status of the roadmap projects
12:29:44 <cait> #link https://wiki.koha-community.org/wiki/Roadmap_for_23.11 Rodmap in the wiki
12:30:09 <cait> #info bug 17427
12:30:09 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17427 normal, P5 - low, ---, koha-bugs, NEW , Replace CGI::Session with Data::Session
12:31:11 <cait> #info bug 33537 is waiting for QA
12:31:11 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33537 enhancement, P5 - low, ---, m.de.rooy, Signed Off , Move domain limits from koha-conf to staff SMTP configuration
12:32:02 <cait> #info bug 17427 will need to be postponed to next cycle, but would be great to have
12:33:05 <cait> #info most of the roadmap is on the way for release
12:36:52 <cait> #topic KohaCon25 update
12:37:02 <cait> #info postponed!
12:37:41 <cait> #topic Roles for 24.05
12:38:05 <cait> #link https://wiki.koha-community.org/wiki/Roles_for_24.05
12:38:57 <cait> #info Elections will be held next Dev Meeting
12:39:12 <cait> #action tcohen will send an email about the roles to the mailing list
12:39:48 <cait> #topic Actions from previous meetings
12:46:32 <cait> #info perldoc still needs updating, need the script to run
12:47:58 <cait> #action paulderscheid[m] to share his script for perldocs
12:48:36 <cait> #info Move from Gitea to Forgejo moved to beginning of next cycle
12:49:56 <cait> #topic General development discussion
12:51:23 <cait> #info DMARC: thd got in touch with Rachel for Koha main list, they would be happy for someone to take over hosting
12:51:31 <cait> #info Joubu could change settings on the Bblibre hosted lists
12:53:02 <cait> #info bug 34927
12:53:02 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34927 enhancement, P5 - low, ---, wizzyrea, NEW , Adding DMARC compatibility to mailing lists
12:55:32 <Joubu> done
12:55:51 <cait> you already made the changes?
12:56:01 <Joubu> yes
12:56:11 <cait> all or only koha-devel?
12:56:18 <Joubu> koha-devel, see comment on the bug
12:56:37 <cait> right now or a while ago? :)
12:56:47 <Joubu> now
12:57:41 <marcelr> Joubu: Should prefetch-count be activemq.prefetchSize in worker script?  See https://metacpan.org/pod/Net::Stomp versus https://www.rabbitmq.com/stomp.html
12:58:20 <cait> #info koha-devel is in testing now with the DMARC improved configuration
12:58:30 <cait> #action thd to inform mailing list
12:59:02 <cait> #info moving master to main to be done next cycle
12:59:57 <cait> #info Draft style guide is still pending, modals info should be added
13:00:41 <cait> #link https://wiki.koha-community.org/wiki/Translation_server_migration_weblate
13:01:06 <cait> # Please visit the wiki page, there is bugs we need to have pushed/worked on and also open question on Weblate
13:01:32 <cait> #topic Review of Coding guidelines
13:01:35 <Joubu> for info koha-manual will move from master to main in the next couple of weeks
13:01:49 <cait> #info no topics on agenda
13:01:59 <Joubu> I need urgently bug 35079; bug 34959; bug 35043; bug 35024 to test the migration to weblate
13:01:59 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=35079 enhancement, P5 - low, ---, julian.maurice, Signed Off , Add option to gulp tasks po:update and po:create to control if POT should be built
13:02:00 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34959 major, P5 - low, ---, jonathan.druart+koha, Passed QA , Translator tool generates too many changes
13:02:01 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=35043 enhancement, P5 - low, ---, jonathan.druart+koha, Signed Off , Handling of \t in PO files is confusing
13:02:02 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=35024 normal, P5 - low, ---, jonathan.druart+koha, Needs Signoff , Do no wrap PO files
13:02:05 <cait> #info koha-manual will move from master to main in a couple of weeks
13:02:47 <cait> #Set time of next meeting
13:02:50 <marcelr> Joubu will look Friday
13:05:02 <cait> #info Next meeting: 1 November 2023, 13 UTC
13:13:45 <cait> #endmeeting