17:02:10 <caroline> #startmeeting Documentation IRC meeting 16 February 2023
17:02:10 <huginn> Meeting started Thu Feb 16 17:02:10 2023 UTC.  The chair is caroline. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:10 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:10 <huginn> The meeting name has been set to 'documentation_irc_meeting_16_february_2023'
17:02:23 <caroline> #link https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_16_February_2023
17:02:32 <caroline> #topic Introductions
17:02:36 <caroline> please use "#info" in front of your introduction to have it show up in the automatic minutes
17:02:40 <caroline> #info Caroline Cyr La Rose, inlibro, Montreal, Qc
17:02:52 <davidnind> #info David Nind, New Zealand
17:02:56 <aude_c> #info Aude Charillon, PTFS Europe, UK
17:03:05 <ashimema> #info Martin Renvoize, PTFS Europe, UK
17:03:16 <cait> #info Katrin Fischer, BSZ, Germany
17:03:42 <marie-luce> #info Marie-Luce Laflamme, inlibro, Montreal, Canada
17:04:41 <caroline> #topic Review of action points
17:04:55 <caroline> caroline to branch the manual -> done!
17:05:12 <caroline> we now have a 22.11 and 23.05 (dev) manual
17:05:23 <caroline> https://koha-community.org/manual/23.05/en/html/index.html
17:05:33 <caroline> https://koha-community.org/manual/22.11/en/html/index.html
17:05:58 <caroline> and latest I think goes to 22.11
17:06:01 <caroline> https://koha-community.org/manual/latest/en/html/index.html
17:06:05 <cait> i emailed bgkriegel for po files, haven't heard back yet
17:06:16 <caroline> Big thanks to everyone who helped :)
17:06:47 <caroline> I also emailed him for the form thing, but didn't hear back either
17:07:20 <caroline> davidnind to check the scripts and translations tweaks in prevision of a possible switch to markdown
17:07:43 <davidnind> still working on my action points, apologies for not getting them done
17:07:51 <caroline> no prob!
17:08:18 <caroline> caroline to plan a screenshot replacing session for hackfest -> done, details to hash out
17:08:44 <davidnind> caroline++
17:08:47 <aude_c> ...to hash out a bit more now or later? :D
17:09:05 <cait> someone eager to do screenshots, I like :)
17:09:12 <caroline> #info on Wednesday March 29, whatever time you are in, we're going to "get together" in person and virtually to update the screenshots in the manual with the new design
17:10:12 <caroline> The details I'm still thinking about are how to actually do it... I think we should just update the actual images, not the information in the images.rst file, otherwise, I will spend all day just rebasing everything
17:10:17 <caroline> what do you think?
17:10:31 <aude_c> I'll be in Marseille in person; Lucy is planning to join in virtually
17:10:42 <aude_c> I'm not sure I understand what you mean, sorry
17:10:58 <caroline> jzairo and kellym also said they'd participate virtually
17:11:06 <aude_c> nice
17:11:17 <davidnind> that sounds great!
17:11:32 <cait> I think there are some more people interested to help out in Marseille
17:11:42 <cait> could be a nice group
17:11:49 <marie-luce> nice
17:11:50 <aude_c> :)
17:12:13 <ashimema> excellent
17:12:13 <wahanui> darn tootin' it is.
17:12:16 <caroline> So when we make parallel changes to a same file, there can be clashes between the changes, that's why I was proposing we only update the actual images and not the images.rst file
17:12:27 * ashimema still thinks medium term we should move away from images.rst
17:12:41 <cait> i think we shoudl automate this
17:12:57 <cait> but not sure we can't this time
17:13:01 <cait> ... can
17:13:06 <caroline> ashimema, I'm now a bit colder to the idea since the images between bundles and erm were mixed up
17:13:18 <ashimema> it seems rather maddening to do it that way
17:13:32 <marie-luce> Is there a way to generate a new images.rst file after all images modifications?
17:13:44 <ashimema> I don't understand how they got mixed up honestly.
17:13:55 <caroline> ashimema, me either...
17:13:56 <cait> you don't need to chang eit if you just replace the image file with the ame name
17:14:04 <aude_c> caroline: does that mean we have to upload the new images with the same file name the old ones have, so we don't have to update the images.rst file??
17:14:05 <ashimema> correct cait
17:14:15 <caroline> marie-luce, not really because the changes to the images.rst file are mostly to add alt text
17:14:19 <ashimema> so in this case just changing the images themselves would work and not require rebasing
17:14:22 <caroline> aude_c, yes exactly
17:14:23 <cait> I think that's what caroline is suggesting, replace the images, don't change file names/references
17:14:30 <aude_c> got it, thanks
17:14:48 <marie-luce> make sense
17:15:02 <caroline> Is that ok with everyone? I really like adding alt text when updating images, but I don't hink in this case it's feasible
17:15:26 <aude_c> I was going to say: it does sound like a bit of a shame we're missing out on adding alt text at the same time
17:15:55 <aude_c> but if there's no other way it can just be a job for another time!
17:16:07 <caroline> cait, I did ask if someone would help us automate images at the hackfest, but didn't hear back from anyone... if you can lobby about it while there, it would be great :)
17:16:19 <cait> I can try
17:16:40 <cait> sadly no idea on how to do this myself, but it would be so nice to have
17:16:49 <davidnind> sorry, I haven't done much work recently on automating screenshots - maybe at the hackfest we could get some traction - I have started https://codeberg.org/davidnind/koha-automated-screenshots
17:17:01 <caroline> aude_c, yeah, I think it's a shame too, but I'm just anticipating the amount of clashes it would create and I'm not super good with git rebases
17:17:06 <davidnind> Just need to add some instructions
17:17:47 <davidnind> Maybe for the alt text have a shared doc, using googe docs or framapad, then it can be done as one commit after
17:18:02 <cait> that sounds like a good idea
17:18:11 <aude_c> yes, i was also thinking we'd need something shared
17:18:13 <caroline> that is going to be another big task davidnind right? we have to manually create the situations (like click here, enter X, click there, etc)?
17:18:43 <aude_c> not if we just have the whole page?
17:18:44 <caroline> davidnind, I like the framapad idea
17:19:22 <caroline> We could copy the images.rst file into frama and edit it as a group and then copy the result back in images.rst and commit that
17:19:38 <cait> +1
17:19:40 <caroline> I like it... I'm going to add it to my notes
17:19:41 <aude_c> yes, i like that
17:19:45 <davidnind> +1
17:20:28 <davidnind> for automated screenshots it would be a big task, particularly setting up the content required - I've mastered some basic scenarios, but am a little out of my depth with cypress.io
17:20:42 <ashimema> what editors are people using/encouraging?
17:21:00 <ashimema> we've recently been using LiveShare in VSCode at PTFS-E...
17:21:10 <aude_c> while we're talking about screenshots; what do we do about the old screenshots? Can we delete the files? How do we make sure they're not used in several locations (and therefore shouldn't yet be deleted)?
17:21:28 <ashimema> it allows live editing of the same file by multiple participants in an editing session.. that might work for a hackfest scenario
17:21:36 <caroline> if they are used in many places, when we update, they should be updated everywhere
17:21:42 <cait> if they are used in several locations, should they not be replaced in all of them?
17:22:03 <davidnind> ashimema: I'm using VS Codium (basically VS Code without the Microsoft Tracking)
17:22:10 * ashimema too
17:22:23 <cait> i tihnk we'd not start with an empty images directory
17:22:24 <caroline> I have seen some instances where one image has different aliases, which I don't understand at all, but I think it should still work
17:22:38 <cait> but replace as we go and maybe if we do the framapad we could also mark the ones done or the ones people are working on there
17:22:40 <ashimema> I think when i last looked 99%+ of our images are unique.. we hardly ever share
17:23:01 <aude_c> caroline, cait: maybe I'm just not understanding how it's supposed to work.
17:23:27 <marie-luce> I've found an old wiki page the other day about ideas on how to automated screenshot. https://wiki.koha-community.org/wiki/Documentation_Automated_Screencapture
17:23:27 <caroline> I try to reuse some when it just shows like a row of buttons, I use the same image in all the places where those buttons are refered
17:23:56 <aude_c> but you still use the same alias for that image?
17:24:09 <caroline> aude_c, yes, I use the same alias everywhere
17:24:48 <caroline> But like I said, at the beginning I think they were a bit zealous with aliases and used a different one for every place the same image was used
17:24:59 <aude_c> so to be thorough before deleting an old image, I'd need to search for its alias in every page
17:25:06 <caroline> Hopefully, we'll phase those out
17:25:10 <davidnind> bug 29716
17:25:10 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29716 enhancement, P4, ---, david, ASSIGNED , [DOCS] Automated screenshots using Cypress.io testing framework
17:25:18 <caroline> aude_c, only if you change the alias
17:25:59 <caroline> if you change lets say "image666" to "patronfile", then yes you need to change image666 in every file if it's used mor than once
17:26:33 <aude_c> ok
17:26:43 <caroline> I also check if images/patrons/patronfile.png is there more than once in images.rst with different aliases just in case
17:27:08 <aude_c> and then it's safe to delete the file
17:27:13 <aude_c> thanks
17:27:16 <caroline> exactly!
17:27:40 <caroline> but if you don't change the filename, you just sub it in the same directory and it's fine
17:29:08 <caroline> Ok so recap, we'll copy images.rst into a frama, change the aliases (? do we change the aliases?) and alt text in there, and sub the old image for the new ones, you can commit for each image or a group of images, and I'll commit the images.rst at the end
17:29:45 <caroline> Maybe I could create a frama for assigning chapters too? so we don't step all over each other?
17:29:53 <aude_c> that would be good
17:31:00 <davidnind> we may need to turn off the automated manual build, or run it each hour
17:31:57 <caroline> I'll probably do some the day before since y'all are gonna start in the middle of the night for me
17:33:14 <caroline> #info for hackfest screenshot update extravaganza, update screenshots in git, commit for each image or a group of images, DO NOT change images.rst in git, there will be a frama for that purpose
17:33:44 <caroline> #info there will be a frama to assign chapters
17:33:51 <aude_c> we could be inducting new people to the joys of Docs and screenshots in the morning (French time)
17:34:10 <caroline> #info remember to turn off auto build
17:34:26 <marie-luce> I'll be keen to learn!
17:34:32 <aude_c> should we set up a video call to have a chat too?
17:34:35 <davidnind> maybe also have a jitsi meeting session running (https://meet.jit.si/KohaDocumentationTeam) for those participating virtually (or Zoom or whatever)
17:35:04 <caroline> I'm ok with jitsi
17:35:13 <caroline> does that link work already?
17:35:15 <aude_c> +1
17:35:38 <aude_c> it should
17:35:42 <davidnind> it should - you can basically make it naything
17:35:47 <caroline> #info have a jitsi meeting session running (https://meet.jit.si/KohaDocumentationTeam) for those participating virtually
17:36:46 <caroline> alright, any other concerns or ideas regarding screenshot update? I didn't follow the automation convo, do I need to action or info anything?
17:38:05 <davidnind> probably not, if anyone is interested I'm happy to chat
17:38:36 <davidnind> feel free to comment on bug 29716
17:38:36 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29716 enhancement, P4, ---, david, ASSIGNED , [DOCS] Automated screenshots using Cypress.io testing framework
17:39:09 <caroline> davidnind++
17:39:45 <marie-luce> davidind++
17:39:46 <caroline> moving on to other action points...
17:39:58 <caroline> cait or ashimema to check if we can change 'manual' keywords to 'Nedds documenting' status in bugzilla in batch
17:40:03 <caroline> was thing feasible?
17:40:26 <caroline> *this
17:40:47 <ashimema> Oh, I hadn't realised I'd been volunteered for that
17:41:12 <ashimema> I imagine it's not too terribly difficult to do... But would need rangi.. I don't have the server access
17:41:36 <ashimema> I've not looked at the database closely enough to really judge
17:41:39 <ashimema> I like the idea though
17:41:45 <caroline> I think we had some reticence on the result, but I don't remember what they were
17:43:10 <ashimema> ?
17:43:55 <caroline> cait had said I think we can do bulk actions, but not sure if it might create a mess the Manual keyword is still kinda nice if you can't change the status yet, but already know it will affect manual
17:44:22 <caroline> https://meetings.koha-community.org/2023/documentation_irc_meeting_2023_01_19.2023-01-19-15.02.log.html (around 15:40)
17:45:02 <caroline> I had added if not possible to change bz in batch we change them as we get to them
17:45:10 <caroline> so it was really just checking if it was possible
17:45:42 <caroline> last action point caroline to send an email to the mailing list about possibly closing it down --> done, no one answered
17:45:51 <caroline> So I guess we can closed it?
17:46:01 <caroline> cait can you do it?
17:46:21 <davidnind> +1
17:47:12 <caroline> #action cait to close the Docs mailing list
17:47:17 <caroline> delegating++ XD
17:47:50 <ashimema> I could try to catch the keyword and docs part of bugzilla instead
17:48:05 <ashimema> I've been meaning to, for the dashboard, just haven't found a moment
17:48:08 <caroline> I want to skip a couple of empty topics and go directly to content development guidelines to talk about sysprefs
17:48:17 <caroline> ok more delegating...
17:48:39 <davidnind> #info Manual reorganisation update and preview - still a work in progress but gives the general idea https://davidnind.gitlab.io/koha-docs-reorganise/ Comments welcome on bug 32391
17:48:39 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32391 enhancement, P1 - high, ---, david, ASSIGNED , [DOCS] Reorganise the manual contents
17:48:39 <caroline> #action ashimema to check for the manual keyword vs Needs documenting status
17:49:38 <caroline> #topic Content development guidelines
17:49:58 <caroline> we talked about bug 29063 before
17:49:58 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29063 major, P5 - low, ---, david, ASSIGNED , [DOCS] Manual: Translation issue with repeated strings in system preferences
17:50:06 <caroline> I tried some things
17:50:18 <caroline> https://snipboard.io/jOqF7W.jpg
17:50:30 <caroline> What do you think?
17:51:10 <caroline> I had a bit of trouble with more complex sysprefs https://snipboard.io/FytHOM.jpg
17:51:45 <caroline> https://snipboard.io/2ZxHrt.jpg
17:52:06 <ashimema> Dinner time here I'm afraid so I'm clocking out, apologies
17:52:16 <caroline> bon appétit!
17:53:03 <caroline> it's almost the end of the hour, but please let me know if this could be a viable option for describing sysprefs
17:53:35 <davidnind> I've some ideas and will post on the bug
17:53:45 <aude_c> i don't think i know enough to comment on this
17:53:50 <caroline> I also tried something different for many sysprefs in the same block/sentence https://snipboard.io/kwxULT.jpg
17:53:53 <davidnind> Does this help with the translation issues (I assume it does)
17:54:26 <caroline> davidnind, I think so since the options are not separate from the sentence
17:54:43 <davidnind> great!
17:55:37 <caroline> the other options we found needed developer help, but this is something we can do to alleviate the problem
17:56:30 <cait> sorry had a call
17:57:04 <cait> the Default is probably an issue
17:57:07 <cait> on the last screenshot
17:57:25 <cait> if the Default is Enable
17:57:30 <caroline> cait the last screenshot, is something different
17:58:05 <cait> hm trying to catch up :)
17:58:16 <cait> I see what you mean about the complex one... that one is insance
18:00:00 <caroline> it's pretty insane already tbh https://koha-community.org/manual/latest/en/html/circulationpreferences.html#decreaseloanhighholds-decreaseloanhighholdsduration-decreaseloanhighholdsvalue-decreaseloanhighholdscontrol-and-decreaseloanhighholdsignorestatuses
18:01:12 <caroline> but it's a good (if extreme) example of what we have to deal with
18:01:18 <cait> yeah
18:01:28 <cait> i wish we had some way to do context :(
18:02:30 <davidnind> A while ago I mapped out some of the elements for system preferences that you would want to know (name, system preference text (asks), options, description, warnings, important notes, history (when added, changed, etc), etc) - just need to decide how to present these and then make them work for translation 8-) (will add comments to the bug)
18:02:32 <caroline> Maybe if we separate it a bit like I did in the last screenshot (https://snipboard.io/kwxULT.jpg), it could help
18:03:10 <caroline> thx davidnind! please do!
18:03:28 <cait> hm the Default line is an issue there
18:03:37 <cait> and not sure how we'd do that for something with a lot of options?
18:04:03 <caroline> yes I know, this last one is only for the separation of several sysprefs in the same sentence, not for the options
18:05:00 <caroline> sorry, I'm confusing things by talking about two things at the same time because they are both about describing sysprefs
18:05:41 <cait> oh
18:05:42 <caroline> we can talk about it next meeting?
18:05:53 <cait> maybe better
18:06:02 <cait> hard to focus right now
18:06:16 <caroline> #topic Set time of next meeting
18:06:39 <caroline> would march 16 work?
18:06:54 <aude_c> yes for me
18:07:13 <cait> should be ok
18:07:16 <davidnind> +1
18:07:22 <marie-luce> +1
18:08:12 <caroline> 16UTC is noon Eastern, 5am in NZ and 5pm in central europe
18:09:09 <caroline> #info Next meeting: 16 March, 2023, 16 UTC
18:09:21 <caroline> #endmeeting