15:02:23 <caroline> #startmeeting Documentation IRC meeting 2023-01-19
15:02:23 <huginn> Meeting started Thu Jan 19 15:02:23 2023 UTC.  The chair is caroline. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:23 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:23 <huginn> The meeting name has been set to 'documentation_irc_meeting_2023_01_19'
15:02:32 <marie-luce> Hi all
15:02:40 <caroline> #topic Introductions
15:02:43 <aude_c> hello
15:02:46 <caroline> please use "#info" in front of your introduction to have it show up in the automatic minutes
15:03:00 <caroline> #info Caroline Cyr La Rose, inlibro, Montreal, Qc
15:03:12 <aude_c> #info Aude Charillon, PTFS Europe, England
15:03:46 <marie-luce> #info Marie-Luce, inlibro, Montreal, QC
15:04:09 <emlam> #info Emily Lamancusa, MCPL, Maryland, US
15:06:21 <caroline> I'll ping the other usual suspects... cait ashimema davidnind
15:08:34 <caroline> Ok, we'll move on
15:08:41 <caroline> #topic Review of action points
15:08:53 <caroline> I needed to branch the manual in january... I forgot :( , so I will do this right after the meeting
15:09:06 <caroline> #action caroline to branch the manual
15:09:45 <caroline> davidnind was to check the scripts and translations tweaks in prevision of a possible switch to markdown. He wrote in the agenda that it was still in progress, so I will mark it as an action for next meeting
15:09:53 <aude_c> ok
15:09:54 <caroline> #action davidnind to check the scripts and translations tweaks in prevision of a possible switch to markdown
15:10:07 <cait> oh no, I am late!
15:10:09 <caroline> davidnind was to work on reorganizing the manual and adding a landing page - also still in progress
15:10:12 <cait> #info Katrin Fischer, BSZ, Germany
15:10:18 <caroline> #action davidnind to work on reorganizing the manual and adding a landing page
15:10:27 <caroline> anything else?
15:10:43 <aude_c> Not on review of action points
15:10:56 <cait> could you (re)post the agenda maybe?
15:11:05 <caroline> omg, sorry I always forget...
15:11:11 <caroline> #link https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_2023-01-19
15:11:24 <aude_c> I don't know if it fits under project updates / what's been done so far, but I revamped the Editing the Koha manual wiki page
15:11:44 <aude_c> to (hopefully) clarify how to use the new Needs documenting status on Bugzilla
15:11:52 <caroline> ooh nice!
15:12:02 <aude_c> please do have a look and make any corrections!
15:12:19 <caroline> #info aude_c has revamped the Editing the manual wiki page
15:12:21 <caroline> #link https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual
15:12:23 <aude_c> it's this one https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual
15:12:39 <aude_c> haha, you were quicker!
15:12:58 <caroline> I have it in my bookmarks :)
15:14:15 <caroline> I am always referring to this page, actually to this one https://wiki.koha-community.org/wiki/ReStructuredText_-_Tips_and_Tricks for the heading marks
15:15:23 <aude_c> ooh I've never had to do that so far
15:15:31 <aude_c> might bookmark that one too :D
15:15:59 <caroline> I think the wiki page is clear, is it the Workflow and special cases parts that you changed?
15:16:32 <aude_c> Yes, the whole part 2 and a bit of parts 1 and 7
15:17:28 <aude_c> ashimema had to make some changes at my request; so you can now create a new bug with the "Needs documenting" status
15:17:53 <aude_c> and also re-open a bug to give it that status (for those resolved / closed before we introduced it)
15:18:01 <caroline> Nice! I love the 1. Do this, 2. Do that format in part 7... it's so clear and foolproof
15:18:11 <cait> aude_c++
15:18:15 <aude_c> phew, good!
15:18:36 <marie-luce> aude_c++
15:18:42 <caroline> aude_c++
15:20:39 <caroline> #topic Project updates
15:20:44 <aude_c> I know last time we said we should focus on newer bugs - so with the new status, but
15:21:27 <aude_c> I have found myself looking at some features from 22.05 because people were asking about them
15:21:48 <caroline> makes sense!
15:22:12 <aude_c> and it made me wonder: at some point, will we need to move the bugs with keyword manual to use the Needs doc status, to make them easier to find through the dashboard?
15:22:20 <aude_c> obviously no rush; just wondering
15:22:36 <caroline> Good idea
15:22:43 <aude_c> and on a similar note: when are we talking about replacing screenshots to show the new UI?
15:22:57 <aude_c> big questions, I know :D
15:22:58 <caroline> do you think it's something that can be done in batch (changing keyword to status)?
15:23:10 <aude_c> now that is a good question!
15:23:28 <caroline> cait or ashimema would know I bet
15:23:33 <aude_c> would anyone here know? (otherwise I can check with ashimema later)
15:24:30 <caroline> For the screenshots, I have been doing them manually as I review sections, but I know davidnind was working on automatic screenshots before
15:25:00 <caroline> I think he said last meeting that he would restart the project since the interface design changed drastically
15:26:06 <aude_c> Ok. I was wondering whether we should look at it more systematically, like picking some sections each. (and also whether we'd want to do that at a hackfest or kohacon, but that's a questions I was also going to ask at the end!)
15:26:16 <caroline> Personally, I think we can do them bit by bit, we still have pretty old screenshots in the manual, but they still show what they need to (and only to people who have no visual impairment)
15:26:33 <aude_c> yes, that works
15:27:14 <caroline> When I work on documenting a new feature, I review the whole section, and update the screenshots as I go (with the new nomenclature and alt text)
15:27:39 <caroline> It's longer, but it apeases my perfectionist side
15:28:07 <aude_c> oh, I should start doing that. Thanks, I'll try and give it a go
15:28:17 <caroline> hackfest/kohacon would be a good time to work together on them
15:29:01 <caroline> When we pool resources and work together, it's much faster, as proven by our change of sysprefs labels throughout the manual over a 2 day period!
15:29:17 <aude_c> yes, and it's nicer too :)
15:29:21 <caroline> (or 1 day? it was pretty fast)
15:30:23 <caroline> what should we call this screenshot squashing event?
15:30:50 <caroline> Screenshot taking extravangaza XD
15:31:21 <aude_c> U&I screenshots :D
15:31:38 <marie-luce> I'll be happy to joint the group.
15:31:59 <aude_c> is anyone in the documentation team planning or hoping to attend KohaCon23 or Hackfest Marseille?
15:33:25 <cait> hackfest in Marseille :)
15:33:52 <caroline> I have never been to hackfest... I'd have to work on my boss to let me go (I'd rather go to Kohacon if I have to choose)
15:33:58 <cait> sorry, I got pulled away for a few minutes - I'll try to catch up
15:36:04 <caroline> #action caroline to plan a screenshot replacing session for hackfest
15:36:17 <aude_c> thanks, I'll see if I can make it :)
15:36:28 <caroline> It's in march right? end of march
15:36:54 <caroline> I'll try to be there virtually even if I can't go eat all the cheese and drink all the wine in person
15:37:20 <aude_c> haha! Yes last week in March
15:39:12 <caroline> #action cait or ashimema to check if we can change 'manual' keywords to 'Nedds documenting' status in bugzilla in batch
15:39:48 <caroline> ok did I forget to #info or #action something?
15:40:08 <cait> I think we can do bulk actions, but not sure if it might create a mess
15:40:33 <cait> the Manual keyword is still kinda nice if you can't change the status yet, but already know it will affect manual
15:40:40 <cait> like old bugs that are already closed
15:41:16 <caroline> apparently, now we can reopen bugs and give them the new Needs documenting status
15:42:09 <caroline> I admit the batch would only need to be done on closed bugs
15:42:25 <caroline> if it's not possible, we can go through manually when we find them
15:42:58 <aude_c> there'll come a point when there won't be that many left (right?! haha)
15:43:17 <caroline> ha ha ha (nervous laugh)
15:43:35 <aude_c> XD
15:45:02 <caroline> #info if not possible to change bz in batch we change tham as we get to them
15:46:28 <caroline> #topic What's been done so far
15:47:49 <caroline> There's nothing in the agenda about this, but I finally finished (I hope) transferring cataloging tools to the cataloging chapter to reflect the new cataloging landing page
15:48:17 <caroline> I also reworked the chapter slightly to go at it by "action" rather than from top to bottom following the landing page
15:48:54 <caroline> e.g. rather than creating an "automation" section, I put the two tools under item editing, which is what they do
15:49:32 <aude_c> sounds good
15:49:42 <caroline> I also put the batch editing / deleting in the record editing or record deletion or item editing or item deletion sections
15:50:31 <caroline> I think people who are looking at "how to edit an item" will be thankful to find how to do it in batch and how to do it automatically in the same section
15:50:57 <caroline> e.g. https://koha-community.org/manual/22.11/en/html/cataloging.html#editing-items
15:51:17 <marie-luce> Good idea
15:51:27 <caroline> (also when I was talking about old screenshots, we can see one there, the first one)
15:51:42 <caroline> (it still show what it needs to show imo)
15:54:33 <caroline> anyone else want to share something?
15:55:53 <aude_c> did cait have on the agenda to talk about translation?
15:56:06 <caroline> yes in the next topic
15:56:07 <caroline> #topic Content development guidelines
15:56:16 <caroline> #topic subtopic translations
15:59:46 <cait> oh sorry
15:59:55 <cait> let me quickly check
16:00:21 <cait> hm I feel like we discussed the bug last time already, but didn't have any idea on how to resolve
16:00:41 <cait> and sadly this hasn't really changed
16:00:51 <cait> it still blocks me from doing the sys pref translations correctly
16:01:04 <caroline> we need to branstorm how to write about the system preferences
16:01:13 <cait> yeah
16:01:26 <caroline> currently the format is https://wiki.koha-community.org/wiki/ReStructuredText_-_Tips_and_Tricks#System_Preferences_Format
16:01:51 <cait> my problem is the value list
16:02:06 <cait> if the value is Allow
16:02:19 <cait> don't allow
16:02:36 <cait> for example, these have been translated differently in german
16:02:41 <cait> but I only get one translation in the po
16:02:52 <cait> for all occurrences
16:03:32 <caroline> I think the two options were 1) change how we document sysprefs or 2) somehow add context like in koha
16:03:38 <cait> yeah
16:03:42 <cait> context would be great
16:03:58 <caroline> maybe we can open a bz about it?
16:04:07 <cait> there is a bug linked already
16:04:22 <cait> bug 29063
16:04:22 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29063 major, P5 - low, ---, david, ASSIGNED , [DOCS] Manual: Translation issue with repeated strings in system preferences
16:05:00 <caroline> oh yes, I already wrote the options lol! I had forgotten
16:05:22 <caroline> we need a developper for 2 out of 3 options
16:05:32 <cait> yes
16:05:51 <cait> or maybe someone who knos more tricks about rst?
16:07:29 <cait> maybe we need to postpone that one again
16:07:49 <cait> for the po updates... we probably need bgkriegel? or do you have a working form to request the po files for merging caroline?
16:08:29 <cait> ideally we shoud merge the current status of translations for all the manuals stil on the website
16:08:33 <cait> because it hasn't been done for so long
16:08:47 <caroline> oh... I probably had them once, I'd have to check in my old emails
16:09:17 <cait> and there is a new bug actually we shoudl look into
16:09:28 <caroline> #caroline to check for translation request form
16:09:55 <cait> some new chapter shows ERM pictures
16:09:59 <cait> it hink curbside
16:10:18 <reiveune> bye
16:10:34 <cait> it was filed and now I can't seem to find it
16:10:38 <caroline> The form I had was this, but it only goes up to 20.11 https://translate.koha-community.org/tools/
16:11:38 <cait> bug 32621
16:11:38 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32621 normal, P5 - low, ---, koha-bugs, NEW , Circulation bundles documentation has wrong pictures
16:11:44 <cait> I think maybe overlapping numbers
16:12:13 <cait> caroline: and the pull down is missing the new versions hm
16:12:17 <caroline> aude_c, is this one of the ones made with the google docs thing ashimema set up?
16:12:34 <aude_c> the ERM chapter, yes
16:12:45 <caroline> not the bundles?
16:13:06 <caroline> cait can you assign that buig to me, I'll check what the problem is
16:13:11 <aude_c> not sure about that one, but maybe
16:13:35 <aude_c> want me to check with him?
16:13:37 <cait> done
16:14:07 <cait> https://koha-community.org/manual/22.11/en/html/circulation.html#circulating-bundles
16:14:19 <caroline> I found the commit https://gitlab.com/koha-community/koha-manual/-/commit/43d86fdd97e95475657b6aa68d047dbb72c024a0
16:14:56 <cait> and the last one was me too: the koha-docs list is not used (never really has been I think)
16:14:59 <cait> and we get spam there
16:15:09 <cait> I was wondering if we shuld close it
16:15:14 <aude_c> is it a problem with image names? (in the bundles chapter)
16:15:21 <caroline> not sure how the images can be mixed unless there is a problem with the actual images, not the link
16:15:30 <cait> i think they are using image-numbers
16:15:40 <cait> so maybe bundles and erm written at the same time using the same numbers
16:15:49 <caroline> anyway, I'll check I have a bit of time rn
16:15:53 <aude_c> I find the koha-docs list most useful to get reminders of docs meeting! haha
16:16:07 <caroline> yeah but the path is images/bundles
16:16:18 <cait> ok, then something else must have gone wrong
16:16:30 <cait> the thing is, maybe we do want to send that to koha main too?
16:16:38 <cait> koha-docs is well hidden... we do want others to know they can join us
16:16:40 <aude_c> true
16:16:46 <caroline> #topic subtopic mailing list
16:16:55 <aude_c> that would give it more visibility
16:18:12 <caroline> I don't have an opinion on this
16:18:34 <caroline> Is the fact that it's underused causing a problem on a server somewhere, like we could liberate resources if we closed it?
16:18:42 <caroline> if not I'd keep it
16:19:13 <cait> the only messages I ever get from it are to moderate spam
16:19:18 <cait> so... that's my issue :)
16:19:58 <cait> but I just wanted to bring it up
16:20:07 <cait> i am ok if the decision is to keep it
16:20:14 <cait> i am not srue why I am moderator on that list, maybe i need to fix that
16:21:34 <cait> that's all from me
16:21:44 <cait> shoudl we request bgkriegel to update the merge form? (maybe a last hting...)
16:22:06 <caroline> ok, we can close it. It's not like we discuss things much outside of the meeting
16:22:23 <caroline> and when we do, it's here or in individual emails
16:22:55 <caroline> we could maybe send an email saying we're thinking of closing it and if anyone objects, speak now or forever hold their peace?
16:24:32 <caroline> #action caroline to send an email to bernardo about the translation form
16:26:23 <caroline> does someone want to volunteer to send an email to the list to say that we're thinking of closing it down?
16:28:22 <caroline> I'll action someone randomly if there is no volunteer ;)
16:29:06 * cait hides behind a wall of support tickets
16:29:46 <caroline> but it was your idea!
16:29:57 <caroline> fine I'll do it...
16:30:17 <caroline> #action caroline to send an email to the mailing list about possibly closing it down
16:31:06 <cait> caroline: I'll bring you chocolate next chance
16:32:14 <caroline> anyone wants to add anything else? we're way over time
16:33:15 <aude_c> no, nothing
16:33:51 <cait> not me
16:33:55 <caroline> #topic Set time of next meeting
16:34:13 <caroline> would feb 16 be ok?
16:34:24 <aude_c> yes
16:34:37 <marie-luce> yes
16:34:59 <caroline> I was thinking maybe 16 or 17 for the time, it would be early for david, but not the middle of the night, and early evening for europe
16:35:31 <caroline> https://www.timeanddate.com/worldclock/meetingdetails.html?year=2023&month=2&day=16&hour=17&min=0&sec=0&p1=165&p2=22&p3=136
16:35:44 <cait> +1
16:35:59 <marie-luce> +1
16:36:04 <aude_c> yes :)
16:36:16 <caroline> #info Next meeting: 16 February 2023, 17 UTC
16:36:24 <caroline> #endmeeting