14:00:25 <paulderscheid[m]> #startmeeting Development IRC meeting 15 May 2024
14:00:25 <huginn`> Meeting started Wed May 15 14:00:25 2024 UTC.  The chair is paulderscheid[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:25 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:25 <huginn`> The meeting name has been set to 'development_irc_meeting_15_may_2024'
14:00:52 <paulderscheid[m]> #topic Introductions
14:01:36 <paulderscheid[m]> #info Paul Derscheid, LMSCloud GmbH, Germany
14:02:35 <cait> #info Katrin Fischer, BSZ, Germany
14:02:40 <MatthewBlenkinsop[m]> #info Matt Blenkinsop, PTFS Europe, UK
14:03:07 <kidclamp> #info, Nick Clemens, BWS
14:03:12 <thd> #info Thomas Dukleth, Agogme, New York City
14:03:27 <mbridge> [mattermost] <lisette> #info Lisette Scheer, BWS
14:03:28 <mbridge> [mattermost] <khall> #info Kyle Hall, BWS
14:03:41 <mbridge> [mattermost] <dcook> #info David Cook, Prosentient Systems
14:03:57 <dcook> Does it work if we do these things from mattermost?
14:04:13 <kidclamp> no
14:04:21 <cait> #info Lisette Scheer, BWS
14:04:25 <cait> #info Kyle Hall, BWS
14:04:25 <dcook> Had a feeling...
14:04:30 <dcook> #info David Cook, Prosentient Systems
14:04:30 <cait> #info David Cook, Prosentient Systems
14:04:33 <dcook> :O
14:04:36 <mbridge> [mattermost] <evelyn> #info Evelyn Hartline, BWS
14:04:44 <cait> #info Evelyn Hartline, BWS
14:04:48 <mbridge> [mattermost] <bag> #info Brendan Gallagher ByWater
14:04:57 <paulderscheid[m]> #chair cait
14:04:57 <huginn`> Current chairs: cait paulderscheid[m]
14:04:57 <mbridge> [mattermost] <bag> (sorry don't have IRC on my laptop)
14:04:58 <cait> #info Brendan Gallagher ByWater
14:04:58 <tcohen> #info Tomas Cohen Arazi
14:05:04 <ashimema> #info Martin Renvoize, PTFS Europe
14:05:07 <cait> #info Tomas Cohen Arazi
14:05:12 <caroline> #info Caroline Cyr La Rose, inlibro, Québec, Canada
14:05:51 <cait> #info Paul Poulain, Biblibre
14:06:16 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:06:20 <paulderscheid[m]> #topic Announcements
14:06:24 <fredericd> #info Frédéric Demians, Tamil
14:06:58 <paulderscheid[m]> #info bag is going to send a poll to the foundation proposal after this meeting
14:07:23 <mbridge> [mattermost] <bag> #link https://ptfs-europe.com/koha-foundation-proposal/
14:08:43 <paulderscheid[m]> #info Michael Kuhn added for newsletter role, domm for QA team
14:10:17 <paulderscheid[m]> #topic Update from the Release manager (24.05)
14:10:37 <paulderscheid[m]> #info on schedule for 24.05 release
14:11:15 <paulderscheid[m]> #info proper string freeze this friday (17th)
14:11:30 <paulderscheid[m]> #info release scheduled for May 28
14:12:01 <paulderscheid[m]> #topic Updates from the Release Maintainers
14:13:15 <paulderscheid[m]> #info a security release was released on monday, please consider updating
14:13:25 <paulderscheid[m]> #topic Updates from the QA team
14:14:03 <paulderscheid[m]> #info couple of busy weeks
14:14:48 <paulderscheid[m]> #topic Status of roadmap projects
14:15:34 <paulderscheid[m]> #info new roadmap pages will be created next week, one for community projects, one for advertising (email will be sent to koha-devel)
14:17:02 <paulderscheid[m]> #info interlibrary loans rethink: bits have been pushed
14:18:23 <paulderscheid[m]> #info OAI-PMH harvester: currently in failed QA
14:18:39 <paulderscheid[m]> #info bookings: bits have been pushed
14:19:14 <paulderscheid[m]> #info plugins (discovery, authenticity): still in discussion, no patches yet
14:19:32 <paulderscheid[m]> #info geo-search: has been pushed, geo-search UI as plugin, will be shared
14:19:54 <paulderscheid[m]> #info using REST API to display items in biblio detail view: pushed to main
14:20:18 <paulderscheid[m]> #info moving patron search to a modal: pushed to main
14:20:32 <paulderscheid[m]> #info move C4 to Koha: not much progress this cycle
14:22:12 <paulderscheid[m]> #info cities on vue: admin app missing to properly build navigation column on the left (LeftMenu), needed for other views as well
14:22:53 <paulderscheid[m]> #info shifting slips and notices to Template Toolkit: bits have been pushed
14:23:28 <paulderscheid[m]> #info move domain limits from koha-conf to staff SMTP config: failed QA
14:23:51 <paulderscheid[m]> #info merge reserves and old_reserves: postponed to beginning of next cycle
14:24:14 <paulderscheid[m]> #info improving tests for koha plugins: pushed to oldstable
14:24:47 <paulderscheid[m]> #info performance improvements: some progress by BibLibre, byWater
14:25:33 <paulderscheid[m]> #info job queue, rabbitMQ bugfixes and improvements: needs more work, some bugfixes available
14:25:44 <paulderscheid[m]> #info move from master to main: done!
14:27:41 <paulderscheid[m]> #info discourse: not much progress, currently stuck at getting mailing list contents scraped
14:28:32 <paulderscheid[m]> #info debian packages, share the load: tcohen made solid progress with koha-dpkg-docker
14:29:52 <tcohen> #link https://gitlab.com/koha-community/koha-dpkg-docker
14:30:22 <paulderscheid[m]> #info prevent pushing to main if jenkins fails: postponed to next cycle
14:30:32 <paulderscheid[m]> #info automated screenshots: wip
14:30:51 <paulderscheid[m]> #info template toolkit reference guide: doc in drafting phase
14:31:10 <paulderscheid[m]> #topic Actions from last meeting
14:37:56 <paulderscheid[m]> #action paulderscheid[m] file an issue for integrating JS15 into QA scripts
14:38:42 <paulderscheid[m]> #topic Foundation Proposal
14:39:04 <paulderscheid[m]> #link https://ptfs-europe.com/koha-foundation-proposal/
14:41:59 <paulderscheid[m]> #info a poll will be shared on mattermost, irc, and via the mailing list, duration of the vote will be 4 weeks
14:44:33 <paulderscheid[m]> #topic General development discussion (trends, ideas, ...)
14:57:53 <paulderscheid[m]> #info using carton instead of debian packages for koha's dependencies?
14:59:17 <paulderscheid[m]> #info debian packages save us from a lot of manual maintenance
15:00:10 <paulderscheid[m]> #info ashimema initially suggested to just use carton for dependencies we maintain ourselves
15:01:51 <paulderscheid[m]> #info bugzilla moved from debian packages to carton which sparked the discussion
15:02:23 <paulderscheid[m]> #link https://chat.koha-community.org/koha-community/pl/tz5pfoonsigz8nr7pr54aiqwrr
15:03:40 <paulderscheid[m]> #info katrin added a workflow for adding new dependencies
15:03:57 <paulderscheid[m]> #link https://wiki.koha-community.org/wiki/Release_management#Dependency_changes
15:05:10 <paulderscheid[m]> #action tcohen to check if any steps for adding new dependencies are missing for koha-testing-docker in the linked document
15:05:20 <mbridge> [mattermost] <ashimema> #info we average adding 8-10 changes to the cpanfile a year
15:05:37 <paulderscheid[m]> #info we average adding 8-10 changes to the cpanfile a year
15:06:00 <mbridge> [mattermost] <ashimema> doh.. I was in the wrong chat window..  😂
15:06:02 <mbridge> [mattermost] <ashimema> thanks
15:08:22 <paulderscheid[m]> #info marcelr added a new table for deleted authorities, discussion about whether this is a pattern we should favor
15:17:37 <paulderscheid[m]> #action put tombstone table pattern on the roadmap for discussion for next cycle
15:21:53 <paulderscheid[m]> #topic Review of coding guidelines
15:22:50 <paulderscheid[m]> #info concerning a coding guideline on adding new perl dependencies: postponed to next meeting
15:23:50 <paulderscheid[m]> #action ashimema to add a qa script check for NOTICE1 in the coding guidelines
15:24:01 <paulderscheid[m]> #topic Any other business
15:24:18 <paulderscheid[m]> #topic Set time of next meeting
15:27:00 <paulderscheid[m]> #info Next meeting: 29 May 2024, 14 UTC
15:27:23 <paulderscheid[m]> #endmeeting