12:00:42 <paulderscheid[m]> #startmeeting Development IRC meeting 17 April 2024
12:00:42 <huginn`> Meeting started Wed Apr 17 12:00:42 2024 UTC.  The chair is paulderscheid[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:42 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:42 <huginn`> The meeting name has been set to 'development_irc_meeting_17_april_2024'
12:01:32 <marcelr> #info Marcel de Rooy
12:01:43 <paulderscheid[m]> #topic Introductions
12:01:52 <paulderscheid[m]> #chair cait
12:01:52 <huginn`> Current chairs: cait paulderscheid[m]
12:02:10 <cait> #info Katrin Fischer, BSZ, Germany
12:02:13 <paulderscheid[m]> #info Paul Derscheid, LMSCloud GmbH, Germany
12:02:16 <mmost> [joubu] #info Jonathan Druart
12:02:19 <bag> #info Brendan Gallagher, ByWater
12:02:23 <mmost> [ashimema] #info Martin Renvoize, PTFS Europe, UK
12:02:29 <EmmiTakkinen[m]> #info Emmi Takkinen, Koha-Suomi Oy, Finland
12:02:33 <mmost> [evelyn] #info Evelyn Hartline, BWS
12:02:36 <thd> #info Thomas Dukleth, Agogme, New York City
12:02:37 <mmost> [mblenk] #info Matt Blenkinsop, PTFS
12:02:41 <marcelr> resent again, not mmost worked
12:02:45 <marcelr> now
12:02:45 <aude_c[m]> #info Aude Charillon, PTFS Europe, UK
12:04:21 <paulderscheid[m]> #topic announcements
12:04:24 <cait> #link https://wiki.koha-community.org/wiki/Roles_for_24.11 Roles page on the wiki
12:05:37 <cait> #info Mattermost chat is live and available at https://chat.koha-community.org - please sign-up!
12:09:10 <Annelisterman[m]> #info Anneli Österman, Koha-Suomi Oy, Finland
12:12:16 <paulderscheid[m]> #topic Update from the Release manager
12:12:19 <cait> #link https://lists.koha-community.org/pipermail/koha-devel/2024-April/048606.html Release dates are out!
12:14:37 <cait> #info Goal is to go through current list by the end of the week
12:14:53 <mmost> [ashimema] #info You can see the order in which bugs are worked through for pushing on the bottom right of the https://dashboard.koha-community.org/
12:15:23 <paulderscheid[m]> #topic Updates from the Release Maintainers
12:15:58 <paulderscheid[m]> #info On track
12:16:15 <paulderscheid[m]> #topic Updates from the QA team
12:16:26 <cait> qa_team
12:16:27 <mmost> [joubu] qa_team?
12:17:23 <cait> #info Still a big backlog on enh, keeping up with bugs, lots of effort went into CSRF explaining that
12:19:29 <paulderscheid[m]> #topic Status if roadmap projects
12:22:23 <mmost> [joubu] https://tree.taiga.io/project/koha-ils/us/223
12:25:00 <paulderscheid[m]> #action cait to send an email to koha-devel announcing the change of the default branch from master to main
12:25:19 <mmost> [joubu] cait: https://tree.taiga.io/project/koha-ils/task/230
12:25:25 <mmost> [joubu] see the comment
12:25:36 <cait> #action change master > main is going to happen this Friday, April 19 2024
12:25:46 <cait> #info change master > main is going to happen this Friday, April 19 2024
12:26:17 <paulderscheid[m]> #info Interlibrary Loans Rethink is moving forward, attention would be appreciated
12:26:58 <paulderscheid[m]> #info OAI-PMH harvester is moving along
12:27:05 <cait> #link https://wiki.koha-community.org/wiki/Road_map_24.05 Road map 24.11
12:27:49 <paulderscheid[m]> #info Bookings moving forward reasonably well, lead-in periods need attention
12:29:08 <mmost> [ashimema] #info Lots of bookings bugs to be QA'd still in the queue.. see [Bug 29002](https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29002) trail
12:29:08 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29002 new feature, P1 - high, ---, martin.renvoize, Needs documenting , Add ability to book items ahead of time
12:29:09 <huginn`> 04Bug 29002: new feature, P1 - high, ---, martin.renvoize, Needs documenting , Add ability to book items ahead of time
12:29:25 <paulderscheid[m]> #info Plugins - Discovery, Authenticity was discussed at hackfest, next steps also in discussion
12:30:11 <paulderscheid[m]> #info Geo-Search is passed QA
12:31:22 <mmost> [ashimema] #action Martin to look at resorting the PQA push queue to allow enhancement and new feature to sort in passed order
12:31:41 <paulderscheid[m]> #info Using the REST API to display items on the biblio detail view has been pushed to master
12:32:18 <paulderscheid[m]> #info Move patron searches to a modal has been pushed to master, needs documentation
12:32:48 <paulderscheid[m]> #info Refactoring C4 to Koha is postponed because the next release is too close already, needs more attention in next cycle
12:33:29 <paulderscheid[m]> #action everyone please mark your roadmap projects as done if they are
12:34:27 <paulderscheid[m]> #info matt is working on isolated vue components, ready for show-and-tell soon
12:36:24 <paulderscheid[m]> #info foundational work made for deprecation of bespoke syntax in slips and notices (move to TT), still long way to go, though
12:37:03 <paulderscheid[m]> #info Move domain limits from koha-conf to staff SMTP config, moved to next cycle
12:37:47 <paulderscheid[m]> #info Improving tests for koha plugins has been pushed to master - oldoldstable
12:38:46 <paulderscheid[m]> #info Performance improvements still in discussion in a pad
12:39:01 <marcelr> ashimema++
12:39:04 <paulderscheid[m]> #link https://annuel.framapad.org/p/koha_optimisations
12:40:14 <paulderscheid[m]> #info Job queue/RabbitMQ bugfixes and improvements, update from KIT would be great, bugs under that umbrella should be worked on next cycle
12:41:02 <paulderscheid[m]> #action joubu please send for retrieval of mailing list content
12:41:44 <paulderscheid[m]> #info debian package packaging needs to be automated next month
12:43:12 <paulderscheid[m]> #info cait needs help with fixing jenkins
12:43:58 <paulderscheid[m]> #info automated screenshots has been presented at the hackfest, offer from joubu to show developers the process
12:44:28 <cait> ask e if you need help finding the bug, but the failing test just fails everywhere :)
12:45:00 <paulderscheid[m]> #info template toolkit reference guide, contact to david nind needs to be established
12:48:00 <paulderscheid[m]> #info we need to have a discussion of separating community efforts which should go in the roadmap to more individual projects that should also be announced in some way close to the roadmap
12:48:23 <paulderscheid[m]> #topic Actions from last meeting
12:52:48 <cait> #info explore email solution for discourse that was discussed for wiki: rangi updated the DNS now, portainer setup is next step
12:52:50 <paulderscheid[m]> #action thd to inquire about a test-server for testing email-relay
12:53:50 <paulderscheid[m]> #action tcohen to write a guideline for the API returns when work has gone through QA
12:54:51 <paulderscheid[m]> #topic General development discussion
12:56:04 <cait> #info In Marseille, there was some talk about reorganizing extended attributes  in general, to simplify code and maybe unify the storage of them. Bug 35508  is proposing to update the patron row *updated_on* column when extended  attributes get modified. I think this needs to be discussed by the team  and a decision made. > please see dicussion on Mattermost
12:56:04 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=35508 enhancement, P5 - low, ---, hammat.wele, Signed Off , Update borrowers.updated_on when modifying a patron's attribute
12:57:29 <paulderscheid[m]> #topic Review of coding guidelines
13:00:54 <paulderscheid[m]> #action paulderscheid[m] to add a section about JSDoc to the coding guidelines(JS)
13:01:45 <paulderscheid[m]> #topic Any other business
13:03:52 <cait> #info trying out starting the meeting one hour later :)
13:03:53 <mmost> [caroline] Sorry, I had to leave bc I have another meeting. But concerning Kohacon, there isn't anything new from last meeting
13:05:46 <paulderscheid[m]> #info ping @bag in mmost for help with anything community related
13:06:07 <paulderscheid[m]> #topic Set time of next meeting
13:09:27 <paulderscheid[m]> #info Next meeting: 02 May 2024, 13 UTC
13:10:38 <paulderscheid[m]> #endmeeting