12:07:37 <cait> #startmeeting Development IRC meeting 28 February 2024
12:07:37 <huginn`> Meeting started Wed Feb 28 12:07:37 2024 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:07:37 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:07:37 <huginn`> The meeting name has been set to 'development_irc_meeting_28_february_2024'
12:07:45 <cait> #topic Introductions
12:07:52 <cait> #info Katrin Fischer, BSZ, Germany
12:08:27 <tcohen> Good morning!
12:08:36 <cait> come join us on Jitsi please!
12:08:41 <tcohen> #info Tomas Cohen Arazi
12:08:53 <kidclamp> #info Nick Clemens, ByWater Solutions
12:09:21 <thd> #info Thomas Dukleth, Agogme, New York City
12:10:07 <cait> so we are only a small group, please feel free to join uns anytime!
12:10:35 <cait> #topic Announcements
12:11:44 <kidclamp> https://annuel.framapad.org/p/koha_34478_remaining
12:11:58 <cait> #info Patches for bug 34478  will be pushed soon - be prepared to have some breakages, report bugs and help with fixing.
12:11:58 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34478 is not accessible.
12:12:38 <cait> #info Register for hackfest in Marseille if you plan on coming! (second week of April)
12:12:54 <cait> #topic Updates from the Release manager (24.05)
12:13:42 <cait> #info No big updates apart from bug 34478
12:14:41 <cait> #info Updates to Jenkins: including takss for the security branches, cleaned up all users and permissions etc.
12:15:21 <cait> #info Jenkins deployment issues with the nodes have been resolved - hopefully giving us less failures
12:16:11 <cait> #topic Updates from Release Maintainers
12:16:38 <cait> #info We will have a coordinated security release this month, stay tuned
12:16:51 <cait> #topic Updates from the QA team
12:16:56 <ashimema> sorry.. in another meeting right now
12:17:17 <cait> #info QA has been delayed, because of the master freeze and work on the big bug - working to resolve that soon
12:17:36 <cait> #topic Status of roadmap proejcts
12:18:36 <cait> #info tcohen: work continues on record locking and sources
12:20:19 <cait> #info cait: master to main has been discussed and we have a list wit todos - need to agree on a date, lots of scripts will need to be adjusted as well
12:21:54 <cait> #info kidclamp: bookings and REST API for item display are next
12:23:58 <cait> #info thd/paulderscheid: work on test instances happened
12:26:35 <cait> #info paulderscheid: still working on cities on Vue, work on Discourse instance
12:28:29 <cait> @action thd to add ask about testing discourse backups to Taiga
12:28:29 <huginn`> cait: I've exhausted my database of quotes
12:28:57 <cait> #topic Actions from last meeting
12:29:03 <cait> #info No actions from last meeting
12:29:05 <paulderscheid[m]> #info Paul Derscheid, LMSCloud GmbH, Germany
12:29:16 <cait> #topic General development discussion
12:29:58 <cait> #info No comments
12:30:10 <cait> #topic Review of coding guidelines
12:30:44 <cait> #action thd to add task about testing discourse backups to Taiga
12:31:16 <cait> #action all add coding guideline for CSRF protection on forms
12:31:50 <cait> #topic Set time of next meeting
12:33:38 <cait> #info Next meeting: 6 March 2024, 13 UTC
12:34:04 <cait> #endmeeting