14:00:16 <paulderscheid[m]> #startmeeting Development IRC meeting 29 May 2024
14:00:16 <huginn`> Meeting started Wed May 29 14:00:16 2024 UTC.  The chair is paulderscheid[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:16 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:16 <huginn`> The meeting name has been set to 'development_irc_meeting_29_may_2024'
14:00:30 <paulderscheid[m]> #topic Introductions
14:00:45 <paulderscheid[m]> #info Paul Derscheid, LMSCloud GmbH, Germany
14:01:34 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:01:57 <caroline> #info Caroline Cyr La Rose, inLibro, Montréal, Québec, Canada
14:02:18 <mbridge> [mattermost] <cait> coming
14:02:26 <mbridge> [mattermost] <mblenk> #info Matt Blenkinsop, PTFS Europe, UK
14:02:29 <mbridge> [mattermost] <khall> #info Kyle Hall, ByWater Solutions
14:02:48 <mbridge> [mattermost] <lisette> #info Lisette Scheer, ByWater Solutions
14:03:06 <MatthewBlenkinsop[m]> #info Matt Blenkinsop, PTFS Europe, UK
14:04:00 <cait> #info Katrin Fischer, BSZ, Germany
14:04:06 <thd> #info Thomas Dukleth, Agogme, New York City
14:04:29 <paulderscheid[m]> Anyone still entering info?
14:04:31 <lisette> #info Lisette Scheer, ByWater Solutions
14:04:59 <kidclamp> #info Nick Clemens, BWS
14:06:05 <mbridge> [mattermost] <evelyn> #info evelyn hartline bws
14:06:07 <tcohen> #info Tomas Cohen Arazi
14:06:38 <khall> #info Kyle Hall, ByWater Solutions
14:06:54 <paulderscheid[m]> #topic Announcements
14:07:30 <paulderscheid[m]> #info koha 24.05 just released
14:08:07 <tcohen> cait++
14:08:36 <paulderscheid[m]> #topic Update from the Release manager (24.05)
14:09:25 <paulderscheid[m]> #info roadmap page + email will be coming this week or early next week for the next cycle
14:10:44 <paulderscheid[m]> #info current release maintainers are going to continue until the next security release
14:11:03 <paulderscheid[m]> #topic Updates from the Release Maintainers
14:11:43 <paulderscheid[m]> #topic Updates from the QA team
14:12:54 <paulderscheid[m]> #info CSRF bugs still need attention
14:13:42 <kidclamp> #info https://annuel.framapad.org/p/koha_34478_remaining
14:15:27 <paulderscheid[m]> #topic Status of roadmap projects
14:15:44 <paulderscheid[m]> #link https://wiki.koha-community.org/wiki/Road_map_24.05
14:15:53 <paulderscheid[m]> #info not much change, port open projects to next roadmap
14:16:21 <paulderscheid[m]> #info next roadmap will be split into: big community projects, advertised projects
14:17:03 <paulderscheid[m]> #topic Actions from last meeting
14:17:48 <paulderscheid[m]> #action paulderscheid file an issue for integrating JS15 into QA scripts
14:19:34 <cait> #link https://wiki.koha-community.org/wiki/Release_maintenance#Backporting_a_patch_with_a_new_perl_dependency new dependency workflow proposal
14:20:16 <paulderscheid[m]> #action tcohen give some feedback on proposed workflow for dependencies
14:20:36 <paulderscheid[m]> #action put tombstone table pattern on the roadmap for discussion for next cycle
14:20:59 <paulderscheid[m]> #action ashimema to add a qa script check for NOTICE1 in the coding guidelines
14:21:15 <cait> #link https://wiki.koha-community.org/wiki/Release_management#Dependency_changes corrected link to workflow proposal
14:21:37 <paulderscheid[m]> #topic General development discussion (trends, ideas, ...)
14:25:38 <paulderscheid[m]> #topic Review of coding guidelines
14:26:22 <paulderscheid[m]> #action kidclamp to write a coding guideline for bug 36246
14:26:22 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=36246 enhancement, P5 - low, ---, nick, Needs documenting , Have a centralized method for submitting a form via a link
14:26:44 <paulderscheid[m]> #topic Any other business
14:28:05 <paulderscheid[m]> #link https://kb.test.koha-community.org
14:28:40 <paulderscheid[m]> #info tcohen added a new tool to document infrastructure related things, that might contain sensitive information
14:28:59 <paulderscheid[m]> #info tcohen wants help to structure the aforementioned knowledge base
14:29:56 <paulderscheid[m]> #topic Set time of next meeting
14:33:57 <paulderscheid[m]> #info Next meeting: 12 June 2024, 14 UTC
14:34:28 <paulderscheid[m]> #endmeeting