11:59:29 <cait> #startmeeting Development IRC meeting 3 April 2024
11:59:29 <huginn`> Meeting started Wed Apr  3 11:59:29 2024 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
11:59:29 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
11:59:29 <huginn`> The meeting name has been set to 'development_irc_meeting_3_april_2024'
11:59:40 <cait> #topic Introductions
11:59:50 <cait> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_3_April_2024 Agenda
12:00:36 <cait> #info Katrin Fischer, BSZ, Germany
12:00:50 <paulderscheid[m]> #info Paul Derscheid, LMSCloud GmbH, Germany
12:02:47 <tcohen> #info Tomas Cohen Arazi
12:02:54 <EmmiTakkinen[m]> #info Emmi Takkinen, Koha-Suomi Oy, Finland
12:03:07 <cait> #chair tcohen
12:03:07 <huginn`> Current chairs: cait tcohen
12:03:40 <cait> #topic Announcements
12:03:53 <cait> #info Hackfest in Marseille is next week!
12:05:08 <cait> #info thd might have a fix for the email issues with the wiki
12:05:28 <cait> thd++
12:06:59 <cait> domm[m]: are you around maybe?
12:07:08 <cait> talking about the email configuration
12:08:28 <emlam> #info Emily Lamancusa, MCPL, USA
12:09:50 <cait> #topic Update from the Release manager
12:11:12 <cait> #topic Updates from the Release maintainers
12:11:35 <cait> #info RM will try to empty queue as much as possible before next week, lots of QA has been done over Easter holidays
12:12:05 <cait> #info Release should happen today!
12:12:32 <cait> #topic Updates from the QA team
12:12:52 <kidclamp> #info Nick Clemens, ByWater Solutions
12:14:00 <cait> #info QA queue is pretty full, please QA!
12:15:10 <cait> #topic Status of roadmap projects
12:15:51 <cait> #info tcohen working on the holds table merge (reserves, old_reserves)
12:16:42 <cait> #info tcohen will be testing a new pipeline for building ktd images on gitlab
12:22:00 <cait> #topic paulderscheid[m] using SMTP settings from HKS3 now for the Discourse project. Stuck on not being able to use DKIM which creates a problem sending to Google/Outlook
12:23:20 <cait> #action paulderscheid[m] and thd to figure out if the same mail solution as for the wiki can be used
12:28:15 <cait> #action cait to set a date for moving master to main after the hackfest (trying not to break workflows right now)
12:29:50 <cait> #info bugs with easy to re-do notices in TT are marked with Academy
12:31:10 <cait> #info TT switch: items.fine and some custom parameters need to be figured out in the code
12:31:16 <cait> #chair emlam
12:31:16 <huginn`> Current chairs: cait emlam tcohen
12:32:00 <cait> #topic Security bugs and news
12:34:03 <cait> bug 35984
12:34:03 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=35984 normal, P5 - low, ---, koha-bugs, NEW , automated static code analysis should include security tests
12:35:39 <tcohen> #info Evelyn and Tomas to contact german company offering static code analysis with Perl support
12:36:56 <cait> #info API still needs some CSRF work
12:37:25 <cait> #topic Actions from last meeting
12:37:31 <cait> #info No actions from last meeting!
12:37:48 <cait> #topic General development discussion
12:38:34 <cait> #info tcohen's proposal for REST API: Make our returns consistent when something doesn't exist
12:40:11 <cait> #info We are leaning towards having specific returns: patron X doesn't exist etc.
12:41:23 <cait> #info tcohen's review turned up a lot of inconsistencies to work on
12:45:06 <fridolin> hi
12:45:17 <cait> #topic Reviewof coding guidelines
12:46:08 <cait> #action tcohen to write a guildeline for the API returns when work has gone through QA
12:46:38 <cait> #topic Any other business
12:51:41 <caroline> I just came in, I can give an update on kohacon if you wish
12:52:19 <cait> #topic Set time of next meeting
12:53:02 <cait> #topic KohaCon24
12:53:28 <cait> will you come into Jitsi or do you ant to type it up?
12:53:41 <caroline> oh I forgot it was video meetings now
12:53:48 <caroline> give me a few seconds
12:53:57 <thd> Yes, caroline but you can also type.
12:54:52 <cait> #info CfP and workshops is still open until end of April
12:55:06 <cait> #info Preliminary program to be sent later this month
12:56:01 <cait> #info Information on hotels and special booking coditions is in the works
12:58:17 <cait> #info Presentations will be streamed online, no plans for online workshops yet
12:59:46 <cait> #info Registrations will probably open by the end of the month/May
13:00:15 <cait> #topic Set time of next meeting
13:01:44 <cait> #info Next meeting: 17 April 2024, 12 UTC
13:01:49 <cait> #endmeeting