#koha: General IRC meeting 19 November 2014 - part 1

Meeting started by cait at 05:04:15 UTC (full logs).

Meeting summary

  1. introductions (cait, 05:04:23)
    1. wahanui, a bot that has become sentient (wahanui, 05:04:23)
    2. Mark Tompsett, Canadian contributor. (mtompset, 05:04:53)
    3. Brendan Gallagher ByWater (bag, 05:04:58)
    4. Katrin Fischer, BSZ (cait, 05:05:08)
    5. Bob Birchall, Calyx Australia (BobB, 05:05:10)
    6. David Cook, Prosentient Systems (dcook, 05:05:12)
    7. Manny, I am Koha- Philippines (manny, 05:05:55)
    8. Arslan Farooq, Pakistan (Oak, 05:06:00)
    9. Clint Anact (clint_, 05:07:28)

  2. Announcements (cait, 05:08:02)
    1. Ryan Terrenal National library of the Philippines (RTerrenal, 05:08:26)
    2. Mason James, NZ (mtj, 05:08:28)

  3. Update on releases (3.8 - 3.18) (cait, 05:08:59)
    1. http://www.youtube.com/watch?v=uHav6PL_4Bo&feature=youtu.be (dcook, 05:09:39)
    2. Koha, a community - http://www.youtube.com/watch?v=uHav6PL_4Bo&feature=youtu.be A video made during KohaCon14 in Argentina got published yesterday (cait, 05:10:14)
    3. String Freeze for 3.18 is on 20th this week (cait, 05:11:25)
    4. Release 3.18 is on 28th next week (cait, 05:11:39)
    5. There is a list of critical bugs to be solved before release on the wiki: http://wiki.koha-community.org/wiki/Critical_circ_bugs (cait, 05:12:21)
    6. bug 11998 is waiting for sign off - syspref caching issues (cait, 05:13:41)
    7. Eugene Espinoza House of Representatives Library (schnydszch, 05:14:31)

  4. Elections! (cait, 05:15:01)
    1. Nominations are http://wiki.koha-community.org/wiki/Roles_for_3.20 (cait, 05:15:27)
    2. Wanted: 3.16 Release maintainer (cait, 05:16:21)
    3. AGREED: Meeting part 1 elects Tomas Cohen Arazi for release manager of 3.20 (cait, 05:19:04)
    4. AGREED: Release Maintainers: 3.18 - Chris Cormack and 3.14 - Fridolin Somers (cait, 05:21:53)
    5. AGREED: Module Maintainers: Martin Renvoize (Auth), Colin Campbell (SIP), Kyle M Hall (Holds), Galen Charlton (Patron Privacy) (cait, 05:26:24)
    6. AGREED: Translation manager: Bernardo Gonzalez Kriegel (cait, 05:29:27)
    7. http://wiki.koha-community.org/wiki/Roles_for_3.20 (mtompset, 05:29:52)
    8. AGREED: (Database) Documentation Manager: Nicole Engard (cait, 05:31:48)
    9. AGREED: Quality Assurance (QA) Manager - Katrin Fischer (bag, 05:34:50)
    10. AGREED: Quality Assurance (QA) Team (all listed on the wiki) (bag, 05:39:57)
    11. AGREED: QA team: Marcel de Rooy, Jonathan Druart, Paul Poulain, Christopher Brannon, Brendan Gallagher, Martin Renvoize, Kyle M Hall (cait, 05:40:02)
    12. AGREED: Packaging Manager: Robin Sheat (cait, 05:41:21)
    13. AGREED: Bug Wrangler: Magnus Enger (cait, 05:42:45)
    14. AGREED: Release Maintainer 3.16: Mason James (cait, 05:45:34)

  5. Establish a roat map for Koha (cait, 05:46:20)
  6. Establish a road map for Koha (cait, 05:46:33)
    1. http://wiki.koha-community.org/wiki/Roadmap_to_3.12 (BobB, 05:47:19)
    2. http://wiki.koha-community.org/wiki/Roadmap_to_3.12 (cait, 05:47:48)
    3. the idea is to have a road map that is not time linked, (BobB, 05:48:13)
    4. not linked to any one release (BobB, 05:48:21)
    5. so people can see what is coming up, but not necessarily when it might get there (BobB, 05:49:02)
    6. The suggestion is to include both proposed new features and also plumbing improvements (BobB, 05:50:11)
    7. It was suggested the Road Map could have just a brief description of each proposal ... (BobB, 05:50:46)
    8. with a link to a separate page where the full RFC might be (BobB, 05:51:09)
    9. It was also suggested .. (BobB, 05:52:20)
    10. the idea is to reevaluate after each release (cait, 05:52:22)
    11. that the meeting after each major release could consider updates to the road map (BobB, 05:52:41)
    12. but that its maintenance can also be a continuous process (BobB, 05:52:56)
    13. IDEA: Have a retrospective meeting as part of the release process (cait, 05:55:16)
    14. IDEA: so we could endorse the idea today, and list it for more discussion at the next meeting? (BobB, 05:55:33)
    15. IDEA: use the next meeting to have more discussion, past and future on the road map (cait, 05:56:57)

  7. Establish new roles within the release team (cait, 05:57:21)
    1. This arose from the same discussion (BobB, 05:57:40)
    2. the proposal is to establish a Wiki Maintainer as a member of the release team (BobB, 05:58:05)
    3. and a Communications Manager (BobB, 05:58:16)
    4. peeps thought these might be available to Librarians rather than developers ... (BobB, 05:58:37)
    5. who are busy enough already (BobB, 05:58:48)
    6. /Wiki Manager/ Wiki Curator/ (BobB, 05:59:39)
    7. , if agreed to, these roles would be defined and advertised on the list: a call for nominations (BobB, 06:04:10)
    8. AGREED: Look for a Wiki Curator and Communication manager (cait, 06:08:34)
    9. ACTION: BobB will email the mailing list about the new roles (cait, 06:09:39)

  8. KohaCon15 (cait, 06:09:58)
    1. http://kohacon15bid.projektlinkkonsult.com/ (mtompset, 06:14:31)
    2. http://kohacon15bid.projektlinkkonsult.com/ (cait, 06:15:22)
    3. http://wiki.koha-community.org/wiki/Kohacon15 (cait, 06:18:37)
    4. http://imgur.com/ZfFPZjt may be amusing (liw, 06:19:36)

  9. Koha on FLOSS weekly (cait, 06:24:33)
    1. we generally like the idea, but no volunteer yet (cait, 06:26:31)
    2. Actions from General IRC meeting 22 October 2014 (cait, 06:27:00)

  10. Actions from General IRC meeting 22 October 2014 (cait, 06:27:14)
    1. http://meetings.koha-community.org/2014/general_irc_meeting_22_october_2014.2014-10-22-13.05.html (cait, 06:27:58)

  11. Set time and date of next General IRC meeting (cait, 06:30:36)
    1. AGREED: meeting part 1 suggests December 17th for the next meeting (cait, 06:33:51)


Meeting ended at 06:34:22 UTC (full logs).

Action items

  1. BobB will email the mailing list about the new roles


Action items, by person

  1. BobB
    1. BobB will email the mailing list about the new roles


People present (lines said)

  1. cait (183)
  2. mtompset (70)
  3. BobB (65)
  4. bag (61)
  5. rangi (40)
  6. Oak (32)
  7. gbengaadara (19)
  8. mtj (11)
  9. clint_ (9)
  10. schnydszch (9)
  11. huginn (8)
  12. dcook (6)
  13. RTerrenal (6)
  14. manny (4)
  15. wahanui (3)
  16. liw (1)


Generated by MeetBot 0.1.4.