#koha: General IRC meeting 19 November 2014, part 2

Meeting started by cait at 21:03:22 UTC (full logs).

Meeting summary

  1. introductions (cait, 21:03:32)
    1. wahanui, a bot that has become sentient (wahanui, 21:03:32)
    2. Bob Birchall, Calyx Australia (BobB, 21:04:29)
    3. Joel Sasse Plum Creek, MN (jmsasse, 21:04:33)
    4. nancyk Reno, Nevada Washoe County Library System (nancyk, 21:04:48)
    5. Mirko Tietgen, Berlin (drojf, 21:04:52)
    6. Katrin Fischer, BSZ, Germany (cait, 21:05:07)
    7. Jesse Maseto, BWS, USA (JesseM, 21:05:21)
    8. Brendan Gallagher ByWater (bag, 21:05:24)
    9. Olugbenga Adara Projektlink Konsult, Nigeria (gbengaadara, 21:05:25)
    10. ! (wajasu, 21:05:25)
    11. edveal, BWS USA (edveal, 21:05:28)
    12. Thomas Dukleth, Agogme, New York City (thd, 21:05:35)
    13. Joy Nelson BWS, USA (talljoy_phone, 21:05:49)
    14. Ed Veal ByWater (edveal, 21:05:50)

  2. Announcements (cait, 21:06:31)
    1. Liz Rea, Catalyst IT (wizzyrea, 21:07:10)
    2. Dani Elder BWS, USA (dani, 21:07:11)
    3. Barton Chittenden, BWS, Louisville, Kentucky, USA (barton, 21:07:46)
    4. ES demo is up from Robin http://elasticsearch.koha.catalystdemo.net.nz/cgi-bin/koha/opac-main.pl (cait, 21:07:51)
    5. Koha, a community - http://www.youtube.com/watch?v=uHav6PL_4Bo&feature=youtu.be A video made during KohaCon14 in Argentina got published yesterday (cait, 21:08:13)
    6. http://wiki.koha-community.org/wiki/Critical_circ_bugs (bag, 21:08:22)

  3. Update on releases (3.8 - 3.18) (cait, 21:09:11)
    1. Mario Guilin ByWater (mario, 21:09:17)
    2. String Freeze for 3.18 is on 21th this week (cait, 21:10:17)
    3. a Beta for 3.18 was released a few days ago: please test (BobB, 21:10:25)
    4. Release 3.18 is on 28th next week (cait, 21:10:33)

  4. Elections! (cait, 21:11:27)
    1. Nominations are http://wiki.koha-community.org/wiki/Roles_for_3.20 (cait, 21:11:36)
    2. AGREED: Release Manager 3.18: Tomas Cohen Arazi (cait, 21:14:45)
    3. Robin Sheat, Catalyst IT (eythian, 21:15:28)
    4. AGREED: Release Maintainers: Chris Cormack (3.18), Mason James (3.16), Fridolin Somers (3.14) (cait, 21:19:35)
    5. AGREED: Module Maintainers: Martin Renvoize (Auth), Colin Campbell (SIP), Kyle M Hall (Holds), Galen Charlton (Patron Privacy) (cait, 21:21:06)
    6. AGREED: Translation Manager: Bernardo Gonzalez Kriegel (cait, 21:23:16)
    7. AGREED: (Database) Documentation Manager: Nicole Engard (cait, 21:25:05)
    8. AGREED: Quality Assurance Manager Katrin Fischer (drojf, 21:28:13)
    9. AGREED: QA Team: Marcel de Rooy, Jonathan Druart, Paul Poulain, Christopher Brannon, Brendan Gallagher, Martin Renvoize, Kyle M Hall (cait, 21:31:01)
    10. AGREED: Packaging Manager: Robin Sheat (cait, 21:32:38)
    11. AGREED: Bug Wrangler: Magnus Enger (cait, 21:34:12)
    12. the first meeting decided to advertise the role on the list and call for nominations (BobB, 21:38:06)
    13. Then there were no nominations, now there are (BobB, 21:38:28)
    14. So I think it still needs a short note to the list, but now ... (BobB, 21:38:53)
    15. official elections for Wiki curator to take place next meeting (cait, 21:40:52)

  5. Establish a Road Map for Koha (cait, 21:41:39)
    1. this arises from a discussion on the sidelines of KohaCon (BobB, 21:42:02)
    2. Until at least 3.12 we had a roadmap that was time (release) based (BobB, 21:42:27)
    3. the idea is to re-create the roadmap, but not time based (BobB, 21:42:40)
    4. so it serves a little like a strategic plan for the code, less formal (BobB, 21:43:04)
    5. we suggest taht the first meeting after the Release should review the release and discuss updates to the roadmap (BobB, 21:43:37)
    6. but maintaining the roadmap can be a continuous process, of course (BobB, 21:44:03)
    7. the other idea was that items in the roadmap would be described in just a few lines ... (BobB, 21:44:32)
    8. with a link to another page providing a full RFC (BobB, 21:45:24)
    9. https://www.drupal.org/roadmap I would like to see a page like this (wizzyrea, 21:46:46)
    10. https://core.trac.wordpress.org/roadmap or something like this (wizzyrea, 21:47:58)
    11. https://core.trac.wordpress.org/roadmap (cait, 21:48:55)
    12. https://www.drupal.org/roadmap (cait, 21:49:12)
    13. https://wiki.mozilla.org/Bugzilla:Roadmap (wizzyrea, 21:50:08)
    14. https://wiki.mozilla.org/Bugzilla:Roadmap (cait, 21:50:25)
    15. AGREED: We will gather information and ideas for the road map on the next meetings agenda (cait, 21:55:25)

  6. Establish new roles within the release team (cait, 21:55:40)
    1. on the sidelines of KohaCon there was discussion about adding a Communications Manager role to the release team (BobB, 21:59:45)
    2. this is to be a coordinating role, more than a doing role (BobB, 22:00:30)
    3. http://wiki.koha-community.org/wiki/Release_Announcements <-- david nind did this (rangi, 22:12:24)
    4. ACTION: BobB will email the mailing list about the new roles (cait, 22:15:10)

  7. KohaCon15 (cait, 22:15:25)
    1. kohacon15 will be between 19th - 25th October 2015 (gbengaadara, 22:16:03)
    2. Conference 19th - 21st, Hackfest 23rd - 25th (gbengaadara, 22:16:36)
    3. http://kohacon15.projektlinkkonsult.com/ updated now :) (cait, 22:19:38)
    4. ACTION: adding a note/link to the kc website about kohacon15 (cait, 22:22:49)

  8. Koha on FLOSS weekly (cait, 22:23:14)
  9. Set time and date of next general IRC meeting (cait, 22:28:13)
    1. AGREED: december 17th - 9 and 21 utc (cait, 22:35:37)


Meeting ended at 22:35:47 UTC (full logs).

Action items

  1. BobB will email the mailing list about the new roles
  2. adding a note/link to the kc website about kohacon15


Action items, by person

  1. BobB
    1. BobB will email the mailing list about the new roles


People present (lines said)

  1. cait (175)
  2. BobB (64)
  3. wizzyrea (43)
  4. bag (38)
  5. thd (35)
  6. drojf (33)
  7. gbengaadara (19)
  8. barton (15)
  9. nancyk (11)
  10. wahanui (10)
  11. eythian (9)
  12. rangi (7)
  13. jmsasse (6)
  14. magnuse (5)
  15. huginn (5)
  16. talljoy (4)
  17. edveal (3)
  18. dani (3)
  19. talljoy_phone (2)
  20. JesseM (2)
  21. mario (2)
  22. learn_koha (2)
  23. dcook (1)
  24. wajasu (1)


Generated by MeetBot 0.1.4.