#koha: Developer IRC meeting 24 June 2015 - part 2

Meeting started by cait at 22:04:44 UTC (full logs).

Meeting summary

  1. Introductions (cait, 22:04:48)
    1. wahanui, a bot that has become sentient (wahanui, 22:04:49)
    2. Indranil Das Gupta (indradg, 22:05:12)
    3. Mirko Tietgen, one eye still open (drojf, 22:05:13)
    4. Robin Sheat, Catalyst IT, Wellington (eythian_, 22:05:21)
    5. Katrin Fischer, BSZ Germany (cait, 22:05:40)
    6. Nick Clemens, VOKAL Consortium, Vermont (wnickc, 22:06:09)
    7. http://wiki.koha-community.org/wiki/Development_IRC_meeting_24_June_2015 (cait, 22:06:34)

  2. RM 3.22 comments (cait, 22:06:51)
    1. the RM considers 'normal' for patches on the PQA list to stay there for more than 2 weeks, if you think something needs to be pushed faster, please contact the RM personally (cait, 22:08:35)

  3. RESTful API implementation (cait, 22:10:13)
    1. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13920 (cait, 22:10:41)
    2. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13799 (cait, 22:10:51)
    3. http://wiki.koha-community.org/wiki/New_REST_API_RFC (cait, 22:11:19)
    4. brendan gallagher bywater (bag, 22:12:54)
    5. IDEA: think about ways for devs to coordinate big tasks better (cait, 22:19:48)
    6. links to logs: http://irc.koha-community.org/koha/2015-06-24#i_1693798 (cait, 22:21:33)
    7. http://mojolicio.us/perldoc/Mojolicious/Guides/FAQ#Which-versions-of-Perl-are-supported-by-Mojolicious (mtj, 22:24:59)
    8. Question: what are the perl requirements of mojolicious? (cait, 22:25:53)
    9. http://mojolicio.us/perldoc/Mojolicious/Guides/FAQ#Which-versions-of-Perl-are-supported-by-Mojolicious (cait, 22:26:09)
    10. ACTION: mtj to bring perl version question to the mailing list (cait, 22:32:56)
    11. https://metacpan.org/pod/Swagger2 (mtj, 22:36:33)
    12. Question: what do we gain by using Mojolicious - are there other ways we could make use of Swagger? (cait, 22:39:02)
    13. Question: can swagger be used without mojo? (mtj, 22:39:52)
    14. Question: can swagger be used without mojo? (cait, 22:41:06)

  4. Koha Naming standards (cait, 22:42:34)
    1. http://wiki.koha-community.org/wiki/Terminology (cait, 22:42:58)
    2. http://i.imgur.com/kn488mY.jpg <-- that's the image I was thinking of (eythian_, 22:49:39)
    3. AGREED: consistency is good - meeting participants in favour of aligning new code terminology with the gui terminology (cait, 22:50:43)

  5. Big stuff we are working on (cait, 22:51:09)
    1. ACTION: eythian to send an email to the list to call for testing when ready (cait, 22:57:25)
    2. ElasticSearch is coming along (cait, 22:58:30)

  6. GBSD (cait, 22:58:39)
    1. Needed: ideas on how to make gbsds more fun and more attractive (cait, 23:01:35)

  7. specific bugs that need feedback (cait, 23:03:45)
    1. Looking for opinions on bug 7710 - confiuration and behavoiur of multiple holds per title (cait, 23:06:18)
    2. IDEA: run a kohadevbox tutorial on gbsd (cait, 23:06:28)
    3. IDEA: gbsd newbie guide - from installing kohadevbox to sign-off (cait, 23:07:29)

  8. Set time of next meeting (cait, 23:08:02)
    1. ACTION: tcohen to set date and time for next meeting - a shift to 14 UTC was suggested (cait, 23:08:21)


Meeting ended at 23:08:50 UTC (full logs).

Action items

  1. mtj to bring perl version question to the mailing list
  2. eythian to send an email to the list to call for testing when ready
  3. tcohen to set date and time for next meeting - a shift to 14 UTC was suggested


Action items, by person

  1. eythian
    1. eythian to send an email to the list to call for testing when ready
  2. mtj
    1. mtj to bring perl version question to the mailing list


People present (lines said)

  1. cait (152)
  2. eythian_ (46)
  3. mtj (32)
  4. rangi (31)
  5. huginn` (7)
  6. wahanui (3)
  7. drojf (2)
  8. bag (1)
  9. wnickc (1)
  10. indradg (1)
  11. eythian (0)


Generated by MeetBot 0.1.4.