#koha: Development IRC meeting 20 April 2016

Meeting started by cait at 15:07:09 UTC (full logs).

Meeting summary

  1. Intorductions (cait, 15:07:17)
    1. Owen Leonard, Athens County Public Libraries, USA (oleonard, 15:07:42)
    2. Mirko Tietgen, Berlin, Germany (drojf, 15:07:46)
    3. Tomas Cohen Arazi, Theke Solutions (tcohen, 15:07:55)
    4. Katrin Fischer, BSZ, Germany (cait, 15:08:04)
    5. Julian Maurice, BibLibre (jajm, 15:08:31)
    6. https://wiki.koha-community.org/wiki/Development_IRC_meeting_20_April_2016 (cait, 15:09:38)

  2. Release 16.05 (cait, 15:10:32)
    1. Feature freeze will be at the end of the day - April 28! (cait, 15:11:01)
    2. Kyle M Hall, ByWater Solutions (khall, 15:11:04)
    3. Additional sign offs for ES requested to free QA tokens (cait, 15:14:47)
    4. 61 in Signed off - help needed for ES and REST related patches specifically (cait, 15:17:01)
    5. Bernardo Gonzalez Kriegel (bgkriegel, 15:21:24)
    6. Need info on status of Swagger2 packages for REST related patches (cait, 15:22:08)
    7. kohadevbox:ansible has been updated so it now accepts external repositories, handy for testing packaging stuff (cait, 15:22:27)
    8. ACTION: gmcharlt to look into feasibility of porting the swagger package on Monday and Tuesday (cait, 15:23:52)

  3. Review coding guidelines (cait, 15:26:06)
    1. khall is working on the draft for a revamped coding guidelines page (cait, 15:27:34)
    2. Proposed wording: Form validation should be done using the jquery form validator unless the form validation will not work with its limitations. Custom validation rules for anythign which isn't already built in can be defined. (cait, 15:36:52)
    3. Brendan Gallagher Bywater (bag, 15:38:11)
    4. VOTE: Voted on "Add coding guideline about use of jquery form validator as proposed?" Results are, yes: 5 (cait, 15:39:10)
    5. AGREED: Coding guideline will be added - yes (5): oleonard, cait, jajm, bgkriegel, khall (cait, 15:39:38)
    6. ACTION: khall to add coding guideline about jquery form validation (cait, 15:39:52)

  4. Any bugs that are in discussion (cait, 15:40:07)
  5. General development discussion (cait, 15:43:20)
    1. http://lists.koha-community.org/pipermail/koha-devel/2016-April/042582.html (cait, 15:47:47)
    2. Barton Chittenden, bws (barton, 15:48:05)

  6. Nominations for release team 16.11 (cait, 15:48:55)
    1. https://wiki.koha-community.org/wiki/Roles_for_16.11 (cait, 15:49:04)
    2. http://editorconfig.org/#download (tcohen, 15:54:32)
    3. ACTION: tcohen to write up some documentation about the use of editorconfig (cait, 15:55:36)
    4. http://editorconfig.org/#download (barton, 15:56:07)

  7. Set time of next meeting (cait, 15:56:37)
    1. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160413T09&msg=Koha%20Developers%20IRC%20Meeting&low=c (cait, 16:01:45)
    2. http://xkcd.com/1335/ (barton, 16:02:40)
    3. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160511T09&msg=Koha%20Developers%20IRC%20Meeting&low=c ? (cait, 16:03:52)
    4. AGREED: next meeting will be held on April 11, 21 UTC (cait, 16:07:29)
    5. AGREED: next meeting will be held on MAY 11, 21 UTC (cait, 16:07:44)


Meeting ended at 16:07:56 UTC (full logs).

Action items

  1. gmcharlt to look into feasibility of porting the swagger package on Monday and Tuesday
  2. khall to add coding guideline about jquery form validation
  3. tcohen to write up some documentation about the use of editorconfig


Action items, by person

  1. gmcharlt
    1. gmcharlt to look into feasibility of porting the swagger package on Monday and Tuesday
  2. khall
    1. khall to add coding guideline about jquery form validation
  3. tcohen
    1. tcohen to write up some documentation about the use of editorconfig


People present (lines said)

  1. cait (146)
  2. tcohen (39)
  3. khall (31)
  4. oleonard (17)
  5. pianohacker (16)
  6. huginn (12)
  7. bag (8)
  8. drojf (7)
  9. wahanui (6)
  10. barton (6)
  11. jajm (6)
  12. bgkriegel (2)
  13. reiveune (1)
  14. gmcharlt (1)


Generated by MeetBot 0.1.4.