#koha: Development IRC meeting 10 October 2018

Meeting started by cait at 20:03:58 UTC (full logs).

Meeting summary

  1. Introductions (cait, 20:04:02)
    1. Martin Renvoize, PTFS Europe, UK (ashimema, 20:04:05)
    2. Thomas Dukleth, Agogme, New York City, [even two ISPs does not protect against power failure] (thd, 20:04:16)
    3. https://wiki.koha-community.org/wiki/Development_IRC_meeting_10_October_2018 today's agenda (cait, 20:04:31)
    4. Katrin Fischer, BSZ, Germany (cait, 20:04:38)
    5. Josef Moravec, Municipal Library Usti nad Orlici, Czech Republic (josef_moravec, 20:05:05)
    6. Chris Cormack, Catalyst, NZ (rangi, 20:05:41)

  2. Announcements (cait, 20:06:16)
    1. Next week is the Swedish user group meeting and hack day (cait, 20:08:02)
    2. KohaCon19 dates are finalized: Monday 20 May to Sunday 26 May 2019 (ashimema, 20:09:06)

  3. Update from the Release manager (18.11) (cait, 20:10:28)
    1. Nick Clemens : Travelling, pushing things to master, dates have been sent to list, keep Qaing :-) (cait, 20:10:46)

  4. Updates from the Release Maintainers (cait, 20:11:24)
    1. Owen Leonard, Athens County Public Libraries, USA, late (oleonard, 20:13:06)
    2. ashimema has proposed to be Rmaint for 18.11 for next cycle (19.05) (cait, 20:14:06)
    3. Fridolin Somers : Last release of 17.05.x is ready will be out in a few days. Proposed to continue on RMaint 17.11. (cait, 20:14:14)
    4. Still looking for a 18.05 Release maintainer for the next cycle (cait, 20:14:50)
    5. https://wiki.koha-community.org/wiki/Roles_for_19.05 Please sign up for the 19.05 release team (cait, 20:15:44)
    6. ACTION: cait to add elections to next general meeting (cait, 20:16:52)
    7. ACTION: ashimema to send an email reminding people to look at and add their names to 19.05 roles page (ashimema, 20:17:56)
    8. ACTION: ashimema to send call for release team to mailing list (cait, 20:18:05)

  5. Updates from the QA team (cait, 20:19:01)
    1. November   2 - Feature slush - no enhancement/new features  that have not passed QA will be considered for release (cait, 20:20:48)
    2. ES patches are a bit behind, would be great to see some work on those (cait, 20:22:34)

  6. General development discussion (trends, ideas,...) (cait, 20:24:01)
    1. https://matrix.org/_matrix/media/v1/download/matrix.org/aftKcYjGeeZfzgOpwIXgNZBe cait (rangi, 20:32:44)
    2. IDEA: Add Pushed to oldstable and Pushed to oldoldstable to get us in line with Debian package codenames and reserve RESOLVED FIXED for applying upon release (cait, 20:34:09)
    3. IDEA: Script for RMaints to mark all Pushed to branch as RESOLVED FIXED upon release. (cait, 20:34:19)
    4. IDEA: Remove Pushed for QA and Pushed by Module Maintainer as they aren't in active use. (cait, 20:34:27)
    5. VOTE: Voted on "Shall we add 2 new status: pushed to oldstable, pushed to oldoldstable and remove 2: pushed for qa, pushed by module maintainer?" Results are, yes: 5 (cait, 20:41:18)
    6. AGREED: we will make the suggested changes to bugzilla status (yes (5): oleonard, ashimema, cait, josef_moravec, thd) (cait, 20:41:42)
    7. ACTION: rangi to change bugzilla (plz) (cait, 20:41:54)
    8. ACTION: ashimema to update release maintanence page to reflect the change (ashimema, 20:42:17)

  7. Review of coding guidelines (cait, 20:42:31)
  8. Set time of next meeting (cait, 20:43:36)
    1. Next meeting: 24 October 2018, 14 UTC (cait, 20:47:11)


Meeting ended at 20:47:25 UTC (full logs).

Action items

  1. cait to add elections to next general meeting
  2. ashimema to send an email reminding people to look at and add their names to 19.05 roles page
  3. ashimema to send call for release team to mailing list
  4. rangi to change bugzilla (plz)
  5. ashimema to update release maintanence page to reflect the change


Action items, by person

  1. ashimema
    1. ashimema to send an email reminding people to look at and add their names to 19.05 roles page
    2. ashimema to send call for release team to mailing list
    3. ashimema to update release maintanence page to reflect the change
  2. cait
    1. cait to add elections to next general meeting
  3. rangi
    1. rangi to change bugzilla (plz)


People present (lines said)

  1. cait (98)
  2. ashimema (65)
  3. josef_moravec (11)
  4. oleonard (9)
  5. huginn (8)
  6. rangi (5)
  7. wahanui (2)
  8. thd (2)


Generated by MeetBot 0.1.4.